pkgbuild/pkgbuild.spec
changeset 5 f091da4b55b4
parent 2 703a514d2a12
child 6 678173477765
equal deleted inserted replaced
4:dc96cad1e9ea 5:f091da4b55b4
    56 Meta(info.classification):	org.opensolaris.category.2008:System/Packaging
    56 Meta(info.classification):	org.opensolaris.category.2008:System/Packaging
    57 %endif
    57 %endif
    58 
    58 
    59 %ifos Solaris
    59 %ifos Solaris
    60 Requires:     SUNWbash
    60 Requires:     SUNWbash
    61 Requires:     SUNWperl584core
    61 Requires:     SUNWperl510core
       
    62 Requires:     library/perl-5/xml-xpath
    62 Requires:     SUNWgpch
    63 Requires:     SUNWgpch
    63 %else
    64 %else
    64 Requires:     perl >= 5.0.0
    65 Requires:     perl >= 5.0.0
    65 Requires:     patch
    66 Requires:     patch
    66 %endif
    67 %endif
    67 Requires:     SFExz
       
    68 
    68 
    69 %description
    69 %description
    70 A tool for building Solaris SVr4 packages based on RPM spec files.
    70 A tool for building Solaris SVr4 packages based on RPM spec files.
    71 Most features and some extensions of the spec format are implemented.
    71 Most features and some extensions of the spec format are implemented.
    72 
    72 
    91 # Originally, pkgtool called pkgbuild with -bb, not -ba. Really, an option controlling this should be added.
    91 # Originally, pkgtool called pkgbuild with -bb, not -ba. Really, an option controlling this should be added.
    92 %patch8 -p1
    92 %patch8 -p1
    93 
    93 
    94 %build
    94 %build
    95 ./configure --prefix=%{pkgbuild_prefix} --docdir=%_docdir/%srcname
    95 ./configure --prefix=%{pkgbuild_prefix} --docdir=%_docdir/%srcname
    96 #./configure --prefix=%{pkgbuild_prefix}
       
    97 make
    96 make
    98 
    97 
    99 %install
    98 %install
   100 rm -rf $RPM_BUILD_ROOT
    99 rm -rf $RPM_BUILD_ROOT
   101 make DESTDIR=$RPM_BUILD_ROOT install
   100 make DESTDIR=$RPM_BUILD_ROOT install