make-rules/cmake.mk
changeset 5597 bcd66d6b1f98
parent 5125 34cc580c62c2
child 5682 94c0ca64c022
equal deleted inserted replaced
5596:c3e2f9778be5 5597:bcd66d6b1f98
    16 # fields enclosed by brackets "[]" replaced with your own identifying
    16 # fields enclosed by brackets "[]" replaced with your own identifying
    17 # information: Portions Copyright [yyyy] [name of copyright owner]
    17 # information: Portions Copyright [yyyy] [name of copyright owner]
    18 #
    18 #
    19 # CDDL HEADER END
    19 # CDDL HEADER END
    20 #
    20 #
    21 # Copyright (c) 2015, Oracle and/or its affiliates. All rights reserved.
    21 # Copyright (c) 2015, 2016, Oracle and/or its affiliates. All rights reserved.
    22 #
    22 #
    23 
    23 
    24 #
    24 #
    25 # This file sets up the default options and base requirements for GNOME
    25 # This file sets up the default options and base requirements for GNOME
    26 # components.
    26 # components.
    74 # Ensure cmake finds the matching 32/64-bit version of dependencies.
    74 # Ensure cmake finds the matching 32/64-bit version of dependencies.
    75 COMPONENT_BUILD_ENV += PKG_CONFIG_PATH="$(PKG_CONFIG_PATH)"
    75 COMPONENT_BUILD_ENV += PKG_CONFIG_PATH="$(PKG_CONFIG_PATH)"
    76 
    76 
    77 REQUIRED_PACKAGES += developer/build/cmake
    77 REQUIRED_PACKAGES += developer/build/cmake
    78 REQUIRED_PACKAGES += developer/build/pkg-config
    78 REQUIRED_PACKAGES += developer/build/pkg-config
       
    79 REQUIRED_PACKAGES += developer/gnome/gettext
    79 REQUIRED_PACKAGES += developer/gnu-binutils
    80 REQUIRED_PACKAGES += developer/gnu-binutils
    80 REQUIRED_PACKAGES += developer/intltool
       
    81 REQUIRED_PACKAGES += system/library
    81 REQUIRED_PACKAGES += system/library
    82 REQUIRED_PACKAGES += system/linker
    82 REQUIRED_PACKAGES += system/linker
    83 # Most cmake-based components expect GNU versions of these.
    83 # Most cmake-based components expect GNU versions of these.
    84 REQUIRED_PACKAGES += text/gawk
    84 REQUIRED_PACKAGES += text/gawk
    85 REQUIRED_PACKAGES += text/gnu-grep
    85 REQUIRED_PACKAGES += text/gnu-grep