components/meta-packages/developer-opensolaris-userland/Makefile
branchs11-update
changeset 3996 20c0f21bbe1e
child 4196 d697072a92f5
child 4495 b5776fb3ca40
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/meta-packages/developer-opensolaris-userland/Makefile	Thu Mar 19 20:44:31 2015 -0700
@@ -0,0 +1,57 @@
+#
+# CDDL HEADER START
+#
+# The contents of this file are subject to the terms of the
+# Common Development and Distribution License (the "License").
+# You may not use this file except in compliance with the License.
+#
+# You can obtain a copy of the license at usr/src/OPENSOLARIS.LICENSE
+# or http://www.opensolaris.org/os/licensing.
+# See the License for the specific language governing permissions
+# and limitations under the License.
+#
+# When distributing Covered Code, include this CDDL HEADER in each
+# file and include the License file at usr/src/OPENSOLARIS.LICENSE.
+# If applicable, add the following below this CDDL HEADER, with the
+# fields enclosed by brackets "[]" replaced with your own identifying
+# information: Portions Copyright [yyyy] [name of copyright owner]
+#
+# CDDL HEADER END
+#
+
+#
+# Copyright (c) 2015, Oracle and/or its affiliates. All rights reserved.
+#
+
+include ../../../make-rules/shared-macros.mk
+
+COMPONENT_NAME=		developer/opensolaris/userland
+COMPONENT_VERSION=	
+COMPONENT_PROJECT_URL=	http://solaris-userland.java.net/
+COMPONENT_ARCHIVE_URL=	http://hg.java.net/solaris-userland-gate/
+COMPONENT_BUGDB=	gate-stuff/userland
+
+include $(WS_MAKE_RULES)/ips.mk
+
+$(WS_MACH)/requires.mk:
+	(cd $(WS_COMPONENTS) ; $(GMAKE) $@)
+
+-include $(WS_MACH)/requires.mk
+
+# The package is created in two parts: the checked-in manifest and a generated
+# file of actions based on the REQUIRED_PACKAGES macro value.
+PKG_OPTIONS += -I $(BUILD_DIR)
+
+$(BUILD_DIR)/package.list:	$(BUILD_DIR) $(WS_MACH)/requires.mk
+	@echo $(REQUIRED_PACKAGES:%="depend type=require fmri=pkg:/%\\n") >$@
+
+download::
+
+prep:
+
+build install: $(BUILD_DIR)/package.list
+
+test:	$(NO_TESTS)
+
+clean clobber::
+	$(RM) -r $(BUILD_DIR)