components/logilab-common/logilab-common-26.p5m
changeset 1666 69d14d547e77
parent 1251 f1fb66b52f41
child 1758 28f01aad153d
--- a/components/logilab-common/logilab-common-26.p5m	Mon Jan 27 15:13:46 2014 -0800
+++ b/components/logilab-common/logilab-common-26.p5m	Mon Jan 27 17:48:58 2014 -0800
@@ -18,12 +18,12 @@
 #
 # CDDL HEADER END
 #
-# Copyright (c) 2011, 2013, Oracle and/or its affiliates. All rights reserved.
+# Copyright (c) 2011, 2014, Oracle and/or its affiliates. All rights reserved.
 #
 
 <transform file path=usr.*/man/.+ -> default mangler.man.stability uncommitted>
 set name=pkg.fmri \
-    value=pkg:/library/python-2/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
+    value=pkg:/library/python/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
 set name=pkg.description \
     value="Modules providing low level functionality shared among various python projects."
 set name=pkg.summary value="common python libraries for logilab applications"
@@ -112,7 +112,7 @@
 
 license logilab-common.license license=LGPLv2.1,GPLv2
 
-# pkgdepend should have picked up the dependency on /library/python-2/pyorbit-26;
+# pkgdepend should have picked up the dependency on /library/python/pyorbit-26;
 # this explicit depend action can be removed if pkgdepend is fixed later
 depend fmri=__TBD \
     pkg.debug.depend.file=usr/lib/python2.6/vendor-packages/CORBA.py \
@@ -124,6 +124,9 @@
        pkg.debug.depend.path=usr/bin type=require
 
 # force a dependency on the logilab-common package
-depend fmri=library/python-2/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION) \
+depend fmri=library/python/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION) \
     type=require
 
+# force the rename with an optional dependency on the old name
+depend type=optional \
+    fmri=library/python-2/[email protected],5.12-5.12.0.0.0.41.0