components/python/kombu/kombu-PYVER.p5m
changeset 1666 69d14d547e77
parent 1602 f0ef141ec2b9
child 1890 5a4ef66c42bf
--- a/components/python/kombu/kombu-PYVER.p5m	Mon Jan 27 15:13:46 2014 -0800
+++ b/components/python/kombu/kombu-PYVER.p5m	Mon Jan 27 17:48:58 2014 -0800
@@ -18,18 +18,18 @@
 #
 # CDDL HEADER END
 #
-# Copyright (c) 2012, 2013, Oracle and/or its affiliates. All rights reserved.
+# Copyright (c) 2012, 2014, Oracle and/or its affiliates. All rights reserved.
 #
 
 # importlib is part of python 2.7, but separate in 2.6
-<transform depend type=require fmri=library/python-2/importlib-27 -> drop>
+<transform depend type=require fmri=library/python/importlib-27 -> drop>
 # ordereddict is part of python 2.7, but separate in 2.6
-<transform depend type=require fmri=library/python-2/ordereddict-27 -> drop>
+<transform depend type=require fmri=library/python/ordereddict-27 -> drop>
 # The test related file actions have not been included because they will fail
 # in dependency generation until the various test related modules that they
 # need are also provided.
 set name=pkg.fmri \
-    value=pkg:/library/python-2/kombu-$(PYV)@$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
+    value=pkg:/library/python/kombu-$(PYV)@$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
 set name=pkg.summary value="Messaging framework for Python"
 set name=pkg.description \
     value="The aim of Kombu is to make messaging in Python as easy as possible by providing an idiomatic high-level interface for the AMQ protocol (AMQP), and also provide proven and tested solutions to common messaging problems."
@@ -110,29 +110,32 @@
     pkg.debug.depend.path=usr/bin
 
 # force a dependency on amqp; pkgdepend work is needed to flush this out.
-depend type=require fmri=library/python-2/amqp-$(PYV)
+depend type=require fmri=library/python/amqp-$(PYV)
 
 # force a dependency on anyjson; pkgdepend work is needed to flush this out.
-depend type=require fmri=library/python-2/anyjson-$(PYV)
+depend type=require fmri=library/python/anyjson-$(PYV)
 
 # force a dependency on boto; pkgdepend work is needed to flush this out.
-depend type=require fmri=library/python-2/boto-$(PYV)
+depend type=require fmri=library/python/boto-$(PYV)
 
 # force a dependency on eventlet; pkgdepend work is needed to flush this out.
-depend type=require fmri=library/python-2/eventlet-$(PYV)
+depend type=require fmri=library/python/eventlet-$(PYV)
 
 # force a dependency on importlib; pkgdepend work is needed to flush this out.
-depend type=require fmri=library/python-2/importlib-$(PYV)
+depend type=require fmri=library/python/importlib-$(PYV)
 
 # force a dependency on the kombu package
 depend type=require \
-    fmri=library/python-2/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
+    fmri=library/python/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
 
 # force a dependency on librabbitmq; pkgdepend work is needed to flush this out.
-depend type=require fmri=library/python-2/librabbitmq-$(PYV)
+depend type=require fmri=library/python/librabbitmq-$(PYV)
 
 # force a dependency on ordereddict; pkgdepend work is needed to flush this out.
-depend type=require fmri=library/python-2/ordereddict-$(PYV)
+depend type=require fmri=library/python/ordereddict-$(PYV)
 
 # force a dependency on pyrabbit; pkgdepend work is needed to flush this out.
-depend type=require fmri=library/python-2/pyrabbit-$(PYV)
+depend type=require fmri=library/python/pyrabbit-$(PYV)
+
+# force the rename with an optional dependency on the old name
+depend type=optional fmri=library/python-2/kombu-$(PYV)@2.5.12,5.12-5.12.0.0.0.41.0