components/openscap/openscap-python-26.p5m
author Mike Sullivan <Mike.Sullivan@Oracle.COM>
Mon, 11 Mar 2013 10:38:09 -0700
branchs11-update
changeset 2520 ceec631e74d1
parent 922 f0a67cc3878c
child 1205 6c6c27bcf9ac
permissions -rw-r--r--
Close of build 10.
#
# CDDL HEADER START
#
# The contents of this file are subject to the terms of the
# Common Development and Distribution License (the "License").
# You may not use this file except in compliance with the License.
#
# You can obtain a copy of the license at usr/src/OPENSOLARIS.LICENSE
# or http://www.opensolaris.org/os/licensing.
# See the License for the specific language governing permissions
# and limitations under the License.
#
# When distributing Covered Code, include this CDDL HEADER in each
# file and include the License file at usr/src/OPENSOLARIS.LICENSE.
# If applicable, add the following below this CDDL HEADER, with the
# fields enclosed by brackets "[]" replaced with your own identifying
# information: Portions Copyright [yyyy] [name of copyright owner]
#
# CDDL HEADER END
#
# Copyright (c) 2012, Oracle and/or its affiliates. All rights reserved.
#

set name=pkg.fmri value=pkg:/library/python-2/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
set name=pkg.summary value="Python 2.6 bindings for the Open implementation of SCAP"
set name=info.classification value="org.opensolaris.category.2008:System/Security"
set name=info.upstream-url value=$(COMPONENT_PROJECT_URL)
set name=info.source-url value=$(COMPONENT_ARCHIVE_URL)
set name=org.opensolaris.consolidation value=$(CONSOLIDATION)
set name=org.opensolaris.arc-caseid \
    value=PSARC/2012/152
set pkg.linted=true

license openscap.license license=LGPLv2.1

dir path=usr
dir path=usr/lib
dir path=usr/lib/python2.6
dir path=usr/lib/python2.6/vendor-packages

file path=usr/lib/python2.6/vendor-packages/_openscap_py.so
file path=usr/lib/python2.6/vendor-packages/openscap.py
file path=usr/lib/python2.6/vendor-packages/openscap_api.py

# force a dependency on the Python 2.6 runtime
depend fmri=__TBD pkg.debug.depend.file=python2.6 \
    pkg.debug.depend.path=usr/bin type=require