20401773 adjust Userland package dependencies for renamed iconv packages
authorJan Hnatek <jan.hnatek@oracle.com>
Mon, 25 May 2015 09:32:46 +0200
changeset 4344 071eb292dd02
parent 4342 ede611c77414
child 4345 28e38d602d09
20401773 adjust Userland package dependencies for renamed iconv packages
components/samba/samba/samba.p5m
components/trousers/trousers.p5m
--- a/components/samba/samba/samba.p5m	Fri May 22 06:02:19 2015 -0700
+++ b/components/samba/samba/samba.p5m	Mon May 25 09:32:46 2015 +0200
@@ -665,4 +665,4 @@
 license samba-license license=GPLv3
 
 # Samba can be used in Asian multibyte language envs. so we need this
-depend type=require fmri=pkg:/system/library/iconv/unicode
+depend type=require fmri=pkg:/system/library/iconv
--- a/components/trousers/trousers.p5m	Fri May 22 06:02:19 2015 -0700
+++ b/components/trousers/trousers.p5m	Mon May 25 09:32:46 2015 +0200
@@ -175,8 +175,8 @@
 dir  path=var/tpm/userps owner=root group=sys mode=1777
 license trousers.license license=CPL
 #
-# libtspi requires 646%UTF-16LE.so and UTF-16LE%646.so, which are in
-# package utf-8. This is for function Trspi_Native_To_UNICODE() which calls
-# iconv_open() to dynamically load these libraries
+# libtspi needs to convert between codesets 646 and UTF-16LE, which are covered
+# by package iconv-core. This is for function Trspi_Native_To_UNICODE() which
+# calls iconv_open()
 #
-depend type=require fmri=pkg:/system/library/iconv/utf-8
+depend type=require fmri=pkg:/system/library/iconv/iconv-core