21234164 python2.6(1) man page should note pending obsoletion s11-update
authorJohn Beck <John.Beck@Oracle.COM>
Wed, 10 Jun 2015 14:59:41 -0700
branchs11-update
changeset 4464 2594d55f79e0
parent 4461 68eb2fdf9b3a
child 4482 aaac3f6161a7
21234164 python2.6(1) man page should note pending obsoletion
components/python/python26/patches/Python26-40-obsolete-man-page.patch
components/python/python26/python-26.p5m
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/python26/patches/Python26-40-obsolete-man-page.patch	Wed Jun 10 14:59:41 2015 -0700
@@ -0,0 +1,14 @@
+--- Python-2.6.8/Misc/python.man.orig	2012-04-10 08:32:09 -0700
++++ Python-2.6.8/Misc/python.man	2015-06-10 13:31:25 -0700
[email protected]@ -108,6 +108,11 @@
+ viewed by running the 
+ .B pydoc
+ program.  
++.SH CAVEAT
++Python 2.6 support from python.org ended in October 2013.  Therefore this
++version of Python is now Obsolete, and will be removed from a future
++release of Solaris.  Please migrate any consumers to use Python version
++2.7 or 3.4 instead.
+ .SH COMMAND LINE OPTIONS
+ .TP
+ .B \-B
--- a/components/python/python26/python-26.p5m	Wed Jun 10 11:25:02 2015 -0700
+++ b/components/python/python26/python-26.p5m	Wed Jun 10 14:59:41 2015 -0700
@@ -21,7 +21,7 @@
 # Copyright (c) 2011, 2015, Oracle and/or its affiliates. All rights reserved.
 #
 
-<transform file path=usr.*/man/.+ -> default mangler.man.stability uncommitted>
+<transform file path=usr.*/man/.+ -> default mangler.man.stability obsolete>
 set name=pkg.fmri \
     value=pkg:/runtime/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
 set name=pkg.summary value="The Python interpreter, libraries and utilities"