17780769 The Websockify module is needed by the openstack project (fix deps)
authorDrew Fisher <drew.fisher@oracle.com>
Wed, 05 Feb 2014 14:41:11 -0800
changeset 1693 31ad79640e2f
parent 1692 dce38b815f7d
child 1694 a9247976d914
17780769 The Websockify module is needed by the openstack project (fix deps) 18029506 Request to integrate django into Userland (fix deps) 18029536 Request to integrate django-openstack_auth into Userland (fix deps)
components/python/django/django-PYVER.p5m
components/python/django_openstack_auth/django_openstack_auth-PYVER.p5m
components/python/websockify/websockify-PYVER.p5m
--- a/components/python/django/django-PYVER.p5m	Wed Feb 05 13:50:15 2014 -0800
+++ b/components/python/django/django-PYVER.p5m	Wed Feb 05 14:41:11 2014 -0800
@@ -3508,9 +3508,6 @@
 depend type=require \
     fmri=library/python/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
 
-# force a dependency on docutils; pkgdepend work is needed to flush this out.
-depend type=require fmri=library/python/docutils-$(PYV)
-
 # force a dependency on ipython; pkgdepend work is needed to flush this out.
 depend type=require fmri=library/python/ipython-$(PYV)
 
--- a/components/python/django_openstack_auth/django_openstack_auth-PYVER.p5m	Wed Feb 05 13:50:15 2014 -0800
+++ b/components/python/django_openstack_auth/django_openstack_auth-PYVER.p5m	Wed Feb 05 14:41:11 2014 -0800
@@ -101,7 +101,3 @@
 # force a dependency on the django_openstack_auth package
 depend type=require \
     fmri=library/python/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
-
-# force a dependency on keystoneclient; pkgdepend work is needed to
-# flush this out.
-depend type=require fmri=library/python/keystoneclient-$(PYV)
--- a/components/python/websockify/websockify-PYVER.p5m	Wed Feb 05 13:50:15 2014 -0800
+++ b/components/python/websockify/websockify-PYVER.p5m	Wed Feb 05 14:41:11 2014 -0800
@@ -23,7 +23,8 @@
 # Copyright (c) 2013, 2014, Oracle and/or its affiliates. All rights reserved.
 #
 
-<transform depend type=require fmri=library/python/python-extra-27 -> drop>
+# python-extra is part of python 2.6 only
+<transform depend type=require fmri=library/python-2/python-extra-27 -> drop>
 set name=pkg.fmri \
     value=pkg:/library/python/websockify-$(PYV)@$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
 set name=pkg.summary value="WebSocket to TCP proxy/bridge"
@@ -61,7 +62,7 @@
 
 # force a dependency on python-extra; pkgdepend work is needed to flush this
 # out.
-depend type=require fmri=library/python/python-extra-$(PYV)
+depend type=require fmri=library/python-2/python-extra-$(PYV)
 
 # force a dependency on the websockify package
 depend type=require \