20230898 problem in UTILITY/ELINKS s11u2-sru
authorRich Burridge <rich.burridge@oracle.com>
Fri, 09 Jan 2015 13:28:57 -0800
branchs11u2-sru
changeset 3607 3319d35f11de
parent 3606 9b5dd01a7206
child 3608 bd6da1c6bb63
20230898 problem in UTILITY/ELINKS
components/elinks/patches/init-openssl.patch
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/elinks/patches/init-openssl.patch	Fri Jan 09 13:28:57 2015 -0800
@@ -0,0 +1,14 @@
+Disable SSLv2 and SSLv3 in elinks to "mitigate POODLE vulnerability".
+
+This change will be passed upstream.
+
+--- elinks-0.11.7/src/network/ssl/ssl.c.orig	2014-12-17 12:23:16.239844159 -0800
++++ elinks-0.11.7/src/network/ssl/ssl.c	2015-01-06 05:41:07.668610655 -0800
[email protected]@ -58,6 +58,7 @@
+ 	SSLeay_add_ssl_algorithms();
+ 	context = SSL_CTX_new(SSLv23_client_method());
+ 	SSL_CTX_set_options(context, SSL_OP_ALL);
++	SSL_CTX_set_options(context, SSL_OP_NO_SSLv2 | SSL_OP_NO_SSLv3);
+ 	SSL_CTX_set_default_verify_paths(context);
+ }
+