25305616 RE audits don't like the userland package anymore
authorMike Sullivan <Mike.Sullivan@Oracle.COM>
Mon, 02 Jan 2017 13:37:03 -0800
changeset 7527 352b7a456c30
parent 7526 196c04a6f823
child 7528 456a11fe7b7b
25305616 RE audits don't like the userland package anymore
components/apache24/Makefile
components/apr-util-1_5/Makefile
components/curl/Makefile
components/cyrus-sasl/Makefile
components/desktop/firefox/Makefile
components/desktop/pidgin/Makefile
components/desktop/thunderbird/Makefile
components/gnome/glib-networking/Makefile
components/gnome/glib2/Makefile
components/gnome/gnome-common/Makefile
components/gnome/gnome-doc-utils/Makefile
components/gnome/gtk-doc/Makefile
components/gnome/json-glib/Makefile
components/gnome/libsoup/Makefile
components/gnome/pygtk2/Makefile
components/gtar/Makefile
components/krb5/Makefile
components/libgpg-error/Makefile
components/libpki/Makefile
components/lighttpd/Makefile
components/meld/Makefile
components/mutt/Makefile
components/openldap/Makefile
components/openscap/Makefile
components/pam_pkcs11/Makefile
components/php/php56/Makefile
components/postfix/Makefile
components/python/python-ldap/Makefile
components/sendmail/Makefile
components/serf/Makefile
components/squid/Makefile
components/subversion/Makefile
components/sudo/Makefile
make-rules/cmake.mk
make-rules/puppetmodule.mk
--- a/components/apache24/Makefile	Fri Dec 23 13:56:44 2016 -0800
+++ b/components/apache24/Makefile	Mon Jan 02 13:37:03 2017 -0800
@@ -92,7 +92,6 @@
 REQUIRED_PACKAGES += library/apr-util-15/dbd-sqlite
 REQUIRED_PACKAGES += library/libxml2
 REQUIRED_PACKAGES += library/nghttp2
-REQUIRED_PACKAGES += library/openldap
 REQUIRED_PACKAGES += library/pcre
 REQUIRED_PACKAGES += library/security/openssl
 REQUIRED_PACKAGES += library/security/openssl/openssl-fips-140
--- a/components/apr-util-1_5/Makefile	Fri Dec 23 13:56:44 2016 -0800
+++ b/components/apr-util-1_5/Makefile	Mon Jan 02 13:37:03 2017 -0800
@@ -95,7 +95,7 @@
 REQUIRED_PACKAGES += developer/documentation-tool/doxygen
 REQUIRED_PACKAGES += library/apr-15
 REQUIRED_PACKAGES += library/expat
-REQUIRED_PACKAGES += library/openldap
+$(SOLARIS_11_ONLY)REQUIRED_PACKAGES += library/openldap
 REQUIRED_PACKAGES += shell/ksh93
 REQUIRED_PACKAGES += system/library/math
 REQUIRED_PACKAGES += system/network/ldap/openldap
--- a/components/curl/Makefile	Fri Dec 23 13:56:44 2016 -0800
+++ b/components/curl/Makefile	Mon Jan 02 13:37:03 2017 -0800
@@ -102,7 +102,7 @@
 REQUIRED_PACKAGES += library/libidn
 REQUIRED_PACKAGES += library/libssh2
 REQUIRED_PACKAGES += library/nghttp2
-REQUIRED_PACKAGES += library/openldap
+$(SOLARIS_11_ONLY)REQUIRED_PACKAGES += library/openldap
 REQUIRED_PACKAGES += library/security/openssl
 REQUIRED_PACKAGES += library/zlib
 REQUIRED_PACKAGES += security/kerberos-5
--- a/components/cyrus-sasl/Makefile	Fri Dec 23 13:56:44 2016 -0800
+++ b/components/cyrus-sasl/Makefile	Mon Jan 02 13:37:03 2017 -0800
@@ -188,7 +188,6 @@
 REQUIRED_PACKAGES += archiver/gnu-tar
 REQUIRED_PACKAGES += database/berkeleydb-5
 REQUIRED_PACKAGES += developer/build/automake-115
-REQUIRED_PACKAGES += library/openldap
 REQUIRED_PACKAGES += library/security/openssl
 REQUIRED_PACKAGES += security/kerberos-5
 REQUIRED_PACKAGES += system/network/ldap/openldap
--- a/components/desktop/firefox/Makefile	Fri Dec 23 13:56:44 2016 -0800
+++ b/components/desktop/firefox/Makefile	Mon Jan 02 13:37:03 2017 -0800
@@ -202,8 +202,6 @@
 REQUIRED_PACKAGES += library/desktop/pango
 REQUIRED_PACKAGES += library/desktop/startup-notification
 REQUIRED_PACKAGES += library/glib2
-# Remove once all build machines have library/desktop/startup-notification:
-REQUIRED_PACKAGES += library/gnome/gnome-libs
 REQUIRED_PACKAGES += library/graphics/pixman
 REQUIRED_PACKAGES += library/libevent
 REQUIRED_PACKAGES += library/libffi
--- a/components/desktop/pidgin/Makefile	Fri Dec 23 13:56:44 2016 -0800
+++ b/components/desktop/pidgin/Makefile	Mon Jan 02 13:37:03 2017 -0800
@@ -129,8 +129,6 @@
 REQUIRED_PACKAGES += library/nspr
 REQUIRED_PACKAGES += library/perl-5/xml-parser
 REQUIRED_PACKAGES += library/python/dbus-python-27
-# Remove once all build machines are upgraded to dbus-python-27:
-REQUIRED_PACKAGES += library/python/python-dbus-27
 REQUIRED_PACKAGES += library/security/nss
 REQUIRED_PACKAGES += $(PERL_PKG)
 REQUIRED_PACKAGES += runtime/python-27
--- a/components/desktop/thunderbird/Makefile	Fri Dec 23 13:56:44 2016 -0800
+++ b/components/desktop/thunderbird/Makefile	Mon Jan 02 13:37:03 2017 -0800
@@ -251,8 +251,6 @@
 REQUIRED_PACKAGES += library/desktop/pango
 REQUIRED_PACKAGES += library/desktop/startup-notification
 REQUIRED_PACKAGES += library/glib2
-# Remove once all build machines have library/desktop/startup-notification:
-REQUIRED_PACKAGES += library/gnome/gnome-libs
 REQUIRED_PACKAGES += library/graphics/pixman
 REQUIRED_PACKAGES += library/libevent
 REQUIRED_PACKAGES += library/libffi
--- a/components/gnome/glib-networking/Makefile	Fri Dec 23 13:56:44 2016 -0800
+++ b/components/gnome/glib-networking/Makefile	Mon Jan 02 13:37:03 2017 -0800
@@ -72,9 +72,11 @@
         '-e "/FAIL:/p" ' \
         '-e "/ERROR:/p" '
 
+REQUIRED_PACKAGES += developer/documentation-tool/gtk-doc
+REQUIRED_PACKAGES += developer/intltool
 REQUIRED_PACKAGES += gnome/gsettings-desktop-schemas
-REQUIRED_PACKAGES += developer/documentation-tool/gtk-doc
-REQUIRED_PACKAGES += developer/gnome/gettext
 REQUIRED_PACKAGES += library/glib2
+REQUIRED_PACKAGES += library/gnome/gnome-common
 REQUIRED_PACKAGES += library/gnutls-3
 REQUIRED_PACKAGES += library/libproxy
+REQUIRED_PACKAGES += text/gnu-gettext
--- a/components/gnome/glib2/Makefile	Fri Dec 23 13:56:44 2016 -0800
+++ b/components/gnome/glib2/Makefile	Mon Jan 02 13:37:03 2017 -0800
@@ -114,13 +114,18 @@
         '-e "/FAIL/p" ' \
         '-e "/ERROR/p" '
 
-REQUIRED_PACKAGES += data/docbook
+REQUIRED_PACKAGES += $(PERL_PKG)
+$(SOLARIS_11_ONLY)REQUIRED_PACKAGES += data/docbook
+REQUIRED_PACKAGES += data/docbook/docbook-dtds
+REQUIRED_PACKAGES += data/docbook/docbook-style-dsssl
+REQUIRED_PACKAGES += data/docbook/docbook-style-xsl
+REQUIRED_PACKAGES += data/sgml-common
+REQUIRED_PACKAGES += data/xml-common
 REQUIRED_PACKAGES += developer/documentation-tool/gtk-doc
 REQUIRED_PACKAGES += library/file-monitor/gamin
 REQUIRED_PACKAGES += library/libffi
 REQUIRED_PACKAGES += library/pcre
 REQUIRED_PACKAGES += library/zlib
-REQUIRED_PACKAGES += $(PERL_PKG)
 REQUIRED_PACKAGES += runtime/python-34
 REQUIRED_PACKAGES += system/core-os
 REQUIRED_PACKAGES += system/library/dbus
--- a/components/gnome/gnome-common/Makefile	Fri Dec 23 13:56:44 2016 -0800
+++ b/components/gnome/gnome-common/Makefile	Mon Jan 02 13:37:03 2017 -0800
@@ -46,6 +46,7 @@
 
 REQUIRED_PACKAGES += developer/build/automake-115
 REQUIRED_PACKAGES += developer/documentation-tool/gtk-doc
-REQUIRED_PACKAGES += developer/gnome/gettext
 REQUIRED_PACKAGES += developer/intltool
 REQUIRED_PACKAGES += library/glib2
+REQUIRED_PACKAGES += library/gnome/gnome-common
+REQUIRED_PACKAGES += text/gnu-gettext
--- a/components/gnome/gnome-doc-utils/Makefile	Fri Dec 23 13:56:44 2016 -0800
+++ b/components/gnome/gnome-doc-utils/Makefile	Mon Jan 02 13:37:03 2017 -0800
@@ -54,7 +54,7 @@
 # Assumes GNU xgettext in PATH.
 CONFIGURE_ENV += PATH=$(GNUBIN):$(PATH)
 
-REQUIRED_PACKAGES += data/docbook
+$(SOLARIS_11_ONLY)REQUIRED_PACKAGES += data/docbook
 REQUIRED_PACKAGES += data/docbook/docbook-dtds
 REQUIRED_PACKAGES += data/docbook/docbook-style-dsssl
 REQUIRED_PACKAGES += data/docbook/docbook-style-xsl 
--- a/components/gnome/gtk-doc/Makefile	Fri Dec 23 13:56:44 2016 -0800
+++ b/components/gnome/gtk-doc/Makefile	Mon Jan 02 13:37:03 2017 -0800
@@ -60,7 +60,7 @@
         '-e "/FAIL:/p" ' \
         '-e "/ERROR:/p" '
 
-REQUIRED_PACKAGES += data/docbook
+$(SOLARIS_11_ONLY)REQUIRED_PACKAGES += data/docbook
 REQUIRED_PACKAGES += data/docbook/docbook-dtds
 REQUIRED_PACKAGES += data/docbook/docbook-style-dsssl
 REQUIRED_PACKAGES += data/docbook/docbook-style-xsl 
@@ -68,12 +68,15 @@
 REQUIRED_PACKAGES += data/xml-common
 REQUIRED_PACKAGES += developer/documentation-tool/itstool
 REQUIRED_PACKAGES += developer/documentation-tool/openjade
-REQUIRED_PACKAGES += developer/gnome/gettext
+$(SOLARIS_11_ONLY)REQUIRED_PACKAGES += developer/gnome/gettext
 REQUIRED_PACKAGES += developer/gnome/gnome-doc-utils
+REQUIRED_PACKAGES += developer/intltool
 REQUIRED_PACKAGES += editor/vim
+REQUIRED_PACKAGES += library/gnome/gnome-common
 REQUIRED_PACKAGES += library/libxml2
 REQUIRED_PACKAGES += library/libxslt
 REQUIRED_PACKAGES += library/python/libxml2-27
+REQUIRED_PACKAGES += runtime/perl-522
 REQUIRED_PACKAGES += runtime/python-27
-REQUIRED_PACKAGES += runtime/perl-522
 REQUIRED_PACKAGES += service/gnome/desktop-cache
+REQUIRED_PACKAGES += text/gnu-gettext
--- a/components/gnome/json-glib/Makefile	Fri Dec 23 13:56:44 2016 -0800
+++ b/components/gnome/json-glib/Makefile	Mon Jan 02 13:37:03 2017 -0800
@@ -64,7 +64,11 @@
         '-e "/FAIL:/p" ' \
         '-e "/ERROR:/p" '
 
-REQUIRED_PACKAGES += data/docbook
+REQUIRED_PACKAGES += data/docbook/docbook-dtds
+REQUIRED_PACKAGES += data/docbook/docbook-style-dsssl
+REQUIRED_PACKAGES += data/docbook/docbook-style-xsl
+REQUIRED_PACKAGES += data/sgml-common
+REQUIRED_PACKAGES += data/xml-common
 REQUIRED_PACKAGES += developer/documentation-tool/gtk-doc
 REQUIRED_PACKAGES += library/desktop/gobject/gobject-introspection
 REQUIRED_PACKAGES += library/glib2
--- a/components/gnome/libsoup/Makefile	Fri Dec 23 13:56:44 2016 -0800
+++ b/components/gnome/libsoup/Makefile	Mon Jan 02 13:37:03 2017 -0800
@@ -69,8 +69,10 @@
 
 REQUIRED_PACKAGES += database/sqlite-3
 REQUIRED_PACKAGES += developer/documentation-tool/gtk-doc
-REQUIRED_PACKAGES += developer/gnome/gettext
+REQUIRED_PACKAGES += developer/intltool
 REQUIRED_PACKAGES += library/desktop/gobject/gobject-introspection
 REQUIRED_PACKAGES += library/glib-networking
 REQUIRED_PACKAGES += library/glib2
+REQUIRED_PACKAGES += library/gnome/gnome-common
 REQUIRED_PACKAGES += library/libxml2
+REQUIRED_PACKAGES += text/gnu-gettext
--- a/components/gnome/pygtk2/Makefile	Fri Dec 23 13:56:44 2016 -0800
+++ b/components/gnome/pygtk2/Makefile	Mon Jan 02 13:37:03 2017 -0800
@@ -77,7 +77,7 @@
 REQUIRED_PACKAGES += library/desktop/libglade
 REQUIRED_PACKAGES += library/desktop/pango
 REQUIRED_PACKAGES += library/glib2
-REQUIRED_PACKAGES += library/python/python-extra-27
+REQUIRED_PACKAGES += library/python/numpy-27
 REQUIRED_PACKAGES += runtime/python-27
 
 
--- a/components/gtar/Makefile	Fri Dec 23 13:56:44 2016 -0800
+++ b/components/gtar/Makefile	Mon Jan 02 13:37:03 2017 -0800
@@ -64,5 +64,4 @@
 REQUIRED_PACKAGES += compress/bzip2
 REQUIRED_PACKAGES += compress/gzip
 REQUIRED_PACKAGES += network/ssh
-REQUIRED_PACKAGES += network/openssh
 REQUIRED_PACKAGES += system/core-os
--- a/components/krb5/Makefile	Fri Dec 23 13:56:44 2016 -0800
+++ b/components/krb5/Makefile	Mon Jan 02 13:37:03 2017 -0800
@@ -205,7 +205,6 @@
 
 REQUIRED_PACKAGES += developer/test/dejagnu
 REQUIRED_PACKAGES += library/libedit
-REQUIRED_PACKAGES += library/openldap
 REQUIRED_PACKAGES += library/security/openssl
 REQUIRED_PACKAGES += network/dns/bind
 REQUIRED_PACKAGES += service/network/ldap/openldap
--- a/components/libgpg-error/Makefile	Fri Dec 23 13:56:44 2016 -0800
+++ b/components/libgpg-error/Makefile	Mon Jan 02 13:37:03 2017 -0800
@@ -47,5 +47,3 @@
 COMPONENT_TEST_MASTER = $(COMPONENT_TEST_RESULTS_DIR)/results-all.master
 
 include ../../make-rules/shared-targets.mk
-
-REQUIRED_PACKAGES += consolidation/desktop/desktop-incorporation
--- a/components/libpki/Makefile	Fri Dec 23 13:56:44 2016 -0800
+++ b/components/libpki/Makefile	Mon Jan 02 13:37:03 2017 -0800
@@ -77,7 +77,7 @@
 	'-e "/\# ERROR:/p" '
 
 REQUIRED_PACKAGES += library/libxml2
-REQUIRED_PACKAGES += library/openldap
+$(SOLARIS_11_ONLY)REQUIRED_PACKAGES += library/openldap
 REQUIRED_PACKAGES += library/security/openssl
 REQUIRED_PACKAGES += library/security/openssl/openssl-fips-140
 REQUIRED_PACKAGES += shell/ksh93
--- a/components/lighttpd/Makefile	Fri Dec 23 13:56:44 2016 -0800
+++ b/components/lighttpd/Makefile	Mon Jan 02 13:37:03 2017 -0800
@@ -78,7 +78,7 @@
 REQUIRED_PACKAGES += database/mysql-55
 REQUIRED_PACKAGES += database/mysql-55/library
 endif
-REQUIRED_PACKAGES += library/openldap
+$(SOLARIS_11_ONLY)REQUIRED_PACKAGES += library/openldap
 REQUIRED_PACKAGES += library/pcre
 REQUIRED_PACKAGES += library/security/openssl
 REQUIRED_PACKAGES += library/security/openssl/openssl-fips-140
--- a/components/meld/Makefile	Fri Dec 23 13:56:44 2016 -0800
+++ b/components/meld/Makefile	Mon Jan 02 13:37:03 2017 -0800
@@ -58,8 +58,9 @@
 
 ASLR_MODE = $(ASLR_NOT_APPLICABLE)
 
-REQUIRED_PACKAGES += developer/gnome/gettext
+REQUIRED_PACKAGES += developer/intltool
 REQUIRED_PACKAGES += library/desktop/gtksourceview3
+REQUIRED_PACKAGES += library/gnome/gnome-common
 REQUIRED_PACKAGES += library/python/pycairo-27
 REQUIRED_PACKAGES += library/python/pygtk2-27
 REQUIRED_PACKAGES += runtime/python-27
--- a/components/mutt/Makefile	Fri Dec 23 13:56:44 2016 -0800
+++ b/components/mutt/Makefile	Mon Jan 02 13:37:03 2017 -0800
@@ -66,5 +66,5 @@
 REQUIRED_PACKAGES += $(PERL_PKG)
 REQUIRED_PACKAGES += shell/ksh93
 REQUIRED_PACKAGES += system/library/math
-REQUIRED_PACKAGES += system/library/security/libsasl
+$(SOLARIS_11_ONLY)REQUIRED_PACKAGES += system/library/security/libsasl
 REQUIRED_PACKAGES += system/library/security/libsasl2
--- a/components/openldap/Makefile	Fri Dec 23 13:56:44 2016 -0800
+++ b/components/openldap/Makefile	Mon Jan 02 13:37:03 2017 -0800
@@ -132,7 +132,7 @@
 REQUIRED_PACKAGES += library/security/openssl
 REQUIRED_PACKAGES += shell/ksh93
 REQUIRED_PACKAGES += system/core-os
-REQUIRED_PACKAGES += system/library/security/libsasl
+$(SOLARIS_11_ONLY)REQUIRED_PACKAGES += system/library/security/libsasl
 REQUIRED_PACKAGES += system/library/security/libsasl2
 REQUIRED_PACKAGES += system/network
 REQUIRED_PACKAGES += text/groff/groff-core
--- a/components/openscap/Makefile	Fri Dec 23 13:56:44 2016 -0800
+++ b/components/openscap/Makefile	Mon Jan 02 13:37:03 2017 -0800
@@ -113,7 +113,6 @@
 REQUIRED_PACKAGES += library/glib2
 REQUIRED_PACKAGES += library/libxml2
 REQUIRED_PACKAGES += library/libxslt
-REQUIRED_PACKAGES += library/openldap
 REQUIRED_PACKAGES += library/pcre
 REQUIRED_PACKAGES += $(PERL_PKG)
 REQUIRED_PACKAGES += runtime/python-27
--- a/components/pam_pkcs11/Makefile	Fri Dec 23 13:56:44 2016 -0800
+++ b/components/pam_pkcs11/Makefile	Mon Jan 02 13:37:03 2017 -0800
@@ -63,7 +63,7 @@
 CONFIGURE_OPTIONS += --with-pcsclite=yes
 CONFIGURE_OPTIONS += PCSC_CFLAGS="-I /usr/include/PCSC"
 
-REQUIRED_PACKAGES += library/openldap
+$(SOLARIS_11_ONLY)REQUIRED_PACKAGES += library/openldap
 REQUIRED_PACKAGES += library/security/openssl
 REQUIRED_PACKAGES += library/security/pcsc/pcsclite
 REQUIRED_PACKAGES += shell/bash
--- a/components/php/php56/Makefile	Fri Dec 23 13:56:44 2016 -0800
+++ b/components/php/php56/Makefile	Mon Jan 02 13:37:03 2017 -0800
@@ -129,11 +129,11 @@
 
 REQUIRED_PACKAGES += developer/icu
 REQUIRED_PACKAGES += library/libxml2
-REQUIRED_PACKAGES += library/openldap
+$(SOLARIS_11_ONLY)REQUIRED_PACKAGES += library/openldap
 REQUIRED_PACKAGES += library/security/openssl
 REQUIRED_PACKAGES += system/dtrace
 REQUIRED_PACKAGES += system/library/gcc/gcc-c-runtime
 REQUIRED_PACKAGES += system/library/math
-REQUIRED_PACKAGES += system/management/snmp/net-snmp-57
+REQUIRED_PACKAGES += system/management/snmp/net-snmp
 REQUIRED_PACKAGES += system/network/ldap/openldap
 REQUIRED_PACKAGES += text/gnu-sed
--- a/components/postfix/Makefile	Fri Dec 23 13:56:44 2016 -0800
+++ b/components/postfix/Makefile	Mon Jan 02 13:37:03 2017 -0800
@@ -77,7 +77,7 @@
 REQUIRED_PACKAGES += database/berkeleydb-5
 REQUIRED_PACKAGES += database/sqlite-3
 REQUIRED_PACKAGES += library/icu
-REQUIRED_PACKAGES += library/openldap
+$(SOLARIS_11_ONLY)REQUIRED_PACKAGES += library/openldap
 REQUIRED_PACKAGES += library/pcre
 REQUIRED_PACKAGES += library/security/openssl
 REQUIRED_PACKAGES += shell/ksh93
--- a/components/python/python-ldap/Makefile	Fri Dec 23 13:56:44 2016 -0800
+++ b/components/python/python-ldap/Makefile	Mon Jan 02 13:37:03 2017 -0800
@@ -76,7 +76,7 @@
 
 system-test:    $(SYSTEM_TESTS_NOT_IMPLEMENTED)
 
-REQUIRED_PACKAGES += library/openldap
+$(SOLARIS_11_ONLY)REQUIRED_PACKAGES += library/openldap
 REQUIRED_PACKAGES += library/python/pyasn1-27
 REQUIRED_PACKAGES += library/python/pyasn1-modules-27
 REQUIRED_PACKAGES += system/library
--- a/components/sendmail/Makefile	Fri Dec 23 13:56:44 2016 -0800
+++ b/components/sendmail/Makefile	Mon Jan 02 13:37:03 2017 -0800
@@ -197,7 +197,6 @@
 
 REQUIRED_PACKAGES += database/berkeleydb-5
 REQUIRED_PACKAGES += library/libmilter
-REQUIRED_PACKAGES += library/openldap
 REQUIRED_PACKAGES += library/security/openssl
 REQUIRED_PACKAGES += $(PERL_PKG)
 REQUIRED_PACKAGES += shell/ksh93
--- a/components/serf/Makefile	Fri Dec 23 13:56:44 2016 -0800
+++ b/components/serf/Makefile	Mon Jan 02 13:37:03 2017 -0800
@@ -96,7 +96,7 @@
 REQUIRED_PACKAGES += library/apr-15
 REQUIRED_PACKAGES += library/apr-util-15
 REQUIRED_PACKAGES += library/expat
-REQUIRED_PACKAGES += library/openldap
+$(SOLARIS_11_ONLY)REQUIRED_PACKAGES += library/openldap
 REQUIRED_PACKAGES += library/security/openssl
 REQUIRED_PACKAGES += library/zlib
 REQUIRED_PACKAGES += system/library
--- a/components/squid/Makefile	Fri Dec 23 13:56:44 2016 -0800
+++ b/components/squid/Makefile	Mon Jan 02 13:37:03 2017 -0800
@@ -166,8 +166,8 @@
 REQUIRED_PACKAGES += system/library/security/crypto
 ifeq ($(OS_VERSION),5.11)
 REQUIRED_PACKAGES += system/library/security/gss
+REQUIRED_PACKAGES += system/library/security/libsasl
 endif
-REQUIRED_PACKAGES += system/library/security/libsasl
 REQUIRED_PACKAGES += system/library/security/libsasl2
 REQUIRED_PACKAGES += system/network
 REQUIRED_PACKAGES += system/network/ldap/openldap
--- a/components/subversion/Makefile	Fri Dec 23 13:56:44 2016 -0800
+++ b/components/subversion/Makefile	Mon Jan 02 13:37:03 2017 -0800
@@ -226,6 +226,6 @@
 REQUIRED_PACKAGES += runtime/perl-522
 REQUIRED_PACKAGES += security/kerberos-5
 REQUIRED_PACKAGES += system/library/c++-runtime
-REQUIRED_PACKAGES += system/library/security/libsasl
+$(SOLARIS_11_ONLY)REQUIRED_PACKAGES += system/library/security/libsasl
 REQUIRED_PACKAGES += system/library/security/libsasl2
 
--- a/components/sudo/Makefile	Fri Dec 23 13:56:44 2016 -0800
+++ b/components/sudo/Makefile	Mon Jan 02 13:37:03 2017 -0800
@@ -95,7 +95,7 @@
 
 VISUDO=$(BUILD_DIR_64)/plugins/sudoers/visudo
 
-REQUIRED_PACKAGES += library/openldap
+$(SOLARIS_11_ONLY)REQUIRED_PACKAGES += library/openldap
 REQUIRED_PACKAGES += library/zlib
 REQUIRED_PACKAGES += system/library/security/crypto
 REQUIRED_PACKAGES += system/network/ldap/openldap
--- a/make-rules/cmake.mk	Fri Dec 23 13:56:44 2016 -0800
+++ b/make-rules/cmake.mk	Mon Jan 02 13:37:03 2017 -0800
@@ -80,11 +80,13 @@
 
 REQUIRED_PACKAGES += developer/build/cmake
 REQUIRED_PACKAGES += developer/build/pkg-config
-REQUIRED_PACKAGES += developer/gnome/gettext
 REQUIRED_PACKAGES += developer/gnu-binutils
+REQUIRED_PACKAGES += developer/intltool
+REQUIRED_PACKAGES += library/gnome/gnome-common
 REQUIRED_PACKAGES += system/library
 REQUIRED_PACKAGES += system/linker
 # Most cmake-based components expect GNU versions of these.
 REQUIRED_PACKAGES += text/gawk
+REQUIRED_PACKAGES += text/gnu-gettext
 REQUIRED_PACKAGES += text/gnu-grep
 REQUIRED_PACKAGES += text/gnu-sed
--- a/make-rules/puppetmodule.mk	Fri Dec 23 13:56:44 2016 -0800
+++ b/make-rules/puppetmodule.mk	Mon Jan 02 13:37:03 2017 -0800
@@ -48,4 +48,4 @@
 	$(COMPONENT_POST_INSTALL_ACTION)
 	$(TOUCH) [email protected]
 
-REQUIRED_PACKAGES += system/management/puppet-19
+REQUIRED_PACKAGES += system/management/puppet