16389924 optional consolidation incorporation dependencies should be unlockable s11-update
authorNorm Jacobs <Norm.Jacobs@Oracle.COM>
Thu, 25 Jul 2013 22:11:16 -0700
branchs11-update
changeset 2691 39a54b66e155
parent 2689 4fc7c38f6688
child 2692 ee922fed53a7
16389924 optional consolidation incorporation dependencies should be unlockable
transforms/defaults
--- a/transforms/defaults	Thu Jul 25 07:44:41 2013 -0700
+++ b/transforms/defaults	Thu Jul 25 22:11:16 2013 -0700
@@ -20,7 +20,7 @@
 #
 
 #
-# Copyright (c) 2010, 2012, Oracle and/or its affiliates. All rights reserved.
+# Copyright (c) 2010, 2013, Oracle and/or its affiliates. All rights reserved.
 #
 
 <transform dir path=etc$ -> default group sys>
@@ -123,3 +123,14 @@
 #
 <transform link mediator=python mediator-version=2.6 -> default mediator-priority vendor>
 
+#
+# Add a facet.version-lock.{package} to each 'optional' consolidation
+# incorporation dependency so that we can install without having to
+# mangle the system in some way.
+#
+<transform depend type=optional fmri=(pkg:/)?consolidation/[email protected] -> \
+    default tmp.fmri %{pkg.fmri} >
+<transform depend tmp.fmri=pkg:/(.+)@.*$ -> \
+    default facet.version-lock.%<1> true >
+<transform depend tmp.fmri=.*-> delete tmp.fmri .* >
+