7075763 php dependencies need some further evaluation
authorCraig Mohrman <craig.mohrman@oracle.com>
Wed, 10 Aug 2011 14:25:14 -0700
changeset 465 48a8e911990f
parent 464 08f94c414553
child 466 89ddfe5a3a92
7075763 php dependencies need some further evaluation
components/php-5_2/apache-php5.p5m
components/php-5_2/php-52.p5m
components/php-5_2/php-apc.p5m
components/php-5_2/php-idn.p5m
components/php-5_2/php-memcache.p5m
components/php-5_2/php-mysql.p5m
components/php-5_2/php-pear.p5m
components/php-5_2/php-suhosin.p5m
components/php-5_2/php-tcpwrap.p5m
components/php-5_2/php-xdebug.p5m
--- a/components/php-5_2/apache-php5.p5m	Mon Aug 08 10:30:52 2011 -0700
+++ b/components/php-5_2/apache-php5.p5m	Wed Aug 10 14:25:14 2011 -0700
@@ -53,4 +53,5 @@
     desc="PHP Server 5.2 module for Apache Web Server V2.2" \
     name="PHP Server 5.2 module for Apache Web Server V2.2"
 
+# need generic dependency on PHP itself
 depend fmri=web/[email protected] type=require
--- a/components/php-5_2/php-52.p5m	Mon Aug 08 10:30:52 2011 -0700
+++ b/components/php-5_2/php-52.p5m	Wed Aug 10 14:25:14 2011 -0700
@@ -451,9 +451,3 @@
     name="PHP Server 5.2 (Root)"
 legacy pkg=SUNWphp52u desc="PHP Server Version 5.2" \
     name="PHP Server Version 5.2"
-
-depend fmri=library/[email protected] type=require
-depend fmri=library/libtool/[email protected] type=require
-depend fmri=system/core-os type=require
-depend fmri=system/library/security/gss type=require
-depend fmri=x11/library/[email protected] type=require
--- a/components/php-5_2/php-apc.p5m	Mon Aug 08 10:30:52 2011 -0700
+++ b/components/php-5_2/php-apc.p5m	Wed Aug 10 14:25:14 2011 -0700
@@ -70,4 +70,5 @@
     desc="PHP-APC(3.0.19) extension provides PHP script caching for PHP(5.2)" \
     name="APC extension module for PHP"
 
+# need generic dependency on PHP itself
 depend fmri=web/[email protected] type=require
--- a/components/php-5_2/php-idn.p5m	Mon Aug 08 10:30:52 2011 -0700
+++ b/components/php-5_2/php-idn.p5m	Wed Aug 10 14:25:14 2011 -0700
@@ -58,4 +58,5 @@
     desc="PHP-IDN(0.2.0) extension module for PHP(5.2)" \
     name="IDN extension module for PHP"
 
+# need generic dependency on PHP itself
 depend fmri=web/[email protected] type=require
--- a/components/php-5_2/php-memcache.p5m	Mon Aug 08 10:30:52 2011 -0700
+++ b/components/php-5_2/php-memcache.p5m	Wed Aug 10 14:25:14 2011 -0700
@@ -69,4 +69,5 @@
     desc="PHP-Memcache(2.2.5) extension to store PHP(5.2) sessions in Memcached server" \
     name="Memcache extension module for PHP"
 
+# need generic dependency on PHP itself
 depend fmri=web/[email protected] type=require
--- a/components/php-5_2/php-mysql.p5m	Mon Aug 08 10:30:52 2011 -0700
+++ b/components/php-5_2/php-mysql.p5m	Wed Aug 10 14:25:14 2011 -0700
@@ -69,6 +69,5 @@
     name="MySQL extension module for PHP (Root)" \
     desc="PHP-MySQL extension to connect MySQL database from PHP(5.2) (Root)"
 
-depend fmri=system/library/math type=require
+# need generic dependency on PHP itself
 depend fmri=web/[email protected] type=require
-depend fmri=library/[email protected] type=require
--- a/components/php-5_2/php-pear.p5m	Mon Aug 08 10:30:52 2011 -0700
+++ b/components/php-5_2/php-pear.p5m	Wed Aug 10 14:25:14 2011 -0700
@@ -310,4 +310,5 @@
     desc="Framework and reusable PHP components from PEAR repository for PHP(5.2)" \
     name="PHP Extension and Application Repository Components"
 
+# need generic dependency on PHP itself
 depend fmri=web/[email protected] type=require
--- a/components/php-5_2/php-suhosin.p5m	Mon Aug 08 10:30:52 2011 -0700
+++ b/components/php-5_2/php-suhosin.p5m	Wed Aug 10 14:25:14 2011 -0700
@@ -59,4 +59,5 @@
     desc="PHP-Suhosin(0.9.29) extension to secure PHP(5.2)" \
     name="Suhosin extension module for PHP"
 
+# need generic dependency on PHP itself
 depend fmri=web/[email protected] type=require
--- a/components/php-5_2/php-tcpwrap.p5m	Mon Aug 08 10:30:52 2011 -0700
+++ b/components/php-5_2/php-tcpwrap.p5m	Wed Aug 10 14:25:14 2011 -0700
@@ -59,4 +59,5 @@
     desc="PHP-Tcpwrap(1.1.3) extension module for PHP(5.2)" \
     name="Tcpwrap extension module for PHP"
 
+# need generic dependency on PHP itself
 depend fmri=web/[email protected] type=require
--- a/components/php-5_2/php-xdebug.p5m	Mon Aug 08 10:30:52 2011 -0700
+++ b/components/php-5_2/php-xdebug.p5m	Wed Aug 10 14:25:14 2011 -0700
@@ -61,4 +61,5 @@
     desc="PHP-XDebug(2.0.5) extension for debugging PHP(5.2)" \
     name="XDebug extension module for PHP"
 
+# need generic dependency on PHP itself
 depend fmri=web/[email protected] type=require