24756839 pylint-3.4 traceback - "The 'mccabe' distribution was not found"
authorRich Burridge <rich.burridge@oracle.com>
Thu, 29 Sep 2016 12:45:18 -0700
changeset 7001 49bc9df236c6
parent 7000 22f549e6467a
child 7002 c68461b25ddb
24756839 pylint-3.4 traceback - "The 'mccabe' distribution was not found" 24757583 pylint in missing a run-time dependency for isort
components/python/pylint/patches/01-remove-mccabe.patch
components/python/pylint/pylint-PYVER.p5m
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/pylint/patches/01-remove-mccabe.patch	Thu Sep 29 12:45:18 2016 -0700
@@ -0,0 +1,25 @@
+Remove the pylint mccabe extension until the Python mccabe module is
+available in Userland/Solaris.
+
+These changes will not be sent upstream (and are only temporary).
+
+--- pylint-1.6.4/pylint/__pkginfo__.py.orig	2016-09-29 09:22:05.276892599 +0000
++++ pylint-1.6.4/pylint/__pkginfo__.py	2016-09-29 09:22:15.294658505 +0000
[email protected]@ -19,7 +19,6 @@
+     'astroid>=1.4.5,<1.5.0',
+     'six',
+     'isort >= 4.2.5',
+-    'mccabe',
+ ]
+ 
+ extras_require = {}
+--- pylint-1.6.4/pylint.egg-info/requires.txt.orig	2016-09-29 09:23:04.147211978 +0000
++++ pylint-1.6.4/pylint.egg-info/requires.txt	2016-09-29 09:23:17.057516302 +0000
[email protected]@ -1,7 +1,6 @@
+ astroid>=1.4.5,<1.5.0
+ six
+ isort >= 4.2.5
+-mccabe
+ 
+ [:python_version=="2.7"]
+ configparser
--- a/components/python/pylint/pylint-PYVER.p5m	Thu Sep 29 10:38:55 2016 -0700
+++ b/components/python/pylint/pylint-PYVER.p5m	Thu Sep 29 12:45:18 2016 -0700
@@ -90,7 +90,6 @@
 file path=usr/lib/python$(PYVER)/vendor-packages/pylint/extensions/check_elif.py
 file path=usr/lib/python$(PYVER)/vendor-packages/pylint/extensions/docparams.py
 file path=usr/lib/python$(PYVER)/vendor-packages/pylint/extensions/docstyle.py
-file path=usr/lib/python$(PYVER)/vendor-packages/pylint/extensions/mccabe.py
 file path=usr/lib/python$(PYVER)/vendor-packages/pylint/graph.py
 file path=usr/lib/python$(PYVER)/vendor-packages/pylint/gui.py
 file path=usr/lib/python$(PYVER)/vendor-packages/pylint/interfaces.py
@@ -128,6 +127,9 @@
 # force a dependency on astroid-$(PYV) version 1.4.8
 depend type=require fmri=library/python/astroid-$(PYV)@1.4.8
 
+# force a dependency on isort-$(PYV) version 4.2.5
+depend type=require fmri=library/python/isort-$(PYV)@4.2.5
+
 # force a dependency on logilab-common-$(PYV) version 1.2.2
 depend type=require fmri=library/python/logilab-common-$(PYV)@1.2.2