16997972 crypto package refactoring breaks userland build s11-update
authorMike Sullivan <Mike.Sullivan@Oracle.COM>
Tue, 07 Apr 2015 15:49:29 -0700
branchs11-update
changeset 4067 4be1f488dda8
parent 4058 2c35b27b5cde
child 4072 db0cec748ec0
16997972 crypto package refactoring breaks userland build
components/ksh93/Makefile
components/net-snmp/Makefile
components/pwgen/Makefile
components/samba/samba/Makefile
components/sudo/Makefile
--- a/components/ksh93/Makefile	Tue Mar 31 13:48:00 2015 -0700
+++ b/components/ksh93/Makefile	Tue Apr 07 15:49:29 2015 -0700
@@ -164,3 +164,4 @@
 REQUIRED_PACKAGES += system/core-os
 REQUIRED_PACKAGES += system/library
 REQUIRED_PACKAGES += system/library/math
+REQUIRED_PACKAGES += system/library/security/crypto
--- a/components/net-snmp/Makefile	Tue Mar 31 13:48:00 2015 -0700
+++ b/components/net-snmp/Makefile	Tue Apr 07 15:49:29 2015 -0700
@@ -148,6 +148,7 @@
 REQUIRED_PACKAGES += shell/ksh93
 REQUIRED_PACKAGES += system/core-os
 REQUIRED_PACKAGES += system/library
+REQUIRED_PACKAGES += system/library/security/pkcs11
 REQUIRED_PACKAGES += system/linker
 REQUIRED_PACKAGES += system/management/snmp/net-snmp
 REQUIRED_PACKAGES += system/network
--- a/components/pwgen/Makefile	Tue Mar 31 13:48:00 2015 -0700
+++ b/components/pwgen/Makefile	Tue Apr 07 15:49:29 2015 -0700
@@ -76,3 +76,4 @@
 
 
 REQUIRED_PACKAGES += system/library
+REQUIRED_PACKAGES += system/library/security/crypto
--- a/components/samba/samba/Makefile	Tue Mar 31 13:48:00 2015 -0700
+++ b/components/samba/samba/Makefile	Tue Apr 07 15:49:29 2015 -0700
@@ -247,6 +247,7 @@
 REQUIRED_PACKAGES += system/library/gcc-3-runtime
 REQUIRED_PACKAGES += system/library/gcc-45-runtime
 REQUIRED_PACKAGES += system/library/gcc/gcc-c-runtime
+REQUIRED_PACKAGES += system/library/security/crypto
 REQUIRED_PACKAGES += system/library/security/gss
 REQUIRED_PACKAGES += system/network
 REQUIRED_PACKAGES += system/network/avahi
--- a/components/sudo/Makefile	Tue Mar 31 13:48:00 2015 -0700
+++ b/components/sudo/Makefile	Tue Apr 07 15:49:29 2015 -0700
@@ -104,3 +104,4 @@
 
 REQUIRED_PACKAGES += library/zlib
 REQUIRED_PACKAGES += system/library
+REQUIRED_PACKAGES += system/library/security/crypto