7056124 gcc-3 package should depend on pkg:/system/linker
authorRich Burridge <rich.burridge@oracle.com>
Mon, 21 Nov 2011 17:52:42 -0800
changeset 590 56e37c6e80dd
parent 589 beabcdec3918
child 591 d3cce09912d0
7056124 gcc-3 package should depend on pkg:/system/linker
components/gcc3/gcc-3.p5m
--- a/components/gcc3/gcc-3.p5m	Mon Nov 21 16:45:38 2011 -0800
+++ b/components/gcc3/gcc-3.p5m	Mon Nov 21 17:52:42 2011 -0800
@@ -478,7 +478,17 @@
 
 license gcc.license license="GPLv2"
 
+depend fmri=__TBD pkg.debug.depend.file=usr/bin/ld type=require
 depend fmri=__TBD pkg.debug.depend.file=usr/gnu/bin/as type=require
+depend fmri=__TBD pkg.debug.depend.file=usr/lib/crt1.o type=require
+depend fmri=__TBD pkg.debug.depend.file=usr/lib/crti.o type=require
+depend fmri=__TBD pkg.debug.depend.file=usr/lib/crtn.o type=require
+depend fmri=__TBD pkg.debug.depend.file=usr/lib/values-Xa.o type=require
+depend fmri=__TBD pkg.debug.depend.file=usr/lib/values-Xc.o type=require
+depend fmri=__TBD pkg.debug.depend.file=usr/lib/values-Xs.o type=require
+depend fmri=__TBD pkg.debug.depend.file=usr/lib/values-Xt.o type=require
+depend fmri=__TBD pkg.debug.depend.file=usr/lib/values-xpg4.o type=require
+depend fmri=__TBD pkg.debug.depend.file=usr/lib/values-xpg6.o type=require
 depend fmri=__TBD pkg.debug.depend.file=usr/sfw/lib/libstdc++.so type=require
 
 legacy pkg=SUNWgcc \