24788919 Adjust pylint dependencies to be unversioned
authorRich Burridge <rich.burridge@oracle.com>
Mon, 03 Oct 2016 07:43:49 -0700
changeset 7020 58ca1f0fa3a7
parent 7018 fdf447a07aff
child 7021 0841deb27d32
24788919 Adjust pylint dependencies to be unversioned
components/python/astroid/astroid-PYVER.p5m
components/python/pylint/pylint-PYVER.p5m
--- a/components/python/astroid/astroid-PYVER.p5m	Thu Sep 22 15:38:45 2016 -0700
+++ b/components/python/astroid/astroid-PYVER.p5m	Mon Oct 03 07:43:49 2016 -0700
@@ -196,9 +196,9 @@
 depend type=require \
     fmri=library/python/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
 
-# force a dependency on logilab-common-$(PYV) version 1.2.2
-depend type=require fmri=library/python/logilab-common-$(PYV)@1.2.2
+# force a dependency on logilab-common; pkgdepend work is needed to flush
+# this out.
+depend type=require fmri=library/python/logilab-common-$(PYV)
 
-# force a dependency on the six package
-depend type=require \
-    fmri=library/python/six-$(PYV)@$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
+# force a dependency on six; pkgdepend work is needed to flush this out.
+depend type=require fmri=library/python/six-$(PYV)
--- a/components/python/pylint/pylint-PYVER.p5m	Thu Sep 22 15:38:45 2016 -0700
+++ b/components/python/pylint/pylint-PYVER.p5m	Mon Oct 03 07:43:49 2016 -0700
@@ -124,18 +124,19 @@
 depend type=require \
     fmri=developer/python/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
 
-# force a dependency on astroid-$(PYV) version 1.4.8
-depend type=require fmri=library/python/astroid-$(PYV)@1.4.8
+# force a dependency on astroid; pkgdepend work is needed to flush this out.
+depend type=require fmri=library/python/astroid-$(PYV)
 
-# force a dependency on isort-$(PYV) version 4.2.5
-depend type=require fmri=library/python/isort-$(PYV)@4.2.5
+# force a dependency on isort; pkgdepend work is needed to flush this out.
+depend type=require fmri=library/python/isort-$(PYV)
 
-# force a dependency on logilab-common-$(PYV) version 1.2.2
-depend type=require fmri=library/python/logilab-common-$(PYV)@1.2.2
+# force a dependency on logilab-common; pkgdepend work is needed to flush
+# this out.
+depend type=require fmri=library/python/logilab-common-$(PYV)
 
-# force a dependency on repoze.lru-27 version 0.6 for Python 2.7 only.
-$(PYTHON_2.7_ONLY)depend type=require fmri=library/python/[email protected]
+# force a dependency on repoze.lru-27; pkgdepend work is needed to flush
+# this out.
+$(PYTHON_2.7_ONLY)depend type=require fmri=library/python/repoze.lru-27
 
-# force a dependency on the six package
-depend type=require \
-    fmri=library/python/six-$(PYV)@$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
+# force a dependency on six; pkgdepend work is needed to flush this out.
+depend type=require fmri=library/python/six-$(PYV)