25681843 Update R to version 3.3.3 (fix build)
authorRich Burridge <rich.burridge@oracle.com>
Tue, 18 Apr 2017 15:31:40 -0700
changeset 7905 6488b90294de
parent 7904 c63c09f88833
child 7906 57070a2dbc4f
25681843 Update R to version 3.3.3 (fix build)
components/r/patches/01-fix-zlib-fail.patch
--- a/components/r/patches/01-fix-zlib-fail.patch	Tue Apr 18 15:20:35 2017 -0700
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,28 +0,0 @@
-zlib version check fails
-
-The proper fix is already committed upstream. See:
-
-https://bugs.r-project.org/bugzilla3/show_bug.cgi?id=17204
-
-For now we just patch the configure script to solve the problem.
-When R is updated to version 3.3.3 (CR #25681843), then the real fix will
-take affect and this patch can be removed.
-
---- R-3.3.2/configure.orig	2017-03-16 10:57:21.167034116 +0000
-+++ R-3.3.2/configure	2017-03-16 10:58:12.704864360 +0000
[email protected]@ -35507,10 +35507,11 @@
- #include <string.h>
- #include <zlib.h>
- int main() {
--#ifdef ZLIB_VERSION
--/* Work around Debian bug: it uses 1.2.3.4 even though there was no such
--   version on the master site zlib.net */
--  exit(strncmp(ZLIB_VERSION, "1.2.5", 5) < 0);
-+#ifdef ZLIB_VERNUM
-+  if (ZLIB_VERNUM < 0x1250) {
-+    exit(1);
-+  }
-+  exit(0);
- #else
-   exit(1);
- #endif