PSARC 2014/190 Python 2.6 EOF
authorJohn Beck <John.Beck@Oracle.COM>
Tue, 20 Oct 2015 15:05:05 -0700
changeset 4984 7145b15b7f0d
parent 4983 db2589571faa
child 4985 eed3576cafd0
PSARC 2014/190 Python 2.6 EOF 21136303 Python 2.6 EOF
components/apache2-modules/mod_wsgi/Makefile
components/apache2-modules/mod_wsgi/history
components/apache2-modules/mod_wsgi/mod_wsgi-26-24.p5m
components/apache2-modules/mod_wsgi/mod_wsgi-26.p5m
components/apache2-modules/mod_wsgi/mod_wsgi.p5m
components/asciidoc/Makefile
components/gdb/Makefile
components/git/Makefile
components/graphviz/Makefile
components/graphviz/graphviz-python-26.p5m
components/graphviz/graphviz.p5m
components/graphviz/history
components/gzip/Makefile
components/hplip/Makefile
components/lcms/Makefile
components/lcms/history
components/lcms/lcms-py26.p5m
components/lcms/lcms.p5m
components/libxml2/Makefile
components/libxml2/history
components/libxml2/libxml2-26.p5m
components/libxml2/libxml2.p5m
components/libxslt/Makefile
components/libxslt/history
components/libxslt/libxsl-26.p5m
components/libxslt/libxslt.p5m
components/meld/Makefile
components/mercurial/Makefile
components/mercurial/history
components/meta-packages/history/history
components/net-snmp/Makefile
components/net-snmp/history
components/net-snmp/net-snmp-26.p5m
components/net-snmp/net-snmp-base.p5m
components/nmap/Makefile
components/openscap/Makefile
components/openscap/history
components/openscap/openscap-python-PYVER.p5m
components/openscap/openscap.p5m
components/python/alembic/Makefile
components/python/alembic/history
components/python/amqp/history
components/python/anyjson/history
components/python/argparse/Makefile
components/python/argparse/argparse-26.p5m
components/python/argparse/argparse.license
components/python/argparse/argparse.p5m
components/python/argparse/test/results-2.6-32.master
components/python/babel/Makefile
components/python/babel/history
components/python/barbicanclient/Makefile
components/python/barbicanclient/history
components/python/beautifulsoup4/history
components/python/boto/Makefile
components/python/boto/history
components/python/ceilometerclient/Makefile
components/python/ceilometerclient/history
components/python/cffi/Makefile
components/python/cffi/history
components/python/cheetah/Makefile
components/python/cheetah/history
components/python/cherrypy/Makefile
components/python/cherrypy/history
components/python/cinderclient/history
components/python/cliff/history
components/python/cmd2/history
components/python/cov-core/Makefile
components/python/cov-core/history
components/python/coverage/Makefile
components/python/coverage/history
components/python/cryptography/cryptography-PYVER.p5m
components/python/cryptography/history
components/python/cssutils/Makefile
components/python/cssutils/history
components/python/cx_oracle/Makefile
components/python/d2to1/history
components/python/decorator/history
components/python/django-appconf/Makefile
components/python/django-appconf/history
components/python/django-pyscss/Makefile
components/python/django-pyscss/history
components/python/django/Makefile
components/python/django/history
components/python/django_compressor/Makefile
components/python/django_compressor/history
components/python/django_openstack_auth/Makefile
components/python/django_openstack_auth/history
components/python/dnspython/Makefile
components/python/dnspython/history
components/python/dogpile.cache/history
components/python/dogpile.core/history
components/python/enum/Makefile
components/python/enum/history
components/python/eventlet/history
components/python/filechunkio/history
components/python/formencode/Makefile
components/python/formencode/history
components/python/futures/Makefile
components/python/futures/history
components/python/glance_store/Makefile
components/python/glance_store/history
components/python/glanceclient/Makefile
components/python/glanceclient/history
components/python/greenlet/greenlet-PYVER.p5m
components/python/greenlet/history
components/python/heatclient/Makefile
components/python/heatclient/history
components/python/httplib2/Makefile
components/python/httplib2/history
components/python/imaging/Makefile
components/python/imaging/history
components/python/importlib/Makefile
components/python/importlib/importlib-26.p5m
components/python/importlib/importlib.license
components/python/importlib/importlib.p5m
components/python/iniparse/Makefile
components/python/iniparse/history
components/python/ipaddr/Makefile
components/python/ipaddr/history
components/python/ipython/Makefile
components/python/ipython/history
components/python/ironicclient/Makefile
components/python/ironicclient/history
components/python/iso8601/history
components/python/jinja2/history
components/python/jsonpatch/history
components/python/jsonpointer/history
components/python/jsonrpclib/Makefile
components/python/jsonrpclib/history
components/python/jsonschema/history
components/python/keystoneclient/Makefile
components/python/keystoneclient/history
components/python/keystonemiddleware/Makefile
components/python/keystonemiddleware/history
components/python/kombu/Makefile
components/python/kombu/history
components/python/ldappool/Makefile
components/python/ldappool/history
components/python/ldtp/Makefile
components/python/ldtp/history
components/python/lesscpy/Makefile
components/python/lesscpy/history
components/python/librabbitmq/Makefile
components/python/librabbitmq/history
components/python/lockfile/history
components/python/logutils/history
components/python/m2crypto/Makefile
components/python/m2crypto/history
components/python/mako/history
components/python/markdown/history
components/python/markupsafe/history
components/python/mock/Makefile
components/python/mock/history
components/python/mysql/Makefile
components/python/mysql/history
components/python/netaddr/Makefile
components/python/netaddr/history
components/python/netifaces/history
components/python/networkx/Makefile
components/python/networkx/history
components/python/networkx/networkx-PYVER.p5m
components/python/neutronclient/Makefile
components/python/neutronclient/history
components/python/nose-cover3/Makefile
components/python/nose-cover3/history
components/python/nose/Makefile
components/python/nose/history
components/python/novaclient/history
components/python/oauthlib/history
components/python/ordereddict/Makefile
components/python/ordereddict/ordereddict-26.p5m
components/python/ordereddict/ordereddict.p5m
components/python/oslo.config/history
components/python/oslo.context/history
components/python/oslo.db/Makefile
components/python/oslo.db/history
components/python/oslo.i18n/history
components/python/oslo.messaging/Makefile
components/python/oslo.messaging/history
components/python/oslo.middleware/history
components/python/oslo.serialization/Makefile
components/python/oslo.serialization/history
components/python/oslo.utils/Makefile
components/python/oslo.utils/history
components/python/oslo.vmware/Makefile
components/python/oslo.vmware/history
components/python/osprofiler/Makefile
components/python/osprofiler/history
components/python/paramiko/history
components/python/passlib/history
components/python/paste.deploy/Makefile
components/python/paste.deploy/history
components/python/paste/Makefile
components/python/paste/history
components/python/pbr/history
components/python/pecan/Makefile
components/python/pecan/history
components/python/pep8/Makefile
components/python/pep8/history
components/python/pip/Makefile
components/python/pip/history
components/python/ply/Makefile
components/python/ply/history
components/python/posix_ipc/history
components/python/prettytable/history
components/python/py/history
components/python/pyasn1-modules/history
components/python/pyasn1/history
components/python/pybonjour/history
components/python/pycadf/Makefile
components/python/pycadf/history
components/python/pycountry/history
components/python/pycparser/history
components/python/pycups/Makefile
components/python/pycups/history
components/python/pycurl/Makefile
components/python/pycurl/history
components/python/pydns/Makefile
components/python/pydns/history
components/python/pyflakes/Makefile
components/python/pyflakes/history
components/python/pygments/Makefile
components/python/pygments/history
components/python/pylxml/history
components/python/pyopenssl/history
components/python/pyparsing/history
components/python/pyrabbit/Makefile
components/python/pyrabbit/history
components/python/pyscss/Makefile
components/python/pyscss/history
components/python/pysendfile/history
components/python/pytest-capturelog/history
components/python/pytest-codecheckers/history
components/python/pytest-cov/Makefile
components/python/pytest-cov/history
components/python/pytest/Makefile
components/python/pytest/history
components/python/python-ldap/Makefile
components/python/python-ldap/history
components/python/python-memcached/Makefile
components/python/python-memcached/history
components/python/python26/Makefile
components/python/python26/Makefile.config
components/python/python26/files/pyconfig.h
components/python/python26/llib-lpython26
components/python/python26/patches/Python26-00-filemagic.patch
components/python/python26/patches/Python26-01-solaris-lib-dirs.patch
components/python/python26/patches/Python26-02-pycc.patch
components/python/python26/patches/Python26-03-distutils-pycc.patch
components/python/python26/patches/Python26-04-distutils-log.patch
components/python/python26/patches/Python26-05-isalibs.patch
components/python/python26/patches/Python26-06-write_compiled_module-atomic.patch
components/python/python26/patches/Python26-07-dtrace.patch
components/python/python26/patches/Python26-08-ctypes.patch
components/python/python26/patches/Python26-09-ucred.patch
components/python/python26/patches/Python26-10-gethostname.patch
components/python/python26/patches/Python26-11-dlpi.patch
components/python/python26/patches/Python26-12-encoding-alias.patch
components/python/python26/patches/Python26-13-cflags.patch
components/python/python26/patches/Python26-14-ctypes-util-find-library.patch
components/python/python26/patches/Python26-15-getcwd.patch
components/python/python26/patches/Python26-16-privrbac.patch
components/python/python26/patches/Python26-17-netpacket-packet-h.patch
components/python/python26/patches/Python26-18-readline.patch
components/python/python26/patches/Python26-19-ext-stdio.patch
components/python/python26/patches/Python26-20-py_db.patch
components/python/python26/patches/Python26-23-none-on-connect.patch
components/python/python26/patches/Python26-24-makedev.patch
components/python/python26/patches/Python26-25-closerange.patch
components/python/python26/patches/Python26-25-studio-profile.patch
components/python/python26/patches/Python26-26-pybench.patch
components/python/python26/patches/Python26-27-get_wch.patch
components/python/python26/patches/Python26-28-pep263.patch
components/python/python26/patches/Python26-29-ossaudiodev.patch
components/python/python26/patches/Python26-30-pycc.patch
components/python/python26/patches/Python26-31-CVE-2013-4238.patch
components/python/python26/patches/Python26-32-osconf-long.patch
components/python/python26/patches/Python26-33-recvfrom_into.patch
components/python/python26/patches/Python26-34-test_posix.patch
components/python/python26/patches/Python26-35-test_pwd.patch
components/python/python26/patches/Python26-36-buffer-overflow.patch
components/python/python26/patches/Python26-37-multiproc-race.patch
components/python/python26/patches/Python26-38-disable-sslv3.patch
components/python/python26/patches/Python26-39-smtplib_readline.patch
components/python/python26/python-26-tests.p5m
components/python/python26/python-26.p5m
components/python/python26/python26.license
components/python/python26/tkinter-26.p5m
components/python/python27/python-27.p5m
components/python/pytz/history
components/python/pywbem/Makefile
components/python/pywbem/history
components/python/pyyaml/history
components/python/pyyaml/pyyaml-PYVER.p5m
components/python/quantumclient/Makefile
components/python/quantumclient/history
components/python/repoze.lru/history
components/python/requests/Makefile
components/python/requests/history
components/python/retrying/history
components/python/rfc3986/Makefile
components/python/rfc3986/history
components/python/routes/history
components/python/saharaclient/Makefile
components/python/saharaclient/history
components/python/scp/history
components/python/setuptools-git/history
components/python/setuptools/history
components/python/simplegeneric/history
components/python/simplejson/history
components/python/simplejson/simplejson-PYVER.p5m
components/python/singledispatch/Makefile
components/python/singledispatch/history
components/python/six/history
components/python/sqlalchemy-migrate/Makefile
components/python/sqlalchemy-migrate/history
components/python/sqlalchemy/history
components/python/stevedore/history
components/python/suds/Makefile
components/python/suds/history
components/python/swiftclient/Makefile
components/python/swiftclient/history
components/python/taskflow/Makefile
components/python/taskflow/history
components/python/tempita/history
components/python/tox/Makefile
components/python/tox/history
components/python/troveclient/Makefile
components/python/troveclient/history
components/python/twisted-web2/Makefile
components/python/twisted-web2/history
components/python/twisted/Makefile
components/python/twisted/history
components/python/unittest2/Makefile
components/python/unittest2/license.txt
components/python/unittest2/unittest2-26.p5m
components/python/unittest2/unittest2.p5m
components/python/virtualenv/Makefile
components/python/virtualenv/history
components/python/waitress/Makefile
components/python/waitress/history
components/python/warlock/history
components/python/webob/history
components/python/websockify/Makefile
components/python/websockify/history
components/python/websockify/websockify-PYVER.p5m
components/python/webtest/Makefile
components/python/webtest/history
components/python/wsme/Makefile
components/python/wsme/history
components/python/xattr/Makefile
components/python/xattr/history
components/python/xattr/xattr-PYVER.p5m
components/python/zope-interface/Makefile
components/python/zope-interface/history
components/rdiff-backup/Makefile
components/rdiff-backup/history
components/subversion/Makefile
components/texinfo/Makefile
make-rules/ips.mk
make-rules/setup.py.mk
make-rules/shared-macros.mk
--- a/components/apache2-modules/mod_wsgi/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/apache2-modules/mod_wsgi/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -43,10 +43,8 @@
 
 APACHE_USR_PREFIX = /usr/apache2/
 
-VARIANT_AP_22_PY26 = $(BUILD_DIR)/apache22-python26
 VARIANT_AP_22_PY27 = $(BUILD_DIR)/apache22-python27
 VARIANT_AP_22_PY34 = $(BUILD_DIR)/apache22-python34
-VARIANT_AP_24_PY26 = $(BUILD_DIR)/apache24-python26
 VARIANT_AP_24_PY27 = $(BUILD_DIR)/apache24-python27
 VARIANT_AP_24_PY34 = $(BUILD_DIR)/apache24-python34
 
@@ -58,8 +56,6 @@
 $(BUILD_DIR)/apache22-%/$(MACH64)/.configured: APXS=$(APACHE_USR_PREFIX)/2.2/bin/$(MACH64)/apxs
 $(BUILD_DIR)/apache24-%/$(MACH64)/.configured: APXS=$(APACHE_USR_PREFIX)/2.4/bin/apxs
 
-$(BUILD_DIR)/apache2%-python26/$(MACH32)/.configured: PYTHON=$(PYTHON.2.6.32)
-$(BUILD_DIR)/apache2%-python26/$(MACH64)/.configured: PYTHON=$(PYTHON.2.6.64)
 $(BUILD_DIR)/apache2%-python27/$(MACH32)/.configured: PYTHON=$(PYTHON.2.7.32)
 $(BUILD_DIR)/apache2%-python27/$(MACH64)/.configured: PYTHON=$(PYTHON.2.7.64)
 $(BUILD_DIR)/apache2%-python34/$(MACH32)/.configured: PYTHON=$(PYTHON.3.4.32)
@@ -82,7 +78,6 @@
 
 system-test:	$(NO_TESTS)
 
-REQUIRED_PACKAGES += runtime/python-26
 REQUIRED_PACKAGES += runtime/python-27
 REQUIRED_PACKAGES += runtime/python-34
 REQUIRED_PACKAGES += system/library
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/apache2-modules/mod_wsgi/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,2 @@
+web/server/apache-22/module/[email protected]
+web/server/apache-24/module/[email protected]
--- a/components/apache2-modules/mod_wsgi/mod_wsgi-26-24.p5m	Tue Oct 20 05:38:14 2015 -0700
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,43 +0,0 @@
-#
-# CDDL HEADER START
-#
-# The contents of this file are subject to the terms of the
-# Common Development and Distribution License (the "License").
-# You may not use this file except in compliance with the License.
-#
-# You can obtain a copy of the license at usr/src/OPENSOLARIS.LICENSE
-# or http://www.opensolaris.org/os/licensing.
-# See the License for the specific language governing permissions
-# and limitations under the License.
-#
-# When distributing Covered Code, include this CDDL HEADER in each
-# file and include the License file at usr/src/OPENSOLARIS.LICENSE.
-# If applicable, add the following below this CDDL HEADER, with the
-# fields enclosed by brackets "[]" replaced with your own identifying
-# information: Portions Copyright [yyyy] [name of copyright owner]
-#
-# CDDL HEADER END
-#
-
-#
-# Copyright (c) 2014, 2015, Oracle and/or its affiliates. All rights reserved.
-#
-
-set name=pkg.fmri \
-    value=pkg:/web/server/apache-24/module/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
-set name=pkg.summary \
-    value="Python 2.6 mod_wsgi plugin for Apache Web Server v2.4"
-set name=com.oracle.info.description \
-    value="the Python 2.6 mod_wsgi plugin for Apache Web Server v2.4"
-set name=com.oracle.info.tpno value=$(TPNO)
-set name=info.classification \
-    value="org.opensolaris.category.2008:Web Services/Application and Web Servers"
-set name=info.source-url value=$(COMPONENT_ARCHIVE_URL)
-set name=info.upstream-url value=$(COMPONENT_PROJECT_URL)
-set name=org.opensolaris.arc-caseid value=PSARC/2014/253
-set name=org.opensolaris.consolidation value=$(CONSOLIDATION)
-file path=usr/apache2/2.4/libexec/mod_wsgi-2.6.so \
-    pkg.linted.userland.action001.2=true
-link path=usr/apache2/2.4/libexec/mod_wsgi.so target=mod_wsgi-2.6.so \
-    mediator=python mediator-priority=vendor mediator-version=2.6
-license mod_wsgi.license license=Apache2.0
--- a/components/apache2-modules/mod_wsgi/mod_wsgi-26.p5m	Tue Oct 20 05:38:14 2015 -0700
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,45 +0,0 @@
-#
-# CDDL HEADER START
-#
-# The contents of this file are subject to the terms of the
-# Common Development and Distribution License (the "License").
-# You may not use this file except in compliance with the License.
-#
-# You can obtain a copy of the license at usr/src/OPENSOLARIS.LICENSE
-# or http://www.opensolaris.org/os/licensing.
-# See the License for the specific language governing permissions
-# and limitations under the License.
-#
-# When distributing Covered Code, include this CDDL HEADER in each
-# file and include the License file at usr/src/OPENSOLARIS.LICENSE.
-# If applicable, add the following below this CDDL HEADER, with the
-# fields enclosed by brackets "[]" replaced with your own identifying
-# information: Portions Copyright [yyyy] [name of copyright owner]
-#
-# CDDL HEADER END
-#
-
-#
-# Copyright (c) 2012, 2015, Oracle and/or its affiliates. All rights reserved.
-#
-
-set name=pkg.fmri \
-    value=pkg:/web/server/apache-22/module/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
-set name=pkg.summary \
-    value="Python 2.6 mod_wsgi plugin for Apache Web Server v2.2"
-set name=com.oracle.info.description \
-    value="the Python 2.6 mod_wsgi plugin for Apache Web Server v2.2"
-set name=com.oracle.info.tpno value=$(TPNO)
-set name=info.classification \
-    value="org.opensolaris.category.2008:Web Services/Application and Web Servers"
-set name=info.source-url value=$(COMPONENT_ARCHIVE_URL)
-set name=info.upstream-url value=$(COMPONENT_PROJECT_URL)
-set name=org.opensolaris.arc-caseid value=PSARC/2012/162
-set name=org.opensolaris.consolidation value=$(CONSOLIDATION)
-file path=usr/apache2/2.2/libexec/$(MACH64)/mod_wsgi-2.6.so
-link path=usr/apache2/2.2/libexec/$(MACH64)/mod_wsgi.so target=mod_wsgi-2.6.so \
-    mediator=python mediator-priority=vendor mediator-version=2.6
-file path=usr/apache2/2.2/libexec/mod_wsgi-2.6.so
-link path=usr/apache2/2.2/libexec/mod_wsgi.so target=mod_wsgi-2.6.so \
-    mediator=python mediator-priority=vendor mediator-version=2.6
-license mod_wsgi.license license=Apache2.0
--- a/components/apache2-modules/mod_wsgi/mod_wsgi.p5m	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/apache2-modules/mod_wsgi/mod_wsgi.p5m	Tue Oct 20 15:05:05 2015 -0700
@@ -35,9 +35,6 @@
 set name=org.opensolaris.arc-caseid value=PSARC/2012/162
 set name=org.opensolaris.consolidation value=$(CONSOLIDATION)
 depend type=conditional \
-    fmri=web/server/apache-22/module/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION) \
-    predicate=runtime/python-26
-depend type=conditional \
     fmri=web/server/apache-22/module/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION) \
     predicate=runtime/python-27
 depend type=conditional \
--- a/components/asciidoc/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/asciidoc/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -120,8 +120,6 @@
 
 system-test:    configure $(SYSTEM_TEST_64)
 
-
 REQUIRED_PACKAGES += library/libxml2
 REQUIRED_PACKAGES += library/libxslt
-REQUIRED_PACKAGES += runtime/python-26
 REQUIRED_PACKAGES += web/browser/lynx
--- a/components/gdb/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/gdb/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -147,7 +147,6 @@
 REQUIRED_PACKAGES += library/ncurses
 REQUIRED_PACKAGES += library/readline
 REQUIRED_PACKAGES += library/zlib
-REQUIRED_PACKAGES += runtime/python-26
 REQUIRED_PACKAGES += shell/ksh93
 REQUIRED_PACKAGES += system/library
 REQUIRED_PACKAGES += system/library/math
--- a/components/git/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/git/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -52,8 +52,6 @@
 include $(WS_MAKE_RULES)/configure.mk
 include $(WS_MAKE_RULES)/ips.mk
 
-PYTHON_VERSION =	2.7
-
 PKG_HARDLINKS +=	usr/lib/git-core/git-cherry-pick
 PKG_HARDLINKS +=	usr/lib/git-core/git-remote-ftps
 
--- a/components/graphviz/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/graphviz/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -57,11 +57,9 @@
 CONFIGURE_ENV +=	CFLAGS="$(CFLAGS)"
 CONFIGURE_ENV +=	CXXFLAGS="$(CXXFLAGS)"
 # Make sure to use the right python, depending on the 32/64-bit build.
-CONFIGURE_ENV +=	PYTHON26=$(PYTHON.2.6)
 CONFIGURE_ENV +=	PYTHON27=$(PYTHON.2.7)
 CONFIGURE_OPTIONS +=	--without-included-ltdl
 CONFIGURE_OPTIONS +=	--enable-python=no
-CONFIGURE_OPTIONS +=	--enable-python26=yes
 CONFIGURE_OPTIONS +=	--enable-python27=yes
 CONFIGURE_OPTIONS +=	--x-libraries=$(CONFIGURE_LIBDIR.$(BITS))
 
@@ -96,7 +94,6 @@
 
 install:	$(INSTALL_32_and_64)
 	env LD_LIBRARY_PATH=$(PROTO_DIR)/usr/lib GVBINDIR=$(PROTO_DIR)/usr/lib/graphviz $(PROTO_DIR)/usr/bin/dot -c
-	$(PYTHON.2.6.32) -m compileall $(PROTO_DIR)/$(PYTHON.2.6.VENDOR_PACKAGES)
 	$(PYTHON.2.7.32) -m compileall $(PROTO_DIR)/$(PYTHON.2.7.VENDOR_PACKAGES)
 
 # The test infrastructure doesn't run in a VPATHed environment.
--- a/components/graphviz/graphviz-python-26.p5m	Tue Oct 20 05:38:14 2015 -0700
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,53 +0,0 @@
-#
-# CDDL HEADER START
-#
-# The contents of this file are subject to the terms of the
-# Common Development and Distribution License (the "License").
-# You may not use this file except in compliance with the License.
-#
-# You can obtain a copy of the license at usr/src/OPENSOLARIS.LICENSE
-# or http://www.opensolaris.org/os/licensing.
-# See the License for the specific language governing permissions
-# and limitations under the License.
-#
-# When distributing Covered Code, include this CDDL HEADER in each
-# file and include the License file at usr/src/OPENSOLARIS.LICENSE.
-# If applicable, add the following below this CDDL HEADER, with the
-# fields enclosed by brackets "[]" replaced with your own identifying
-# information: Portions Copyright [yyyy] [name of copyright owner]
-#
-# CDDL HEADER END
-#
-# Copyright (c) 2011, 2015, Oracle and/or its affiliates. All rights reserved.
-#
-
-<transform file path=usr.*/man/.+ -> default mangler.man.stability volatile>
-#
-set name=pkg.fmri \
-    value=pkg:/image/graphviz/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
-set name=pkg.summary value="Python 2.6 bindings for Graphviz"
-set name=com.oracle.info.description value="Python 2.6 bindings for Graphviz"
-set name=com.oracle.info.tpno value=$(TPNO)
-set name=info.classification \
-    value="org.opensolaris.category.2008:Applications/System Utilities"
-set name=info.source-url value=$(COMPONENT_ARCHIVE_URL)
-set name=info.upstream-url value=$(COMPONENT_PROJECT_URL)
-set name=org.opensolaris.arc-caseid value=PSARC/2011/269
-set name=org.opensolaris.consolidation value=$(CONSOLIDATION)
-#
-link path=usr/lib/$(MACH64)/graphviz/python26/_gv.so target=libgv_python26.so
-file path=usr/lib/$(MACH64)/graphviz/python26/libgv_python26.so
-link path=usr/lib/graphviz/python26/_gv.so target=libgv_python26.so
-file path=usr/lib/graphviz/python26/gv.py pkg.tmp.autopyc=false
-file path=usr/lib/graphviz/python26/libgv_python26.so
-link path=usr/lib/python2.6/vendor-packages/64/_gv.so \
-    target=../../../$(MACH64)/graphviz/python26/libgv_python26.so
-link path=usr/lib/python2.6/vendor-packages/_gv.so \
-    target=../../graphviz/python26/libgv_python26.so
-link path=usr/lib/python2.6/vendor-packages/gv.py \
-    target=../../graphviz/python26/gv.py
-file path=usr/lib/python2.6/vendor-packages/gv.pyc
-file usr/share/man/man3/gv.3python path=usr/share/man/man3/gv-python.3
-#
-license COPYING license=EPL1.0
-license graphviz.license.extra license="Other Notices"
--- a/components/graphviz/graphviz.p5m	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/graphviz/graphviz.p5m	Tue Oct 20 15:05:05 2015 -0700
@@ -529,9 +529,6 @@
     fmri=image/graphviz/[email protected]$(IPS_COMPONENT_VERSION) \
     predicate=web/php-53
 depend type=conditional \
-    fmri=image/graphviz/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION) \
-    predicate=runtime/python-26
-depend type=conditional \
     fmri=image/graphviz/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION) \
     predicate=runtime/python-27
 depend type=conditional \
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/graphviz/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+image/graphviz/[email protected]
--- a/components/gzip/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/gzip/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -106,7 +106,6 @@
 system-test:    configure $(SYSTEM_TEST_64)
 
 
-REQUIRED_PACKAGES += runtime/python-26
 REQUIRED_PACKAGES += runtime/python-27
 REQUIRED_PACKAGES += shell/bash
 REQUIRED_PACKAGES += system/library
--- a/components/hplip/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/hplip/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -48,8 +48,6 @@
 
 ROOTPPDCACHE =  $(PROTO_DIR)/usr/lib/lp/caches/SUNWhpijs.cache
 
-PYTHON_VERSION = 2.7
-
 # common configure options
 CONFIGURE_OPTIONS +=	--localedir=$(CONFIGURE_LOCALEDIR)
 CONFIGURE_OPTIONS +=	--disable-pp-build
--- a/components/lcms/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/lcms/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -61,10 +61,6 @@
 CXXFLAGS += -features=extensions,nestedaccess,tmplrefstatic
 CXXFLAGS += -template=geninlinefuncs
 
-# When 2.6 goes away, we can remove the version line below, as well as the
-# COMPONENT_POST_{CONFIGURE,INSTALL_ACTION} lines below.
-PYTHON_VERSION=2.6
-
 CONFIGURE_ENV += CFLAGS="$(CFLAGS)"
 CONFIGURE_ENV += CXXFLAGS="$(CXXFLAGS)"
 CONFIGURE_ENV += PYTHON="$(PYTHON)"
@@ -91,16 +87,6 @@
     $(RM) -f $(SOURCE_DIR)/include/icc34.h ; \
     $(CP) -p include/icc34.h $(SOURCE_DIR)/include/ )
 
-# After we have configured, make a copy of the python bits so we
-# can build separate python 2.7 support.
-COMPONENT_POST_CONFIGURE_ACTION += ; (cd $(@D) ; cp -rp python python2.7 ; \
-	 		$(GSED) -i -e 's/2[.]6/2.7/g' python2.7/Makefile)
-
-# After we have built/installed lcms, rebuild/install the python
-# support for python 2.7
-COMPONENT_POST_INSTALL_ACTION = \
-    (cd $(@D)/python2.7 ; $(GMAKE) $(COMPONENT_INSTALL_ARGS) install)
-
 LINT_FLAGS += -I$(COMPONENT_DIR)/$(COMPONENT_SRC)/include
 
 configure:	$(CONFIGURE_32_and_64)
@@ -108,7 +94,6 @@
 build: $(BUILD_32_and_64)
 
 install: $(INSTALL_32_and_64)
-	$(PYTHON.2.6.32) -m compileall $(PROTO_DIR)/usr/lib/python2.6/vendor-packages
 	$(PYTHON.2.7.32) -m compileall $(PROTO_DIR)/usr/lib/python2.7/vendor-packages
 
 
@@ -119,7 +104,6 @@
 REQUIRED_PACKAGES += image/library/libjpeg
 REQUIRED_PACKAGES += image/library/libtiff
 REQUIRED_PACKAGES += library/lcms
-REQUIRED_PACKAGES += runtime/python-26
 REQUIRED_PACKAGES += runtime/python-27
 REQUIRED_PACKAGES += system/library
 REQUIRED_PACKAGES += system/library/c++-runtime
--- a/components/lcms/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/lcms/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,2 +1,3 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/lcms-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/lcms-27
+library/python/[email protected]
--- a/components/lcms/lcms-py26.p5m	Tue Oct 20 05:38:14 2015 -0700
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,50 +0,0 @@
-#
-# CDDL HEADER START
-#
-# The contents of this file are subject to the terms of the
-# Common Development and Distribution License (the "License").
-# You may not use this file except in compliance with the License.
-#
-# You can obtain a copy of the license at usr/src/OPENSOLARIS.LICENSE
-# or http://www.opensolaris.org/os/licensing.
-# See the License for the specific language governing permissions
-# and limitations under the License.
-#
-# When distributing Covered Code, include this CDDL HEADER in each
-# file and include the License file at usr/src/OPENSOLARIS.LICENSE.
-# If applicable, add the following below this CDDL HEADER, with the
-# fields enclosed by brackets "[]" replaced with your own identifying
-# information: Portions Copyright [yyyy] [name of copyright owner]
-#
-# CDDL HEADER END
-#
-# Copyright (c) 2012, 2015, Oracle and/or its affiliates. All rights reserved.
-#
-<transform file path=usr.*/man/.+ -> default mangler.man.stability uncommitted>
-set name=pkg.fmri \
-    value=pkg:/library/python/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
-set name=pkg.summary \
-    value="Python 2.6 bindings for the Little Color Management System"
-set name=com.oracle.info.description \
-    value="the Python 2.6 bindings for the Little Color Management System"
-set name=com.oracle.info.tpno value=$(TPNO)
-set name=info.classification \
-    value=org.opensolaris.category.2008:System/Libraries
-set name=info.source-url value=$(COMPONENT_ARCHIVE_URL)
-set name=info.upstream-url value=$(COMPONENT_PROJECT_URL)
-set name=org.opensolaris.arc-caseid value=PSARC/2008/071
-set name=org.opensolaris.consolidation value=$(CONSOLIDATION)
-#
-#
-file path=usr/lib/python2.6/vendor-packages/64/_lcms.so
-file path=usr/lib/python2.6/vendor-packages/_lcms.so
-file path=usr/lib/python2.6/vendor-packages/lcms.py
-#
-license lcms.license license=MIT
-
-# force the rename with an optional dependency on the old name
-depend type=optional fmri=library/python-2/[email protected],5.12-5.12.0.0.0.41.0
-
-# force a dependency on the Python 2.6 runtime
-depend type=require fmri=__TBD pkg.debug.depend.file=python2.6 \
-    pkg.debug.depend.path=usr/bin
--- a/components/lcms/lcms.p5m	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/lcms/lcms.p5m	Tue Oct 20 15:05:05 2015 -0700
@@ -66,8 +66,5 @@
 #
 license lcms.license license=MIT
 depend type=conditional \
-    fmri=library/python/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION) \
-    predicate=runtime/python-26
-depend type=conditional \
     fmri=library/python/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION) \
     predicate=runtime/python-27
--- a/components/libxml2/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/libxml2/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -53,9 +53,6 @@
 CFLAGS +=	$(CPP_LARGEFILES)
 LDFLAGS +=	$(LD_Z_DEFS) $(LD_Z_TEXT) -lpthread
 
-# Once Python 2.6 goes away, the various POST_*_ACTIONs below can be simplified.
-PYTHON_VERSION=2.6
-
 CONFIGURE_OPTIONS += --disable-static
 CONFIGURE_OPTIONS += --with-pic
 CONFIGURE_OPTIONS += --with-threads
@@ -72,8 +69,8 @@
 # test separate python 2.7 and 3.4 support.  Note for 3.4: .py files need to
 # go in .../vendor-packages (whether building 32-bit or 64-bit) whereas .so
 # files need to go in .../vendor-packages for 32-bit but .../vendor-packages/64
-# for 64-bit.  For 2.6 and 2.7, Python is built 32- and 64-bit, so .py files
-# end up in both places even though only the 32-bit location is needed, but the
+# for 64-bit.  For 2.7, Python is built 32- and 64-bit, so .py files end
+# up in both places even though only the 32-bit location is needed, but the
 # superfluous files in the proto area are harmless; meanwhile, the .so files
 # end up in their proper 32- and 64-bit locations.  But Python 3.4 is built
 # 64-bit only, so we have an extra sed edit below to force the .py files into
@@ -82,38 +79,36 @@
 # where it belongs.  Further, Python 3.4 needs an extra 'm' on the link and
 # include paths, plus a tweak to the binary path; see PEP 3149 for details.
 COMPONENT_POST_CONFIGURE_ACTION = \
-    (cd $(@D) ; cp -rp python python2.7 ; \
-    $(GSED) -i -e 's/2[.]6/2.7/g' `find python2.7 -name Makefile` ; \
-     cd $(@D) ; cp -rp python python3.4 ; \
-    $(GSED) -i -e 's|-lpython2[.]6|-lpython3.4m|' \
-     -e 's|usr/bin/$(MACH64)/python2[.]6|usr/bin/python3.4m|' \
-     -e 's|usr/include/python2[.]6|usr/include/python3.4m|' \
-     -e 's/2[.]6/3.4/g' -e 's|vendor-packages/64|vendor-packages|' \
+    (cd $(@D) ; cp -rp python python3.4 ; \
+    $(GSED) -i -e 's|-lpython2[.]7|-lpython3.4m|' \
+     -e 's|usr/bin/$(MACH64)/python2[.]7|usr/bin/python3.4m|' \
+     -e 's|usr/include/python2[.]7|usr/include/python3.4m|' \
+     -e 's/2[.]7/3.4/g' -e 's|vendor-packages/64|vendor-packages|' \
      `find python3.4 -name Makefile` ; \
 )
 
 # After we have built/installed libxml2, build/install the python
-# support for python 2.7 and 3.4
+# support for python 3.4
 COMPONENT_POST_INSTALL_ACTION = \
-    (cd $(@D)/python2.7 ; $(GMAKE) $(COMPONENT_INSTALL_ARGS) install ; \
-     [ $(BITS) -eq 64 ] && cd $(@D)/python3.4 ; \
-     $(GMAKE) $(COMPONENT_INSTALL_ARGS) install)
+    ( if [ $(BITS) -eq 64 ]; then \
+	cd $(@D)/python3.4 ; \
+	$(GMAKE) $(COMPONENT_INSTALL_ARGS) install ; \
+     else \
+	true ; \
+     fi )
 
-# It's nice to test also python 2.7 and 3.4 modules.
+# It's also nice to test python 3.4 modules.
 COMPONENT_POST_TEST_ACTION = \
-    (cd $(@D)/python2.7 ; $(GMAKE) $(COMPONENT_TEST_ARGS) test ; \
-     [ $(BITS) -eq 64 ] && cd $(@D)/python3.4 ; \
-     $(GMAKE) $(COMPONENT_TEST_ARGS) test)
+    ([ $(BITS) -eq 64 ] && (cd $(@D)/python3.4 ; \
+     $(GMAKE) $(COMPONENT_TEST_ARGS) test))
 
 # We have patched our 64 bit python so it will search for modules only in
 # '64/' directories. Now we need to provide one. Otherwise python will
 # end up using libxml2mod.so installed on system.
 $(BUILD_DIR)/$(MACH64)/.tested: COMPONENT_PRE_TEST_ACTION = ( \
     $(MKDIR) $(@D)/python/.libs/64 \
-             $(@D)/python2.7/.libs/64 \
              $(@D)/python3.4/.libs/64; \
     $(SYMLINK) ../libxml2mod.so $(@D)/python/.libs/64/libxml2mod.so; \
-    $(SYMLINK) ../libxml2mod.so $(@D)/python2.7/.libs/64/libxml2mod.so; \
     $(SYMLINK) ../libxml2mod.so $(@D)/python3.4/.libs/64/libxml2mod.so);
 
 COMPONENT_PRE_TEST_ACTION += \
@@ -136,7 +131,6 @@
 build:		$(BUILD_32_and_64)
 
 install:	$(INSTALL_32_and_64)
-	$(PYTHON.2.6.32) -m compileall $(PROTO_DIR)/usr/lib/python2.6/vendor-packages
 	$(PYTHON.2.7.32) -m compileall $(PROTO_DIR)/usr/lib/python2.7/vendor-packages
 	$(PYTHON.3.4.64) -m compileall $(PROTO_DIR)/usr/lib/python3.4/vendor-packages
 
@@ -147,7 +141,6 @@
 
 REQUIRED_PACKAGES += library/libxml2
 REQUIRED_PACKAGES += library/zlib
-REQUIRED_PACKAGES += runtime/python-26
 REQUIRED_PACKAGES += runtime/python-27
 REQUIRED_PACKAGES += runtime/python-34
 REQUIRED_PACKAGES += shell/ksh93
--- a/components/libxml2/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/libxml2/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,2 +1,3 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/libxml2-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/libxml2-27
+library/python/[email protected]
--- a/components/libxml2/libxml2-26.p5m	Tue Oct 20 05:38:14 2015 -0700
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,43 +0,0 @@
-#
-# CDDL HEADER START
-#
-# The contents of this file are subject to the terms of the
-# Common Development and Distribution License (the "License").
-# You may not use this file except in compliance with the License.
-#
-# You can obtain a copy of the license at usr/src/OPENSOLARIS.LICENSE
-# or http://www.opensolaris.org/os/licensing.
-# See the License for the specific language governing permissions
-# and limitations under the License.
-#
-# When distributing Covered Code, include this CDDL HEADER in each
-# file and include the License file at usr/src/OPENSOLARIS.LICENSE.
-# If applicable, add the following below this CDDL HEADER, with the
-# fields enclosed by brackets "[]" replaced with your own identifying
-# information: Portions Copyright [yyyy] [name of copyright owner]
-#
-# CDDL HEADER END
-#
-# Copyright (c) 2011, 2015, Oracle and/or its affiliates. All rights reserved.
-#
-
-set name=pkg.fmri \
-    value=pkg:/library/python/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
-set name=pkg.summary value="The XML library - Python 2.6 bindings"
-set name=com.oracle.info.description \
-    value="Python 2.6 bindings for the XML library"
-set name=com.oracle.info.tpno value=$(TPNO)
-set name=info.classification \
-    value=org.opensolaris.category.2008:Development/Python
-set name=info.source-url value=$(COMPONENT_ARCHIVE_URL)
-set name=info.upstream-url value=$(COMPONENT_PROJECT_URL)
-set name=org.opensolaris.arc-caseid value=PSARC/2009/630
-set name=org.opensolaris.consolidation value=$(CONSOLIDATION)
-file path=usr/lib/python2.6/vendor-packages/64/libxml2mod.so
-file path=usr/lib/python2.6/vendor-packages/drv_libxml2.py
-file path=usr/lib/python2.6/vendor-packages/libxml2.py
-file path=usr/lib/python2.6/vendor-packages/libxml2mod.so
-license libxml2.license license="libxml license"
-
-# force the rename with an optional dependency on the old name
-depend type=optional fmri=library/python-2/[email protected],5.12-5.12.0.0.0.41.0
--- a/components/libxml2/libxml2.p5m	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/libxml2/libxml2.p5m	Tue Oct 20 15:05:05 2015 -0700
@@ -109,9 +109,6 @@
 legacy pkg=SUNWlxml desc="The XML library" name="The XML library"
 license libxml2.license license="libxml license"
 depend type=conditional \
-    fmri=library/python/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION) \
-    predicate=runtime/python-26
-depend type=conditional \
     fmri=library/python/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION) \
     predicate=runtime/python-27
 depend type=conditional \
--- a/components/libxslt/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/libxslt/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -49,10 +49,6 @@
 CFLAGS +=	$(CPP_LARGEFILES)
 LDFLAGS +=	$(LD_Z_DEFS) $(LD_Z_TEXT) -lpthread
 
-# When 2.6 goes away, we can remove the version line below, as well as the
-# COMPONENT_POST_{CONFIGURE,INSTALL_ACTION} lines below.
-PYTHON_VERSION=2.6
-
 CONFIGURE_OPTIONS += --disable-static
 CONFIGURE_OPTIONS += --with-pic
 CONFIGURE_OPTIONS += --with-python=$(PYTHON.$(BITS))
@@ -71,30 +67,12 @@
 COMPONENT_PREP_ACTION += \
 	(cd $(@D) ; ACLOCAL=aclocal-1.11 AUTOMAKE=automake-1.11 autoreconf -fiv)
 
-# After we have configured, make a copy of the python bits so we
-# can build separate python 2.7 support.
-COMPONENT_POST_CONFIGURE_ACTION = (cd $(@D) ; cp -rp python python2.7)
-
-# After we have built/installed libxslt, rebuild/install the python
-# support for python 2.7
-COMPONENT_POST_INSTALL_ACTION = \
-    (cd $(@D)/python2.7 ; $(GMAKE) $(COMPONENT_INSTALL_ARGS) \
-                                PYTHON=$(PYTHON.2.7.$(BITS)) \
-                                PYTHON_VERSION=2.7 \
-                                PYTHON_INCLUDES=/usr/include/python2.7 \
-                                PYTHON_LIBS=$(PYTHON.2.7.VENDOR_PACKAGES) \
-                                PYTHON_SITE_PACKAGES=$(PYTHON.2.7.VENDOR_PACKAGES) \
-                                install)
-
-
-
 # common targets
 configure:	$(CONFIGURE_32_and_64)
 
 build:		$(BUILD_32_and_64)
 
 install:	$(INSTALL_32_and_64)
-	$(PYTHON.2.6.32) -m compileall $(PROTO_DIR)/usr/lib/python2.6/vendor-packages
 	$(PYTHON.2.7.32) -m compileall $(PROTO_DIR)/usr/lib/python2.7/vendor-packages
 
 test:		$(TEST_32_and_64)
@@ -104,7 +82,7 @@
 
 REQUIRED_PACKAGES += library/libxml2
 REQUIRED_PACKAGES += library/libxslt
-REQUIRED_PACKAGES += runtime/python-26
+REQUIRED_PACKAGES += runtime/python-27
 REQUIRED_PACKAGES += shell/ksh93
 REQUIRED_PACKAGES += system/library
 REQUIRED_PACKAGES += system/library/math
--- a/components/libxslt/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/libxslt/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,2 +1,3 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/libxsl-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/libxsl-27
+library/python/[email protected]
--- a/components/libxslt/libxsl-26.p5m	Tue Oct 20 05:38:14 2015 -0700
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,42 +0,0 @@
-#
-# CDDL HEADER START
-#
-# The contents of this file are subject to the terms of the
-# Common Development and Distribution License (the "License").
-# You may not use this file except in compliance with the License.
-#
-# You can obtain a copy of the license at usr/src/OPENSOLARIS.LICENSE
-# or http://www.opensolaris.org/os/licensing.
-# See the License for the specific language governing permissions
-# and limitations under the License.
-#
-# When distributing Covered Code, include this CDDL HEADER in each
-# file and include the License file at usr/src/OPENSOLARIS.LICENSE.
-# If applicable, add the following below this CDDL HEADER, with the
-# fields enclosed by brackets "[]" replaced with your own identifying
-# information: Portions Copyright [yyyy] [name of copyright owner]
-#
-# CDDL HEADER END
-#
-# Copyright (c) 2011, 2015, Oracle and/or its affiliates. All rights reserved.
-#
-
-set name=pkg.fmri \
-    value=pkg:/library/python/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
-set name=pkg.summary value="The XSLT library - Python 2.6 bindings"
-set name=com.oracle.info.description \
-    value="Python 2.6 bindings for the XSLT library"
-set name=com.oracle.info.tpno value=$(TPNO)
-set name=info.classification \
-    value=org.opensolaris.category.2008:Development/Python
-set name=info.source-url value=$(COMPONENT_ARCHIVE_URL)
-set name=info.upstream-url value=$(COMPONENT_PROJECT_URL)
-set name=org.opensolaris.arc-caseid value=PSARC/2002/244
-set name=org.opensolaris.consolidation value=$(CONSOLIDATION)
-file path=usr/lib/python2.6/vendor-packages/64/libxsltmod.so
-file path=usr/lib/python2.6/vendor-packages/libxslt.py
-file path=usr/lib/python2.6/vendor-packages/libxsltmod.so
-license xsl.license license=SUNWlxsl-python26.copyright
-
-# force the rename with an optional dependency on the old name
-depend type=optional fmri=library/python-2/[email protected],5.12-5.12.0.0.0.41.0
--- a/components/libxslt/libxslt.p5m	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/libxslt/libxslt.p5m	Tue Oct 20 15:05:05 2015 -0700
@@ -174,8 +174,5 @@
 legacy pkg=SUNWlxsl desc="The XSLT library" name="The XSLT library"
 license xsl.license license=SUNWlxsl.copyright
 depend type=conditional \
-    fmri=library/python/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION) \
-    predicate=runtime/python-26
-depend type=conditional \
     fmri=library/python/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION) \
     predicate=runtime/python-27
--- a/components/meld/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/meld/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -42,8 +42,6 @@
 # Needed to find the GNU version of install.
 PATH =			/usr/gnu/bin:/usr/bin
 
-PYTHON_VERSION =	2.7
-
 PKG_MACROS +=		PYVER=$(PYTHON_VERSION)
 
 # Meld has no configure however it honors DESTDIR which is necessary so
--- a/components/mercurial/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/mercurial/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -41,7 +41,7 @@
 TPNO=			22534
 
 # Mercurial does not yet support Python 3.
-PYTHON_VERSIONS = 2.7 2.6
+PYTHON_VERSIONS = $(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/mercurial/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+developer/versioning/[email protected]
--- a/components/meta-packages/history/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/meta-packages/history/history	Tue Oct 20 15:05:05 2015 -0700
@@ -5,8 +5,8 @@
 [email protected],5.11-0.171
 [email protected],5.11-0.171
 [email protected]
[email protected],5.11-0.175.0.0.0.0.0 library/python-2/[email protected]
[email protected],5.11-0.133 runtime/[email protected]
[email protected]
[email protected]
 [email protected],5.11-0.133 runtime/[email protected]
 [email protected],5.11-0.133 runtime/[email protected]
 [email protected],5.11-0.133 print/lp/filter/[email protected]
@@ -153,9 +153,9 @@
 [email protected],5.11-0.133 library/python-2/[email protected],5.11-0.133
 [email protected],5.11-0.133 library/libtool/[email protected]
 [email protected],5.11-0.133 runtime/[email protected]
[email protected],5.11-0.133 library/python-2/[email protected]
[email protected]
 [email protected],5.11-0.133 library/[email protected]
[email protected],5.11-0.133 library/python-2/[email protected]
[email protected]
 [email protected],5.11-0.133 library/[email protected]
 [email protected],5.11-0.133 developer/[email protected]
 [email protected],5.11-0.133 library/java/[email protected]
@@ -164,7 +164,7 @@
 [email protected],5.11-0.133 media/[email protected],5.11-0.133
 [email protected],5.11-0.133 mail/[email protected]
 [email protected],5.11-0.133 database/[email protected]
[email protected],5.11-0.175.0.0.0.0.0 library/python-2/[email protected]
[email protected]
 [email protected],5.12-5.12.0.0.0.45.0
 [email protected],5.12-5.12.0.0.0.45.0
 [email protected],5.12-5.12.0.0.0.45.0
@@ -221,15 +221,15 @@
 [email protected],5.11-0.133 library/python-2/[email protected]
 [email protected],5.11-0.133 library/python-2/[email protected]
 [email protected]
[email protected],5.11-0.175.0.0.0.0.0 library/python-2/[email protected]
[email protected],5.11-0.175.0.0.0.0.0 library/python-2/[email protected]
[email protected],5.11-0.144 library/python-2/[email protected]
[email protected],5.11-0.133 library/python-2/[email protected]
[email protected] library/python-2/[email protected]
[email protected],5.11-0.175.0.0.0.0.0 library/python-2/[email protected]
[email protected],5.11-0.175.0.0.0.0.0 library/python-2/[email protected]
[email protected],5.11-0.175.0.0.0.1.0 library/python-2/[email protected]
[email protected],5.11-0.175.0.0.0.0.0 library/python-2/[email protected]
[email protected]
[email protected]
[email protected]
[email protected]
[email protected]
[email protected]
[email protected]
[email protected]
[email protected]
 [email protected],5.11-0.133 system/network/routing/[email protected]
 [email protected],5.11-0.133 developer/[email protected]
 [email protected],5.11-0.133 backup/[email protected]
@@ -316,15 +316,35 @@
 library/perl-5/[email protected],5.12-5.12.0.0.0.81.0
 library/perl-5/[email protected],5.12-5.12.0.0.0.14.0
 library/perl5/[email protected],5.12-5.12.0.0.0.81.0
+library/python-2/[email protected]
+library/python-2/[email protected]
+library/python-2/[email protected]
+library/python-2/[email protected]
+library/python-2/[email protected]
+library/python-2/[email protected]
 library/python-2/[email protected],5.11-0.175.0.0.0.0.0
+library/python-2/[email protected]
+library/python-2/[email protected]
+library/python-2/[email protected]
+library/python/[email protected]
+library/python/[email protected]
+library/python/[email protected]
+library/python/[email protected]
+library/python/[email protected]
+library/python/[email protected]
+library/python/[email protected]
+library/python/[email protected]
+library/python/[email protected]
 network/chat/[email protected]
 network/[email protected],5.11-0.170
 print/lp/filter/[email protected],5.11-0.173.0.0.0.0.0 print/filter/[email protected],5.11-0.173.0.0.0.0.0
 runtime/ocaml/[email protected],5.11-0.170
+runtime/python-26/[email protected]
+runtime/[email protected]
 runtime/[email protected],5.12-5.12.0.0.0.55.0
 runtime/tcl-8/[email protected],5.12-5.12.0.0.0.70.0
 security/[email protected],5.11-0.175.1.0.0.21.0 library/perl-5/[email protected],5.11-0.175.1.0.0.21.0
-security/[email protected],5.11-0.175.1.0.0.21.0 library/python-2/[email protected],5.11-0.175.1.0.0.21.0
+security/[email protected]
 security/[email protected],5.11-0.175.1.0.0.21.0 security/compliance/[email protected],5.11-0.175.1.0.0.21.0
 system/management/rad/module/[email protected],5.11-0.175.1.0.0.14
 system/management/[email protected]
@@ -345,8 +365,8 @@
 system/trusted/[email protected]
 terminal/[email protected],5.12-5.12.0.0.0.81.0
 web/[email protected],5.11-0.174.0.0.0.0.0 group/feature/[email protected]
+web/java-servlet/tomcat/[email protected],5.12-5.12.0.0.0.82.0
 web/java-servlet/[email protected],5.12-5.12.0.0.0.82.0
-web/java-servlet/tomcat/[email protected],5.12-5.12.0.0.0.82.0
 web/library/apache/apr-13/[email protected],5.12-5.12.0.0.0.57.0
 web/library/apache/[email protected],5.12-5.12.0.0.0.57.0
 web/library/apache/apr-util-13/[email protected],5.12-5.12.0.0.0.57.0
--- a/components/net-snmp/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/net-snmp/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -46,11 +46,6 @@
 CFLAGS += $(studio_C99_ENABLE)
 CPPFLAGS += "-DFALSE_SHARING_ALIGN=64"
 
-# After Python 2.6 goes away, the COMPONENT_POST_{CONFIGURE,INSTALL}_ACTIONs
-# below can go away as well (for INSTALL_ACTION, 32-bit goes away; 64-bit
-# remains).
-PYTHON_VERSION=2.6
-
 CONFIGURE_ENV +=	PYTHONPROG=$(PYTHON.$(BITS))
 
 CONFIGURE_OPTIONS  +=	--with-default-snmp-version=3
@@ -97,10 +92,6 @@
 COMPONENT_PRE_CONFIGURE_ACTION = \
 	($(CLONEY) $(SOURCE_DIR) $(@D); $(CLONEY) $(COMPONENT_DIR)/sun $(@D)/sun)
 
-# After we have configured, make a copy of the python bits so we
-# can build separate python 2.7 support.
-COMPONENT_POST_CONFIGURE_ACTION = (cd $(@D) ; cp -rp python python2.7)
-
 # for the goofy definition of ARCH in the extra Makefiles
 ARCH=32
 ARCH=$(BITS:64=$(MACH64))
@@ -122,11 +113,7 @@
 
 $(INSTALL_32): COMPONENT_POST_INSTALL_ACTION= \
 	($(MKDIR) -p $(BUILD_DIR)/prototype/$(MACH)/etc/net-snmp/snmp/mibs; \
-	 cd $(BUILD_DIR)/$(MACH32)/sun ; ls agent; $(CCSMAKE) -e $(CCSMAKE_ARGS) install) ; \
-	(cd $(@D)/python2.7 ; env PYTHON=$(PYTHON.2.7.$(BITS)) \
-		$(PYTHON.2.7.$(BITS)) ./setup.py install \
-			--root $(PROTO_DIR) \
-			--install-lib=$(PYTHON.2.7.VENDOR_PACKAGES))
+	 cd $(BUILD_DIR)/$(MACH32)/sun ; ls agent; $(CCSMAKE) -e $(CCSMAKE_ARGS) install)
 
 $(INSTALL_64): COMPONENT_POST_INSTALL_ACTION= \
 	($(MKDIR) -p $(BUILD_DIR)/prototype/$(MACH64)/etc/net-snmp/snmp/mibs; \
@@ -153,7 +140,6 @@
 
 REQUIRED_PACKAGES += developer/documentation-tool/doxygen
 REQUIRED_PACKAGES += runtime/perl-512
-REQUIRED_PACKAGES += runtime/python-26
 REQUIRED_PACKAGES += runtime/python-27
 REQUIRED_PACKAGES += shell/bash
 REQUIRED_PACKAGES += shell/ksh93
--- a/components/net-snmp/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/net-snmp/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,2 +1,3 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/net-snmp-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/net-snmp-27
+library/python/[email protected]
--- a/components/net-snmp/net-snmp-26.p5m	Tue Oct 20 05:38:14 2015 -0700
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,48 +0,0 @@
-#
-# CDDL HEADER START
-#
-# The contents of this file are subject to the terms of the
-# Common Development and Distribution License (the "License").
-# You may not use this file except in compliance with the License.
-#
-# You can obtain a copy of the license at usr/src/OPENSOLARIS.LICENSE
-# or http://www.opensolaris.org/os/licensing.
-# See the License for the specific language governing permissions
-# and limitations under the License.
-#
-# When distributing Covered Code, include this CDDL HEADER in each
-# file and include the License file at usr/src/OPENSOLARIS.LICENSE.
-# If applicable, add the following below this CDDL HEADER, with the
-# fields enclosed by brackets "[]" replaced with your own identifying
-# information: Portions Copyright [yyyy] [name of copyright owner]
-#
-# CDDL HEADER END
-#
-# Copyright (c) 2012, 2015, Oracle and/or its affiliates. All rights reserved.
-#
-
-set name=pkg.fmri \
-    value=pkg:/library/python/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
-set name=pkg.summary value="The Net-SNMP - Python 2.6 bindings"
-set name=com.oracle.info.description value="Python 2.6 bindings for Net-SNMP"
-set name=com.oracle.info.tpno value=$(TPNO)
-set name=info.classification \
-    value=org.opensolaris.category.2008:Development/Python
-set name=info.source-url value=$(COMPONENT_ARCHIVE_URL)
-set name=info.upstream-url value=$(COMPONENT_PROJECT_URL)
-set name=org.opensolaris.arc-caseid value=LSARC/2008/355
-set name=org.opensolaris.consolidation value=$(CONSOLIDATION)
-file path=usr/lib/python2.6/vendor-packages/netsnmp/__init__.py
-file path=usr/lib/python2.6/vendor-packages/netsnmp/client.py
-file path=usr/lib/python2.6/vendor-packages/netsnmp/client_intf.so
-file path=usr/lib/python2.6/vendor-packages/netsnmp/tests/__init__.py
-file path=usr/lib/python2.6/vendor-packages/netsnmp/tests/test.py
-file path=usr/lib/python2.6/vendor-packages/netsnmp_python-1.0a1-py2.6.egg-info/PKG-INFO
-file path=usr/lib/python2.6/vendor-packages/netsnmp_python-1.0a1-py2.6.egg-info/SOURCES.txt
-file path=usr/lib/python2.6/vendor-packages/netsnmp_python-1.0a1-py2.6.egg-info/dependency_links.txt
-file path=usr/lib/python2.6/vendor-packages/netsnmp_python-1.0a1-py2.6.egg-info/top_level.txt
-license COPYING license="BSD, BSD-like"
-
-# force the rename with an optional dependency on the old name
-depend type=optional \
-    fmri=library/python-2/[email protected],5.12-5.12.0.0.0.41.0
--- a/components/net-snmp/net-snmp-base.p5m	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/net-snmp/net-snmp-base.p5m	Tue Oct 20 15:05:05 2015 -0700
@@ -671,8 +671,5 @@
 hardlink path=usr/sbin/snmptrapd target=../../usr/lib/isaexec
 license COPYING license="BSD, BSD-like"
 depend type=conditional \
-    fmri=library/python/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION) \
-    predicate=runtime/python-26
-depend type=conditional \
     fmri=library/python/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION) \
     predicate=runtime/python-27
--- a/components/nmap/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/nmap/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -48,8 +48,6 @@
 COMPONENT_PRE_CONFIGURE_ACTION = \
 	($(CLONEY) $(SOURCE_DIR) $(@D))
 
-PYTHON_VERSION =	2.7
-
 PKG_MACROS +=		PYVER=$(PYTHON_VERSION)
 
 CONFIGURE_OPTIONS  +=   CFLAGS="$(CFLAGS)"
--- a/components/openscap/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/openscap/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -42,9 +42,6 @@
 CFLAGS+=		-DNDEBUG
 CFLAGS+=		-DOSCAP_THREAD_SAFE
 
-# When Python 2.6 goes away, the _VERSION (singular) line below can go as well,
-# as can the COMPONENT_POST_CONFIGURE_ACTION and possibly more.
-PYTHON_VERSION=		2.6
 PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 PERL_VERSIONS = 5.12 5.20
@@ -68,17 +65,7 @@
 COMPONENT_PRE_CONFIGURE_ACTION = \
     ($(CLONEY) $(SOURCE_DIR) $(@D))
 
-# We could use a single regular expression to cover all of the following,
-# but we want to be as specific as possible to avoid accidentally catching
-# workspace paths in our substitution.
-COMPONENT_POST_CONFIGURE_ACTION = \
-    (cd $(@D) ; cp -rp swig swig2.7 ; \
-    $(GSED) -i -e 's|usr/include/python2.6|usr/include/python2.7|' \
-     -e 's|$(PYTHON.2.6.VENDOR_PACKAGES.32)|$(PYTHON.2.7.VENDOR_PACKAGES.32)|' \
-     -e 's|PYTHON_VERSION = 2.6|PYTHON_VERSION = 2.7|' swig2.7/Makefile swig2.7/python2/Makefile)
-
 COMPONENT_POST_INSTALL_ACTION =	\
-	(cd $(@D)/swig2.7 ; $(GMAKE) $(COMPONENT_INSTALL_ARGS) install) ; \
 	$(RM) $(PROTO_DIR)/usr/share/openscap/cpe/* && \
 	$(CP) files/cpe/* $(PROTO_DIR)/usr/share/openscap/cpe
 
@@ -134,7 +121,6 @@
 REQUIRED_PACKAGES += library/pcre
 REQUIRED_PACKAGES += runtime/perl-512
 REQUIRED_PACKAGES += runtime/perl-520
-REQUIRED_PACKAGES += runtime/python-26
 REQUIRED_PACKAGES += runtime/python-27
 REQUIRED_PACKAGES += security/compliance/openscap
 REQUIRED_PACKAGES += system/library
--- a/components/openscap/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/openscap/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,1 +1,2 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.45.0 library/python/[email protected]
+library/python-2/[email protected]
+library/python/[email protected]
--- a/components/openscap/openscap-python-PYVER.p5m	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/openscap/openscap-python-PYVER.p5m	Tue Oct 20 15:05:05 2015 -0700
@@ -40,10 +40,6 @@
 file path=usr/lib/python$(PYVER)/vendor-packages/openscap_api.py
 license openscap.license license="LGPLv2.1, LGPLv3, OVAL"
 
-# force the rename with an optional dependency on the old name
-$(PYTHON_2.6_ONLY)depend type=optional \
-    fmri=library/python-2/[email protected],5.12-5.12.0.0.0.41.0
-
 # force a dependency on the Python $(PYVER) runtime
 depend type=require fmri=__TBD pkg.debug.depend.file=python$(PYVER) \
     pkg.debug.depend.path=usr/bin
--- a/components/openscap/openscap.p5m	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/openscap/openscap.p5m	Tue Oct 20 15:05:05 2015 -0700
@@ -1494,9 +1494,6 @@
     fmri=library/perl-5/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION) \
     predicate=runtime/perl-512
 depend type=conditional \
-    fmri=library/python/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION) \
-    predicate=runtime/python-26
-depend type=conditional \
     fmri=library/python/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION) \
     predicate=runtime/python-27
 depend type=conditional \
--- a/components/python/alembic/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/alembic/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -60,6 +60,5 @@
 system-test:    $(SYSTEM_TESTS_NOT_IMPLEMENTED)
 
 
-REQUIRED_PACKAGES += library/python/setuptools-26
 REQUIRED_PACKAGES += library/python/setuptools-27
 REQUIRED_PACKAGES += library/python/setuptools-34
--- a/components/python/alembic/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/alembic/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/alembic-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/alembic-27
 library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/alembic
+library/python/[email protected]
--- a/components/python/amqp/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/amqp/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/amqp-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/amqp-27
 library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/amqp
+library/python/[email protected]
--- a/components/python/anyjson/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/anyjson/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/anyjson-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/anyjson-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/anyjson
+library/python/[email protected]
--- a/components/python/argparse/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,65 +0,0 @@
-#
-# CDDL HEADER START
-#
-# The contents of this file are subject to the terms of the
-# Common Development and Distribution License (the "License").
-# You may not use this file except in compliance with the License.
-#
-# You can obtain a copy of the license at usr/src/OPENSOLARIS.LICENSE
-# or http://www.opensolaris.org/os/licensing.
-# See the License for the specific language governing permissions
-# and limitations under the License.
-#
-# When distributing Covered Code, include this CDDL HEADER in each
-# file and include the License file at usr/src/OPENSOLARIS.LICENSE.
-# If applicable, add the following below this CDDL HEADER, with the
-# fields enclosed by brackets "[]" replaced with your own identifying
-# information: Portions Copyright [yyyy] [name of copyright owner]
-#
-# CDDL HEADER END
-#
-# Copyright (c) 2013, 2015, Oracle and/or its affiliates. All rights reserved.
-#
-include ../../../make-rules/shared-macros.mk
-
-COMPONENT_NAME=		argparse
-COMPONENT_VERSION=	1.2.1
-COMPONENT_SRC=		$(COMPONENT_NAME)-$(COMPONENT_VERSION)
-COMPONENT_ARCHIVE=	$(COMPONENT_SRC).tar.gz
-COMPONENT_ARCHIVE_HASH=	\
-    sha256:ddaf4b0a618335a32b6664d4ae038a1de8fbada3b25033f9021510ed2b3941a4
-COMPONENT_ARCHIVE_URL=	$(call pypi_url)
-COMPONENT_PROJECT_URL=	http://code.google.com/p/argparse/
-COMPONENT_BUGDB=	python-mod/argparse
-
-TPNO=			13152
-
-# The argparse module was integrated into Python 2.7, so we should only deliver
-# a 2.6 module.
-PYTHON_VERSIONS = 2.6
-
-include $(WS_MAKE_RULES)/prep.mk
-include $(WS_MAKE_RULES)/setup.py.mk
-include $(WS_MAKE_RULES)/ips.mk
-
-COMPONENT_TEST_DIR =	$(COMPONENT_SRC)/test
-COMPONENT_TEST_ARGS =	test_argparse.py
-
-COMPONENT_SYSTEM_TEST_ENV =
-COMPONENT_SYSTEM_TEST_CMD=	$(PYTHON.2.6)
-COMPONENT_SYSTEM_TEST_ARGS =	test_argparse.py
-
-# The additional argparse specific set of transforms to be applied to the test
-# results to try to normalize them.
-COMPONENT_TEST_TRANSFORMS += \
-	'-e "s|\(Ran 1524 tests in\).*|\1|" '
-
-ASLR_MODE = $(ASLR_NOT_APPLICABLE)
-
-build:		$(BUILD_NO_ARCH)
-
-install:	$(INSTALL_NO_ARCH)
-
-test:		$(TEST_NO_ARCH)
-
-system-test:    $(SYSTEM_TEST_NO_ARCH)
--- a/components/python/argparse/argparse-26.p5m	Tue Oct 20 05:38:14 2015 -0700
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,56 +0,0 @@
-#
-# CDDL HEADER START
-#
-# The contents of this file are subject to the terms of the
-# Common Development and Distribution License (the "License").
-# You may not use this file except in compliance with the License.
-#
-# You can obtain a copy of the license at usr/src/OPENSOLARIS.LICENSE
-# or http://www.opensolaris.org/os/licensing.
-# See the License for the specific language governing permissions
-# and limitations under the License.
-#
-# When distributing Covered Code, include this CDDL HEADER in each
-# file and include the License file at usr/src/OPENSOLARIS.LICENSE.
-# If applicable, add the following below this CDDL HEADER, with the
-# fields enclosed by brackets "[]" replaced with your own identifying
-# information: Portions Copyright [yyyy] [name of copyright owner]
-#
-# CDDL HEADER END
-#
-# Copyright (c) 2013, 2014, Oracle and/or its affiliates. All rights reserved.
-#
-
-set name=pkg.fmri \
-    value=pkg:/library/python/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
-set name=pkg.summary value="Python argparse command-line parsing library"
-set name=pkg.description \
-    value="The argparse module makes it easy to write user-friendly command-line interfaces. The program defines what arguments it requires, and argparse will figure out how to parse those out of sys.argv. The argparse module also automatically generates help and usage messages and issues errors when users give the program invalid arguments."
-set name=com.oracle.info.description \
-    value="the Python argparse command-line parsing library"
-set name=com.oracle.info.tpno value=$(TPNO)
-set name=info.classification \
-    value=org.opensolaris.category.2008:Development/Python
-set name=info.source-url value=$(COMPONENT_ARCHIVE_URL)
-set name=info.upstream value="Steven Bethard <[email protected]>"
-set name=info.upstream-url value=$(COMPONENT_PROJECT_URL)
-set name=org.opensolaris.arc-caseid value=PSARC/2013/096
-set name=org.opensolaris.consolidation value=$(CONSOLIDATION)
-file path=usr/lib/python2.6/vendor-packages/argparse-$(COMPONENT_VERSION)-py2.6.egg-info/PKG-INFO
-file path=usr/lib/python2.6/vendor-packages/argparse-$(COMPONENT_VERSION)-py2.6.egg-info/SOURCES.txt
-file path=usr/lib/python2.6/vendor-packages/argparse-$(COMPONENT_VERSION)-py2.6.egg-info/dependency_links.txt
-file path=usr/lib/python2.6/vendor-packages/argparse-$(COMPONENT_VERSION)-py2.6.egg-info/top_level.txt
-file path=usr/lib/python2.6/vendor-packages/argparse.py
-license argparse.license license=PSFv2
-
-# force the rename with an optional dependency on the old name
-depend type=optional \
-    fmri=library/python-2/[email protected],5.12-5.12.0.0.0.41.0
-
-# force a dependency on the Python runtime
-depend type=require fmri=__TBD pkg.debug.depend.file=python2.6 \
-    pkg.debug.depend.path=usr/bin
-
-# force a dependency on the argparse package
-depend type=require \
-    fmri=library/python/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
--- a/components/python/argparse/argparse.license	Tue Oct 20 05:38:14 2015 -0700
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,279 +0,0 @@
-A. HISTORY OF THE SOFTWARE
-==========================
-
-Python was created in the early 1990s by Guido van Rossum at Stichting
-Mathematisch Centrum (CWI, see http://www.cwi.nl) in the Netherlands
-as a successor of a language called ABC.  Guido remains Python's
-principal author, although it includes many contributions from others.
-
-In 1995, Guido continued his work on Python at the Corporation for
-National Research Initiatives (CNRI, see http://www.cnri.reston.va.us)
-in Reston, Virginia where he released several versions of the
-software.
-
-In May 2000, Guido and the Python core development team moved to
-BeOpen.com to form the BeOpen PythonLabs team.  In October of the same
-year, the PythonLabs team moved to Digital Creations (now Zope
-Corporation, see http://www.zope.com).  In 2001, the Python Software
-Foundation (PSF, see http://www.python.org/psf/) was formed, a
-non-profit organization created specifically to own Python-related
-Intellectual Property.  Zope Corporation is a sponsoring member of
-the PSF.
-
-All Python releases are Open Source (see http://www.opensource.org for
-the Open Source Definition).  Historically, most, but not all, Python
-releases have also been GPL-compatible; the table below summarizes
-the various releases.
-
-    Release         Derived     Year        Owner       GPL-
-                    from                                compatible? (1)
-
-    0.9.0 thru 1.2              1991-1995   CWI         yes
-    1.3 thru 1.5.2  1.2         1995-1999   CNRI        yes
-    1.6             1.5.2       2000        CNRI        no
-    2.0             1.6         2000        BeOpen.com  no
-    1.6.1           1.6         2001        CNRI        yes (2)
-    2.1             2.0+1.6.1   2001        PSF         no
-    2.0.1           2.0+1.6.1   2001        PSF         yes
-    2.1.1           2.1+2.0.1   2001        PSF         yes
-    2.2             2.1.1       2001        PSF         yes
-    2.1.2           2.1.1       2002        PSF         yes
-    2.1.3           2.1.2       2002        PSF         yes
-    2.2.1           2.2         2002        PSF         yes
-    2.2.2           2.2.1       2002        PSF         yes
-    2.2.3           2.2.2       2003        PSF         yes
-    2.3             2.2.2       2002-2003   PSF         yes
-    2.3.1           2.3         2002-2003   PSF         yes
-    2.3.2           2.3.1       2002-2003   PSF         yes
-    2.3.3           2.3.2       2002-2003   PSF         yes
-    2.3.4           2.3.3       2004        PSF         yes
-    2.3.5           2.3.4       2005        PSF         yes
-    2.4             2.3         2004        PSF         yes
-    2.4.1           2.4         2005        PSF         yes
-    2.4.2           2.4.1       2005        PSF         yes
-    2.4.3           2.4.2       2006        PSF         yes
-    2.4.4           2.4.3       2006        PSF         yes
-    2.5             2.4         2006        PSF         yes
-    2.5.1           2.5         2007        PSF         yes
-    2.5.2           2.5.1       2008        PSF         yes
-    2.5.3           2.5.2       2008        PSF         yes
-    2.6             2.5         2008        PSF         yes
-    2.6.1           2.6         2008        PSF         yes
-    2.6.2           2.6.1       2009        PSF         yes
-    2.6.3           2.6.2       2009        PSF         yes
-    2.6.4           2.6.3       2009        PSF         yes
-    2.6.5           2.6.4       2010        PSF         yes
-    2.7             2.6         2010        PSF         yes
-
-Footnotes:
-
-(1) GPL-compatible doesn't mean that we're distributing Python under
-    the GPL.  All Python licenses, unlike the GPL, let you distribute
-    a modified version without making your changes open source.  The
-    GPL-compatible licenses make it possible to combine Python with
-    other software that is released under the GPL; the others don't.
-
-(2) According to Richard Stallman, 1.6.1 is not GPL-compatible,
-    because its license has a choice of law clause.  According to
-    CNRI, however, Stallman's lawyer has told CNRI's lawyer that 1.6.1
-    is "not incompatible" with the GPL.
-
-Thanks to the many outside volunteers who have worked under Guido's
-direction to make these releases possible.
-
-
-B. TERMS AND CONDITIONS FOR ACCESSING OR OTHERWISE USING PYTHON
-===============================================================
-
-PYTHON SOFTWARE FOUNDATION LICENSE VERSION 2
---------------------------------------------
-
-1. This LICENSE AGREEMENT is between the Python Software Foundation
-("PSF"), and the Individual or Organization ("Licensee") accessing and
-otherwise using this software ("Python") in source or binary form and
-its associated documentation.
-
-2. Subject to the terms and conditions of this License Agreement, PSF hereby
-grants Licensee a nonexclusive, royalty-free, world-wide license to reproduce,
-analyze, test, perform and/or display publicly, prepare derivative works,
-distribute, and otherwise use Python alone or in any derivative version,
-provided, however, that PSF's License Agreement and PSF's notice of copyright,
-i.e., "Copyright (c) 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010
-Python Software Foundation; All Rights Reserved" are retained in Python alone or
-in any derivative version prepared by Licensee.
-
-3. In the event Licensee prepares a derivative work that is based on
-or incorporates Python or any part thereof, and wants to make
-the derivative work available to others as provided herein, then
-Licensee hereby agrees to include in any such work a brief summary of
-the changes made to Python.
-
-4. PSF is making Python available to Licensee on an "AS IS"
-basis.  PSF MAKES NO REPRESENTATIONS OR WARRANTIES, EXPRESS OR
-IMPLIED.  BY WAY OF EXAMPLE, BUT NOT LIMITATION, PSF MAKES NO AND
-DISCLAIMS ANY REPRESENTATION OR WARRANTY OF MERCHANTABILITY OR FITNESS
-FOR ANY PARTICULAR PURPOSE OR THAT THE USE OF PYTHON WILL NOT
-INFRINGE ANY THIRD PARTY RIGHTS.
-
-5. PSF SHALL NOT BE LIABLE TO LICENSEE OR ANY OTHER USERS OF PYTHON
-FOR ANY INCIDENTAL, SPECIAL, OR CONSEQUENTIAL DAMAGES OR LOSS AS
-A RESULT OF MODIFYING, DISTRIBUTING, OR OTHERWISE USING PYTHON,
-OR ANY DERIVATIVE THEREOF, EVEN IF ADVISED OF THE POSSIBILITY THEREOF.
-
-6. This License Agreement will automatically terminate upon a material
-breach of its terms and conditions.
-
-7. Nothing in this License Agreement shall be deemed to create any
-relationship of agency, partnership, or joint venture between PSF and
-Licensee.  This License Agreement does not grant permission to use PSF
-trademarks or trade name in a trademark sense to endorse or promote
-products or services of Licensee, or any third party.
-
-8. By copying, installing or otherwise using Python, Licensee
-agrees to be bound by the terms and conditions of this License
-Agreement.
-
-
-BEOPEN.COM LICENSE AGREEMENT FOR PYTHON 2.0
--------------------------------------------
-
-BEOPEN PYTHON OPEN SOURCE LICENSE AGREEMENT VERSION 1
-
-1. This LICENSE AGREEMENT is between BeOpen.com ("BeOpen"), having an
-office at 160 Saratoga Avenue, Santa Clara, CA 95051, and the
-Individual or Organization ("Licensee") accessing and otherwise using
-this software in source or binary form and its associated
-documentation ("the Software").
-
-2. Subject to the terms and conditions of this BeOpen Python License
-Agreement, BeOpen hereby grants Licensee a non-exclusive,
-royalty-free, world-wide license to reproduce, analyze, test, perform
-and/or display publicly, prepare derivative works, distribute, and
-otherwise use the Software alone or in any derivative version,
-provided, however, that the BeOpen Python License is retained in the
-Software, alone or in any derivative version prepared by Licensee.
-
-3. BeOpen is making the Software available to Licensee on an "AS IS"
-basis.  BEOPEN MAKES NO REPRESENTATIONS OR WARRANTIES, EXPRESS OR
-IMPLIED.  BY WAY OF EXAMPLE, BUT NOT LIMITATION, BEOPEN MAKES NO AND
-DISCLAIMS ANY REPRESENTATION OR WARRANTY OF MERCHANTABILITY OR FITNESS
-FOR ANY PARTICULAR PURPOSE OR THAT THE USE OF THE SOFTWARE WILL NOT
-INFRINGE ANY THIRD PARTY RIGHTS.
-
-4. BEOPEN SHALL NOT BE LIABLE TO LICENSEE OR ANY OTHER USERS OF THE
-SOFTWARE FOR ANY INCIDENTAL, SPECIAL, OR CONSEQUENTIAL DAMAGES OR LOSS
-AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THE SOFTWARE, OR ANY
-DERIVATIVE THEREOF, EVEN IF ADVISED OF THE POSSIBILITY THEREOF.
-
-5. This License Agreement will automatically terminate upon a material
-breach of its terms and conditions.
-
-6. This License Agreement shall be governed by and interpreted in all
-respects by the law of the State of California, excluding conflict of
-law provisions.  Nothing in this License Agreement shall be deemed to
-create any relationship of agency, partnership, or joint venture
-between BeOpen and Licensee.  This License Agreement does not grant
-permission to use BeOpen trademarks or trade names in a trademark
-sense to endorse or promote products or services of Licensee, or any
-third party.  As an exception, the "BeOpen Python" logos available at
-http://www.pythonlabs.com/logos.html may be used according to the
-permissions granted on that web page.
-
-7. By copying, installing or otherwise using the software, Licensee
-agrees to be bound by the terms and conditions of this License
-Agreement.
-
-
-CNRI LICENSE AGREEMENT FOR PYTHON 1.6.1
----------------------------------------
-
-1. This LICENSE AGREEMENT is between the Corporation for National
-Research Initiatives, having an office at 1895 Preston White Drive,
-Reston, VA 20191 ("CNRI"), and the Individual or Organization
-("Licensee") accessing and otherwise using Python 1.6.1 software in
-source or binary form and its associated documentation.
-
-2. Subject to the terms and conditions of this License Agreement, CNRI
-hereby grants Licensee a nonexclusive, royalty-free, world-wide
-license to reproduce, analyze, test, perform and/or display publicly,
-prepare derivative works, distribute, and otherwise use Python 1.6.1
-alone or in any derivative version, provided, however, that CNRI's
-License Agreement and CNRI's notice of copyright, i.e., "Copyright (c)
-1995-2001 Corporation for National Research Initiatives; All Rights
-Reserved" are retained in Python 1.6.1 alone or in any derivative
-version prepared by Licensee.  Alternately, in lieu of CNRI's License
-Agreement, Licensee may substitute the following text (omitting the
-quotes): "Python 1.6.1 is made available subject to the terms and
-conditions in CNRI's License Agreement.  This Agreement together with
-Python 1.6.1 may be located on the Internet using the following
-unique, persistent identifier (known as a handle): 1895.22/1013.  This
-Agreement may also be obtained from a proxy server on the Internet
-using the following URL: http://hdl.handle.net/1895.22/1013".
-
-3. In the event Licensee prepares a derivative work that is based on
-or incorporates Python 1.6.1 or any part thereof, and wants to make
-the derivative work available to others as provided herein, then
-Licensee hereby agrees to include in any such work a brief summary of
-the changes made to Python 1.6.1.
-
-4. CNRI is making Python 1.6.1 available to Licensee on an "AS IS"
-basis.  CNRI MAKES NO REPRESENTATIONS OR WARRANTIES, EXPRESS OR
-IMPLIED.  BY WAY OF EXAMPLE, BUT NOT LIMITATION, CNRI MAKES NO AND
-DISCLAIMS ANY REPRESENTATION OR WARRANTY OF MERCHANTABILITY OR FITNESS
-FOR ANY PARTICULAR PURPOSE OR THAT THE USE OF PYTHON 1.6.1 WILL NOT
-INFRINGE ANY THIRD PARTY RIGHTS.
-
-5. CNRI SHALL NOT BE LIABLE TO LICENSEE OR ANY OTHER USERS OF PYTHON
-1.6.1 FOR ANY INCIDENTAL, SPECIAL, OR CONSEQUENTIAL DAMAGES OR LOSS AS
-A RESULT OF MODIFYING, DISTRIBUTING, OR OTHERWISE USING PYTHON 1.6.1,
-OR ANY DERIVATIVE THEREOF, EVEN IF ADVISED OF THE POSSIBILITY THEREOF.
-
-6. This License Agreement will automatically terminate upon a material
-breach of its terms and conditions.
-
-7. This License Agreement shall be governed by the federal
-intellectual property law of the United States, including without
-limitation the federal copyright law, and, to the extent such
-U.S. federal law does not apply, by the law of the Commonwealth of
-Virginia, excluding Virginia's conflict of law provisions.
-Notwithstanding the foregoing, with regard to derivative works based
-on Python 1.6.1 that incorporate non-separable material that was
-previously distributed under the GNU General Public License (GPL), the
-law of the Commonwealth of Virginia shall govern this License
-Agreement only as to issues arising under or with respect to
-Paragraphs 4, 5, and 7 of this License Agreement.  Nothing in this
-License Agreement shall be deemed to create any relationship of
-agency, partnership, or joint venture between CNRI and Licensee.  This
-License Agreement does not grant permission to use CNRI trademarks or
-trade name in a trademark sense to endorse or promote products or
-services of Licensee, or any third party.
-
-8. By clicking on the "ACCEPT" button where indicated, or by copying,
-installing or otherwise using Python 1.6.1, Licensee agrees to be
-bound by the terms and conditions of this License Agreement.
-
-        ACCEPT
-
-
-CWI LICENSE AGREEMENT FOR PYTHON 0.9.0 THROUGH 1.2
---------------------------------------------------
-
-Copyright (c) 1991 - 1995, Stichting Mathematisch Centrum Amsterdam,
-The Netherlands.  All rights reserved.
-
-Permission to use, copy, modify, and distribute this software and its
-documentation for any purpose and without fee is hereby granted,
-provided that the above copyright notice appear in all copies and that
-both that copyright notice and this permission notice appear in
-supporting documentation, and that the name of Stichting Mathematisch
-Centrum or CWI not be used in advertising or publicity pertaining to
-distribution of the software without specific, written prior
-permission.
-
-STICHTING MATHEMATISCH CENTRUM DISCLAIMS ALL WARRANTIES WITH REGARD TO
-THIS SOFTWARE, INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND
-FITNESS, IN NO EVENT SHALL STICHTING MATHEMATISCH CENTRUM BE LIABLE
-FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
-WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
-ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT
-OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
--- a/components/python/argparse/argparse.p5m	Tue Oct 20 05:38:14 2015 -0700
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,43 +0,0 @@
-#
-# CDDL HEADER START
-#
-# The contents of this file are subject to the terms of the
-# Common Development and Distribution License (the "License").
-# You may not use this file except in compliance with the License.
-#
-# You can obtain a copy of the license at usr/src/OPENSOLARIS.LICENSE
-# or http://www.opensolaris.org/os/licensing.
-# See the License for the specific language governing permissions
-# and limitations under the License.
-#
-# When distributing Covered Code, include this CDDL HEADER in each
-# file and include the License file at usr/src/OPENSOLARIS.LICENSE.
-# If applicable, add the following below this CDDL HEADER, with the
-# fields enclosed by brackets "[]" replaced with your own identifying
-# information: Portions Copyright [yyyy] [name of copyright owner]
-#
-# CDDL HEADER END
-#
-# Copyright (c) 2013, 2014, Oracle and/or its affiliates. All rights reserved.
-#
-
-set name=pkg.fmri \
-    value=pkg:/library/python/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
-set name=pkg.summary value="Python argparse command-line parsing library"
-set name=pkg.description \
-    value="The argparse module makes it easy to write user-friendly command-line interfaces. The program defines what arguments it requires, and argparse will figure out how to parse those out of sys.argv. The argparse module also automatically generates help and usage messages and issues errors when users give the program invalid arguments."
-set name=com.oracle.info.description \
-    value="the Python argparse command-line parsing library"
-set name=info.classification \
-    value=org.opensolaris.category.2008:Development/Python
-set name=info.source-url value=$(COMPONENT_ARCHIVE_URL)
-set name=info.upstream value="Steven Bethard <[email protected]>"
-set name=info.upstream-url value=$(COMPONENT_PROJECT_URL)
-set name=org.opensolaris.arc-caseid value=PSARC/2013/096
-set name=org.opensolaris.consolidation value=$(CONSOLIDATION)
-depend type=conditional \
-    fmri=library/python/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION) \
-    predicate=runtime/python-26
-
-# force the rename with an optional dependency on the old name
-depend type=optional fmri=library/python-2/[email protected],5.12-5.12.0.0.0.41.0
--- a/components/python/argparse/test/results-2.6-32.master	Tue Oct 20 05:38:14 2015 -0700
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,5 +0,0 @@
-....................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
-----------------------------------------------------------------------
-Ran 1524 tests in
-
-OK
--- a/components/python/babel/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/babel/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -60,6 +60,5 @@
 system-test:    $(SYSTEM_TESTS_NOT_IMPLEMENTED)
 
 
-REQUIRED_PACKAGES += library/python/setuptools-26
 REQUIRED_PACKAGES += library/python/setuptools-27
 REQUIRED_PACKAGES += library/python/setuptools-34
--- a/components/python/babel/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/babel/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.44.0 library/python/babel-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.44.0 library/python/babel-27
 library/python-2/[email protected],5.12-5.12.0.0.0.44.0 library/python/babel
+library/python/[email protected]
--- a/components/python/barbicanclient/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/barbicanclient/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -38,7 +38,7 @@
 TPNO=			21635
 
 # Depends on keystoneclient which is not Python 3 ready.
-PYTHON_VERSIONS =	2.7 2.6
+PYTHON_VERSIONS =	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/barbicanclient/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- a/components/python/beautifulsoup4/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/beautifulsoup4/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/beautifulsoup4-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/beautifulsoup4-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/beautifulsoup4
+library/python/[email protected]
--- a/components/python/boto/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/boto/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -38,7 +38,7 @@
 TPNO=			21716
 
 # Syntax issues: not Python 3 ready.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
@@ -82,7 +82,4 @@
 
 system-test:    $(NO_TESTS)
 
-
-REQUIRED_PACKAGES += library/python/argparse-26
-REQUIRED_PACKAGES += library/python/filechunkio-26
 REQUIRED_PACKAGES += library/python/filechunkio-27
--- a/components/python/boto/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/boto/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/boto-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/boto-27
 library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/boto
+library/python/[email protected]
--- a/components/python/ceilometerclient/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/ceilometerclient/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -38,7 +38,7 @@
 TPNO=			21727
 
 # Depends on keystoneclient which is not Python 3 ready.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/ceilometerclient/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- a/components/python/cffi/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/cffi/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -76,7 +76,6 @@
 
 
 REQUIRED_PACKAGES += library/libffi
-REQUIRED_PACKAGES += library/python/pycparser-26
 REQUIRED_PACKAGES += library/python/pycparser-27
 REQUIRED_PACKAGES += library/python/pycparser-34
 REQUIRED_PACKAGES += library/python/pycparser-35
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/cffi/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- a/components/python/cheetah/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/cheetah/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -35,7 +35,7 @@
 TPNO=			14503
 
 # Syntax issues: not Python 3 ready.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
@@ -65,6 +65,5 @@
 system-test:    $(SYSTEM_TESTS_NOT_IMPLEMENTED)
 
 
-REQUIRED_PACKAGES += runtime/python-26/tests
 REQUIRED_PACKAGES += runtime/python-27/tests
 REQUIRED_PACKAGES += system/library
--- a/components/python/cheetah/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/cheetah/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/cheetah-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/cheetah-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/cheetah
+library/python/[email protected]
--- a/components/python/cherrypy/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/cherrypy/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -39,7 +39,7 @@
 PATCH_LEVEL=0
 
 # This module is not Python 3 ready: syntax issues.
-PYTHON_VERSIONS = 2.7 2.6
+PYTHON_VERSIONS = $(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- a/components/python/cherrypy/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/cherrypy/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/cherrypy-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/cherrypy-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/cherrypy
+library/python/[email protected]
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/cinderclient/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- a/components/python/cliff/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/cliff/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/cliff-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/cliff-27
 library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/cliff
+library/python/[email protected]
--- a/components/python/cmd2/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/cmd2/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/cmd2-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/cmd2-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/cmd2
+library/python/[email protected]
--- a/components/python/cov-core/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/cov-core/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -35,7 +35,7 @@
 TPNO=			14503
 
 # Depends on coverage, which is not Python 3 ready.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- a/components/python/cov-core/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/cov-core/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/cov-core-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/cov-core-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/cov-core
+library/python/[email protected]
--- a/components/python/coverage/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/coverage/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -40,7 +40,7 @@
 # Not Python 3 ready: weird build issues (tries to download & install
 # "distribute").  But coverage version 3.7.1 has fixed these issues; it
 # builds and publishes fine with Python 3.
-PYTHON_VERSIONS = 2.7 2.6
+PYTHON_VERSIONS = $(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
@@ -61,6 +61,5 @@
 system-test:    $(NO_TESTS)
 
 
-REQUIRED_PACKAGES += library/python/setuptools-26
 REQUIRED_PACKAGES += library/python/setuptools-27
 REQUIRED_PACKAGES += system/library
--- a/components/python/coverage/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/coverage/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/coverage-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/coverage-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/coverage
+library/python/[email protected]
--- a/components/python/cryptography/cryptography-PYVER.p5m	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/cryptography/cryptography-PYVER.p5m	Tue Oct 20 15:05:05 2015 -0700
@@ -49,21 +49,15 @@
 file path=usr/lib/python$(PYVER)/vendor-packages/cryptography-$(COMPONENT_VERSION)-py$(PYVER).egg-info/top_level.txt
 $(PYTHON_3.5_ONLY)file path=usr/lib/python$(PYVER)/vendor-packages/cryptography/64/_Cryptography_cffi_15f8accfx62b488b1.so
 $(PYTHON_2.7_ONLY)file path=usr/lib/python$(PYVER)/vendor-packages/cryptography/64/_Cryptography_cffi_26cb75b8x62b488b1.so
-$(PYTHON_2.6_ONLY)file path=usr/lib/python$(PYVER)/vendor-packages/cryptography/64/_Cryptography_cffi_353274b2xffc7b1ce.so
-$(PYTHON_2.6_ONLY)file path=usr/lib/python$(PYVER)/vendor-packages/cryptography/64/_Cryptography_cffi_383020b0x62b488b1.so
 $(PYTHON_2.7_ONLY)file path=usr/lib/python$(PYVER)/vendor-packages/cryptography/64/_Cryptography_cffi_590da19fxffc7b1ce.so
 $(PYTHON_3.5_ONLY)file path=usr/lib/python$(PYVER)/vendor-packages/cryptography/64/_Cryptography_cffi_89292e72x399b1113.so
-$(PYTHON_2.6_ONLY)file path=usr/lib/python$(PYVER)/vendor-packages/cryptography/64/_Cryptography_cffi_93dac7cbx399b1113.so
 $(PYTHON_3.4_ONLY)file path=usr/lib/python$(PYVER)/vendor-packages/cryptography/64/_Cryptography_cffi_a8febd48xffc7b1ce.so
 $(PYTHON_3.4_ONLY)file path=usr/lib/python$(PYVER)/vendor-packages/cryptography/64/_Cryptography_cffi_b03f9c7x62b488b1.so
 $(PYTHON_3.5_ONLY)file path=usr/lib/python$(PYVER)/vendor-packages/cryptography/64/_Cryptography_cffi_c4c16865xffc7b1ce.so
 $(PYTHON_3.4_ONLY)file path=usr/lib/python$(PYVER)/vendor-packages/cryptography/64/_Cryptography_cffi_e9178e86x399b1113.so
 $(PYTHON_2.7_ONLY)file path=usr/lib/python$(PYVER)/vendor-packages/cryptography/64/_Cryptography_cffi_f3e4673fx399b1113.so
 $(PYTHON_2.7_ONLY)file path=usr/lib/python$(PYVER)/vendor-packages/cryptography/_Cryptography_cffi_26cb75b8x62b488b1.so
-$(PYTHON_2.6_ONLY)file path=usr/lib/python$(PYVER)/vendor-packages/cryptography/_Cryptography_cffi_353274b2xffc7b1ce.so
-$(PYTHON_2.6_ONLY)file path=usr/lib/python$(PYVER)/vendor-packages/cryptography/_Cryptography_cffi_383020b0x62b488b1.so
 $(PYTHON_2.7_ONLY)file path=usr/lib/python$(PYVER)/vendor-packages/cryptography/_Cryptography_cffi_590da19fxffc7b1ce.so
-$(PYTHON_2.6_ONLY)file path=usr/lib/python$(PYVER)/vendor-packages/cryptography/_Cryptography_cffi_93dac7cbx399b1113.so
 $(PYTHON_2.7_ONLY)file path=usr/lib/python$(PYVER)/vendor-packages/cryptography/_Cryptography_cffi_f3e4673fx399b1113.so
 file path=usr/lib/python$(PYVER)/vendor-packages/cryptography/__about__.py
 file path=usr/lib/python$(PYVER)/vendor-packages/cryptography/__init__.py
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/cryptography/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- a/components/python/cssutils/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/cssutils/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -38,7 +38,7 @@
 TPNO=			7908
 
 # This module is not Python 3 ready: syntax issues.
-PYTHON_VERSIONS = 2.7 2.6
+PYTHON_VERSIONS = $(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- a/components/python/cssutils/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/cssutils/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/cssutils-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/cssutils-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/cssutils
+library/python/[email protected]
--- a/components/python/cx_oracle/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/cx_oracle/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -36,12 +36,6 @@
 
 TPNO=			23247
 
-# Specifying PYTHON2_VERSIONS so that we don't get the 2.6
-# version built as well. It's an oversight in setup.py.mk
-# that isn't worth fixing since 2.6 is going away very soon.
-PYTHON2_VERSIONS=	2.7
-PYTHON_VERSIONS=	2.7 $(PYTHON3_VERSIONS)
-
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/ips.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- a/components/python/d2to1/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/d2to1/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/d2to1-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/d2to1-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/d2to1
+library/python/[email protected]
--- a/components/python/decorator/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/decorator/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/decorator-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/decorator-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/decorator
+library/python/[email protected]
--- a/components/python/django-appconf/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/django-appconf/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -35,7 +35,7 @@
 TPNO=			14503
 
 # Depends on django, which is not Python 3 ready.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- a/components/python/django-appconf/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/django-appconf/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.44.0 library/python/django-appconf-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.44.0 library/python/django-appconf-27
 library/python-2/[email protected],5.12-5.12.0.0.0.44.0 library/python/django-appconf
+library/python/[email protected]
--- a/components/python/django-pyscss/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/django-pyscss/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -38,7 +38,7 @@
 TPNO=			20370
 
 # Depends on django which is not Python 3 ready.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/django-pyscss/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- a/components/python/django/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/django/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -38,7 +38,7 @@
 TPNO=			24189
 
 # Syntax issues: not Python 3 ready.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- a/components/python/django/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/django/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.44.0 library/python/django-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.44.0 library/python/django-27
 library/python-2/[email protected],5.12-5.12.0.0.0.44.0 library/python/django
+library/python/[email protected]
--- a/components/python/django_compressor/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/django_compressor/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -38,7 +38,7 @@
 TPNO=			21719
 
 # Depends on django, which is not Python 3 ready.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- a/components/python/django_compressor/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/django_compressor/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/django_compressor-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/django_compressor-27
 library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/django_compressor
+library/python/[email protected]
--- a/components/python/django_openstack_auth/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/django_openstack_auth/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -38,7 +38,7 @@
 TPNO=			21746
 
 # Depends on django, which is not Python 3 ready.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- a/components/python/django_openstack_auth/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/django_openstack_auth/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/django_openstack_auth-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/django_openstack_auth-27
 library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/django_openstack_auth
+library/python/[email protected]
--- a/components/python/dnspython/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/dnspython/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -38,7 +38,7 @@
 
 # dnspython is not Python3 ready.  dnspython3 should be used for
 # Python3
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/dnspython/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/dogpile.cache/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/dogpile.core/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- a/components/python/enum/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/enum/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -38,7 +38,7 @@
 TPNO=			21360
 
 # enum34 is superfluous in Python 3.4
-PYTHON_VERSIONS =	2.7 2.6
+PYTHON_VERSIONS =	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/enum/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- a/components/python/eventlet/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/eventlet/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/eventlet-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/eventlet-27
 library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/eventlet
+library/python/[email protected]
--- a/components/python/filechunkio/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/filechunkio/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/filechunkio-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/filechunkio-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/filechunkio
+library/python/[email protected]
--- a/components/python/formencode/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/formencode/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -35,7 +35,7 @@
 TPNO=			14503
 
 # Code explicitly checks for sys.version < '3.0'
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- a/components/python/formencode/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/formencode/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/formencode-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/formencode-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/formencode
+library/python/[email protected]
--- a/components/python/futures/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/futures/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -41,7 +41,7 @@
 # The futures module was integrated into Python 3.2, so we should only
 # deliver 2.6 & 2.7 modules.
 #
-PYTHON_VERSIONS = 2.7 2.6
+PYTHON_VERSIONS = $(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/futures/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- a/components/python/glance_store/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/glance_store/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -38,7 +38,7 @@
 TPNO=			21623
 
 # Depends on oslo.vmware which is not Python 3 ready.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/glance_store/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- a/components/python/glanceclient/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/glanceclient/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -38,7 +38,7 @@
 TPNO=			21731
 
 # Depends on keystoneclient & oslo.utils which are not Python 3 ready.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/glanceclient/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- a/components/python/greenlet/greenlet-PYVER.p5m	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/greenlet/greenlet-PYVER.p5m	Tue Oct 20 15:05:05 2015 -0700
@@ -39,7 +39,6 @@
 set name=org.opensolaris.arc-caseid value=PSARC/2013/140
 set name=org.opensolaris.consolidation value=$(CONSOLIDATION)
 #
-$(PYTHON_2.6_ONLY)file path=usr/include/python$(PYVER)/greenlet/greenlet.h
 $(PYTHON_2.7_ONLY)file path=usr/include/python$(PYVER)/greenlet/greenlet.h
 $(PYTHON_3.4_ONLY)file path=usr/include/python$(PYVER)m/greenlet/greenlet.h
 $(PYTHON_3.5_ONLY)file path=usr/include/python$(PYVER)m/greenlet/greenlet.h
--- a/components/python/greenlet/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/greenlet/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/greenlet-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/greenlet-27
 library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/greenlet
+library/python/[email protected]
--- a/components/python/heatclient/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/heatclient/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -38,7 +38,7 @@
 TPNO=			21733
 
 # Depends on keystoneclient which is not Python 3 ready.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/heatclient/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- a/components/python/httplib2/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/httplib2/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -37,7 +37,7 @@
 # Depends on SocksiPy; for Python 2.x, the module is part of httplib2, but
 # for Python 3.x, it is separate.  Once we add this module, httplib2 will
 # most likely work with Python 3.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- a/components/python/httplib2/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/httplib2/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/httplib2-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/httplib2-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/httplib2
+library/python/[email protected]
--- a/components/python/imaging/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/imaging/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -38,7 +38,7 @@
 TPNO=			7909
 
 # Syntax issues: not Python 3 ready.
-PYTHON_VERSIONS = 2.7 2.6
+PYTHON_VERSIONS = $(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- a/components/python/imaging/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/imaging/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/python-imaging-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/python-imaging-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/python-imaging
+library/python/[email protected]
--- a/components/python/importlib/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,55 +0,0 @@
-#
-# CDDL HEADER START
-#
-# The contents of this file are subject to the terms of the
-# Common Development and Distribution License (the "License").
-# You may not use this file except in compliance with the License.
-#
-# You can obtain a copy of the license at usr/src/OPENSOLARIS.LICENSE
-# or http://www.opensolaris.org/os/licensing.
-# See the License for the specific language governing permissions
-# and limitations under the License.
-#
-# When distributing Covered Code, include this CDDL HEADER in each
-# file and include the License file at usr/src/OPENSOLARIS.LICENSE.
-# If applicable, add the following below this CDDL HEADER, with the
-# fields enclosed by brackets "[]" replaced with your own identifying
-# information: Portions Copyright [yyyy] [name of copyright owner]
-#
-# CDDL HEADER END
-#
-# Copyright (c) 2013, 2015, Oracle and/or its affiliates. All rights reserved.
-#
-include ../../../make-rules/shared-macros.mk
-
-COMPONENT_NAME=		importlib
-COMPONENT_VERSION=	1.0.2
-COMPONENT_SRC=		$(COMPONENT_NAME)-$(COMPONENT_VERSION)
-COMPONENT_ARCHIVE=	$(COMPONENT_SRC).tar.gz
-COMPONENT_ARCHIVE_HASH=	\
-    sha256:24d0966aa76859b288485803f310076512f87377e6c9afe9c28c52a8ccdd328c
-COMPONENT_ARCHIVE_URL=	$(call pypi_url)
-COMPONENT_PROJECT_URL=	https://pypi.python.org/pypi/importlib
-COMPONENT_BUGDB=	python-mod/importlib
-
-TPNO=			14503
-
-# The importlib module was integrated into Python 2.7, so we should
-# only deliver a 2.6 module.
-PYTHON_VERSIONS = 2.6
-
-include $(WS_MAKE_RULES)/prep.mk
-include $(WS_MAKE_RULES)/setup.py.mk
-include $(WS_MAKE_RULES)/ips.mk
-
-ASLR_MODE = $(ASLR_NOT_APPLICABLE)
-
-# common targets
-build:		$(BUILD_NO_ARCH)
-
-install:	$(INSTALL_NO_ARCH)
-
-test:		$(NO_TESTS)
-
-system-test:    $(NO_TESTS)
-
--- a/components/python/importlib/importlib-26.p5m	Tue Oct 20 05:38:14 2015 -0700
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,53 +0,0 @@
-#
-# CDDL HEADER START
-#
-# The contents of this file are subject to the terms of the
-# Common Development and Distribution License (the "License").
-# You may not use this file except in compliance with the License.
-#
-# You can obtain a copy of the license at usr/src/OPENSOLARIS.LICENSE
-# or http://www.opensolaris.org/os/licensing.
-# See the License for the specific language governing permissions
-# and limitations under the License.
-#
-# When distributing Covered Code, include this CDDL HEADER in each
-# file and include the License file at usr/src/OPENSOLARIS.LICENSE.
-# If applicable, add the following below this CDDL HEADER, with the
-# fields enclosed by brackets "[]" replaced with your own identifying
-# information: Portions Copyright [yyyy] [name of copyright owner]
-#
-# CDDL HEADER END
-#
-# Copyright (c) 2013, 2015, Oracle and/or its affiliates. All rights reserved.
-#
-
-set name=pkg.fmri \
-    value=pkg:/library/python/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
-set name=pkg.summary value="Python importlib module"
-set name=pkg.description \
-    value="The importlib module contains the code from importlib as found in Python 2.7. It is provided so that people who wish to use importlib.import_module() with a version of Python prior to 2.7 or in 3.0 have the function readily available."
-set name=com.oracle.info.description value="the Python importlib module"
-set name=com.oracle.info.tpno value=$(TPNO)
-set name=info.classification \
-    value=org.opensolaris.category.2008:Development/Python
-set name=info.source-url value=$(COMPONENT_ARCHIVE_URL)
-set name=info.upstream value="Brett Cannon <[email protected]>"
-set name=info.upstream-url value=$(COMPONENT_PROJECT_URL)
-set name=org.opensolaris.arc-caseid value=PSARC/2013/279
-set name=org.opensolaris.consolidation value=$(CONSOLIDATION)
-file path=usr/lib/python2.6/vendor-packages/importlib-$(COMPONENT_VERSION)-py2.6.egg-info
-file path=usr/lib/python2.6/vendor-packages/importlib/__init__.py
-#
-license importlib.license license=PSFv2
-
-# force the rename with an optional dependency on the old name
-depend type=optional \
-    fmri=library/python-2/[email protected],5.12-5.12.0.0.0.41.0
-
-# force a dependency on the Python runtime
-depend type=require fmri=__TBD pkg.debug.depend.file=python2.6 \
-    pkg.debug.depend.path=usr/bin
-
-# force a dependency on the importlib package
-depend type=require \
-    fmri=library/python/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
--- a/components/python/importlib/importlib.license	Tue Oct 20 05:38:14 2015 -0700
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,47 +0,0 @@
-             PYTHON SOFTWARE FOUNDATION LICENSE VERSION 2
-
-1. This LICENSE AGREEMENT is between the Python Software Foundation
-   ("PSF"), and the Individual or Organization ("Licensee") accessing and
-   otherwise using this software ("Python") in source or binary form and
-   its associated documentation.
-
-2. Subject to the terms and conditions of this License Agreement, PSF
-   hereby grants Licensee a nonexclusive, royalty-free, world-wide
-   license to reproduce, analyze, test, perform and/or display publicly,
-   prepare derivative works, distribute, and otherwise use Python
-   alone or in any derivative version, provided, however, that PSF's
-   License Agreement and PSF's notice of copyright, i.e., "Copyright (c)
-   2001, 2002, 2003, 2004, 2005, 2006 Python Software Foundation; All Rights
-   Reserved" are retained in Python alone or in any derivative version
-   prepared by Licensee.
-
-3. In the event Licensee prepares a derivative work that is based on
-   or incorporates Python or any part thereof, and wants to make
-   the derivative work available to others as provided herein, then
-   Licensee hereby agrees to include in any such work a brief summary of
-   the changes made to Python.
-
-4. PSF is making Python available to Licensee on an "AS IS"
-   basis. PSF MAKES NO REPRESENTATIONS OR WARRANTIES, EXPRESS OR
-   IMPLIED. BY WAY OF EXAMPLE, BUT NOT LIMITATION, PSF MAKES NO AND
-   DISCLAIMS ANY REPRESENTATION OR WARRANTY OF MERCHANTABILITY OR FITNESS
-   FOR ANY PARTICULAR PURPOSE OR THAT THE USE OF PYTHON WILL NOT
-   INFRINGE ANY THIRD PARTY RIGHTS.
-
-5. PSF SHALL NOT BE LIABLE TO LICENSEE OR ANY OTHER USERS OF PYTHON
-   FOR ANY INCIDENTAL, SPECIAL, OR CONSEQUENTIAL DAMAGES OR LOSS AS
-   A RESULT OF MODIFYING, DISTRIBUTING, OR OTHERWISE USING PYTHON,
-   OR ANY DERIVATIVE THEREOF, EVEN IF ADVISED OF THE POSSIBILITY THEREOF.
-
-6. This License Agreement will automatically terminate upon a material
-   breach of its terms and conditions.
-
-7. Nothing in this License Agreement shall be deemed to create any
-   relationship of agency, partnership, or joint venture between PSF and
-   Licensee. This License Agreement does not grant permission to use PSF
-   trademarks or trade name in a trademark sense to endorse or promote
-   products or services of Licensee, or any third party.
-
-8. By copying, installing or otherwise using Python, Licensee
-   agrees to be bound by the terms and conditions of this License
-   Agreement.
--- a/components/python/importlib/importlib.p5m	Tue Oct 20 05:38:14 2015 -0700
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,42 +0,0 @@
-#
-# CDDL HEADER START
-#
-# The contents of this file are subject to the terms of the
-# Common Development and Distribution License (the "License").
-# You may not use this file except in compliance with the License.
-#
-# You can obtain a copy of the license at usr/src/OPENSOLARIS.LICENSE
-# or http://www.opensolaris.org/os/licensing.
-# See the License for the specific language governing permissions
-# and limitations under the License.
-#
-# When distributing Covered Code, include this CDDL HEADER in each
-# file and include the License file at usr/src/OPENSOLARIS.LICENSE.
-# If applicable, add the following below this CDDL HEADER, with the
-# fields enclosed by brackets "[]" replaced with your own identifying
-# information: Portions Copyright [yyyy] [name of copyright owner]
-#
-# CDDL HEADER END
-#
-# Copyright (c) 2013, 2014, Oracle and/or its affiliates. All rights reserved.
-#
-
-set name=pkg.fmri \
-    value=pkg:/library/python/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
-set name=pkg.summary value="Python importlib module"
-set name=pkg.description \
-    value="The importlib module contains the code from importlib as found in Python 2.7. It is provided so that people who wish to use importlib.import_module() with a version of Python prior to 2.7 or in 3.0 have the function readily available."
-set name=com.oracle.info.description value="the Python importlib module"
-set name=info.classification \
-    value=org.opensolaris.category.2008:Development/Python
-set name=info.source-url value=$(COMPONENT_ARCHIVE_URL)
-set name=info.upstream value="Brett Cannon <[email protected]>"
-set name=info.upstream-url value=$(COMPONENT_PROJECT_URL)
-set name=org.opensolaris.arc-caseid value=PSARC/2013/279
-set name=org.opensolaris.consolidation value=$(CONSOLIDATION)
-depend type=conditional \
-    fmri=library/python/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION) \
-    predicate=runtime/python-26
-
-# force the rename with an optional dependency on the old name
-depend type=optional fmri=library/python-2/[email protected],5.12-5.12.0.0.0.41.0
--- a/components/python/iniparse/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/iniparse/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -38,7 +38,7 @@
 TPNO=			21564
 
 # Syntax Errors - not Python 3 ready
-PYTHON_VERSIONS =	2.7 2.6
+PYTHON_VERSIONS =	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/iniparse/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- a/components/python/ipaddr/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/ipaddr/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -38,7 +38,7 @@
 TPNO=			20373
 
 # ipaddr is not Python 3.x compatible, ipaddress should be used instead.
-PYTHON_VERSIONS=	2.6 2.7
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/ipaddr/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- a/components/python/ipython/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/ipython/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -80,8 +80,6 @@
 
 system-test:    $(NO_TESTS)
 
-REQUIRED_PACKAGES += library/python/python-twisted-26
 REQUIRED_PACKAGES += library/python/python-twisted-27
-REQUIRED_PACKAGES += library/python/setuptools-26
 REQUIRED_PACKAGES += library/python/setuptools-27
 
--- a/components/python/ipython/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/ipython/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/ipython-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/ipython-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/ipython
+library/python/[email protected]
--- a/components/python/ironicclient/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/ironicclient/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -38,7 +38,7 @@
 TPNO=			22204
 
 # Depends on keystoneclient which is not Python 3 ready.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/ironicclient/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- a/components/python/iso8601/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/iso8601/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/iso8601-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/iso8601-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/iso8601
+library/python/[email protected]
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/jinja2/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- a/components/python/jsonpatch/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/jsonpatch/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/jsonpatch-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/jsonpatch-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/jsonpatch
+library/python/[email protected]
--- a/components/python/jsonpointer/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/jsonpointer/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/jsonpointer-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/jsonpointer-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/jsonpointer
+library/python/[email protected]
--- a/components/python/jsonrpclib/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/jsonrpclib/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -40,7 +40,7 @@
 
 # This module builds with Python 3, but depends on simplejson.  The following
 # line can be removed when simplejson supports Python 3.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- a/components/python/jsonrpclib/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/jsonrpclib/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/jsonrpclib-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/jsonrpclib-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/jsonrpclib
+library/python/[email protected]
--- a/components/python/jsonschema/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/jsonschema/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/jsonschema-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/jsonschema-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/jsonschema
+library/python/[email protected]
--- a/components/python/keystoneclient/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/keystoneclient/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -38,7 +38,7 @@
 TPNO=			21732
 
 # Depends on netaddr & python-memcached which are not Python 3 ready.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/keystoneclient/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- a/components/python/keystonemiddleware/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/keystonemiddleware/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -38,7 +38,7 @@
 TPNO=			21624
 
 # Depends on keystoneclient which is not Python 3 ready.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/keystonemiddleware/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- a/components/python/kombu/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/kombu/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -40,7 +40,7 @@
 # Depends on pyrabbit which depends on httplib2 which has its own dependency
 # issues (see its Makefile for details).  So don't build for Python 3 until
 # dependencies resolved.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- a/components/python/kombu/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/kombu/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/kombu-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/kombu-27
 library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/kombu
+library/python/[email protected]
--- a/components/python/ldappool/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/ldappool/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -38,7 +38,7 @@
 TPNO=			21665
 
 # Depends on python-ldap which is not Python 3 ready.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/ldappool/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- a/components/python/ldtp/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/ldtp/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -39,7 +39,7 @@
 TPNO=			10015
 
 # Syntax issues: not Python 3 ready.
-PYTHON_VERSIONS = 2.7 2.6
+PYTHON_VERSIONS = $(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/ldtp/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+system/desktop/[email protected]
--- a/components/python/lesscpy/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/lesscpy/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -35,7 +35,7 @@
 TPNO=			16108
 
 # Depends on ply which is not Python 3 ready.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 # convert the 'j' in COMPONENT_VERSION to 10
 IPS_COMPONENT_VERSION = 0.9.10
--- a/components/python/lesscpy/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/lesscpy/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.44.0 library/python/lesscpy-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.44.0 library/python/lesscpy-27
 library/python-2/[email protected],5.12-5.12.0.0.0.44.0 library/python/lesscpy
+library/python/[email protected]
--- a/components/python/librabbitmq/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/librabbitmq/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -35,7 +35,7 @@
 TPNO=			14503
 
 # This module is not Python 3 ready: syntax work needed.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- a/components/python/librabbitmq/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/librabbitmq/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/librabbitmq-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/librabbitmq-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/librabbitmq
+library/python/[email protected]
--- a/components/python/lockfile/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/lockfile/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.44.0 library/python/lockfile-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.44.0 library/python/lockfile-27
 library/python-2/[email protected],5.12-5.12.0.0.0.44.0 library/python/lockfile
+library/python/[email protected]
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/logutils/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- a/components/python/m2crypto/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/m2crypto/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -38,7 +38,7 @@
 TPNO=			4424
 
 # Syntax issues: not Python 3 ready.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- a/components/python/m2crypto/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/m2crypto/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/m2crypto-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/m2crypto-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/m2crypto
+library/python/[email protected]
--- a/components/python/mako/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/mako/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/mako-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/mako-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/mako
+library/python/[email protected]
--- a/components/python/markdown/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/markdown/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/markdown-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/markdown-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/markdown
+library/python/[email protected]
--- a/components/python/markupsafe/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/markupsafe/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/markupsafe-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/markupsafe-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/markupsafe
+library/python/[email protected]
--- a/components/python/mock/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/mock/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -36,7 +36,7 @@
 
 # mock has been subsumed into Python starting with 3.3, so no need to build
 # it for Python 3.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- a/components/python/mock/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/mock/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/mock-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/mock-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/mock
+library/python/[email protected]
--- a/components/python/mysql/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/mysql/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -38,7 +38,7 @@
 TPNO=			21723
 
 # Syntax issues: not Python 3 ready.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- a/components/python/mysql/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/mysql/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/python-mysql-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/python-mysql-27
 library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/python-mysql
+library/python/[email protected]
--- a/components/python/netaddr/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/netaddr/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -38,7 +38,7 @@
 TPNO=			21724
 
 # Depends on iPython which is not Python 3 ready.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
@@ -75,5 +75,4 @@
 system-test:    $(SYSTEM_TESTS_NOT_IMPLEMENTED)
 
 
-REQUIRED_PACKAGES += library/python/ipython-26
 REQUIRED_PACKAGES += library/python/ipython-27
--- a/components/python/netaddr/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/netaddr/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/netaddr-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/netaddr-27
 library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/netaddr
+library/python/[email protected]
--- a/components/python/netifaces/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/netifaces/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/netifaces-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/netifaces-27
 library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/netifaces
+library/python/[email protected]
--- a/components/python/networkx/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/networkx/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -38,7 +38,7 @@
 TPNO=			21625
 
 # Depends on python-extra (numpy) which is not Python 3 ready.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/networkx/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- a/components/python/networkx/networkx-PYVER.p5m	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/networkx/networkx-PYVER.p5m	Tue Oct 20 15:05:05 2015 -0700
@@ -235,10 +235,6 @@
 depend type=require fmri=__TBD pkg.debug.depend.file=python$(PYVER) \
     pkg.debug.depend.path=usr/bin
 
-# force a dependency on python-extra; pkgdepend work is needed to flush this
-# out.
-$(PYTHON_2.6_ONLY)depend type=require fmri=library/python-2/python-extra-$(PYV)
-
 # force a dependency on decorator; pkgdepend work is needed to flush this out.
 depend type=require fmri=library/python/decorator-$(PYV)
 
--- a/components/python/neutronclient/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/neutronclient/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -38,7 +38,7 @@
 TPNO=			21734
 
 # Depends on netaddr which is not Python 3 ready.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/neutronclient/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- a/components/python/nose-cover3/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/nose-cover3/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -35,7 +35,7 @@
 TPNO=			14503
 
 # Depends on coverage, which is not Python 3 ready.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- a/components/python/nose-cover3/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/nose-cover3/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/nose-cover3-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/nose-cover3-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/nose-cover3
+library/python/[email protected]
--- a/components/python/nose/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/nose/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -94,6 +94,5 @@
 
 system-test:    $(SYSTEM_TEST_NO_ARCH)
 
-REQUIRED_PACKAGES += library/python/setuptools-26
 REQUIRED_PACKAGES += library/python/setuptools-27
 REQUIRED_PACKAGES += library/python/setuptools-34
--- a/components/python/nose/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/nose/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/nose-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/nose-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/nose
+library/python/[email protected]
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/novaclient/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/oauthlib/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- a/components/python/ordereddict/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,55 +0,0 @@
-#
-# CDDL HEADER START
-#
-# The contents of this file are subject to the terms of the
-# Common Development and Distribution License (the "License").
-# You may not use this file except in compliance with the License.
-#
-# You can obtain a copy of the license at usr/src/OPENSOLARIS.LICENSE
-# or http://www.opensolaris.org/os/licensing.
-# See the License for the specific language governing permissions
-# and limitations under the License.
-#
-# When distributing Covered Code, include this CDDL HEADER in each
-# file and include the License file at usr/src/OPENSOLARIS.LICENSE.
-# If applicable, add the following below this CDDL HEADER, with the
-# fields enclosed by brackets "[]" replaced with your own identifying
-# information: Portions Copyright [yyyy] [name of copyright owner]
-#
-# CDDL HEADER END
-#
-# Copyright (c) 2013, 2015, Oracle and/or its affiliates. All rights reserved.
-#
-include ../../../make-rules/shared-macros.mk
-
-COMPONENT_NAME=		ordereddict
-COMPONENT_VERSION=	1.1
-COMPONENT_SRC=		$(COMPONENT_NAME)-$(COMPONENT_VERSION)
-COMPONENT_ARCHIVE=	$(COMPONENT_SRC).tar.gz
-COMPONENT_ARCHIVE_HASH=	\
-    sha256:1c35b4ac206cef2d24816c89f89cf289dd3d38cf7c449bb3fab7bf6d43f01b1f
-COMPONENT_ARCHIVE_URL=	$(call pypi_url)
-COMPONENT_PROJECT_URL=	https://pypi.python.org/pypi/ordereddict
-COMPONENT_BUGDB=	python-mod/ordereddict
-
-TPNO=			14503
-
-# The ordereddict module was integrated into Python 2.7, so we should
-# only deliver a 2.6 module.
-PYTHON_VERSIONS = 2.6
-
-include $(WS_MAKE_RULES)/prep.mk
-include $(WS_MAKE_RULES)/setup.py.mk
-include $(WS_MAKE_RULES)/ips.mk
-
-ASLR_MODE = $(ASLR_NOT_APPLICABLE)
-
-# common targets
-build:		$(BUILD_NO_ARCH)
-
-install:	$(INSTALL_NO_ARCH)
-
-test:		$(NO_TESTS)
-
-system-test:    $(NO_TESTS)
-
--- a/components/python/ordereddict/ordereddict-26.p5m	Tue Oct 20 05:38:14 2015 -0700
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,51 +0,0 @@
-#
-# CDDL HEADER START
-#
-# The contents of this file are subject to the terms of the
-# Common Development and Distribution License (the "License").
-# You may not use this file except in compliance with the License.
-#
-# You can obtain a copy of the license at usr/src/OPENSOLARIS.LICENSE
-# or http://www.opensolaris.org/os/licensing.
-# See the License for the specific language governing permissions
-# and limitations under the License.
-#
-# When distributing Covered Code, include this CDDL HEADER in each
-# file and include the License file at usr/src/OPENSOLARIS.LICENSE.
-# If applicable, add the following below this CDDL HEADER, with the
-# fields enclosed by brackets "[]" replaced with your own identifying
-# information: Portions Copyright [yyyy] [name of copyright owner]
-#
-# CDDL HEADER END
-#
-# Copyright (c) 2013, 2015, Oracle and/or its affiliates. All rights reserved.
-#
-
-set name=pkg.fmri \
-    value=pkg:/library/python/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
-set name=pkg.summary value="Python ordereddict library"
-set name=com.oracle.info.description \
-    value="Drop-in substitute for Py2.7's new collections.OrderedDict. The recipe has big-oh performance that matches regular dictionaries (amortized O(1) insertion/deletion/lookup and O(n) iteration/repr/copy/equality_testing)."
-set name=com.oracle.info.tpno value=$(TPNO)
-set name=info.classification \
-    value=org.opensolaris.category.2008:Development/Python
-set name=info.source-url value=$(COMPONENT_ARCHIVE_URL)
-set name=info.upstream-url value=$(COMPONENT_PROJECT_URL)
-set name=org.opensolaris.arc-caseid value=PSARC/2013/280
-set name=org.opensolaris.consolidation value=$(CONSOLIDATION)
-file path=usr/lib/python2.6/vendor-packages/ordereddict-$(COMPONENT_VERSION)-py2.6.egg-info
-file path=usr/lib/python2.6/vendor-packages/ordereddict.py
-#
-license LICENSE license=BSD-like
-
-# force the rename with an optional dependency on the old name
-depend type=optional \
-    fmri=library/python-2/[email protected],5.12-5.12.0.0.0.41.0
-
-# force a dependency on the Python runtime
-depend type=require fmri=__TBD pkg.debug.depend.file=python2.6 \
-    pkg.debug.depend.path=usr/bin
-
-# force a dependency on the ordereddict package
-depend type=require \
-    fmri=library/python/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
--- a/components/python/ordereddict/ordereddict.p5m	Tue Oct 20 05:38:14 2015 -0700
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,40 +0,0 @@
-#
-# CDDL HEADER START
-#
-# The contents of this file are subject to the terms of the
-# Common Development and Distribution License (the "License").
-# You may not use this file except in compliance with the License.
-#
-# You can obtain a copy of the license at usr/src/OPENSOLARIS.LICENSE
-# or http://www.opensolaris.org/os/licensing.
-# See the License for the specific language governing permissions
-# and limitations under the License.
-#
-# When distributing Covered Code, include this CDDL HEADER in each
-# file and include the License file at usr/src/OPENSOLARIS.LICENSE.
-# If applicable, add the following below this CDDL HEADER, with the
-# fields enclosed by brackets "[]" replaced with your own identifying
-# information: Portions Copyright [yyyy] [name of copyright owner]
-#
-# CDDL HEADER END
-#
-# Copyright (c) 2013, 2014, Oracle and/or its affiliates. All rights reserved.
-#
-
-set name=pkg.fmri \
-    value=pkg:/library/python/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
-set name=pkg.summary value="Python ordereddict library"
-set name=com.oracle.info.description \
-    value="Drop-in substitute for Py2.7's new collections.OrderedDict. The recipe has big-oh performance that matches regular dictionaries (amortized O(1) insertion/deletion/lookup and O(n) iteration/repr/copy/equality_testing)."
-set name=info.classification \
-    value=org.opensolaris.category.2008:Development/Python
-set name=info.source-url value=$(COMPONENT_ARCHIVE_URL)
-set name=info.upstream-url value=$(COMPONENT_PROJECT_URL)
-set name=org.opensolaris.arc-caseid value=PSARC/2013/280
-set name=org.opensolaris.consolidation value=$(CONSOLIDATION)
-depend type=conditional \
-    fmri=library/python/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION) \
-    predicate=runtime/python-26
-
-# force the rename with an optional dependency on the old name
-depend type=optional fmri=library/python-2/[email protected],5.12-5.12.0.0.0.41.0
--- a/components/python/oslo.config/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/oslo.config/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.44.0 library/python/oslo.config-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.44.0 library/python/oslo.config-27
 library/python-2/[email protected],5.12-5.12.0.0.0.44.0 library/python/oslo.config
+library/python/[email protected]
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/oslo.context/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- a/components/python/oslo.db/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/oslo.db/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -38,7 +38,7 @@
 TPNO=			21627
 
 # Depends on sqlalchemy-migrate which is not Python3 ready.
-PYTHON_VERSIONS =	2.6 2.7
+PYTHON_VERSIONS =	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/oslo.db/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/oslo.i18n/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- a/components/python/oslo.messaging/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/oslo.messaging/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -38,7 +38,7 @@
 TPNO=			20378
 
 # Depends on oslo.utils which is not Python 3 ready.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
@@ -62,8 +62,5 @@
 
 system-test:    $(NO_TESTS)
 
-
-REQUIRED_PACKAGES += library/python/eventlet-26
 REQUIRED_PACKAGES += library/python/eventlet-27
-REQUIRED_PACKAGES += library/python/oslo.config-26
 REQUIRED_PACKAGES += library/python/oslo.config-27
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/oslo.messaging/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/oslo.middleware/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- a/components/python/oslo.serialization/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/oslo.serialization/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -38,7 +38,7 @@
 TPNO=			21630
 
 # Depends on oslo.utils which is not Python 3 ready.
-PYTHON_VERSIONS =	2.7 2.6
+PYTHON_VERSIONS =	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/oslo.serialization/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- a/components/python/oslo.utils/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/oslo.utils/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -38,7 +38,7 @@
 TPNO=			21631
 
 # Depends on netaddr which is not Python 3 ready.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/oslo.utils/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- a/components/python/oslo.vmware/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/oslo.vmware/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -38,7 +38,7 @@
 TPNO=			21632
 
 # Depends on netaddr & suds which are not Python 3 ready.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/oslo.vmware/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- a/components/python/osprofiler/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/osprofiler/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -38,7 +38,7 @@
 TPNO=			20382
 
 # Depends on ceilometerclient, which is not Python 3 ready.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/osprofiler/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/paramiko/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- a/components/python/passlib/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/passlib/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/passlib-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/passlib-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/passlib
+library/python/[email protected]
--- a/components/python/paste.deploy/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/paste.deploy/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -35,7 +35,7 @@
 TPNO=			14503
 
 # Depends on paste which is not Python 3 ready.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- a/components/python/paste.deploy/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/paste.deploy/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/paste.deploy-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/paste.deploy-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/paste.deploy
+library/python/[email protected]
--- a/components/python/paste/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/paste/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -35,7 +35,7 @@
 TPNO=			14503
 
 # Syntax issues: not Python 3 ready.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- a/components/python/paste/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/paste/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/paste-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/paste-27
 library/python-2/[email protected].1,5.12-5.12.0.0.0.41.0 library/python/paste
+library/python/[email protected]
--- a/components/python/pbr/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/pbr/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pbr-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pbr-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pbr
+library/python/[email protected]
--- a/components/python/pecan/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/pecan/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -38,7 +38,7 @@
 TPNO=			22205
 
 # Depends on logutils and webtest which are not Python 3 ready.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
@@ -60,5 +60,4 @@
 test:		$(TEST_NO_ARCH)
 
 
-REQUIRED_PACKAGES += library/python/setuptools-26
 REQUIRED_PACKAGES += library/python/setuptools-27
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/pecan/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- a/components/python/pep8/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/pep8/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -78,7 +78,5 @@
 
 system-test:    $(SYSTEM_TEST_NO_ARCH)
 
-
-REQUIRED_PACKAGES += library/python/setuptools-26
 REQUIRED_PACKAGES += library/python/setuptools-27
 REQUIRED_PACKAGES += library/python/setuptools-34
--- a/components/python/pep8/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/pep8/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pep8-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pep8-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pep8
+library/python/[email protected]
--- a/components/python/pip/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/pip/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -56,11 +56,9 @@
 
 system-test:    $(NO_TESTS)
 
-REQUIRED_PACKAGES += library/python/requests-26
 REQUIRED_PACKAGES += library/python/requests-27
 REQUIRED_PACKAGES += library/python/requests-34
 REQUIRED_PACKAGES += library/python/requests-35
-REQUIRED_PACKAGES += library/python/setuptools-26
 REQUIRED_PACKAGES += library/python/setuptools-27
 REQUIRED_PACKAGES += library/python/setuptools-34
 REQUIRED_PACKAGES += library/python/setuptools-35
--- a/components/python/pip/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/pip/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.77.0 library/python/pip-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.77.0 library/python/pip-27
 library/python-2/[email protected],5.12-5.12.0.0.0.77.0 library/python/pip
+library/python/[email protected]
--- a/components/python/ply/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/ply/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -37,7 +37,7 @@
 TPNO=			10013
 
 # Syntax issues: not Python 3 ready.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- a/components/python/ply/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/ply/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/ply-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/ply-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/ply
+library/python/[email protected]
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/posix_ipc/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- a/components/python/prettytable/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/prettytable/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/prettytable-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/prettytable-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/prettytable
+library/python/[email protected]
--- a/components/python/py/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/py/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/py-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/py-27
 library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/py
+library/python/[email protected]
--- a/components/python/pyasn1-modules/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/pyasn1-modules/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pyasn1-modules-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pyasn1-modules-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pyasn1-modules
+library/python/[email protected]
--- a/components/python/pyasn1/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/pyasn1/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pyasn1-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pyasn1-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pyasn1
+library/python/[email protected]
--- a/components/python/pybonjour/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/pybonjour/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pybonjour-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pybonjour-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pybonjour
+library/python/[email protected]
--- a/components/python/pycadf/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/pycadf/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -38,7 +38,7 @@
 TPNO=			19271
 
 # Depends on oslo.messaging which is not Python 3 ready.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/pycadf/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- a/components/python/pycountry/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/pycountry/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pycountry-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pycountry-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pycountry
+library/python/[email protected]
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/pycparser/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- a/components/python/pycups/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/pycups/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -38,7 +38,7 @@
 TPNO=			9025
 
 # Fails to compile: not Python 3 ready.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- a/components/python/pycups/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/pycups/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pycups-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pycups-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pycups
+library/python/[email protected]
--- a/components/python/pycurl/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/pycurl/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -42,7 +42,7 @@
 TPNO=			5912
 
 # Syntax issues: not Python 3 ready.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- a/components/python/pycurl/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/pycurl/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pycurl-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pycurl-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pycurl
+library/python/[email protected]
--- a/components/python/pydns/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/pydns/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -35,7 +35,7 @@
 TPNO=			14503
 
 # Import/syntax issues: not Python 3 ready.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- a/components/python/pydns/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/pydns/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pydns-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pydns-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pydns
+library/python/[email protected]
--- a/components/python/pyflakes/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/pyflakes/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -59,7 +59,5 @@
 
 system-test:    $(SYSTEM_TESTS_NOT_IMPLEMENTED)
 
-
-REQUIRED_PACKAGES += library/python/setuptools-26
 REQUIRED_PACKAGES += library/python/setuptools-27
 REQUIRED_PACKAGES += library/python/setuptools-34
--- a/components/python/pyflakes/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/pyflakes/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/pyflakes-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/pyflakes-27
 library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/pyflakes
+library/python/[email protected]
--- a/components/python/pygments/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/pygments/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -62,7 +62,5 @@
 
 system-test:    $(SYSTEM_TESTS_NOT_IMPLEMENTED)
 
-
-REQUIRED_PACKAGES += library/python/setuptools-26
 REQUIRED_PACKAGES += library/python/setuptools-27
 REQUIRED_PACKAGES += library/python/setuptools-34
--- a/components/python/pygments/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/pygments/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pygments-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pygments-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pygments
+library/python/[email protected]
--- a/components/python/pylxml/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/pylxml/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/lxml-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/lxml-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/lxml
+library/python/[email protected]
--- a/components/python/pyopenssl/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/pyopenssl/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pyopenssl-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pyopenssl-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pyopenssl
+library/python/[email protected]
--- a/components/python/pyparsing/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/pyparsing/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pyparsing-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pyparsing-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pyparsing
+library/python/[email protected]
--- a/components/python/pyrabbit/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/pyrabbit/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -37,7 +37,7 @@
 # pyrabbit itself is Python 3 ready: builds & publishes cleanly.  But it
 # depends on httplib2 which has its own dependency issues (see its Makefile
 # for details).  So don't build for Python 3 until dependencies resolved.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- a/components/python/pyrabbit/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/pyrabbit/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pyrabbit-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pyrabbit-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pyrabbit
+library/python/[email protected]
--- a/components/python/pyscss/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/pyscss/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -38,7 +38,7 @@
 TPNO=			20384
 
 # Python 3.4 has build errors.  Need to investigate...
-PYTHON_VERSIONS =	2.7 2.6
+PYTHON_VERSIONS =	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
@@ -59,11 +59,7 @@
 
 system-test:    $(NO_TESTS)
 
-
 REQUIRED_PACKAGES += library/pcre
-REQUIRED_PACKAGES += library/python/pytest-26
 REQUIRED_PACKAGES += library/python/pytest-27
-REQUIRED_PACKAGES += library/python/setuptools-26
 REQUIRED_PACKAGES += library/python/setuptools-27
-REQUIRED_PACKAGES += library/python/six-26
 REQUIRED_PACKAGES += library/python/six-27
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/pyscss/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/pysendfile/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- a/components/python/pytest-capturelog/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/pytest-capturelog/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pytest-capturelog-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pytest-capturelog-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pytest-capturelog
+library/python/[email protected]
--- a/components/python/pytest-codecheckers/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/pytest-codecheckers/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pytest-codecheckers-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pytest-codecheckers-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pytest-codecheckers
+library/python/[email protected]
--- a/components/python/pytest-cov/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/pytest-cov/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -37,7 +37,7 @@
 # pytest-cov itself is Python 3 ready (builds & publishes cleanly with usual
 # changes applied) but it depends on cov-core which depends on coverage which
 # needs to be upgraded.  Thus, skip Python 3 until then.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- a/components/python/pytest-cov/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/pytest-cov/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pytest-cov-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pytest-cov-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/pytest-cov
+library/python/[email protected]
--- a/components/python/pytest/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/pytest/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -57,7 +57,5 @@
 
 system-test:    $(SYSTEM_TESTS_NOT_IMPLEMENTED)
 
-
-REQUIRED_PACKAGES += library/python/setuptools-26
 REQUIRED_PACKAGES += library/python/setuptools-27
 REQUIRED_PACKAGES += library/python/setuptools-34
--- a/components/python/pytest/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/pytest/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/pytest-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/pytest-27
 library/python-2/[email protected],5.12-5.12.0.0.0.75.0 library/python/pytest
+library/python/[email protected]
--- a/components/python/python-ldap/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/python-ldap/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -35,7 +35,7 @@
 TPNO=			14503
 
 # This module has syntax issues and thus is not Python 3 ready.
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
@@ -74,10 +74,7 @@
 
 system-test:    $(SYSTEM_TESTS_NOT_IMPLEMENTED)
 
-
 REQUIRED_PACKAGES += library/openldap
-REQUIRED_PACKAGES += library/python/pyasn1-26
 REQUIRED_PACKAGES += library/python/pyasn1-27
-REQUIRED_PACKAGES += library/python/pyasn1-modules-26
 REQUIRED_PACKAGES += library/python/pyasn1-modules-27
 REQUIRED_PACKAGES += system/library
--- a/components/python/python-ldap/history	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/python-ldap/history	Tue Oct 20 15:05:05 2015 -0700
@@ -1,3 +1,4 @@
-library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/python-ldap-26
+library/python-2/[email protected]
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/python-ldap-27
 library/python-2/[email protected],5.12-5.12.0.0.0.41.0 library/python/python-ldap
+library/python/[email protected]
--- a/components/python/python-memcached/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ b/components/python/python-memcached/Makefile	Tue Oct 20 15:05:05 2015 -0700
@@ -38,7 +38,7 @@
 TPNO=			17839
 
 # Syntax errors: not Python 3 ready
-PYTHON_VERSIONS=	2.7 2.6
+PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/components/python/python-memcached/history	Tue Oct 20 15:05:05 2015 -0700
@@ -0,0 +1,1 @@
+library/python/[email protected]
--- a/components/python/python26/Makefile	Tue Oct 20 05:38:14 2015 -0700
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,164 +0,0 @@
-#
-# CDDL HEADER START
-#
-# The contents of this file are subject to the terms of the
-# Common Development and Distribution License (the "License").
-# You may not use this file except in compliance with the License.
-#
-# You can obtain a copy of the license at usr/src/OPENSOLARIS.LICENSE
-# or http://www.opensolaris.org/os/licensing.
-# See the License for the specific language governing permissions
-# and limitations under the License.
-#
-# When distributing Covered Code, include this CDDL HEADER in each
-# file and include the License file at usr/src/OPENSOLARIS.LICENSE.
-# If applicable, add the following below this CDDL HEADER, with the
-# fields enclosed by brackets "[]" replaced with your own identifying
-# information: Portions Copyright [yyyy] [name of copyright owner]
-#
-# CDDL HEADER END
-#
-# Copyright (c) 2011, 2015, Oracle and/or its affiliates. All rights reserved.
-#
-include ../../../make-rules/shared-macros.mk
-
-PATH=/usr/bin:/usr/gnu/bin:/usr/sbin
-
-COMPONENT_NAME=		Python
-COMPONENT_VERSION=	2.6.8
-COMPONENT_PROJECT_URL=	http://python.org/
-COMPONENT_SRC=		$(COMPONENT_NAME)-$(COMPONENT_VERSION)
-COMPONENT_ARCHIVE=	$(COMPONENT_SRC).tar.bz2
-COMPONENT_ARCHIVE_HASH=	\
-    sha256:c34036718ee1f091736677f543bc7960861cf9fcbea77d49572b59f7f1ab3c3f
-COMPONENT_ARCHIVE_URL=	$(COMPONENT_PROJECT_URL)ftp/python/$(COMPONENT_VERSION)/$(COMPONENT_ARCHIVE)
-COMPONENT_BUGDB=	utility/python
-
-TPNO=			9104
-
-include $(WS_MAKE_RULES)/prep.mk
-include $(WS_MAKE_RULES)/configure.mk
-include $(WS_MAKE_RULES)/ips.mk
-include $(WS_MAKE_RULES)/lint-libraries.mk
-
-# Need to preserve timestamp for Grammar files.  If the pickle files are older, 
-# Python will try to rebuild them.  
-PKGSEND_PUBLISH_OPTIONS += -T \*Grammar\*.txt
-PKGSEND_PUBLISH_OPTIONS += -T \*Grammar\*.pickle
-
-# We patch auto* files, so regenerate headers and configure
-COMPONENT_PREP_ACTION = \
-	(cd $(@D) ; autoheader ; autoconf)
-
-# This seems horribly wrong, but these defines break the ability to build c99
-# compliant modules or with gcc.
-COMPONENT_POST_CONFIGURE_ACTION = \
-	(cd $(@D) ; \
-	 perl -pi -e 's/(^\#define _POSIX_C_SOURCE.*)/\/* $$1 *\//' pyconfig.h ; \
-	 perl -pi -e 's/^(\#define _XOPEN_SOURCE.*)/\/* $$1 *\//' pyconfig.h ; \
-	 perl -pi -e 's/^(\#define _XOPEN_SOURCE_EXTENDED.*)/\/* $$1 *\//' \
-			pyconfig.h)
-
-# The python build is profile-guided for studio; to see the benefits of that,
-# Python must be compiled with -xO5 and a different build target must be used.
-# Use of xprofile requires that the same options be used during compilation and
-# linking.  The targets chosen are based on Solaris 11 minimum supported system
-# requirements.
-COMPONENT_BUILD_TARGETS = profile-opt
-XPROFILE_DIR = $(BUILD_DIR_$(BITS))/.profile
-PYFLAGS.i386 = -xtarget=opteron -xarch=sse2 -xcache=generic
-PYFLAGS.sparc =
-CFLAGS += -xO5 $(PYFLAGS.$(MACH))
-LDFLAGS += -xO5 $(PYFLAGS.$(MACH))
-
-# we don't want to leak $(CC_BITS) into BASECFLAGS as it causes problems with
-# python-config
-CC +=	$(CFLAGS)
-
-C99MODE=
-CPPFLAGS +=	-IPython
-
-# so we find the ncurses headers
-CPPFLAGS +=	-I/usr/include/ncurses
-# enable large files how they did in JDS
-CPPFLAGS +=	-D_LARGEFILE64_SOURCE
-# libffi for _ctypes
-CPPFLAGS +=	$(shell pkg-config --cflags-only-I libffi)
-
-# Python puts its header files in a special place.
-LINT_FLAGS +=	-I$(SOURCE_DIR)/Include
-
-CONFIGURE_OPTIONS  +=		--infodir=$(CONFIGURE_INFODIR)
-CONFIGURE_OPTIONS  +=		--enable-shared
-CONFIGURE_OPTIONS  +=		--with-system-ffi
-CONFIGURE_OPTIONS  +=		--without-gcc
-CONFIGURE_OPTIONS  +=		CPPFLAGS="$(CPPFLAGS)"
-CONFIGURE_OPTIONS  +=		CFLAGS="$(CFLAGS)"
-CONFIGURE_OPTIONS  +=		CCSHARED="$(CC_PIC)"
-CONFIGURE_OPTIONS  +=		CXX="$(CXX)"
-CONFIGURE_OPTIONS  +=		CXXFLAGS="$(CXXFLAGS)"
-CONFIGURE_OPTIONS  +=		DFLAGS="-$(BITS)"
-CONFIGURE_OPTIONS  +=		XPROFILE_DIR="$(XPROFILE_DIR)"
-COMPONENT_BUILD_ENV  +=		DFLAGS="-$(BITS)"
-COMPONENT_BUILD_ENV  +=		XPROFILE_DIR="$(XPROFILE_DIR)"
-
-# 64 bit shared objects need to go in a 64-bit directory
-COMPONENT_INSTALL_ARGS.64 += DESTSHARED=$(CONFIGURE_PREFIX)/lib/python2.6/lib-dynload
-
-# Setup pyconfig.h file to support 32 & 64 bit.
-# If the /usr/lib/python2.6/lib2to3/*.pickle files are older than the related
-# *.txt files in the same directory, it will rebuild them anytime you try to
-# build a Python module.  So here we also touch the pickle files to avoid this.
-#
-COMPONENT_POST_INSTALL_ACTION= \
-            (cd $(PROTOUSRDIR) ;  \
-             $(MV) include/python2.6/pyconfig.h include/python2.6/pyconfig-$(BITS).h ; \
-             $(TOUCH) lib/python2.6/lib2to3/*.pickle)
-                
-ASLR_MODE = $(ASLR_ENABLE)
-
-# common targets
-$(INSTALL_32):  $(INSTALL_64)
-configure:	$(CONFIGURE_32_and_64)
-
-build:		$(BUILD_32_and_64)
-install:	$(INSTALL_32_and_64)
-
-# Using "-uall,-network" ensures all tests are run except the network tests.
-# The network tests contain many expected failures when run behind a firewall.
-# The "-v" ensures verbose mode.  You can set TESTOPTS_PYTHON_TEST to a
-# particular test if you want to run just one test.  For example, run gmake with
-# "-k" so it continues and does both 32-bit and 64-bit tests, even if there is a
-# failure, like this:
-# $ TESTOPTS_PYTHON_TEST=test_sys gmake -k test
-# Note that when a test succeeds, the builds/*/.tested file gets created.  You
-# may need to remove these files, or run "gmake clobber" or "gmake clean"
-# between tests.
-#
-COMPONENT_TEST_ENV = EXTRATESTOPTS="-v -uall,-network $(TESTOPTS_PYTHON_TEST)"
-COMPONENT_TEST_TARGETS = test
-
-test:				$(TEST_32_and_64)
-
-system-test:    $(SYSTEM_TESTS_NOT_IMPLEMENTED)
-
-
-REQUIRED_PACKAGES += compress/bzip2
-REQUIRED_PACKAGES += database/sqlite-3
-REQUIRED_PACKAGES += developer/library/xprofile
-REQUIRED_PACKAGES += library/database/gdbm
-REQUIRED_PACKAGES += library/libffi
-REQUIRED_PACKAGES += library/ncurses
-REQUIRED_PACKAGES += library/python/tkinter-26
-REQUIRED_PACKAGES += library/readline
-REQUIRED_PACKAGES += library/security/openssl
-REQUIRED_PACKAGES += library/zlib
-REQUIRED_PACKAGES += runtime/tcl-8
-REQUIRED_PACKAGES += runtime/tk-8
-REQUIRED_PACKAGES += shell/ksh93
-REQUIRED_PACKAGES += system/core-os
-REQUIRED_PACKAGES += system/library
-REQUIRED_PACKAGES += system/library/math
-REQUIRED_PACKAGES += system/linker
-REQUIRED_PACKAGES += x11/compatibility/links-xorg
-REQUIRED_PACKAGES += x11/library/libx11
--- a/components/python/python26/Makefile.config	Tue Oct 20 05:38:14 2015 -0700
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,1275 +0,0 @@
-#
-# This file is a static, checked in version of the build generated python
-# Makefile.pre.  It is packaged in place of the one in the proto area.
-#
-# Generated automatically from Makefile.pre by makesetup.
-# Top-level Makefile for Python
-#
-# As distributed, this file is called Makefile.pre.in; it is processed
-# into the real Makefile by running the script ./configure, which
-# replaces things like @[email protected] with values appropriate for your system.
-# This means that if you edit Makefile, your changes get lost the next
-# time you run the configure script.  Ideally, you can do:
-#
-#	./configure
-#	make
-#	make test
-#	make install
-#
-# If you have a previous version of Python installed that you don't
-# want to overwrite, you can use "make altinstall" instead of "make
-# install".  Refer to the "Installing" section in the README file for
-# additional details.
-#
-# See also the section "Build instructions" in the README file.
-
-# === Variables set by makesetup ===
-
-MODOBJS=          Modules/threadmodule.o  Modules/signalmodule.o  Modules/posixmodule.o  Modules/errnomodule.o  Modules/pwdmodule.o  Modules/_sre.o  Modules/_codecsmodule.o  Modules/zipimport.o  Modules/symtablemodule.o  Modules/xxsubtype.o
-MODLIBS=        $(LOCALMODLIBS) $(BASEMODLIBS)
-
-# === Variables set by configure
-VERSION=	2.6
-srcdir=		.
-
-
-CC=		/usr/lib/python2.6/pycc
-CXX=		/usr/lib/python2.6/pyCC
-MAINCC=		$(CC)
-LINKCC=		$(PURIFY) $(MAINCC)
-AR=		ar
-RANLIB=		ranlib
-SVNVERSION=	svnversion $(srcdir)
-
-# Shell used by make (some versions default to the login shell, which is bad)
-SHELL=		/bin/sh
-
-# Use this to make a link between python$(VERSION) and python in $(BINDIR)
-LN=		ln
-
-# Portable install script (configure doesn't always guess right)
-INSTALL=	install
-INSTALL_PROGRAM=${INSTALL}
-INSTALL_SCRIPT= ${INSTALL}
-INSTALL_DATA=	${INSTALL} -m 644
-# Shared libraries must be installed with executable mode on some systems;
-# rather than figuring out exactly which, we always give them executable mode.
-# Also, making them read-only seems to be a good idea...
-INSTALL_SHARED= ${INSTALL} -m 555
-
-MAKESETUP=      $(srcdir)/Modules/makesetup
-
-# Compiler options
-OPT=		-DNDEBUG
-BASECFLAGS=	
-CFLAGS=		$(BASECFLAGS) $(OPT) $(EXTRA_CFLAGS)
-# Both CPPFLAGS and LDFLAGS need to contain the shell's value for setup.py to
-# be able to build extension modules using the directories specified in the
-# environment variables
-CPPFLAGS=	-I. -IInclude -I$(srcdir)/Include -D_LARGEFILE64_SOURCE -I/usr/lib/libffi-3.0.9/include  
-LDFLAGS=	  -Wl,-zignore -Wl,-zcombreloc -Wl,-Bdirect  -L. -L/usr/gnu/lib
-LDLAST=		
-SGI_ABI=	
-CCSHARED=	-KPIC
-LINKFORSHARED=	
-# Extra C flags added for building the interpreter object files.
-CFLAGSFORSHARED=$(CCSHARED)
-# C flags used for building the interpreter object files
-PY_CFLAGS=	$(CFLAGS) $(CPPFLAGS) $(CFLAGSFORSHARED) -DPy_BUILD_CORE
-
-
-# Machine-dependent subdirectories
-MACHDEP=	sunos5
-
-# Install prefix for architecture-independent files
-prefix=		/usr
-
-# Install prefix for architecture-dependent files
-exec_prefix=	${prefix}
-
-# Install prefix for data files
-datarootdir=    ${prefix}/share
-
-# Expanded directories
-BINDIR=		$(exec_prefix)/bin
-LIBDIR=		/usr/lib
-MANDIR=		/usr/share/man
-INCLUDEDIR=	${prefix}/include
-CONFINCLUDEDIR=	$(exec_prefix)/include
-SCRIPTDIR=	$(prefix)/lib
-
-# Detailed destination directories
-BINLIBDEST=		$(exec_prefix)/lib/python$(VERSION)
-LIBDEST=		$(SCRIPTDIR)/python$(VERSION)
-INCLUDEPY=		$(INCLUDEDIR)/python$(VERSION)
-CONFINCLUDEPY=		$(CONFINCLUDEDIR)/python$(VERSION)
-LIBP=			$(exec_prefix)/lib/python$(VERSION)
-
-# Symbols used for using shared libraries
-SO=		.so
-LDSHARED=	$(CC) -G
-BLDSHARED=	$(CC) -G
-DESTSHARED=	$(BINLIBDEST)/lib-dynload
-
-# Executable suffix (.exe on Windows and Mac OS X)
-EXE=		
-BUILDEXE=	
-
-# Short name and location for Mac OS X Python framework
-UNIVERSALSDK=
-PYTHONFRAMEWORK=	
-PYTHONFRAMEWORKDIR=	no-framework
-PYTHONFRAMEWORKPREFIX=	
-PYTHONFRAMEWORKINSTALLDIR= 
-# Deployment target selected during configure, to be checked
-# by distutils. The export statement is needed to ensure that the
-# deployment target is active during build.
-MACOSX_DEPLOYMENT_TARGET=
-#export MACOSX_DEPLOYMENT_TARGET
-
-# Options to enable prebinding (for fast startup prior to Mac OS X 10.3)
-OTHER_LIBTOOL_OPT=
-
-# Environment to run shared python without installed libraries
-RUNSHARED=       
-
-# Modes for directories, executables and data files created by the
-# install process.  Default to user-only-writable for all file types.
-DIRMODE=	755
-EXEMODE=	755
-FILEMODE=	644
-
-# configure script arguments
-CONFIG_ARGS=	 '--prefix=/usr' '--libdir=/usr/lib' '--mandir=/usr/share/man' '--datadir=/usr/share' '--infodir=/usr/share/info' '--enable-shared' '--with-system-ffi' '--disable-static' 'CC=/usr/lib/python2.6/pycc' 'CFLAGS=' 'LDFLAGS=  -Wl,-zignore -Wl,-zcombreloc -Wl,-Bdirect  -L. -L/usr/gnu/lib' 'CPPFLAGS=-D_LARGEFILE64_SOURCE -I/usr/lib/libffi-3.0.9/include  '
-
-
-# Subdirectories with code
-SRCDIRS= 	Parser Grammar Objects Python Modules Mac
-
-# Other subdirectories
-SUBDIRSTOO=	Include Lib Misc Demo
-
-# Files and directories to be distributed
-CONFIGFILES=	configure configure.in acconfig.h pyconfig.h.in Makefile.pre.in
-DISTFILES=	README ChangeLog $(CONFIGFILES)
-DISTDIRS=	$(SUBDIRS) $(SUBDIRSTOO) Ext-dummy
-DIST=		$(DISTFILES) $(DISTDIRS)
-
-
-LIBRARY=	libpython$(VERSION).a
-LDLIBRARY=      libpython$(VERSION).so
-BLDLIBRARY=     -Wl,-R,$(LIBDIR) -L. -lpython$(VERSION)
-DLLLIBRARY=	
-LDLIBRARYDIR=   
-INSTSONAME=	libpython$(VERSION).so.1.0
-
-
-LIBS=		-lsocket -lnsl -ldl 
-LIBM=		-lm
-LIBC=		
-SYSLIBS=	$(LIBM) $(LIBC)
-SHLIBS=		$(LIBS)
-
-THREADOBJ=	Python/thread.o
-DLINCLDIR=	.
-DYNLOADFILE=	dynload_shlib.o
-MACHDEP_OBJS=	
-LIBOBJDIR=	Python/
-LIBOBJS=	
-UNICODE_OBJS=   Objects/unicodeobject.o Objects/unicodectype.o
-
-PYTHON=		python$(EXE)
-BUILDPYTHON=	python$(BUILDEXE)
-
-# The task to run while instrument when building the profile-opt target
-PROFILE_TASK=	$(srcdir)/Tools/pybench/pybench.py -n 2 --with-gc --with-syscheck
-#PROFILE_TASK=	$(srcdir)/Lib/test/regrtest.py
-
-# === Definitions added by makesetup ===
-
-LOCALMODLIBS=          
-BASEMODLIBS=
-GLHACK=-Dclear=__GLclear
-PYTHONPATH=$(COREPYTHONPATH)
-COREPYTHONPATH=$(DESTPATH)$(SITEPATH)$(TESTPATH)$(MACHDEPPATH)$(EXTRAMACHDEPPATH)$(TKPATH)$(OLDPATH)
-OLDPATH=:lib-old
-TKPATH=:lib-tk
-EXTRAMACHDEPPATH=
-MACHDEPPATH=:plat-$(MACHDEP)
-TESTPATH=
-SITEPATH=
-DESTPATH=
-MACHDESTLIB=$(BINLIBDEST)
-DESTLIB=$(LIBDEST)
-
-
-
-##########################################################################
-# Modules
-MODULE_OBJS=	\
-		Modules/config.o \
-		Modules/getpath.o \
-		Modules/main.o \
-		Modules/gcmodule.o
-
-# Used of signalmodule.o is not available
-SIGNAL_OBJS=	
-
-
-##########################################################################
-# Grammar
-GRAMMAR_H=	$(srcdir)/Include/graminit.h
-GRAMMAR_C=	$(srcdir)/Python/graminit.c
-GRAMMAR_INPUT=	$(srcdir)/Grammar/Grammar
-
-DTRACE_OBJS=Python/dtrace.o Python/phelper.o
-
-##########################################################################
-# Parser
-PGEN=		Parser/pgen$(EXE)
-
-POBJS=		\
-		Parser/acceler.o \
-		Parser/grammar1.o \
-		Parser/listnode.o \
-		Parser/node.o \
-		Parser/parser.o \
-		Parser/parsetok.o \
-		Parser/bitset.o \
-		Parser/metagrammar.o \
-		Parser/firstsets.o \
-		Parser/grammar.o \
-		Parser/pgen.o
-
-PARSER_OBJS=	$(POBJS) Parser/myreadline.o Parser/tokenizer.o
-
-PGOBJS=		\
-		Objects/obmalloc.o \
-		Python/mysnprintf.o \
-		Parser/tokenizer_pgen.o \
-		Parser/printgrammar.o \
-		Parser/pgenmain.o
-
-PARSER_HEADERS= \
-		Parser/parser.h \
-		Parser/tokenizer.h
-
-PGENOBJS=	$(PGENMAIN) $(POBJS) $(PGOBJS)
-
-##########################################################################
-# AST
-AST_H_DIR=	$(srcdir)/Include
-AST_H=		$(AST_H_DIR)/Python-ast.h
-AST_C_DIR=	$(srcdir)/Python
-AST_C=		$(AST_C_DIR)/Python-ast.c
-AST_ASDL=	$(srcdir)/Parser/Python.asdl
-
-ASDLGEN_FILES=	$(srcdir)/Parser/asdl.py $(srcdir)/Parser/asdl_c.py
-# XXX Note that a build now requires Python exist before the build starts
-ASDLGEN=	$(srcdir)/Parser/asdl_c.py
-
-##########################################################################
-# Python
-PYTHON_OBJS=	\
-		Python/_warnings.o \
-		Python/Python-ast.o \
-		Python/asdl.o \
-		Python/ast.o \
-		Python/bltinmodule.o \
-		Python/ceval.o \
-		Python/compile.o \
-		Python/codecs.o \
-		Python/errors.o \
-		Python/frozen.o \
-		Python/frozenmain.o \
-		Python/future.o \
-		Python/getargs.o \
-		Python/getcompiler.o \
-		Python/getcopyright.o \
-		Python/getmtime.o \
-		Python/getplatform.o \
-		Python/getversion.o \
-		Python/graminit.o \
-		Python/import.o \
-		Python/importdl.o \
-		Python/marshal.o \
-		Python/modsupport.o \
-		Python/mystrtoul.o \
-		Python/mysnprintf.o \
-		Python/peephole.o \
-		Python/pyarena.o \
-		Python/pyfpe.o \
-		Python/pymath.o \
-		Python/pystate.o \
-		Python/pythonrun.o \
-		Python/structmember.o \
-		Python/symtable.o \
-		Python/sysmodule.o \
-		Python/traceback.o \
-		Python/getopt.o \
-		Python/pystrcmp.o \
-		Python/pystrtod.o \
-		Python/formatter_unicode.o \
-		Python/formatter_string.o \
-		Python/$(DYNLOADFILE) \
-		$(DTRACE_OBJS) \
-		$(LIBOBJS) \
-		$(MACHDEP_OBJS) \
-		$(THREADOBJ)
-
-
-##########################################################################
-# Objects
-OBJECT_OBJS=	\
-		Objects/abstract.o \
-		Objects/boolobject.o \
-		Objects/bufferobject.o \
-		Objects/bytes_methods.o \
-		Objects/bytearrayobject.o \
-		Objects/cellobject.o \
-		Objects/classobject.o \
-		Objects/cobject.o \
-		Objects/codeobject.o \
-		Objects/complexobject.o \
-		Objects/descrobject.o \
-		Objects/enumobject.o \
-		Objects/exceptions.o \
-		Objects/genobject.o \
-		Objects/fileobject.o \
-		Objects/floatobject.o \
-		Objects/frameobject.o \
-		Objects/funcobject.o \
-		Objects/intobject.o \
-		Objects/iterobject.o \
-		Objects/listobject.o \
-		Objects/longobject.o \
-		Objects/dictobject.o \
-		Objects/methodobject.o \
-		Objects/moduleobject.o \
-		Objects/object.o \
-		Objects/obmalloc.o \
-		Objects/rangeobject.o \
-		Objects/setobject.o \
-		Objects/sliceobject.o \
-		Objects/stringobject.o \
-		Objects/structseq.o \
-		Objects/tupleobject.o \
-		Objects/typeobject.o \
-		Objects/weakrefobject.o \
-		$(UNICODE_OBJS)
-
-
-##########################################################################
-# objects that get linked into the Python library
-LIBRARY_OBJS=	\
-		Modules/getbuildinfo.o \
-		$(PARSER_OBJS) \
-		$(OBJECT_OBJS) \
-		$(PYTHON_OBJS) \
-		$(MODULE_OBJS) \
-		$(SIGNAL_OBJS) \
-		$(MODOBJS)
-
-#########################################################################
-# Rules
-
-# Default target
-all:		build_all
-build_all:	$(BUILDPYTHON) oldsharedmods sharedmods
-
-# Compile a binary with gcc profile guided optimization.
-profile-opt:
-	@echo "Building with support for profile generation:"
-	$(MAKE) clean
-	$(MAKE) build_all_generate_profile
-	@echo "Running benchmark to generate profile data:"
-	$(MAKE) profile-removal
-	$(MAKE) run_profile_task
-	@echo "Rebuilding with profile guided optimizations:"
-	$(MAKE) clean
-	$(MAKE) build_all_use_profile
-
-build_all_generate_profile:
-	$(MAKE) all CFLAGS="$(CFLAGS) -fprofile-generate" LIBS="$(LIBS) -lgcov"
-
-run_profile_task:
-	./$(BUILDPYTHON) $(PROFILE_TASK)
-
-build_all_use_profile:
-	$(MAKE) all CFLAGS="$(CFLAGS) -fprofile-use"
-
-coverage:
-	@echo "Building with support for coverage checking:"
-	$(MAKE) clean
-	$(MAKE) all CFLAGS="$(CFLAGS) -O0 -pg -fprofile-arcs -ftest-coverage" LIBS="$(LIBS) -lgcov"
-
-
-# Build the interpreter
-$(BUILDPYTHON):	Modules/python.o $(LIBRARY) $(LDLIBRARY)
-		$(LINKCC) $(LDFLAGS) $(LINKFORSHARED) -o [email protected] \
-			Modules/python.o \
-			$(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
-
-platform: $(BUILDPYTHON)
-	$(RUNSHARED) ./$(BUILDPYTHON) -E -c 'import sys ; from distutils.util import get_platform ; print get_platform()+"-"+sys.version[0:3]' >platform
-
-
-# Build the shared modules
-sharedmods: $(BUILDPYTHON)
-	@case $$MAKEFLAGS in \
-	*s*) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' ./$(BUILDPYTHON) -E $(srcdir)/setup.py -q build;; \
-	*) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' ./$(BUILDPYTHON) -E $(srcdir)/setup.py build;; \
-	esac
-
-# Build static library
-# avoid long command lines, same as LIBRARY_OBJS
-$(LIBRARY): $(LIBRARY_OBJS)
-	-rm -f [email protected]
-	$(AR) cr [email protected] Modules/getbuildinfo.o
-	$(AR) cr [email protected] $(PARSER_OBJS)
-	$(AR) cr [email protected] $(OBJECT_OBJS)
-	$(AR) cr [email protected] $(PYTHON_OBJS)
-	$(AR) cr [email protected] $(MODULE_OBJS) $(SIGNAL_OBJS)
-	$(AR) cr [email protected] $(MODOBJS)
-	$(RANLIB) [email protected]
-
-libpython$(VERSION).so: $(LIBRARY_OBJS)
-	if test $(INSTSONAME) != $(LDLIBRARY); then \
-		$(LDSHARED) $(LDFLAGS) -Wl,-h$(INSTSONAME) -o $(INSTSONAME) $(LIBRARY_OBJS) $(MODLIBS) $(SHLIBS) $(LIBC) $(LIBM) $(LDLAST); \
-		$(LN) -f $(INSTSONAME) [email protected]; \
-	else \
-		$(LDSHARED) $(LDFLAGS) -o [email protected] $(LIBRARY_OBJS) $(MODLIBS) $(SHLIBS) $(LIBC) $(LIBM) $(LDLAST); \
-	fi
-
-libpython$(VERSION).dylib: $(LIBRARY_OBJS)
-	 $(CC) -dynamiclib -Wl,-single_module $(LDFLAGS) -undefined dynamic_lookup -Wl,-install_name,$(prefix)/lib/libpython$(VERSION).dylib -Wl,-compatibility_version,$(VERSION) -Wl,-current_version,$(VERSION) -o [email protected] $(LIBRARY_OBJS) $(SHLIBS) $(LIBC) $(LIBM) $(LDLAST); \
-		 
-
-libpython$(VERSION).sl: $(LIBRARY_OBJS)
-	$(LDSHARED) $(LDFLAGS) -o [email protected] $(LIBRARY_OBJS) $(MODLIBS) $(SHLIBS) $(LIBC) $(LIBM) $(LDLAST)
-
-# This rule is here for OPENSTEP/Rhapsody/MacOSX. It builds a temporary
-# minimal framework (not including the Lib directory and such) in the current
-# directory.
-RESSRCDIR=Mac/Resources/framework
-$(PYTHONFRAMEWORKDIR)/Versions/$(VERSION)/$(PYTHONFRAMEWORK): \
-		$(LIBRARY) \
-		$(RESSRCDIR)/Info.plist
-	$(INSTALL) -d -m $(DIRMODE) $(PYTHONFRAMEWORKDIR)/Versions/$(VERSION)
-	if test "${UNIVERSALSDK}"; then \
-		$(CC) -o $(LDLIBRARY)  -dynamiclib \
-			-isysroot "${UNIVERSALSDK}" \
-			-all_load $(LIBRARY) -Wl,-single_module \
-			-install_name $(DESTDIR)$(PYTHONFRAMEWORKINSTALLDIR)/Versions/$(VERSION)/$(PYTHONFRAMEWORK) \
-			-compatibility_version $(VERSION) \
-			-current_version $(VERSION); \
-        else \
-		/usr/bin/libtool -o $(LDLIBRARY) -dynamic $(OTHER_LIBTOOL_OPT) $(LIBRARY) \
-			 ;\
-	fi
-	$(INSTALL) -d -m $(DIRMODE)  \
-		$(PYTHONFRAMEWORKDIR)/Versions/$(VERSION)/Resources/English.lproj
-	$(INSTALL_DATA) $(RESSRCDIR)/Info.plist \
-		$(PYTHONFRAMEWORKDIR)/Versions/$(VERSION)/Resources/Info.plist
-	$(LN) -fsn $(VERSION) $(PYTHONFRAMEWORKDIR)/Versions/Current
-	$(LN) -fsn Versions/Current/$(PYTHONFRAMEWORK) $(PYTHONFRAMEWORKDIR)/$(PYTHONFRAMEWORK)
-	$(LN) -fsn Versions/Current/Headers $(PYTHONFRAMEWORKDIR)/Headers
-	$(LN) -fsn Versions/Current/Resources $(PYTHONFRAMEWORKDIR)/Resources
-
-# This rule builds the Cygwin Python DLL and import library if configured
-# for a shared core library; otherwise, this rule is a noop.
-$(DLLLIBRARY) libpython$(VERSION).dll.a: $(LIBRARY_OBJS)
-	if test -n "$(DLLLIBRARY)"; then \
-		$(LDSHARED) $(LDFLAGS) -Wl,[email protected] -o $(DLLLIBRARY) $^ \
-			$(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST); \
-	else true; \
-	fi
-
-
-oldsharedmods: $(SHAREDMODS)
-
-
-Makefile Modules/config.c: Makefile.pre \
-				$(srcdir)/Modules/config.c.in \
-				$(MAKESETUP) \
-				Modules/Setup.config \
-				Modules/Setup \
-				Modules/Setup.local
-	$(SHELL) $(MAKESETUP) -c $(srcdir)/Modules/config.c.in \
-				-s Modules \
-				Modules/Setup.config \
-				Modules/Setup.local \
-				Modules/Setup
-	@mv config.c Modules
-	@echo "The Makefile was updated, you may need to re-run make."
-
-
-Modules/Setup: $(srcdir)/Modules/Setup.dist
-	@if test -f Modules/Setup; then \
-		echo "-----------------------------------------------"; \
-		echo "Modules/Setup.dist is newer than Modules/Setup;"; \
-		echo "check to make sure you have all the updates you"; \
-		echo "need in your Modules/Setup file."; \
-		echo "Usually, copying Modules/Setup.dist to Modules/Setup will work."; \
-		echo "-----------------------------------------------"; \
-	fi
-
-############################################################################
-# Special rules for object files
-
-Modules/getbuildinfo.o: $(PARSER_OBJS) \
-		$(OBJECT_OBJS) \
-		$(PYTHON_OBJS) \
-		$(MODULE_OBJS) \
-		$(SIGNAL_OBJS) \
-		$(MODOBJS) \
-		$(srcdir)/Modules/getbuildinfo.c
-	$(CC) -c $(PY_CFLAGS) -DSVNVERSION="\"`LC_ALL=C $(SVNVERSION)`\"" -o [email protected] $(srcdir)/Modules/getbuildinfo.c
-
-Modules/getpath.o: $(srcdir)/Modules/getpath.c Makefile
-	$(CC) -c $(PY_CFLAGS) -DPYTHONPATH='"$(PYTHONPATH)"' \
-		-DPREFIX='"$(prefix)"' \
-		-DEXEC_PREFIX='"$(exec_prefix)"' \
-		-DVERSION='"$(VERSION)"' \
-		-DVPATH='"$(VPATH)"' \
-		-o [email protected] $(srcdir)/Modules/getpath.c
-
-Modules/python.o: $(srcdir)/Modules/python.c
-	$(MAINCC) -c $(PY_CFLAGS) -o [email protected] $(srcdir)/Modules/python.c
-
-
-$(GRAMMAR_H) $(GRAMMAR_C): $(PGEN) $(GRAMMAR_INPUT)
-		[email protected]$(INSTALL) -d Include
-		-$(PGEN) $(GRAMMAR_INPUT) $(GRAMMAR_H) $(GRAMMAR_C)
-
-$(PGEN):	$(PGENOBJS)
-		$(CC) $(OPT) $(LDFLAGS) $(PGENOBJS) $(LIBS) -o $(PGEN)
-
-Parser/grammar.o:	$(srcdir)/Parser/grammar.c \
-				$(srcdir)/Include/token.h \
-				$(srcdir)/Include/grammar.h
-Parser/metagrammar.o:	$(srcdir)/Parser/metagrammar.c
-
-Parser/tokenizer_pgen.o:	$(srcdir)/Parser/tokenizer.c
-
-Parser/pgenmain.o:	$(srcdir)/Include/parsetok.h
-
-$(AST_H): $(AST_ASDL) $(ASDLGEN_FILES)
-	$(ASDLGEN) -h $(AST_H_DIR) $(AST_ASDL)
-
-$(AST_C): $(AST_ASDL) $(ASDLGEN_FILES)
-	$(ASDLGEN) -c $(AST_C_DIR) $(AST_ASDL)
-
-Python/compile.o Python/symtable.o: $(GRAMMAR_H) $(AST_H)
-
-Python/getplatform.o: $(srcdir)/Python/getplatform.c
-		$(CC) -c $(PY_CFLAGS) -DPLATFORM='"$(MACHDEP)"' -o [email protected] $(srcdir)/Python/getplatform.c
-
-Python/importdl.o: $(srcdir)/Python/importdl.c
-		$(CC) -c $(PY_CFLAGS) -I$(DLINCLDIR) -o [email protected] $(srcdir)/Python/importdl.c
-
-Objects/unicodectype.o:	$(srcdir)/Objects/unicodectype.c \
-				$(srcdir)/Objects/unicodetype_db.h
-
-STRINGLIB_HEADERS= \
-		$(srcdir)/Include/bytes_methods.h \
-		$(srcdir)/Objects/stringlib/count.h \
-		$(srcdir)/Objects/stringlib/ctype.h \
-		$(srcdir)/Objects/stringlib/fastsearch.h \
-		$(srcdir)/Objects/stringlib/find.h \
-		$(srcdir)/Objects/stringlib/formatter.h \
-		$(srcdir)/Objects/stringlib/partition.h \
-		$(srcdir)/Objects/stringlib/stringdefs.h \
-		$(srcdir)/Objects/stringlib/string_format.h \
-		$(srcdir)/Objects/stringlib/transmogrify.h \
-		$(srcdir)/Objects/stringlib/unicodedefs.h \
-		$(srcdir)/Objects/stringlib/localeutil.h
-
-Objects/unicodeobject.o: $(srcdir)/Objects/unicodeobject.c \
-				$(STRINGLIB_HEADERS)
-
-Objects/bytearrayobject.o: $(srcdir)/Objects/bytearrayobject.c \
-				$(STRINGLIB_HEADERS)
-
-Objects/stringobject.o: $(srcdir)/Objects/stringobject.c \
-				$(STRINGLIB_HEADERS)
-
-Python/formatter_unicode.o: $(srcdir)/Python/formatter_unicode.c \
-				$(STRINGLIB_HEADERS)
-
-Python/formatter_string.o: $(srcdir)/Python/formatter_string.c \
-				$(STRINGLIB_HEADERS)
-
-Python/phelper.o: $(srcdir)/Python/phelper.d
-	dtrace -o [email protected] -DPHELPER $(DFLAGS) $(CPPFLAGS) -C -G -s $(srcdir)/Python/phelper.d
-
-Python/python.h: $(srcdir)/Python/python.d
-	dtrace -o [email protected] $(DFLAGS) -C -h -s $(srcdir)/Python/python.d
-
-Python/ceval.o: Python/python.h
-
-Python/dtrace.o: $(srcdir)/Python/python.d Python/ceval.o
-	dtrace -o [email protected] $(DFLAGS) -C -G -s $(srcdir)/Python/python.d Python/ceval.o
-
-############################################################################
-# Header files
-
-PYTHON_HEADERS= \
-		Include/Python-ast.h \
-		Include/Python.h \
-		Include/abstract.h \
-		Include/asdl.h \
-		Include/ast.h \
-		Include/bitset.h \
-		Include/boolobject.h \
-		Include/bytearrayobject.h \
-		Include/bytes_methods.h \
-		Include/bytesobject.h \
-		Include/bufferobject.h \
-		Include/cellobject.h \
-		Include/ceval.h \
-		Include/classobject.h \
-		Include/cobject.h \
-		Include/code.h \
-		Include/codecs.h \
-		Include/compile.h \
-		Include/complexobject.h \
-		Include/descrobject.h \
-		Include/dictobject.h \
-		Include/enumobject.h \
-		Include/errcode.h \
-		Include/eval.h \
-		Include/fileobject.h \
-		Include/floatobject.h \
-		Include/frameobject.h \
-		Include/funcobject.h \
-		Include/genobject.h \
-		Include/import.h \
-		Include/intobject.h \
-		Include/intrcheck.h \
-		Include/iterobject.h \
-		Include/listobject.h \
-		Include/longintrepr.h \
-		Include/longobject.h \
-		Include/marshal.h \
-		Include/metagrammar.h \
-		Include/methodobject.h \
-		Include/modsupport.h \
-		Include/moduleobject.h \
-		Include/node.h \
-		Include/object.h \
-		Include/objimpl.h \
-		Include/opcode.h \
-		Include/osdefs.h \
-		Include/parsetok.h \
-		Include/patchlevel.h \
-		Include/pgen.h \
-		Include/pgenheaders.h \
-		Include/pyarena.h \
-		Include/pydebug.h \
-		Include/pyerrors.h \
-		Include/pyfpe.h \
-		Include/pymath.h \
-		Include/pygetopt.h \
-		Include/pymem.h \
-		Include/pyport.h \
-		Include/pystate.h \
-		Include/pystrcmp.h \
-		Include/pystrtod.h \
-		Include/pythonrun.h \
-		Include/pythread.h \
-		Include/rangeobject.h \
-		Include/setobject.h \
-		Include/sliceobject.h \
-		Include/stringobject.h \
-		Include/structmember.h \
-		Include/structseq.h \
-		Include/symtable.h \
-		Include/sysmodule.h \
-		Include/traceback.h \
-		Include/tupleobject.h \
-		Include/ucnhash.h \
-		Include/unicodeobject.h \
-		Include/warnings.h \
-		Include/weakrefobject.h \
-		pyconfig.h \
-		$(PARSER_HEADERS)
-
-$(LIBRARY_OBJS) $(MODOBJS) Modules/python.o: $(PYTHON_HEADERS)
-
-
-######################################################################
-
-# Test the interpreter (twice, once without .pyc files, once with)
-# In the past, we've had problems where bugs in the marshalling or
-# elsewhere caused bytecode read from .pyc files to behave differently
-# than bytecode generated directly from a .py source file.  Sometimes
-# the bytecode read from a .pyc file had the bug, somtimes the directly
-# generated bytecode.  This is sometimes a very shy bug needing a lot of
-# sample data.
-
-TESTOPTS=	-l $(EXTRATESTOPTS)
-TESTPROG=	$(srcdir)/Lib/test/regrtest.py
-TESTPYTHON=	$(RUNSHARED) ./$(BUILDPYTHON) -E -tt
-test:		all platform
-		-find $(srcdir)/Lib -name '*.py[co]' -print | xargs rm -f
-		-$(TESTPYTHON) $(TESTPROG) $(TESTOPTS)
-		$(TESTPYTHON) $(TESTPROG) $(TESTOPTS)
-
-testall:	all platform
-		-find $(srcdir)/Lib -name '*.py[co]' -print | xargs rm -f
-		$(TESTPYTHON) $(srcdir)/Lib/compileall.py
-		-find $(srcdir)/Lib -name '*.py[co]' -print | xargs rm -f
-		-$(TESTPYTHON) $(TESTPROG) $(TESTOPTS) -uall
-		$(TESTPYTHON) $(TESTPROG) $(TESTOPTS) -uall
-
-#  Run the unitests for both architectures in a Universal build on OSX
-#  Must be run on an Intel box.
-testuniversal:	all platform
-		if [ `arch` != 'i386' ];then \
-			echo "This can only be used on OSX/i386" ;\
-			exit 1 ;\
-		fi
-		-find $(srcdir)/Lib -name '*.py[co]' -print | xargs rm -f
-		-$(TESTPYTHON) $(TESTPROG) $(TESTOPTS) -uall
-		$(TESTPYTHON) $(TESTPROG) $(TESTOPTS) -uall
-		$(RUNSHARED) /usr/libexec/oah/translate ./$(BUILDPYTHON) -E -tt $(TESTPROG) $(TESTOPTS) -uall
-
-
-# Like testall, but with a single pass only
-# run an optional script to include some information about the build environment
-buildbottest:	all platform
-		[email protected] which pybuildbot.identify >/dev/null 2>&1; then \
-			pybuildbot.identify "CC='$(CC)'" "CXX='$(CXX)'"; \
-		fi
-		$(TESTPYTHON) $(TESTPROG) $(TESTOPTS) -uall -rw
-
-QUICKTESTOPTS=	$(TESTOPTS) -x test_thread test_signal test_strftime \
-		test_unicodedata test_re test_sre test_select test_poll \
-		test_linuxaudiodev test_struct test_sunaudiodev test_zlib
-quicktest:	all platform
-		-find $(srcdir)/Lib -name '*.py[co]' -print | xargs rm -f
-		-$(TESTPYTHON) $(TESTPROG) $(QUICKTESTOPTS)
-		$(TESTPYTHON) $(TESTPROG) $(QUICKTESTOPTS)
-
-MEMTESTOPTS=    $(QUICKTESTOPTS) -x test_dl test___all__ test_fork1 \
-		test_longexp
-memtest:	all platform
-		-rm -f $(srcdir)/Lib/test/*.py[co]
-		-$(TESTPYTHON) $(TESTPROG) $(MEMTESTOPTS)
-		$(TESTPYTHON) $(TESTPROG) $(MEMTESTOPTS)
-
-# Install everything
-install:	 altinstall bininstall maninstall 
-
-# Install almost everything without disturbing previous versions
-altinstall:	 altbininstall libinstall inclinstall libainstall \
-                sharedinstall oldsharedinstall 
-
-# Install shared libraries enabled by Setup
-DESTDIRS=	$(exec_prefix) $(LIBDIR) $(BINLIBDEST) $(DESTSHARED)
-
-oldsharedinstall: $(DESTSHARED) $(SHAREDMODS)
-		@for i in X $(SHAREDMODS); do \
-		  if test $$i != X; then \
-		    echo $(INSTALL_SHARED) $$i $(DESTSHARED)/`basename $$i`; \
-		    $(INSTALL_SHARED) $$i $(DESTDIR)$(DESTSHARED)/`basename $$i`; \
-		  fi; \
-		done
-
-$(DESTSHARED):
-		@for i in $(DESTDIRS); \
-		do \
-			if test ! -d $(DESTDIR)$$i; then \
-				echo "Creating directory $$i"; \
-				$(INSTALL) -d -m $(DIRMODE) $(DESTDIR)$$i; \
-			else    true; \
-			fi; \
-		done
-
-
-# Install the interpreter (by creating a hard link to python$(VERSION))
-bininstall:	altbininstall
-	-if test -f $(DESTDIR)$(BINDIR)/$(PYTHON) -o -h $(DESTDIR)$(BINDIR)/$(PYTHON); \
-	then rm -f $(DESTDIR)$(BINDIR)/$(PYTHON); \
-	else true; \
-	fi
-	(cd $(DESTDIR)$(BINDIR); $(LN) python$(VERSION)$(EXE) $(PYTHON))
-	-rm -f $(DESTDIR)$(BINDIR)/python-config
-	(cd $(DESTDIR)$(BINDIR); $(LN) -s python$(VERSION)-config python-config)
-
-# Install the interpreter with $(VERSION) affixed
-# This goes into $(exec_prefix)
-altbininstall:	$(BUILDPYTHON)
-	@for i in $(BINDIR) $(LIBDIR); \
-	do \
-		if test ! -d $(DESTDIR)$$i; then \
-			echo "Creating directory $$i"; \
-			$(INSTALL) -d -m $(DIRMODE) $(DESTDIR)$$i; \
-		else	true; \
-		fi; \
-	done
-	$(INSTALL_PROGRAM) $(BUILDPYTHON) $(DESTDIR)$(BINDIR)/python$(VERSION)$(EXE)
-	if test -f $(LDLIBRARY); then \
-		if test -n "$(DLLLIBRARY)" ; then \
-			$(INSTALL_SHARED) $(DLLLIBRARY) $(DESTDIR)$(BINDIR); \
-		else \
-			$(INSTALL_SHARED) $(LDLIBRARY) $(DESTDIR)$(LIBDIR)/$(INSTSONAME); \
-			if test $(LDLIBRARY) != $(INSTSONAME); then \
-				(cd $(DESTDIR)$(LIBDIR); $(LN) -sf $(INSTSONAME) $(LDLIBRARY)) \
-			fi \
-		fi; \
-	else	true; \
-	fi
-
-# Install the manual page
-maninstall:
-	@for i in $(MANDIR) $(MANDIR)/man1; \
-	do \
-		if test ! -d $(DESTDIR)$$i; then \
-			echo "Creating directory $$i"; \
-			$(INSTALL) -d -m $(DIRMODE) $(DESTDIR)$$i; \
-		else	true; \
-		fi; \
-	done
-	$(INSTALL_DATA) $(srcdir)/Misc/python.man \
-		$(DESTDIR)$(MANDIR)/man1/python.1
-
-# Install the library
-PLATDIR=	plat-$(MACHDEP)
-EXTRAPLATDIR= 
-EXTRAMACHDEPPATH=
-MACHDEPS=	$(PLATDIR) $(EXTRAPLATDIR)
-XMLLIBSUBDIRS=  xml xml/dom xml/etree xml/parsers xml/sax
-PLATMACDIRS= plat-mac plat-mac/Carbon plat-mac/lib-scriptpackages \
-	plat-mac/lib-scriptpackages/_builtinSuites \
-	plat-mac/lib-scriptpackages/CodeWarrior \
-	plat-mac/lib-scriptpackages/Explorer \
-	plat-mac/lib-scriptpackages/Finder \
-	plat-mac/lib-scriptpackages/Netscape \
-	plat-mac/lib-scriptpackages/StdSuites \
-	plat-mac/lib-scriptpackages/SystemEvents \
-	plat-mac/lib-scriptpackages/Terminal 
-PLATMACPATH=:plat-mac:plat-mac/lib-scriptpackages
-LIBSUBDIRS=	lib-tk site-packages test test/output test/data \
-		test/decimaltestdata \
-		encodings compiler hotshot \
-		email email/mime email/test email/test/data \
-		json json/tests \
-		sqlite3 sqlite3/test \
-		logging bsddb bsddb/test csv wsgiref \
-		lib2to3 lib2to3/fixes lib2to3/pgen2 lib2to3/tests \
-		ctypes ctypes/test ctypes/macholib idlelib idlelib/Icons \
-		distutils distutils/command distutils/tests $(XMLLIBSUBDIRS) \
-		multiprocessing multiprocessing/dummy \
-		lib-old \
-		curses $(MACHDEPS)
-libinstall:	build_all $(srcdir)/Lib/$(PLATDIR)
-	@for i in $(SCRIPTDIR) $(LIBDEST); \
-	do \
-		if test ! -d $(DESTDIR)$$i; then \
-			echo "Creating directory $$i"; \
-			$(INSTALL) -d -m $(DIRMODE) $(DESTDIR)$$i; \
-		else	true; \
-		fi; \
-	done
-	@for d in $(LIBSUBDIRS); \
-	do \
-		a=$(srcdir)/Lib/$$d; \
-		if test ! -d $$a; then continue; else true; fi; \
-		b=$(LIBDEST)/$$d; \
-		if test ! -d $(DESTDIR)$$b; then \
-			echo "Creating directory $$b"; \
-			$(INSTALL) -d -m $(DIRMODE) $(DESTDIR)$$b; \
-		else	true; \
-		fi; \
-	done
-	@for i in $(srcdir)/Lib/*.py $(srcdir)/Lib/*.doc $(srcdir)/Lib/*.egg-info ; \
-	do \
-		if test -x $$i; then \
-			$(INSTALL_SCRIPT) $$i $(DESTDIR)$(LIBDEST); \
-			echo $(INSTALL_SCRIPT) $$i $(LIBDEST); \
-		else \
-			$(INSTALL_DATA) $$i $(DESTDIR)$(LIBDEST); \
-			echo $(INSTALL_DATA) $$i $(LIBDEST); \
-		fi; \
-	done
-	@for d in $(LIBSUBDIRS); \
-	do \
-		a=$(srcdir)/Lib/$$d; \
-		if test ! -d $$a; then continue; else true; fi; \
-		if test `ls $$a | wc -l` -lt 1; then continue; fi; \
-		b=$(LIBDEST)/$$d; \
-		for i in $$a/*; \
-		do \
-			case $$i in \
-			*CVS) ;; \
-			*.py[co]) ;; \
-			*.orig) ;; \
-			*~) ;; \
-			*) \
-				if test -d $$i; then continue; fi; \
-				if test -x $$i; then \
-				    echo $(INSTALL_SCRIPT) $$i $$b; \
-				    $(INSTALL_SCRIPT) $$i $(DESTDIR)$$b; \
-				else \
-				    echo $(INSTALL_DATA) $$i $$b; \
-				    $(INSTALL_DATA) $$i $(DESTDIR)$$b; \
-				fi;; \
-			esac; \
-		done; \
-	done
-	$(INSTALL_DATA) $(srcdir)/LICENSE $(DESTDIR)$(LIBDEST)/LICENSE.txt
-	PYTHONPATH=$(DESTDIR)$(LIBDEST)  $(RUNSHARED) \
-		./$(BUILDPYTHON) -Wi -tt $(DESTDIR)$(LIBDEST)/compileall.py \
-		-d $(LIBDEST) -f \
-		-x 'bad_coding|badsyntax|site-packages' $(DESTDIR)$(LIBDEST)
-	PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
-		./$(BUILDPYTHON) -Wi -tt -O $(DESTDIR)$(LIBDEST)/compileall.py \
-		-d $(LIBDEST) -f \
-		-x 'bad_coding|badsyntax|site-packages' $(DESTDIR)$(LIBDEST)
-	-PYTHONPATH=$(DESTDIR)$(LIBDEST)  $(RUNSHARED) \
-		./$(BUILDPYTHON) -Wi -t $(DESTDIR)$(LIBDEST)/compileall.py \
-		-d $(LIBDEST)/site-packages -f \
-		-x badsyntax $(DESTDIR)$(LIBDEST)/site-packages
-	-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
-		./$(BUILDPYTHON) -Wi -t -O $(DESTDIR)$(LIBDEST)/compileall.py \
-		-d $(LIBDEST)/site-packages -f \
-		-x badsyntax $(DESTDIR)$(LIBDEST)/site-packages
-	-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
-		./$(BUILDPYTHON) -Wi -t -c "import lib2to3.pygram, lib2to3.patcomp;lib2to3.patcomp.PatternCompiler()"
-
-# Create the PLATDIR source directory, if one wasn't distributed..
-$(srcdir)/Lib/$(PLATDIR):
-	mkdir $(srcdir)/Lib/$(PLATDIR)
-	cp $(srcdir)/Lib/plat-generic/regen $(srcdir)/Lib/$(PLATDIR)/regen
-	export PATH; PATH="`pwd`:$$PATH"; \
-	export PYTHONPATH; PYTHONPATH="`pwd`/Lib"; \
-	export DYLD_FRAMEWORK_PATH; DYLD_FRAMEWORK_PATH="`pwd`"; \
-	export EXE; EXE="$(BUILDEXE)"; \
-	cd $(srcdir)/Lib/$(PLATDIR); $(RUNSHARED) ./regen
-
-# Install the include files
-INCLDIRSTOMAKE=$(INCLUDEDIR) $(CONFINCLUDEDIR) $(INCLUDEPY) $(CONFINCLUDEPY)
-inclinstall:
-	@for i in $(INCLDIRSTOMAKE); \
-	do \
-		if test ! -d $(DESTDIR)$$i; then \
-			echo "Creating directory $$i"; \
-			$(INSTALL) -d -m $(DIRMODE) $(DESTDIR)$$i; \
-		else	true; \
-		fi; \
-	done
-	@for i in $(srcdir)/Include/*.h; \
-	do \
-		echo $(INSTALL_DATA) $$i $(INCLUDEPY); \
-		$(INSTALL_DATA) $$i $(DESTDIR)$(INCLUDEPY); \
-	done
-	$(INSTALL_DATA) pyconfig.h $(DESTDIR)$(CONFINCLUDEPY)/pyconfig.h
-
-# Install the library and miscellaneous stuff needed for extending/embedding
-# This goes into $(exec_prefix)
-LIBPL=		$(LIBP)/config
-libainstall:	all
-	@for i in $(LIBDIR) $(LIBP) $(LIBPL); \
-	do \
-		if test ! -d $(DESTDIR)$$i; then \
-			echo "Creating directory $$i"; \
-			$(INSTALL) -d -m $(DIRMODE) $(DESTDIR)$$i; \
-		else	true; \
-		fi; \
-	done
-	@if test -d $(LIBRARY); then :; else \
-		if test "$(PYTHONFRAMEWORKDIR)" = no-framework; then \
-			if test "$(SO)" = .dll; then \
-				$(INSTALL_DATA) $(LDLIBRARY) $(DESTDIR)$(LIBPL) ; \
-			else \
-				$(INSTALL_DATA) $(LIBRARY) $(DESTDIR)$(LIBPL)/$(LIBRARY) ; \
-				$(RANLIB) $(DESTDIR)$(LIBPL)/$(LIBRARY) ; \
-			fi; \
-		else \
-			echo Skip install of $(LIBRARY) - use make frameworkinstall; \
-		fi; \
-	fi
-	$(INSTALL_DATA) Modules/config.c $(DESTDIR)$(LIBPL)/config.c
-	$(INSTALL_DATA) Modules/python.o $(DESTDIR)$(LIBPL)/python.o
-	$(INSTALL_DATA) $(srcdir)/Modules/config.c.in $(DESTDIR)$(LIBPL)/config.c.in
-	$(INSTALL_DATA) Makefile $(DESTDIR)$(LIBPL)/Makefile
-	$(INSTALL_DATA) Modules/Setup $(DESTDIR)$(LIBPL)/Setup
-	$(INSTALL_DATA) Modules/Setup.local $(DESTDIR)$(LIBPL)/Setup.local
-	$(INSTALL_DATA) Modules/Setup.config $(DESTDIR)$(LIBPL)/Setup.config
-	$(INSTALL_SCRIPT) $(srcdir)/Modules/makesetup $(DESTDIR)$(LIBPL)/makesetup
-	$(INSTALL_SCRIPT) $(srcdir)/install-sh $(DESTDIR)$(LIBPL)/install-sh
-	# Substitution happens here, as the completely-expanded BINDIR
-	# is not available in configure
-	sed -e "s,@[email protected],$(BINDIR)/python$(VERSION)$(EXE)," < $(srcdir)/Misc/python-config.in >python-config
-	$(INSTALL_SCRIPT) python-config $(DESTDIR)$(BINDIR)/python$(VERSION)-config
-	rm python-config
-	@if [ -s Modules/python.exp -a \
-		"`echo $(MACHDEP) | sed 's/^\(...\).*/\1/'`" = "aix" ]; then \
-		echo; echo "Installing support files for building shared extension modules on AIX:"; \
-		$(INSTALL_DATA) Modules/python.exp		\
-				$(DESTDIR)$(LIBPL)/python.exp;		\
-		echo; echo "$(LIBPL)/python.exp";		\
-		$(INSTALL_SCRIPT) $(srcdir)/Modules/makexp_aix	\
-				$(DESTDIR)$(LIBPL)/makexp_aix;		\
-		echo "$(LIBPL)/makexp_aix";			\
-		$(INSTALL_SCRIPT) $(srcdir)/Modules/ld_so_aix	\
-				$(DESTDIR)$(LIBPL)/ld_so_aix;		\
-		echo "$(LIBPL)/ld_so_aix";			\
-		echo; echo "See Misc/AIX-NOTES for details.";	\
-	else true; \
-	fi
-	@case "$(MACHDEP)" in beos*) \
-		echo; echo "Installing support files for building shared extension modules on BeOS:"; \
-		$(INSTALL_DATA) Misc/BeOS-NOTES $(DESTDIR)$(LIBPL)/README;	\
-		echo; echo "$(LIBPL)/README";			\
-		$(INSTALL_SCRIPT) Modules/ar_beos $(DESTDIR)$(LIBPL)/ar_beos; \
-		echo "$(LIBPL)/ar_beos";			\
-		$(INSTALL_SCRIPT) Modules/ld_so_beos $(DESTDIR)$(LIBPL)/ld_so_beos; \
-		echo "$(LIBPL)/ld_so_beos";			\
-		echo; echo "See Misc/BeOS-NOTES for details.";	\
-		;; \
-	esac
-
-# Install the dynamically loadable modules
-# This goes into $(exec_prefix)
-sharedinstall:
-	$(RUNSHARED) ./$(BUILDPYTHON) -E $(srcdir)/setup.py install \
-	   	--prefix=$(prefix) \
-		--install-scripts=$(BINDIR) \
-		--install-platlib=$(DESTSHARED) \
-		--root=/$(DESTDIR)
-
-# Here are a couple of targets for MacOSX again, to install a full
-# framework-based Python. frameworkinstall installs everything, the
-# subtargets install specific parts. Much of the actual work is offloaded to
-# the Makefile in Mac
-#
-#
-# This target is here for backward compatiblity, previous versions of Python
-# hadn't integrated framework installation in the normal install process.
-frameworkinstall: install
-
-# On install, we re-make the framework
-# structure in the install location, /Library/Frameworks/ or the argument to
-# --enable-framework. If --enable-framework has been specified then we have
-# automatically set prefix to the location deep down in the framework, so we
-# only have to cater for the structural bits of the framework.
-
-frameworkinstallframework: frameworkinstallstructure install frameworkinstallmaclib
-
-frameworkinstallstructure:	$(LDLIBRARY)
-	@if test "$(PYTHONFRAMEWORKDIR)" = no-framework; then \
-		echo Not configured with --enable-framework; \
-		exit 1; \
-	else true; \
-	fi
-	@for i in $(prefix)/Resources/English.lproj $(prefix)/lib; do\
-		if test ! -d $(DESTDIR)$$i; then \
-			echo "Creating directory $(DESTDIR)$$i"; \
-			$(INSTALL) -d -m $(DIRMODE) $(DESTDIR)$$i; \
-		else	true; \
-		fi; \
-	done
-	$(LN) -fsn include/python$(VERSION) $(DESTDIR)$(prefix)/Headers
-	sed 's/%VERSION%/'"`$(RUNSHARED) ./$(BUILDPYTHON) -c 'import platform; print platform.python_version()'`"'/g' < $(RESSRCDIR)/Info.plist > $(DESTDIR)$(prefix)/Resources/Info.plist
-	$(LN) -fsn $(VERSION) $(DESTDIR)$(PYTHONFRAMEWORKINSTALLDIR)/Versions/Current
-	$(LN) -fsn Versions/Current/$(PYTHONFRAMEWORK) $(DESTDIR)$(PYTHONFRAMEWORKINSTALLDIR)/$(PYTHONFRAMEWORK)
-	$(LN) -fsn Versions/Current/Headers $(DESTDIR)$(PYTHONFRAMEWORKINSTALLDIR)/Headers
-	$(LN) -fsn Versions/Current/Resources $(DESTDIR)$(PYTHONFRAMEWORKINSTALLDIR)/Resources
-	$(INSTALL_SHARED) $(LDLIBRARY) $(DESTDIR)$(PYTHONFRAMEWORKPREFIX)/$(LDLIBRARY)
-
-# This installs Mac/Lib into the framework
-# Install a number of symlinks to keep software that expects a normal unix
-# install (which includes python-config) happy.
-frameworkinstallmaclib:
-	ln -fs "../../../$(PYTHONFRAMEWORK)" "$(DESTDIR)$(prefix)/lib/python$(VERSION)/config/libpython$(VERSION).a"
-	cd Mac && $(MAKE) installmacsubtree DESTDIR="$(DESTDIR)"
-
-# This installs the IDE, the Launcher and other apps into /Applications
-frameworkinstallapps:
-	cd Mac && $(MAKE) installapps DESTDIR="$(DESTDIR)"
-
-frameworkinstallapps4way:
-	cd Mac && $(MAKE) installapps4way DESTDIR="$(DESTDIR)"
-
-# This install the unix python and pythonw tools in /usr/local/bin
-frameworkinstallunixtools:
-	cd Mac && $(MAKE) installunixtools DESTDIR="$(DESTDIR)"
-
-frameworkinstallunixtools4way:
-	cd Mac && $(MAKE) installunixtools4way DESTDIR="$(DESTDIR)"
-
-frameworkaltinstallunixtools:
-	cd Mac && $(MAKE) altinstallunixtools DESTDIR="$(DESTDIR)"
-
-frameworkaltinstallunixtools4way:
-	cd Mac && $(MAKE) altinstallunixtools4way DESTDIR="$(DESTDIR)"
-
-# This installs the Demos and Tools into the applications directory.
-# It is not part of a normal frameworkinstall
-frameworkinstallextras:
-	cd Mac && $(MAKE) installextras DESTDIR="$(DESTDIR)"
-
-# This installs a few of the useful scripts in Tools/scripts
-scriptsinstall:
-	SRCDIR=$(srcdir) $(RUNSHARED) \
-	./$(BUILDPYTHON) $(srcdir)/Tools/scripts/setup.py install \
-	--prefix=$(prefix) \
-	--install-scripts=$(BINDIR) \
-	--root=/$(DESTDIR)
-
-# Build the toplevel Makefile
-Makefile.pre: Makefile.pre.in config.status
-	CONFIG_FILES=Makefile.pre CONFIG_HEADERS= $(SHELL) config.status
-	$(MAKE) -f Makefile.pre Makefile
-
-# Run the configure script.
-config.status:	$(srcdir)/configure
-	$(SHELL) $(srcdir)/configure $(CONFIG_ARGS)
-
-.PRECIOUS: config.status $(BUILDPYTHON) Makefile Makefile.pre
-
-# Some make's put the object file in the current directory
-.c.o:
-	$(CC) -c $(PY_CFLAGS) -o [email protected] $<
-
-# Run reindent on the library
-reindent:
-	./$(BUILDPYTHON) $(srcdir)/Tools/scripts/reindent.py -r $(srcdir)/Lib
-
-# Rerun configure with the same options as it was run last time,
-# provided the config.status script exists
-recheck:
-	$(SHELL) config.status --recheck
-	$(SHELL) config.status
-
-# Rebuild the configure script from configure.in; also rebuild pyconfig.h.in
-autoconf:
-	(cd $(srcdir); autoconf)
-	(cd $(srcdir); autoheader)
-
-# Create a tags file for vi
-tags::
-	cd $(srcdir); \
-	ctags -w -t Include/*.h; \
-	for i in $(SRCDIRS); do ctags -w -t -a $$i/*.[ch]; \
-	done; \
-	sort -o tags tags
-
-# Create a tags file for GNU Emacs
-TAGS::
-	cd $(srcdir); \
-	etags Include/*.h; \
-	for i in $(SRCDIRS); do etags -a $$i/*.[ch]; done
-
-# Sanitation targets -- clean leaves libraries, executables and tags
-# files, which clobber removes as well
-pycremoval:
-	find $(srcdir) -name '*.py[co]' -exec rm -f {} ';'
-
-clean: pycremoval
-	find . -name '*.o' -exec rm -f {} ';'
-	find . -name '*.s[ol]' -exec rm -f {} ';'
-	find $(srcdir)/build -name 'fficonfig.h' -exec rm -f {} ';' || true
-	find $(srcdir)/build -name 'fficonfig.py' -exec rm -f {} ';' || true
-	-rm -f Lib/lib2to3/*Grammar*.pickle
-
-profile-removal:
-	find . -name '*.gc??' -exec rm -f {} ';'
-
-clobber: clean profile-removal
-	-rm -f $(BUILDPYTHON) $(PGEN) $(LIBRARY) $(LDLIBRARY) $(DLLLIBRARY) \
-		tags TAGS \
-		config.cache config.log pyconfig.h Modules/config.c
-	-rm -rf build platform
-	-rm -rf $(PYTHONFRAMEWORKDIR)
-
-# Make things extra clean, before making a distribution:
-# remove all generated files, even Makefile[.pre]
-# Keep configure and Python-ast.[ch], it's possible they can't be generated
-distclean: clobber
-	-rm -f core Makefile Makefile.pre config.status \
-		Modules/Setup Modules/Setup.local Modules/Setup.config
-	find $(srcdir) '(' -name '*.fdc' -o -name '*~' \
-			   -o -name '[@,#]*' -o -name '*.old' \
-			   -o -name '*.orig' -o -name '*.rej' \
-			   -o -name '*.bak' ')' \
-			   -exec rm -f {} ';'
-
-# Check for smelly exported symbols (not starting with Py/_Py)
-smelly: all
-	nm -p $(LIBRARY) | \
-		sed -n "/ [TDB] /s/.* //p" | grep -v "^_*Py" | sort -u; \
-
-# Find files with funny names
-funny:
-	find $(DISTDIRS) -type d \
-		-o -name '*.[chs]' \
-		-o -name '*.py' \
-		-o -name '*.doc' \
-		-o -name '*.sty' \
-		-o -name '*.bib' \
-		-o -name '*.dat' \
-		-o -name '*.el' \
-		-o -name '*.fd' \
-		-o -name '*.in' \
-		-o -name '*.tex' \
-		-o -name '*,[vpt]' \
-		-o -name 'Setup' \
-		-o -name 'Setup.*' \
-		-o -name README \
-		-o -name Makefile \
-		-o -name ChangeLog \
-		-o -name Repository \
-		-o -name Root \
-		-o -name Entries \
-		-o -name Tag \
-		-o -name tags \
-		-o -name TAGS \
-		-o -name .cvsignore \
-		-o -name MANIFEST \
-		-o -print
-
-# Perform some verification checks on any modified files.
-patchcheck:
-	$(RUNSHARED) ./$(BUILDPYTHON) $(srcdir)/Tools/scripts/patchcheck.py
-
-# Dependencies
-
-Python/thread.o:  $(srcdir)/Python/thread_atheos.h $(srcdir)/Python/thread_beos.h $(srcdir)/Python/thread_cthread.h $(srcdir)/Python/thread_foobar.h $(srcdir)/Python/thread_lwp.h $(srcdir)/Python/thread_nt.h $(srcdir)/Python/thread_os2.h $(srcdir)/Python/thread_pth.h $(srcdir)/Python/thread_pthread.h $(srcdir)/Python/thread_sgi.h $(srcdir)/Python/thread_solaris.h $(srcdir)/Python/thread_wince.h
-
-# Declare targets that aren't real files
-.PHONY: all build_all sharedmods oldsharedmods test quicktest memtest
-.PHONY: install altinstall oldsharedinstall bininstall altbininstall
-.PHONY: maninstall libinstall inclinstall libainstall sharedinstall
-.PHONY: frameworkinstall frameworkinstallframework frameworkinstallstructure
-.PHONY: frameworkinstallmaclib frameworkinstallapps frameworkinstallunixtools
-.PHONY: frameworkaltinstallunixtools recheck autoconf clean clobber distclean 
-.PHONY: smelly funny patchcheck
-
-# IF YOU PUT ANYTHING HERE IT WILL GO AWAY
-
-# Rules appended by makedepend
-
-Modules/threadmodule.o: $(srcdir)/Modules/threadmodule.c; $(CC) $(PY_CFLAGS)  -c $(srcdir)/Modules/threadmodule.c -o Modules/threadmodule.o
-Modules/threadmodule$(SO):  Modules/threadmodule.o; $(BLDSHARED)  Modules/threadmodule.o   -o Modules/threadmodule$(SO)
-Modules/signalmodule.o: $(srcdir)/Modules/signalmodule.c; $(CC) $(PY_CFLAGS)  -c $(srcdir)/Modules/signalmodule.c -o Modules/signalmodule.o
-Modules/signalmodule$(SO):  Modules/signalmodule.o; $(BLDSHARED)  Modules/signalmodule.o   -o Modules/signalmodule$(SO)
-Modules/posixmodule.o: $(srcdir)/Modules/posixmodule.c; $(CC) $(PY_CFLAGS)  -c $(srcdir)/Modules/posixmodule.c -o Modules/posixmodule.o
-Modules/posixmodule$(SO):  Modules/posixmodule.o; $(BLDSHARED)  Modules/posixmodule.o   -o Modules/posixmodule$(SO)
-Modules/errnomodule.o: $(srcdir)/Modules/errnomodule.c; $(CC) $(PY_CFLAGS)  -c $(srcdir)/Modules/errnomodule.c -o Modules/errnomodule.o
-Modules/errnomodule$(SO):  Modules/errnomodule.o; $(BLDSHARED)  Modules/errnomodule.o   -o Modules/errnomodule$(SO)
-Modules/pwdmodule.o: $(srcdir)/Modules/pwdmodule.c; $(CC) $(PY_CFLAGS)  -c $(srcdir)/Modules/pwdmodule.c -o Modules/pwdmodule.o
-Modules/pwdmodule$(SO):  Modules/pwdmodule.o; $(BLDSHARED)  Modules/pwdmodule.o   -o Modules/pwdmodule$(SO)
-Modules/_sre.o: $(srcdir)/Modules/_sre.c; $(CC) $(PY_CFLAGS)  -c $(srcdir)/Modules/_sre.c -o Modules/_sre.o
-Modules/_sre$(SO):  Modules/_sre.o; $(BLDSHARED)  Modules/_sre.o   -o Modules/_sre$(SO)
-Modules/_codecsmodule.o: $(srcdir)/Modules/_codecsmodule.c; $(CC) $(PY_CFLAGS)  -c $(srcdir)/Modules/_codecsmodule.c -o Modules/_codecsmodule.o
-Modules/_codecsmodule$(SO):  Modules/_codecsmodule.o; $(BLDSHARED)  Modules/_codecsmodule.o   -o Modules/_codecsmodule$(SO)
-Modules/zipimport.o: $(srcdir)/Modules/zipimport.c; $(CC) $(PY_CFLAGS)  -c $(srcdir)/Modules/zipimport.c -o Modules/zipimport.o
-Modules/zipimport$(SO):  Modules/zipimport.o; $(BLDSHARED)  Modules/zipimport.o   -o Modules/zipimport$(SO)
-Modules/symtablemodule.o: $(srcdir)/Modules/symtablemodule.c; $(CC) $(PY_CFLAGS)  -c $(srcdir)/Modules/symtablemodule.c -o Modules/symtablemodule.o
-Modules/_symtablemodule$(SO):  Modules/symtablemodule.o; $(BLDSHARED)  Modules/symtablemodule.o   -o Modules/_symtablemodule$(SO)
-Modules/xxsubtype.o: $(srcdir)/Modules/xxsubtype.c; $(CC) $(PY_CFLAGS)  -c $(srcdir)/Modules/xxsubtype.c -o Modules/xxsubtype.o
-Modules/xxsubtype$(SO):  Modules/xxsubtype.o; $(BLDSHARED)  Modules/xxsubtype.o   -o Modules/xxsubtype$(SO)
--- a/components/python/python26/files/pyconfig.h	Tue Oct 20 05:38:14 2015 -0700
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,5 +0,0 @@
-#ifdef _LP64
-#include <python2.6/pyconfig-64.h>
-#else
-#include <python2.6/pyconfig-32.h>
-#endif
--- a/components/python/python26/llib-lpython26	Tue Oct 20 05:38:14 2015 -0700
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,30 +0,0 @@
-/*
- * CDDL HEADER START
- *
- * The contents of this file are subject to the terms of the
- * Common Development and Distribution License (the "License").
- * You may not use this file except in compliance with the License.
- *
- * You can obtain a copy of the license at usr/src/OPENSOLARIS.LICENSE
- * or http://www.opensolaris.org/os/licensing.
- * See the License for the specific language governing permissions
- * and limitations under the License.
- *
- * When distributing Covered Code, include this CDDL HEADER in each
- * file and include the License file at usr/src/OPENSOLARIS.LICENSE.
- * If applicable, add the following below this CDDL HEADER, with the
- * fields enclosed by brackets "[]" replaced with your own identifying
- * information: Portions Copyright [yyyy] [name of copyright owner]
- *
- * CDDL HEADER END
- */
-
-/*
- * Copyright (c) 2011, Oracle and/or its affiliates. All rights reserved.
- */
-
-/* LINTLIBRARY */
-/* PROTOLIB1 */
-
-#include <Python.h>
-
--- a/components/python/python26/patches/Python26-00-filemagic.patch	Tue Oct 20 05:38:14 2015 -0700
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,2242 +0,0 @@
-diff -u Python-2.6.4/Lib/platform.py.orig Python-2.6.4/Lib/platform.py
---- Python-2.6.4/Lib/platform.py.orig	Mon Feb 21 10:46:30 2011
-+++ Python-2.6.4/Lib/platform.py	Mon Feb 21 10:46:30 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python2.6
- 
- """ This module tries to retrieve as much platform-identifying data as
-     possible. It makes this information available via function APIs.
-diff -u Python-2.6.4/Lib/profile.py.orig Python-2.6.4/Lib/profile.py
---- Python-2.6.4/Lib/profile.py.orig	Mon Feb 21 10:46:25 2011
-+++ Python-2.6.4/Lib/profile.py	Mon Feb 21 10:46:25 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- #
- # Class for profiling python code. rev 1.0  6/2/94
- #
-diff -u Python-2.6.4/Lib/trace.py.orig Python-2.6.4/Lib/trace.py
---- Python-2.6.4/Lib/trace.py.orig	Mon Feb 21 10:46:29 2011
-+++ Python-2.6.4/Lib/trace.py	Mon Feb 21 10:46:29 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python2.6
- 
- # portions copyright 2001, Autonomous Zones Industries, Inc., all rights...
- # err...  reserved and offered to the public under the terms of the
-diff -u Python-2.6.4/Lib/cProfile.py.orig Python-2.6.4/Lib/cProfile.py
---- Python-2.6.4/Lib/cProfile.py.orig	Mon Feb 21 10:46:29 2011
-+++ Python-2.6.4/Lib/cProfile.py	Mon Feb 21 10:46:29 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- 
- """Python interface for the 'lsprof' profiler.
-    Compatible with the 'profile' module.
-diff -u Python-2.6.4/Lib/idlelib/PyShell.py.orig Python-2.6.4/Lib/idlelib/PyShell.py
---- Python-2.6.4/Lib/idlelib/PyShell.py.orig	Mon Feb 21 10:46:23 2011
-+++ Python-2.6.4/Lib/idlelib/PyShell.py	Mon Feb 21 10:46:23 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- 
- import os
- import os.path
-diff -u Python-2.6.4/Lib/UserString.py.orig Python-2.6.4/Lib/UserString.py
---- Python-2.6.4/Lib/UserString.py.orig	Mon Feb 21 10:46:27 2011
-+++ Python-2.6.4/Lib/UserString.py	Mon Feb 21 10:46:27 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python2.6
- ## vim:ts=4:et:nowrap
- """A user-defined wrapper around string objects
- 
-diff -u Python-2.6.4/Lib/lib2to3/tests/pytree_idempotency.py.orig Python-2.6.4/Lib/lib2to3/tests/pytree_idempotency.py
---- Python-2.6.4/Lib/lib2to3/tests/pytree_idempotency.py.orig	Mon Feb 21 10:46:24 2011
-+++ Python-2.6.4/Lib/lib2to3/tests/pytree_idempotency.py	Mon Feb 21 10:46:24 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python2.6
- # Copyright 2006 Google, Inc. All Rights Reserved.
- # Licensed to PSF under a Contributor Agreement.
- 
-diff -u Python-2.6.4/Lib/lib2to3/tests/test_all_fixers.py.orig Python-2.6.4/Lib/lib2to3/tests/test_all_fixers.py
---- Python-2.6.4/Lib/lib2to3/tests/test_all_fixers.py.orig	Mon Feb 21 10:46:24 2011
-+++ Python-2.6.4/Lib/lib2to3/tests/test_all_fixers.py	Mon Feb 21 10:46:24 2011
[email protected]@ -1,3 +1,4 @@
-+#!/usr/bin/python2.6
- """Tests that run all fixer modules over an input stream.
- 
- This has been broken out into its own test module because of its
-diff -u Python-2.6.4/Lib/lib2to3/tests/test_util.py.orig Python-2.6.4/Lib/lib2to3/tests/test_util.py
---- Python-2.6.4/Lib/lib2to3/tests/test_util.py.orig	Mon Feb 21 10:46:24 2011
-+++ Python-2.6.4/Lib/lib2to3/tests/test_util.py	Mon Feb 21 10:46:24 2011
[email protected]@ -1,3 +1,4 @@
-+#!/usr/bin/python2.6
- """ Test suite for the code in fixer_util """
- 
- # Testing imports
-diff -u Python-2.6.4/Lib/lib2to3/tests/test_parser.py.orig Python-2.6.4/Lib/lib2to3/tests/test_parser.py
---- Python-2.6.4/Lib/lib2to3/tests/test_parser.py.orig	Mon Feb 21 10:46:24 2011
-+++ Python-2.6.4/Lib/lib2to3/tests/test_parser.py	Mon Feb 21 10:46:24 2011
[email protected]@ -1,3 +1,4 @@
-+#!/usr/bin/python2.6
- """Test suite for 2to3's parser and grammar files.
- 
- This is the place to add tests for changes to 2to3's grammar, such as those
-diff -u Python-2.6.4/Lib/lib2to3/tests/test_pytree.py.orig Python-2.6.4/Lib/lib2to3/tests/test_pytree.py
---- Python-2.6.4/Lib/lib2to3/tests/test_pytree.py.orig	Mon Feb 21 10:46:24 2011
-+++ Python-2.6.4/Lib/lib2to3/tests/test_pytree.py	Mon Feb 21 10:46:24 2011
[email protected]@ -1,3 +1,4 @@
-+#!/usr/bin/python2.6
- # Copyright 2006 Google, Inc. All Rights Reserved.
- # Licensed to PSF under a Contributor Agreement.
- 
-diff -u Python-2.6.4/Lib/lib2to3/tests/test_fixers.py.orig Python-2.6.4/Lib/lib2to3/tests/test_fixers.py
---- Python-2.6.4/Lib/lib2to3/tests/test_fixers.py.orig	Mon Feb 21 10:46:24 2011
-+++ Python-2.6.4/Lib/lib2to3/tests/test_fixers.py	Mon Feb 21 10:46:24 2011
[email protected]@ -1,3 +1,4 @@
-+#!/usr/bin/python2.6
- """ Test suite for the fixer modules """
- # Author: Collin Winter
- 
-diff -u Python-2.6.4/Lib/lib2to3/refactor.py.orig Python-2.6.4/Lib/lib2to3/refactor.py
---- Python-2.6.4/Lib/lib2to3/refactor.py.orig	Mon Feb 21 10:46:24 2011
-+++ Python-2.6.4/Lib/lib2to3/refactor.py	Mon Feb 21 10:46:24 2011
[email protected]@ -1,3 +1,4 @@
-+#!/usr/bin/python2.6
- # Copyright 2006 Google, Inc. All Rights Reserved.
- # Licensed to PSF under a Contributor Agreement.
- 
-diff -u Python-2.6.4/Lib/lib2to3/pgen2/token.py.orig Python-2.6.4/Lib/lib2to3/pgen2/token.py
---- Python-2.6.4/Lib/lib2to3/pgen2/token.py.orig	Mon Feb 21 10:46:25 2011
-+++ Python-2.6.4/Lib/lib2to3/pgen2/token.py	Mon Feb 21 10:46:25 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- 
- """Token constants (from "token.h")."""
- 
-diff -u Python-2.6.4/Lib/cgi.py.orig Python-2.6.4/Lib/cgi.py
---- Python-2.6.4/Lib/cgi.py.orig	Mon Feb 21 10:46:24 2011
-+++ Python-2.6.4/Lib/cgi.py	Mon Feb 21 10:46:24 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/local/bin/python
-+#!/usr/bin/python2.6
- 
- # NOTE: the above "/usr/local/bin/python" is NOT a mistake.  It is
- # intentionally NOT "/usr/bin/env python".  On many systems
-diff -u Python-2.6.4/Lib/base64.py.orig Python-2.6.4/Lib/base64.py
---- Python-2.6.4/Lib/base64.py.orig	Mon Feb 21 10:46:36 2011
-+++ Python-2.6.4/Lib/base64.py	Mon Feb 21 10:46:36 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- 
- """RFC 3548: Base16, Base32, Base64 Data Encodings"""
- 
-diff -u Python-2.6.4/Lib/encodings/rot_13.py.orig Python-2.6.4/Lib/encodings/rot_13.py
---- Python-2.6.4/Lib/encodings/rot_13.py.orig	Mon Feb 21 10:46:26 2011
-+++ Python-2.6.4/Lib/encodings/rot_13.py	Mon Feb 21 10:46:26 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python2.6
- """ Python Character Mapping Codec for ROT13.
- 
-     See http://ucsub.colorado.edu/~kominek/rot13/ for details.
-diff -u Python-2.6.4/Lib/tabnanny.py.orig Python-2.6.4/Lib/tabnanny.py
---- Python-2.6.4/Lib/tabnanny.py.orig	Mon Feb 21 10:46:27 2011
-+++ Python-2.6.4/Lib/tabnanny.py	Mon Feb 21 10:46:27 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- 
- """The Tab Nanny despises ambiguous indentation.  She knows no mercy.
- 
-diff -u Python-2.6.4/Lib/timeit.py.orig Python-2.6.4/Lib/timeit.py
---- Python-2.6.4/Lib/timeit.py.orig	Mon Feb 21 10:46:23 2011
-+++ Python-2.6.4/Lib/timeit.py	Mon Feb 21 10:46:23 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- 
- """Tool for measuring execution time of small code snippets.
- 
-diff -u Python-2.6.4/Lib/pydoc.py.orig Python-2.6.4/Lib/pydoc.py
---- Python-2.6.4/Lib/pydoc.py.orig	Mon Feb 21 10:46:28 2011
-+++ Python-2.6.4/Lib/pydoc.py	Mon Feb 21 10:46:28 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python2.6
- # -*- coding: latin-1 -*-
- """Generate Python documentation in HTML or text for interactive use.
- 
-diff -u Python-2.6.4/Lib/quopri.py.orig Python-2.6.4/Lib/quopri.py
---- Python-2.6.4/Lib/quopri.py.orig	Mon Feb 21 10:46:29 2011
-+++ Python-2.6.4/Lib/quopri.py	Mon Feb 21 10:46:29 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- 
- """Conversions to/from quoted-printable transport encoding as per RFC 1521."""
- 
-diff -u Python-2.6.4/Lib/keyword.py.orig Python-2.6.4/Lib/keyword.py
---- Python-2.6.4/Lib/keyword.py.orig	Mon Feb 21 10:46:24 2011
-+++ Python-2.6.4/Lib/keyword.py	Mon Feb 21 10:46:24 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- 
- """Keywords (from "graminit.c")
- 
-diff -u Python-2.6.4/Lib/mailbox.py.orig Python-2.6.4/Lib/mailbox.py
---- Python-2.6.4/Lib/mailbox.py.orig	Mon Feb 21 10:46:27 2011
-+++ Python-2.6.4/Lib/mailbox.py	Mon Feb 21 10:46:27 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- 
- """Read/write support for Maildir, mbox, MH, Babyl, and MMDF mailboxes."""
- 
-diff -u Python-2.6.4/Lib/difflib.py.orig Python-2.6.4/Lib/difflib.py
---- Python-2.6.4/Lib/difflib.py.orig	Mon Feb 21 10:46:36 2011
-+++ Python-2.6.4/Lib/difflib.py	Mon Feb 21 10:46:36 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- 
- """
- Module difflib -- helpers for computing deltas between objects.
-diff -u Python-2.6.4/Lib/webbrowser.py.orig Python-2.6.4/Lib/webbrowser.py
---- Python-2.6.4/Lib/webbrowser.py.orig	Mon Feb 21 10:46:26 2011
-+++ Python-2.6.4/Lib/webbrowser.py	Mon Feb 21 10:46:26 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- """Interfaces for launching and remotely controlling Web browsers."""
- # Maintained by Georg Brandl.
- 
-diff -u Python-2.6.4/Lib/unittest.py.orig Python-2.6.4/Lib/unittest.py
---- Python-2.6.4/Lib/unittest.py.orig	Mon Feb 21 10:46:28 2011
-+++ Python-2.6.4/Lib/unittest.py	Mon Feb 21 10:46:28 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python2.6
- '''
- Python unit testing framework, based on Erich Gamma's JUnit and Kent Beck's
- Smalltalk testing framework.
-diff -u Python-2.6.4/Lib/bsddb/test/test_dbtables.py.orig Python-2.6.4/Lib/bsddb/test/test_dbtables.py
---- Python-2.6.4/Lib/bsddb/test/test_dbtables.py.orig	Mon Feb 21 10:46:28 2011
-+++ Python-2.6.4/Lib/bsddb/test/test_dbtables.py	Mon Feb 21 10:46:28 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python2.6
- #
- #-----------------------------------------------------------------------
- # A test suite for the table interface built on bsddb.db
-diff -u Python-2.6.4/Lib/bsddb/dbshelve.py.orig Python-2.6.4/Lib/bsddb/dbshelve.py
---- Python-2.6.4/Lib/bsddb/dbshelve.py.orig	Mon Feb 21 10:46:28 2011
-+++ Python-2.6.4/Lib/bsddb/dbshelve.py	Mon Feb 21 10:46:28 2011
[email protected]@ -1,4 +1,4 @@
--#!/bin/env python
-+#!/usr/bin/python2.6
- #------------------------------------------------------------------------
- #           Copyright (c) 1997-2001 by Total Control Software
- #                         All Rights Reserved
-diff -u Python-2.6.4/Lib/token.py.orig Python-2.6.4/Lib/token.py
---- Python-2.6.4/Lib/token.py.orig	Mon Feb 21 10:46:28 2011
-+++ Python-2.6.4/Lib/token.py	Mon Feb 21 10:46:28 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- 
- """Token constants (from "token.h")."""
- 
-diff -u Python-2.6.4/Lib/Cookie.py.orig Python-2.6.4/Lib/Cookie.py
---- Python-2.6.4/Lib/Cookie.py.orig	Mon Feb 21 10:46:25 2011
-+++ Python-2.6.4/Lib/Cookie.py	Mon Feb 21 10:46:25 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python2.6
- #
- 
- ####
-diff -u Python-2.6.4/Lib/smtplib.py.orig Python-2.6.4/Lib/smtplib.py
---- Python-2.6.4/Lib/smtplib.py.orig	Mon Feb 21 10:46:28 2011
-+++ Python-2.6.4/Lib/smtplib.py	Mon Feb 21 10:46:28 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- 
- '''SMTP/ESMTP client class.
- 
-diff -u Python-2.6.4/Lib/smtpd.py.orig Python-2.6.4/Lib/smtpd.py
---- Python-2.6.4/Lib/smtpd.py.orig	Mon Feb 21 10:46:28 2011
-+++ Python-2.6.4/Lib/smtpd.py	Mon Feb 21 10:46:28 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- """An RFC 2821 smtp proxy.
- 
- Usage: %(program)s [options] [localhost:localport [remotehost:remoteport]]
-diff -u Python-2.6.4/Lib/test/regrtest.py.orig Python-2.6.4/Lib/test/regrtest.py
---- Python-2.6.4/Lib/test/regrtest.py.orig	Mon Feb 21 10:46:35 2011
-+++ Python-2.6.4/Lib/test/regrtest.py	Mon Feb 21 10:46:35 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- 
- """Regression test.
- 
-diff -u Python-2.6.4/Lib/test/test_sets.py.orig Python-2.6.4/Lib/test/test_sets.py
---- Python-2.6.4/Lib/test/test_sets.py.orig	Mon Feb 21 10:46:33 2011
-+++ Python-2.6.4/Lib/test/test_sets.py	Mon Feb 21 10:46:33 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python2.6
- 
- import warnings
- warnings.filterwarnings("ignore", "the sets module is deprecated",
-diff -u Python-2.6.4/Lib/test/test_dl.py.orig Python-2.6.4/Lib/test/test_dl.py
---- Python-2.6.4/Lib/test/test_dl.py.orig	Mon Feb 21 10:46:34 2011
-+++ Python-2.6.4/Lib/test/test_dl.py	Mon Feb 21 10:46:34 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- """Test dlmodule.c
-    Roger E. Masse  revised strategy by Barry Warsaw
- """
-diff -u Python-2.6.4/Lib/test/test_multiprocessing.py.orig Python-2.6.4/Lib/test/test_multiprocessing.py
---- Python-2.6.4/Lib/test/test_multiprocessing.py.orig	Mon Feb 21 10:46:35 2011
-+++ Python-2.6.4/Lib/test/test_multiprocessing.py	Mon Feb 21 10:46:35 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python2.6
- 
- #
- # Unit tests for the multiprocessing package
-diff -u Python-2.6.4/Lib/test/test_cmd.py.orig Python-2.6.4/Lib/test/test_cmd.py
---- Python-2.6.4/Lib/test/test_cmd.py.orig	Mon Feb 21 10:46:36 2011
-+++ Python-2.6.4/Lib/test/test_cmd.py	Mon Feb 21 10:46:36 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python2.6
- """
- Test script for the 'cmd' module
- Original by Michael Schneider
-diff -u Python-2.6.4/Lib/test/test_userstring.py.orig Python-2.6.4/Lib/test/test_userstring.py
---- Python-2.6.4/Lib/test/test_userstring.py.orig	Mon Feb 21 10:46:33 2011
-+++ Python-2.6.4/Lib/test/test_userstring.py	Mon Feb 21 10:46:33 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python2.6
- # UserString is a wrapper around the native builtin string type.
- # UserString instances should behave similar to builtin string objects.
- 
-diff -u Python-2.6.4/Lib/test/test_popen.py.orig Python-2.6.4/Lib/test/test_popen.py
---- Python-2.6.4/Lib/test/test_popen.py.orig	Mon Feb 21 10:46:33 2011
-+++ Python-2.6.4/Lib/test/test_popen.py	Mon Feb 21 10:46:33 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- """Basic tests for os.popen()
- 
-   Particularly useful for platforms that fake popen.
-diff -u Python-2.6.4/Lib/test/test_cd.py.orig Python-2.6.4/Lib/test/test_cd.py
---- Python-2.6.4/Lib/test/test_cd.py.orig	Mon Feb 21 10:46:33 2011
-+++ Python-2.6.4/Lib/test/test_cd.py	Mon Feb 21 10:46:33 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- """Whimpy test script for the cd module
-    Roger E. Masse
- """
-diff -u Python-2.6.4/Lib/test/test_cl.py.orig Python-2.6.4/Lib/test/test_cl.py
---- Python-2.6.4/Lib/test/test_cl.py.orig	Mon Feb 21 10:46:34 2011
-+++ Python-2.6.4/Lib/test/test_cl.py	Mon Feb 21 10:46:34 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- """Whimpy test script for the cl module
-    Roger E. Masse
- """
-diff -u Python-2.6.4/Lib/test/test_imgfile.py.orig Python-2.6.4/Lib/test/test_imgfile.py
---- Python-2.6.4/Lib/test/test_imgfile.py.orig	Mon Feb 21 10:46:35 2011
-+++ Python-2.6.4/Lib/test/test_imgfile.py	Mon Feb 21 10:46:35 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- 
- """Simple test script for imgfile.c
-    Roger E. Masse
-diff -u Python-2.6.4/Lib/test/test_random.py.orig Python-2.6.4/Lib/test/test_random.py
---- Python-2.6.4/Lib/test/test_random.py.orig	Mon Feb 21 10:46:35 2011
-+++ Python-2.6.4/Lib/test/test_random.py	Mon Feb 21 10:46:35 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python2.6
- 
- import unittest
- import random
-diff -u Python-2.6.4/Lib/test/curses_tests.py.orig Python-2.6.4/Lib/test/curses_tests.py
---- Python-2.6.4/Lib/test/curses_tests.py.orig	Mon Feb 21 10:46:32 2011
-+++ Python-2.6.4/Lib/test/curses_tests.py	Mon Feb 21 10:46:32 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python2.6
- #
- # $Id: ncurses.py 36559 2004-07-18 05:56:09Z tim_one $
- #
-diff -u Python-2.6.4/Lib/test/test_codecmaps_cn.py.orig Python-2.6.4/Lib/test/test_codecmaps_cn.py
---- Python-2.6.4/Lib/test/test_codecmaps_cn.py.orig	Mon Feb 21 10:46:34 2011
-+++ Python-2.6.4/Lib/test/test_codecmaps_cn.py	Mon Feb 21 10:46:34 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python2.6
- #
- # test_codecmaps_cn.py
- #   Codec mapping tests for PRC encodings
-diff -u Python-2.6.4/Lib/test/test_whichdb.py.orig Python-2.6.4/Lib/test/test_whichdb.py
---- Python-2.6.4/Lib/test/test_whichdb.py.orig	Mon Feb 21 10:46:36 2011
-+++ Python-2.6.4/Lib/test/test_whichdb.py	Mon Feb 21 10:46:36 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- """Test script for the whichdb module
-    based on test_anydbm.py
- """
-diff -u Python-2.6.4/Lib/test/test_eof.py.orig Python-2.6.4/Lib/test/test_eof.py
---- Python-2.6.4/Lib/test/test_eof.py.orig	Mon Feb 21 10:46:35 2011
-+++ Python-2.6.4/Lib/test/test_eof.py	Mon Feb 21 10:46:35 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- """test script for a few new invalid token catches"""
- 
- import unittest
-diff -u Python-2.6.4/Lib/test/test_imageop.py.orig Python-2.6.4/Lib/test/test_imageop.py
---- Python-2.6.4/Lib/test/test_imageop.py.orig	Mon Feb 21 10:46:31 2011
-+++ Python-2.6.4/Lib/test/test_imageop.py	Mon Feb 21 10:46:31 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- 
- """Test script for the imageop module.  This has the side
-    effect of partially testing the imgfile module as well.
-diff -u Python-2.6.4/Lib/test/test_codecmaps_tw.py.orig Python-2.6.4/Lib/test/test_codecmaps_tw.py
---- Python-2.6.4/Lib/test/test_codecmaps_tw.py.orig	Mon Feb 21 10:46:35 2011
-+++ Python-2.6.4/Lib/test/test_codecmaps_tw.py	Mon Feb 21 10:46:35 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python2.6
- #
- # test_codecmaps_tw.py
- #   Codec mapping tests for ROC encodings
-diff -u Python-2.6.4/Lib/test/test_codecencodings_hk.py.orig Python-2.6.4/Lib/test/test_codecencodings_hk.py
---- Python-2.6.4/Lib/test/test_codecencodings_hk.py.orig	Mon Feb 21 10:46:33 2011
-+++ Python-2.6.4/Lib/test/test_codecencodings_hk.py	Mon Feb 21 10:46:33 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python2.6
- #
- # test_codecencodings_hk.py
- #   Codec encoding tests for HongKong encodings.
-diff -u Python-2.6.4/Lib/test/test_codecencodings_jp.py.orig Python-2.6.4/Lib/test/test_codecencodings_jp.py
---- Python-2.6.4/Lib/test/test_codecencodings_jp.py.orig	Mon Feb 21 10:46:33 2011
-+++ Python-2.6.4/Lib/test/test_codecencodings_jp.py	Mon Feb 21 10:46:33 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python2.6
- #
- # test_codecencodings_jp.py
- #   Codec encoding tests for Japanese encodings.
-diff -u Python-2.6.4/Lib/test/test_with.py.orig Python-2.6.4/Lib/test/test_with.py
---- Python-2.6.4/Lib/test/test_with.py.orig	Mon Feb 21 10:46:33 2011
-+++ Python-2.6.4/Lib/test/test_with.py	Mon Feb 21 10:46:33 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python2.6
- 
- """Unit tests for the with statement specified in PEP 343."""
- 
-diff -u Python-2.6.4/Lib/test/crashers/recursive_call.py.orig Python-2.6.4/Lib/test/crashers/recursive_call.py
---- Python-2.6.4/Lib/test/crashers/recursive_call.py.orig	Mon Feb 21 10:46:33 2011
-+++ Python-2.6.4/Lib/test/crashers/recursive_call.py	Mon Feb 21 10:46:33 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python2.6
- 
- # No bug report AFAIK, mail on python-dev on 2006-01-10
- 
-diff -u Python-2.6.4/Lib/test/test_codecmaps_kr.py.orig Python-2.6.4/Lib/test/test_codecmaps_kr.py
---- Python-2.6.4/Lib/test/test_codecmaps_kr.py.orig	Mon Feb 21 10:46:32 2011
-+++ Python-2.6.4/Lib/test/test_codecmaps_kr.py	Mon Feb 21 10:46:32 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python2.6
- #
- # test_codecmaps_kr.py
- #   Codec mapping tests for ROK encodings
-diff -u Python-2.6.4/Lib/test/test_array.py.orig Python-2.6.4/Lib/test/test_array.py
---- Python-2.6.4/Lib/test/test_array.py.orig	Mon Feb 21 10:46:34 2011
-+++ Python-2.6.4/Lib/test/test_array.py	Mon Feb 21 10:46:34 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- """Test the arraymodule.
-    Roger E. Masse
- """
-diff -u Python-2.6.4/Lib/test/test_pep263.py.orig Python-2.6.4/Lib/test/test_pep263.py
---- Python-2.6.4/Lib/test/test_pep263.py.orig   Mon Feb 21 10:46:32 2011
-+++ Python-2.6.4/Lib/test/test_pep263.py        Mon Feb 21 10:46:32 2011
[email protected]@ -1,4 +1,4 @@
--# -*- coding: koi8-r -*-
-+#!/usr/bin/python2.6
- 
- import unittest
- from test import test_support
-diff -u Python-2.6.4/Lib/test/test_anydbm.py.orig Python-2.6.4/Lib/test/test_anydbm.py
---- Python-2.6.4/Lib/test/test_anydbm.py.orig	Mon Feb 21 10:46:35 2011
-+++ Python-2.6.4/Lib/test/test_anydbm.py	Mon Feb 21 10:46:35 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- """Test script for the anydbm module
-    based on testdumbdbm.py
- """
-diff -u Python-2.6.4/Lib/test/test_smtpnet.py.orig Python-2.6.4/Lib/test/test_smtpnet.py
---- Python-2.6.4/Lib/test/test_smtpnet.py.orig	Mon Feb 21 10:46:34 2011
-+++ Python-2.6.4/Lib/test/test_smtpnet.py	Mon Feb 21 10:46:34 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python2.6
- 
- import unittest
- from test import test_support
-diff -u Python-2.6.4/Lib/test/test_al.py.orig Python-2.6.4/Lib/test/test_al.py
---- Python-2.6.4/Lib/test/test_al.py.orig	Mon Feb 21 10:46:31 2011
-+++ Python-2.6.4/Lib/test/test_al.py	Mon Feb 21 10:46:31 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- """Whimpy test script for the al module
-    Roger E. Masse
- """
-diff -u Python-2.6.4/Lib/test/test_urllib2net.py.orig Python-2.6.4/Lib/test/test_urllib2net.py
---- Python-2.6.4/Lib/test/test_urllib2net.py.orig	Mon Feb 21 10:46:33 2011
-+++ Python-2.6.4/Lib/test/test_urllib2net.py	Mon Feb 21 10:46:33 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python2.6
- 
- import unittest
- from test import test_support
-diff -u Python-2.6.4/Lib/test/test_marshal.py.orig Python-2.6.4/Lib/test/test_marshal.py
---- Python-2.6.4/Lib/test/test_marshal.py.orig	Mon Feb 21 10:46:32 2011
-+++ Python-2.6.4/Lib/test/test_marshal.py	Mon Feb 21 10:46:32 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python2.6
- # -*- coding: iso-8859-1 -*-
- 
- from test import test_support
-diff -u Python-2.6.4/Lib/test/test_urlparse.py.orig Python-2.6.4/Lib/test/test_urlparse.py
---- Python-2.6.4/Lib/test/test_urlparse.py.orig	Mon Feb 21 10:46:33 2011
-+++ Python-2.6.4/Lib/test/test_urlparse.py	Mon Feb 21 10:46:33 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- 
- from test import test_support
- import unittest
-diff -u Python-2.6.4/Lib/test/test_bz2.py.orig Python-2.6.4/Lib/test/test_bz2.py
---- Python-2.6.4/Lib/test/test_bz2.py.orig	Mon Feb 21 10:46:34 2011
-+++ Python-2.6.4/Lib/test/test_bz2.py	Mon Feb 21 10:46:34 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/python
-+#!/usr/bin/python2.6
- from test import test_support
- from test.test_support import TESTFN
- 
-diff -u Python-2.6.4/Lib/test/test_urllibnet.py.orig Python-2.6.4/Lib/test/test_urllibnet.py
---- Python-2.6.4/Lib/test/test_urllibnet.py.orig	Mon Feb 21 10:46:32 2011
-+++ Python-2.6.4/Lib/test/test_urllibnet.py	Mon Feb 21 10:46:32 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python2.6
- 
- import unittest
- from test import test_support
-diff -u Python-2.6.4/Lib/test/test_logging.py.orig Python-2.6.4/Lib/test/test_logging.py
---- Python-2.6.4/Lib/test/test_logging.py.orig	Mon Feb 21 10:46:33 2011
-+++ Python-2.6.4/Lib/test/test_logging.py	Mon Feb 21 10:46:33 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python2.6
- #
- # Copyright 2001-2004 by Vinay Sajip. All Rights Reserved.
- #
-diff -u Python-2.6.4/Lib/test/test_socket.py.orig Python-2.6.4/Lib/test/test_socket.py
---- Python-2.6.4/Lib/test/test_socket.py.orig	Mon Feb 21 10:46:35 2011
-+++ Python-2.6.4/Lib/test/test_socket.py	Mon Feb 21 10:46:35 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python2.6
- 
- import unittest
- from test import test_support
-diff -u Python-2.6.4/Lib/test/pystone.py.orig Python-2.6.4/Lib/test/pystone.py
---- Python-2.6.4/Lib/test/pystone.py.orig	Mon Feb 21 10:46:34 2011
-+++ Python-2.6.4/Lib/test/pystone.py	Mon Feb 21 10:46:34 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- 
- """
- "PYSTONE" Benchmark Program
-diff -u Python-2.6.4/Lib/test/test_multibytecodec.py.orig Python-2.6.4/Lib/test/test_multibytecodec.py
---- Python-2.6.4/Lib/test/test_multibytecodec.py.orig	Mon Feb 21 10:46:35 2011
-+++ Python-2.6.4/Lib/test/test_multibytecodec.py	Mon Feb 21 10:46:35 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python2.6
- #
- # test_multibytecodec.py
- #   Unit test for multibytecodec itself
-diff -u Python-2.6.4/Lib/test/test_popen2.py.orig Python-2.6.4/Lib/test/test_popen2.py
---- Python-2.6.4/Lib/test/test_popen2.py.orig	Mon Feb 21 10:46:33 2011
-+++ Python-2.6.4/Lib/test/test_popen2.py	Mon Feb 21 10:46:33 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- """Test script for popen2.py"""
- 
- import warnings
-diff -u Python-2.6.4/Lib/test/test_binhex.py.orig Python-2.6.4/Lib/test/test_binhex.py
---- Python-2.6.4/Lib/test/test_binhex.py.orig	Mon Feb 21 10:46:34 2011
-+++ Python-2.6.4/Lib/test/test_binhex.py	Mon Feb 21 10:46:34 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- """Test script for the binhex C module
- 
-    Uses the mechanism of the python binhex module
-diff -u Python-2.6.4/Lib/test/test_gzip.py.orig Python-2.6.4/Lib/test/test_gzip.py
---- Python-2.6.4/Lib/test/test_gzip.py.orig	Mon Feb 21 10:46:36 2011
-+++ Python-2.6.4/Lib/test/test_gzip.py	Mon Feb 21 10:46:36 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- """Test script for the gzip module.
- """
- 
-diff -u Python-2.6.4/Lib/test/re_tests.py.orig Python-2.6.4/Lib/test/re_tests.py
---- Python-2.6.4/Lib/test/re_tests.py.orig	Mon Feb 21 10:46:35 2011
-+++ Python-2.6.4/Lib/test/re_tests.py	Mon Feb 21 10:46:35 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python2.6
- # -*- mode: python -*-
- 
- # Re test suite and benchmark suite v1.5
-diff -u Python-2.6.4/Lib/test/test_urllib2_localnet.py.orig Python-2.6.4/Lib/test/test_urllib2_localnet.py
---- Python-2.6.4/Lib/test/test_urllib2_localnet.py.orig	Mon Feb 21 10:46:35 2011
-+++ Python-2.6.4/Lib/test/test_urllib2_localnet.py	Mon Feb 21 10:46:35 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python2.6
- 
- import mimetools
- import threading
-diff -u Python-2.6.4/Lib/test/test_codecencodings_kr.py.orig Python-2.6.4/Lib/test/test_codecencodings_kr.py
---- Python-2.6.4/Lib/test/test_codecencodings_kr.py.orig	Mon Feb 21 10:46:32 2011
-+++ Python-2.6.4/Lib/test/test_codecencodings_kr.py	Mon Feb 21 10:46:32 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python2.6
- #
- # test_codecencodings_kr.py
- #   Codec encoding tests for ROK encodings.
-diff -u Python-2.6.4/Lib/test/test_multibytecodec_support.py.orig Python-2.6.4/Lib/test/test_multibytecodec_support.py
---- Python-2.6.4/Lib/test/test_multibytecodec_support.py.orig	Mon Feb 21 10:46:35 2011
-+++ Python-2.6.4/Lib/test/test_multibytecodec_support.py	Mon Feb 21 10:46:35 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python2.6
- #
- # test_multibytecodec_support.py
- #   Common Unittest Routines for CJK codecs
-diff -u Python-2.6.4/Lib/test/test_tcl.py.orig Python-2.6.4/Lib/test/test_tcl.py
---- Python-2.6.4/Lib/test/test_tcl.py.orig	Mon Feb 21 10:46:36 2011
-+++ Python-2.6.4/Lib/test/test_tcl.py	Mon Feb 21 10:46:36 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python2.6
- 
- import unittest
- import os
-diff -u Python-2.6.4/Lib/test/test_codecencodings_cn.py.orig Python-2.6.4/Lib/test/test_codecencodings_cn.py
---- Python-2.6.4/Lib/test/test_codecencodings_cn.py.orig	Mon Feb 21 10:46:34 2011
-+++ Python-2.6.4/Lib/test/test_codecencodings_cn.py	Mon Feb 21 10:46:34 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python2.6
- #
- # test_codecencodings_cn.py
- #   Codec encoding tests for PRC encodings.
-diff -u Python-2.6.4/Lib/test/test_gl.py.orig Python-2.6.4/Lib/test/test_gl.py
---- Python-2.6.4/Lib/test/test_gl.py.orig	Mon Feb 21 10:46:32 2011
-+++ Python-2.6.4/Lib/test/test_gl.py	Mon Feb 21 10:46:32 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- """Very simple test script for the SGI gl library extension module
-     taken mostly from the documentation.
-     Roger E. Masse
-diff -u Python-2.6.4/Lib/test/test___future__.py.orig Python-2.6.4/Lib/test/test___future__.py
---- Python-2.6.4/Lib/test/test___future__.py.orig	Mon Feb 21 10:46:35 2011
-+++ Python-2.6.4/Lib/test/test___future__.py	Mon Feb 21 10:46:35 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- import unittest
- from test import test_support
- import __future__
-diff -u Python-2.6.4/Lib/test/test_bsddb.py.orig Python-2.6.4/Lib/test/test_bsddb.py
---- Python-2.6.4/Lib/test/test_bsddb.py.orig	Mon Feb 21 10:46:36 2011
-+++ Python-2.6.4/Lib/test/test_bsddb.py	Mon Feb 21 10:46:36 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- """Test script for the bsddb C module by Roger E. Masse
-    Adapted to unittest format and expanded scope by Raymond Hettinger
- """
-diff -u Python-2.6.4/Lib/test/test_errno.py.orig Python-2.6.4/Lib/test/test_errno.py
---- Python-2.6.4/Lib/test/test_errno.py.orig	Mon Feb 21 10:46:34 2011
-+++ Python-2.6.4/Lib/test/test_errno.py	Mon Feb 21 10:46:34 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- """Test the errno module
-    Roger E. Masse
- """
-diff -u Python-2.6.4/Lib/test/test_optparse.py.orig Python-2.6.4/Lib/test/test_optparse.py
---- Python-2.6.4/Lib/test/test_optparse.py.orig	Mon Feb 21 10:46:32 2011
-+++ Python-2.6.4/Lib/test/test_optparse.py	Mon Feb 21 10:46:32 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/python
-+#!/usr/bin/python2.6
- 
- #
- # Test suite for Optik.  Supplied by Johannes Gijsbers
-diff -u Python-2.6.4/Lib/test/test_codecencodings_tw.py.orig Python-2.6.4/Lib/test/test_codecencodings_tw.py
---- Python-2.6.4/Lib/test/test_codecencodings_tw.py.orig	Mon Feb 21 10:46:35 2011
-+++ Python-2.6.4/Lib/test/test_codecencodings_tw.py	Mon Feb 21 10:46:35 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python2.6
- #
- # test_codecencodings_tw.py
- #   Codec encoding tests for ROC encodings.
-diff -u Python-2.6.4/Lib/test/test_codecmaps_jp.py.orig Python-2.6.4/Lib/test/test_codecmaps_jp.py
---- Python-2.6.4/Lib/test/test_codecmaps_jp.py.orig	Mon Feb 21 10:46:32 2011
-+++ Python-2.6.4/Lib/test/test_codecmaps_jp.py	Mon Feb 21 10:46:32 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python2.6
- #
- # test_codecmaps_jp.py
- #   Codec mapping tests for Japanese encodings
-diff -u Python-2.6.4/Lib/test/test_codecmaps_hk.py.orig Python-2.6.4/Lib/test/test_codecmaps_hk.py
---- Python-2.6.4/Lib/test/test_codecmaps_hk.py.orig	Mon Feb 21 10:46:34 2011
-+++ Python-2.6.4/Lib/test/test_codecmaps_hk.py	Mon Feb 21 10:46:34 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python2.6
- #
- # test_codecmaps_hk.py
- #   Codec mapping tests for HongKong encodings
-diff -u Python-2.6.4/Lib/test/test_dumbdbm.py.orig Python-2.6.4/Lib/test/test_dumbdbm.py
---- Python-2.6.4/Lib/test/test_dumbdbm.py.orig	Mon Feb 21 10:46:34 2011
-+++ Python-2.6.4/Lib/test/test_dumbdbm.py	Mon Feb 21 10:46:34 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- """Test script for the dumbdbm module
-    Original by Roger E. Masse
- """
-diff -u Python-2.6.4/Lib/tarfile.py.orig Python-2.6.4/Lib/tarfile.py
---- Python-2.6.4/Lib/tarfile.py.orig	Mon Feb 21 10:46:38 2011
-+++ Python-2.6.4/Lib/tarfile.py	Mon Feb 21 10:46:38 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python2.6
- # -*- coding: iso-8859-1 -*-
- #-------------------------------------------------------------------
- # tarfile.py
-diff -u Python-2.6.4/Lib/uu.py.orig Python-2.6.4/Lib/uu.py
---- Python-2.6.4/Lib/uu.py.orig	Mon Feb 21 10:46:25 2011
-+++ Python-2.6.4/Lib/uu.py	Mon Feb 21 10:46:25 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- 
- # Copyright 1994 by Lance Ellinghouse
- # Cathedral City, California Republic, United States of America.
-diff -u Python-2.6.4/Lib/symbol.py.orig Python-2.6.4/Lib/symbol.py
---- Python-2.6.4/Lib/symbol.py.orig	Mon Feb 21 10:46:27 2011
-+++ Python-2.6.4/Lib/symbol.py	Mon Feb 21 10:46:27 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- 
- """Non-terminal symbols of Python grammar (from "graminit.h")."""
- 
-diff -u Python-2.6.4/Lib/mimify.py.orig Python-2.6.4/Lib/mimify.py
---- Python-2.6.4/Lib/mimify.py.orig	Mon Feb 21 10:46:28 2011
-+++ Python-2.6.4/Lib/mimify.py	Mon Feb 21 10:46:28 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- 
- """Mimification and unmimification of mail messages.
- 
-diff -u Python-2.6.4/Lib/pdb.py.orig Python-2.6.4/Lib/pdb.py
---- Python-2.6.4/Lib/pdb.py.orig	Mon Feb 21 10:46:38 2011
-+++ Python-2.6.4/Lib/pdb.py	Mon Feb 21 10:46:38 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- 
- """A Python debugger."""
- 
-diff -u Python-2.6.4/Lib/plat-mac/bundlebuilder.py.orig Python-2.6.4/Lib/plat-mac/bundlebuilder.py
---- Python-2.6.4/Lib/plat-mac/bundlebuilder.py.orig	Mon Feb 21 10:46:38 2011
-+++ Python-2.6.4/Lib/plat-mac/bundlebuilder.py	Mon Feb 21 10:46:38 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- 
- """\
- bundlebuilder.py -- Tools to assemble MacOS X (application) bundles.
-diff -u Python-2.6.4/Lib/plat-mac/appletrunner.py.orig Python-2.6.4/Lib/plat-mac/appletrunner.py
---- Python-2.6.4/Lib/plat-mac/appletrunner.py.orig	Mon Feb 21 10:46:38 2011
-+++ Python-2.6.4/Lib/plat-mac/appletrunner.py	Mon Feb 21 10:46:38 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python2.6
- # This file is meant as an executable script for running applets.
- # BuildApplet will use it as the main executable in the .app bundle if
- # we are not running in a framework build.
-diff -u Python-2.6.4/Demo/scripts/primes.py.orig Python-2.6.4/Demo/scripts/primes.py
---- Python-2.6.4/Demo/scripts/primes.py.orig	Mon Feb 21 10:46:39 2011
-+++ Python-2.6.4/Demo/scripts/primes.py	Mon Feb 21 10:46:39 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- 
- # Print prime numbers in a given range
- 
-diff -u Python-2.6.4/Demo/scripts/mkrcs.py.orig Python-2.6.4/Demo/scripts/mkrcs.py
---- Python-2.6.4/Demo/scripts/mkrcs.py.orig	Mon Feb 21 10:46:39 2011
-+++ Python-2.6.4/Demo/scripts/mkrcs.py	Mon Feb 21 10:46:39 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- 
- # A rather specialized script to make sure that a symbolic link named
- # RCS exists pointing to a real RCS directory in a parallel tree
-diff -u Python-2.6.4/Demo/scripts/queens.py.orig Python-2.6.4/Demo/scripts/queens.py
---- Python-2.6.4/Demo/scripts/queens.py.orig	Mon Feb 21 10:46:39 2011
-+++ Python-2.6.4/Demo/scripts/queens.py	Mon Feb 21 10:46:39 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- 
- """N queens problem.
- 
-diff -u Python-2.6.4/Demo/scripts/pi.py.orig Python-2.6.4/Demo/scripts/pi.py
---- Python-2.6.4/Demo/scripts/pi.py.orig	Mon Feb 21 10:46:39 2011
-+++ Python-2.6.4/Demo/scripts/pi.py	Mon Feb 21 10:46:39 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- 
- # Print digits of pi forever.
- #
-diff -u Python-2.6.4/Demo/scripts/mboxconvert.py.orig Python-2.6.4/Demo/scripts/mboxconvert.py
---- Python-2.6.4/Demo/scripts/mboxconvert.py.orig	Mon Feb 21 10:46:39 2011
-+++ Python-2.6.4/Demo/scripts/mboxconvert.py	Mon Feb 21 10:46:39 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- 
- # Convert  MH directories (1 message per file) or MMDF mailboxes (4x^A
- # delimited) to unix mailbox (From ... delimited) on stdout.
-diff -u Python-2.6.4/Demo/scripts/eqfix.py.orig Python-2.6.4/Demo/scripts/eqfix.py
---- Python-2.6.4/Demo/scripts/eqfix.py.orig	Mon Feb 21 10:46:39 2011
-+++ Python-2.6.4/Demo/scripts/eqfix.py	Mon Feb 21 10:46:39 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- 
- # Fix Python source files to use the new equality test operator, i.e.,
- #       if x = y: ...
-diff -u Python-2.6.4/Demo/scripts/find-uname.py.orig Python-2.6.4/Demo/scripts/find-uname.py
---- Python-2.6.4/Demo/scripts/find-uname.py.orig	Mon Feb 21 10:46:39 2011
-+++ Python-2.6.4/Demo/scripts/find-uname.py	Mon Feb 21 10:46:39 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python2.6
- 
- """
- For each argument on the command line, look for it in the set of all Unicode
-diff -u Python-2.6.4/Demo/scripts/pp.py.orig Python-2.6.4/Demo/scripts/pp.py
---- Python-2.6.4/Demo/scripts/pp.py.orig	Mon Feb 21 10:46:39 2011
-+++ Python-2.6.4/Demo/scripts/pp.py	Mon Feb 21 10:46:39 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- 
- # Emulate some Perl command line options.
- # Usage: pp [-a] [-c] [-d] [-e scriptline] [-F fieldsep] [-n] [-p] [file] ...
-diff -u Python-2.6.4/Demo/scripts/unbirthday.py.orig Python-2.6.4/Demo/scripts/unbirthday.py
---- Python-2.6.4/Demo/scripts/unbirthday.py.orig	Mon Feb 21 10:46:39 2011
-+++ Python-2.6.4/Demo/scripts/unbirthday.py	Mon Feb 21 10:46:39 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- 
- # Calculate your unbirthday count (see Alice in Wonderland).
- # This is defined as the number of days from your birth until today
-diff -u Python-2.6.4/Demo/scripts/update.py.orig Python-2.6.4/Demo/scripts/update.py
---- Python-2.6.4/Demo/scripts/update.py.orig	Mon Feb 21 10:46:39 2011
-+++ Python-2.6.4/Demo/scripts/update.py	Mon Feb 21 10:46:39 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- 
- # Update a bunch of files according to a script.
- # The input file contains lines of the form <filename>:<lineno>:<text>,
-diff -u Python-2.6.4/Demo/scripts/markov.py.orig Python-2.6.4/Demo/scripts/markov.py
---- Python-2.6.4/Demo/scripts/markov.py.orig	Mon Feb 21 10:46:39 2011
-+++ Python-2.6.4/Demo/scripts/markov.py	Mon Feb 21 10:46:39 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- 
- class Markov:
-     def __init__(self, histsize, choice):
-diff -u Python-2.6.4/Demo/scripts/from.py.orig Python-2.6.4/Demo/scripts/from.py
---- Python-2.6.4/Demo/scripts/from.py.orig	Mon Feb 21 10:46:39 2011
-+++ Python-2.6.4/Demo/scripts/from.py	Mon Feb 21 10:46:39 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- 
- # Print From and Subject of messages in $MAIL.
- # Extension to multiple mailboxes and other bells & whistles are left
-diff -u Python-2.6.4/Demo/scripts/script.py.orig Python-2.6.4/Demo/scripts/script.py
---- Python-2.6.4/Demo/scripts/script.py.orig	Mon Feb 21 10:46:39 2011
-+++ Python-2.6.4/Demo/scripts/script.py	Mon Feb 21 10:46:39 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- # script.py -- Make typescript of terminal session.
- # Usage:
- #       -a      Append to typescript.
-diff -u Python-2.6.4/Demo/scripts/lpwatch.py.orig Python-2.6.4/Demo/scripts/lpwatch.py
---- Python-2.6.4/Demo/scripts/lpwatch.py.orig	Mon Feb 21 10:46:39 2011
-+++ Python-2.6.4/Demo/scripts/lpwatch.py	Mon Feb 21 10:46:39 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- 
- # Watch line printer queue(s).
- # Intended for BSD 4.3 lpq.
-diff -u Python-2.6.4/Demo/scripts/fact.py.orig Python-2.6.4/Demo/scripts/fact.py
---- Python-2.6.4/Demo/scripts/fact.py.orig	Mon Feb 21 10:46:39 2011
-+++ Python-2.6.4/Demo/scripts/fact.py	Mon Feb 21 10:46:39 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- 
- # Factorize numbers.
- # The algorithm is not efficient, but easy to understand.
-diff -u Python-2.6.4/Demo/scripts/beer.py.orig Python-2.6.4/Demo/scripts/beer.py
---- Python-2.6.4/Demo/scripts/beer.py.orig	Mon Feb 21 10:46:39 2011
-+++ Python-2.6.4/Demo/scripts/beer.py	Mon Feb 21 10:46:39 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- # By GvR, demystified after a version by Fredrik Lundh.
- import sys
- n = 100
-diff -u Python-2.6.4/Demo/scripts/newslist.py.orig Python-2.6.4/Demo/scripts/newslist.py
---- Python-2.6.4/Demo/scripts/newslist.py.orig	Mon Feb 21 10:46:39 2011
-+++ Python-2.6.4/Demo/scripts/newslist.py	Mon Feb 21 10:46:39 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- #######################################################################
- # Newslist  $Revision: 66429 $
- #
-diff -u Python-2.6.4/Demo/scripts/ftpstats.py.orig Python-2.6.4/Demo/scripts/ftpstats.py
---- Python-2.6.4/Demo/scripts/ftpstats.py.orig	Mon Feb 21 10:46:39 2011
-+++ Python-2.6.4/Demo/scripts/ftpstats.py	Mon Feb 21 10:46:39 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- 
- # Extract statistics from ftp daemon log.
- 
-diff -u Python-2.6.4/Demo/scripts/makedir.py.orig Python-2.6.4/Demo/scripts/makedir.py
---- Python-2.6.4/Demo/scripts/makedir.py.orig	Mon Feb 21 10:46:39 2011
-+++ Python-2.6.4/Demo/scripts/makedir.py	Mon Feb 21 10:46:39 2011
[email protected]@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/python2.6
- 
- # Like mkdir, but also make intermediate directories if necessary.
- # It is not an error if the given directory already exists (as long
-diff -u Python-2.6.4/Demo/turtle/tdemo_clock.py.orig Python-2.6.4/Demo/turtle/tdemo_clock.py
---- Python-2.6.4/Demo/turtle/tdemo_clock.py.orig	Mon Feb 21 10:46:39 2011
-+++ Python-2.6.4/Demo/turtle/tdemo_clock.py	Mon Feb 21 10:46:39 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/python
-+#!/usr/bin/python2.6
- # -*- coding: cp1252 -*-
- """       turtle-example-suite:
- 
-diff -u Python-2.6.4/Demo/turtle/tdemo_planet_and_moon.py.orig Python-2.6.4/Demo/turtle/tdemo_planet_and_moon.py
---- Python-2.6.4/Demo/turtle/tdemo_planet_and_moon.py.orig	Mon Feb 21 10:46:39 2011
-+++ Python-2.6.4/Demo/turtle/tdemo_planet_and_moon.py	Mon Feb 21 10:46:39 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/python
-+#!/usr/bin/python2.6
- """       turtle-example-suite:
- 
-         tdemo_planets_and_moon.py
-diff -u Python-2.6.4/Demo/turtle/tdemo_lindenmayer_indian.py.orig Python-2.6.4/Demo/turtle/tdemo_lindenmayer_indian.py
---- Python-2.6.4/Demo/turtle/tdemo_lindenmayer_indian.py.orig	Mon Feb 21 10:46:39 2011
-+++ Python-2.6.4/Demo/turtle/tdemo_lindenmayer_indian.py	Mon Feb 21 10:46:39 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/python
-+#!/usr/bin/python2.6
- """       turtle-example-suite:
- 
-         xtx_lindenmayer_indian.py
-diff -u Python-2.6.4/Demo/turtle/tdemo_penrose.py.orig Python-2.6.4/Demo/turtle/tdemo_penrose.py
---- Python-2.6.4/Demo/turtle/tdemo_penrose.py.orig	Mon Feb 21 10:46:39 2011
-+++ Python-2.6.4/Demo/turtle/tdemo_penrose.py	Mon Feb 21 10:46:39 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/python
-+#!/usr/bin/python2.6
- """       xturtle-example-suite:
- 
-           xtx_kites_and_darts.py
-diff -u Python-2.6.4/Demo/turtle/turtleDemo.py.orig Python-2.6.4/Demo/turtle/turtleDemo.py
---- Python-2.6.4/Demo/turtle/turtleDemo.py.orig	Mon Feb 21 10:46:39 2011
-+++ Python-2.6.4/Demo/turtle/turtleDemo.py	Mon Feb 21 10:46:39 2011
[email protected]@ -1,4 +1,4 @@
--#!/usr/bin/python
-+#!/usr/bin/python2.6
- import sys
- import os
- 
-diff -u Python-2.6.4/Demo/turtle/tdemo_yinyang.py.orig Python-2.6.4/Demo/turtle/tdemo_yinyang.py
---- Python-2.6.4/Demo/turtle/tdemo_yinyang.py.orig	Mon