20934529 versioned pywbem package lacks a dependency on unversioned one s11-update
authordavid.comay@oracle.com
Wed, 29 Apr 2015 09:50:52 -0700
branchs11-update
changeset 4220 86c0ad4a33d5
parent 4213 9164037457d6
child 4221 691b0959b959
20934529 versioned pywbem package lacks a dependency on unversioned one
components/python/pywbem/pywbem-PYVER.p5m
--- a/components/python/pywbem/pywbem-PYVER.p5m	Wed Apr 29 07:18:52 2015 -0700
+++ b/components/python/pywbem/pywbem-PYVER.p5m	Wed Apr 29 09:50:52 2015 -0700
@@ -20,8 +20,9 @@
 #
 
 #
-# Copyright (c) 2014, Oracle and/or its affiliates. All rights reserved.
+# Copyright (c) 2014, 2015, Oracle and/or its affiliates. All rights reserved.
 #
+
 set name=pkg.fmri \
     value=pkg:/library/python/pywbem-$(PYV)@$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
 set name=pkg.summary value="Python WBEM Client and Provider Interface"
@@ -60,3 +61,7 @@
 file path=usr/lib/python$(PYVER)/vendor-packages/pywbem/yacc.py
 #
 license pywbem.license license=LGPLv2
+
+# force a dependency on the pywbem package
+depend type=require \
+    fmri=library/python/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)