23209237 Upgrade stevedore to 1.12.0
authorLaszlo Peter <laszlo.peter@oracle.com>
Wed, 07 Sep 2016 14:48:39 -0700
changeset 6837 b53f25b635fb
parent 6836 464d17ec745f
child 6838 e94853206ef3
23209237 Upgrade stevedore to 1.12.0
components/python/stevedore/Makefile
components/python/stevedore/patches/01-requirements.patch
components/python/stevedore/stevedore-PYVER.p5m
components/python/stevedore/stevedore.license
--- a/components/python/stevedore/Makefile	Wed Sep 07 14:48:38 2016 -0700
+++ b/components/python/stevedore/Makefile	Wed Sep 07 14:48:39 2016 -0700
@@ -26,16 +26,16 @@
 include ../../../make-rules/shared-macros.mk
 
 COMPONENT_NAME=		stevedore
-COMPONENT_VERSION=	1.3.0
+COMPONENT_VERSION=	1.12.0
 COMPONENT_SRC=		$(COMPONENT_NAME)-$(COMPONENT_VERSION)
 COMPONENT_ARCHIVE=	$(COMPONENT_SRC).tar.gz
 COMPONENT_ARCHIVE_HASH=	\
-    sha256:beab2b7f91966d259796392c39ed6f260b32851861561dd9f3b9be2fd0c426a5
+    sha256:1bdeb2562d8f2c1e3047c2f17134a38b37a6e53e16ca1d9f79ff2ac5d5fe2925
 COMPONENT_ARCHIVE_URL=	$(call pypi_url)
 COMPONENT_PROJECT_URL=	https://github.com/dreamhost/stevedore
 COMPONENT_BUGDB=	python-mod/stevedore
 
-TPNO=			25761
+TPNO=			27865
 
 include $(WS_MAKE_RULES)/prep.mk
 include $(WS_MAKE_RULES)/setup.py.mk
@@ -53,4 +53,4 @@
 
 test:		$(TEST_NO_ARCH)
 
-system-test:    $(SYSTEM_TESTS_NOT_IMPLEMENTED)
+system-test:	$(SYSTEM_TESTS_NOT_IMPLEMENTED)
--- a/components/python/stevedore/patches/01-requirements.patch	Wed Sep 07 14:48:38 2016 -0700
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,20 +0,0 @@
-In-house patch to remove the dependency on argparse.  Since we use
-Python 2.7 only for OpenStack, argparse is already included.  If this
-line is present, stevedore will fail to find the pip package for it,
-causing a cascade of failures to other tools.
-
---- stevedore-1.3.0/requirements.txt.orig	2015-08-02 02:09:31.789673594 -0400
-+++ stevedore-1.3.0/requirements.txt	2015-08-02 02:10:40.216924993 -0400
[email protected]@ -3,5 +3,4 @@
- # process, which may cause wedges in the gate later.
- 
- pbr>=0.6,!=0.7,<1.0
--argparse
- six>=1.9.0
-
---- stevedore-1.3.0/stevedore.egg-info/requires.txt.orig	2015-08-02 17:20:18.360243112 -0400
-+++ stevedore-1.3.0/stevedore.egg-info/requires.txt	2015-08-02 02:10:24.673250914 -0400
[email protected]@ -1,3 +1,2 @@
- pbr>=0.6,!=0.7,<1.0
--argparse
- six>=1.9.0
--- a/components/python/stevedore/stevedore-PYVER.p5m	Wed Sep 07 14:48:38 2016 -0700
+++ b/components/python/stevedore/stevedore-PYVER.p5m	Wed Sep 07 14:48:39 2016 -0700
@@ -52,14 +52,18 @@
 file path=usr/lib/python$(PYVER)/vendor-packages/stevedore/enabled.py
 file path=usr/lib/python$(PYVER)/vendor-packages/stevedore/example/__init__.py
 file path=usr/lib/python$(PYVER)/vendor-packages/stevedore/example/base.py
-file path=usr/lib/python$(PYVER)/vendor-packages/stevedore/example/fields.py
 file path=usr/lib/python$(PYVER)/vendor-packages/stevedore/example/load_as_driver.py
 file path=usr/lib/python$(PYVER)/vendor-packages/stevedore/example/load_as_extension.py
 file path=usr/lib/python$(PYVER)/vendor-packages/stevedore/example/setup.py
 file path=usr/lib/python$(PYVER)/vendor-packages/stevedore/example/simple.py
+file path=usr/lib/python$(PYVER)/vendor-packages/stevedore/example2/__init__.py
+file path=usr/lib/python$(PYVER)/vendor-packages/stevedore/example2/fields.py
+file path=usr/lib/python$(PYVER)/vendor-packages/stevedore/example2/setup.py
+file path=usr/lib/python$(PYVER)/vendor-packages/stevedore/exception.py
 file path=usr/lib/python$(PYVER)/vendor-packages/stevedore/extension.py
 file path=usr/lib/python$(PYVER)/vendor-packages/stevedore/hook.py
 file path=usr/lib/python$(PYVER)/vendor-packages/stevedore/named.py
+file path=usr/lib/python$(PYVER)/vendor-packages/stevedore/sphinxext.py
 #
 license stevedore.license license="Apache v2.0"
 
@@ -71,12 +75,6 @@
 depend type=require fmri=__TBD pkg.debug.depend.file=python$(PYVER) \
     pkg.debug.depend.path=usr/bin
 
-# force a dependency on argparse; pkgdepend work is needed to flush this out.
-depend type=require fmri=library/python/argparse-$(PYV)
-
-# force a dependency on pbr; pkgdepend work is needed to flush this out.
-depend type=require fmri=library/python/pbr-$(PYV)
-
 # force a dependency on setuptools; pkgdepend work is needed to flush this out.
 depend type=require fmri=library/python/setuptools-$(PYV)
 
--- a/components/python/stevedore/stevedore.license	Wed Sep 07 14:48:38 2016 -0700
+++ b/components/python/stevedore/stevedore.license	Wed Sep 07 14:48:39 2016 -0700
@@ -1,14 +1,3 @@
-The following applies to all products licensed under the Apache 2.0 License:
-
-You may not use the identified files except in compliance with the Apache License, Version 2.0 (the "License.")
- 
-You may obtain a copy of the License at http://www.apache.org/licenses/LICENSE-2.0.  A copy of the license is also reproduced below.
-
-Unless required by applicable law or agreed to in writing, software distributed under the License is distributed on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-
-See the License for the specific language governing permissions and limitations under the License.
-
-
                                  Apache License
                            Version 2.0, January 2004
                         http://www.apache.org/licenses/