23169139 Move glib to Userland and update to 2.46.0 (fix packaging)
authorAlan Coopersmith <Alan.Coopersmith@Oracle.COM>
Fri, 29 Apr 2016 17:25:54 -0700
changeset 5898 bec0360592b2
parent 5897 495a9e2444e4
child 5899 aa78da80bb9c
23169139 Move glib to Userland and update to 2.46.0 (fix packaging)
components/gnome/glib2/Makefile
components/gnome/glib2/glib2.p5m
--- a/components/gnome/glib2/Makefile	Fri Apr 29 16:32:46 2016 -0700
+++ b/components/gnome/glib2/Makefile	Fri Apr 29 17:25:54 2016 -0700
@@ -101,8 +101,8 @@
         '-e "/ERROR/p" '
 
 REQUIRED_PACKAGES += data/docbook
-REQUIRED_PACKAGES += desktop/xdg/desktop-file-utils
 REQUIRED_PACKAGES += developer/documentation-tool/gtk-doc
+REQUIRED_PACKAGES += gnome/preferences/control-center
 REQUIRED_PACKAGES += library/file-monitor/gamin
 REQUIRED_PACKAGES += library/libffi
 REQUIRED_PACKAGES += library/pcre
--- a/components/gnome/glib2/glib2.p5m	Fri Apr 29 16:32:46 2016 -0700
+++ b/components/gnome/glib2/glib2.p5m	Fri Apr 29 17:25:54 2016 -0700
@@ -524,3 +524,6 @@
 file files/libgthread-2.0.3lib path=usr/share/man/man3lib/libgthread-2.0.3lib
 file files/gnome-interfaces.7 path=usr/share/man/man7/gnome-interfaces.7
 license COPYING license=LGPLv2
+# code in gio/gdesktopappinfo.c execs update-desktop-database
+depend type=require fmri=__TBD \
+    pkg.debug.depend.file=usr/bin/update-desktop-database