23093872 Upgrade django-appconf to 1.0.2
authorLaszlo Peter <laszlo.peter@oracle.com>
Wed, 07 Sep 2016 14:48:27 -0700
changeset 6779 bf5dfa70d3b9
parent 6778 2d8467c6aa45
child 6780 753fc1140d2a
23093872 Upgrade django-appconf to 1.0.2
components/python/django-appconf/Makefile
components/python/django-appconf/django-appconf-PYVER.p5m
--- a/components/python/django-appconf/Makefile	Wed Sep 07 14:48:27 2016 -0700
+++ b/components/python/django-appconf/Makefile	Wed Sep 07 14:48:27 2016 -0700
@@ -20,23 +20,24 @@
 #
 
 #
-# Copyright (c) 2013, 2015, Oracle and/or its affiliates. All rights reserved.
+# Copyright (c) 2013, 2016, Oracle and/or its affiliates. All rights reserved.
 #
+
 include ../../../make-rules/shared-macros.mk
 
 COMPONENT_NAME=		django-appconf
-COMPONENT_VERSION=	0.6
+COMPONENT_VERSION=	1.0.2
 COMPONENT_SRC=		$(COMPONENT_NAME)-$(COMPONENT_VERSION)
 COMPONENT_ARCHIVE=	$(COMPONENT_SRC).tar.gz
 COMPONENT_ARCHIVE_HASH=	\
-    sha256:a88ed8fb923a53c70c2c46fbe4508b5f81646b4b01401f1568a821671b33215c
+    sha256:6a4d9aea683b4c224d97ab8ee11ad2d29a37072c0c6c509896dd9857466fb261
 COMPONENT_ARCHIVE_URL=	$(call pypi_url)
 COMPONENT_PROJECT_URL=	http://django-appconf.readthedocs.org/
 COMPONENT_BUGDB=	python-mod/django-appconf
 
-TPNO=			14503
+TPNO=			28036
 
-# Depends on django, which is not Python 3 ready.
+# Depends on django which is not Python 3 ready.
 PYTHON_VERSIONS=	$(PYTHON2_VERSIONS)
 
 include $(WS_MAKE_RULES)/prep.mk
@@ -53,5 +54,4 @@
 # unittests require django-discover-runner which is not integrated
 test:		$(NO_TESTS)
 
-system-test:    $(NO_TESTS)
-
+system-test:	$(NO_TESTS)
--- a/components/python/django-appconf/django-appconf-PYVER.p5m	Wed Sep 07 14:48:27 2016 -0700
+++ b/components/python/django-appconf/django-appconf-PYVER.p5m	Wed Sep 07 14:48:27 2016 -0700
@@ -18,7 +18,9 @@
 #
 # CDDL HEADER END
 #
-# Copyright (c) 2013, 2014, Oracle and/or its affiliates. All rights reserved.
+
+#
+# Copyright (c) 2013, 2016, Oracle and/or its affiliates. All rights reserved.
 #
 
 set name=pkg.fmri \
@@ -37,14 +39,15 @@
 set name=info.upstream-url value=$(COMPONENT_PROJECT_URL)
 set name=org.opensolaris.arc-caseid value=PSARC/2014/003
 set name=org.opensolaris.consolidation value=$(CONSOLIDATION)
+#
 file path=usr/lib/python$(PYVER)/vendor-packages/appconf/__init__.py
 file path=usr/lib/python$(PYVER)/vendor-packages/appconf/base.py
 file path=usr/lib/python$(PYVER)/vendor-packages/appconf/utils.py
 file path=usr/lib/python$(PYVER)/vendor-packages/django_appconf-$(COMPONENT_VERSION)-py$(PYVER).egg-info/PKG-INFO
 file path=usr/lib/python$(PYVER)/vendor-packages/django_appconf-$(COMPONENT_VERSION)-py$(PYVER).egg-info/SOURCES.txt
 file path=usr/lib/python$(PYVER)/vendor-packages/django_appconf-$(COMPONENT_VERSION)-py$(PYVER).egg-info/dependency_links.txt
-file path=usr/lib/python$(PYVER)/vendor-packages/django_appconf-$(COMPONENT_VERSION)-py$(PYVER).egg-info/requires.txt
 file path=usr/lib/python$(PYVER)/vendor-packages/django_appconf-$(COMPONENT_VERSION)-py$(PYVER).egg-info/top_level.txt
+#
 license LICENSE license=BSD
 
 # force the rename with an optional dependency on the old name
@@ -61,6 +64,3 @@
 # force a dependency on the django-appconf package
 depend type=require \
     fmri=library/python/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
-
-# force a dependency on six; pkgdepend work is needed to flush this out
-depend type=require fmri=library/python/six-$(PYV)