24737221 pyatspi-27 seems uninstallable
authorAlan Coopersmith <Alan.Coopersmith@Oracle.COM>
Mon, 26 Sep 2016 13:09:41 -0700
changeset 6982 d3b6a08a1ea2
parent 6979 93dcf1920c71
child 6983 f0786dbc4343
24737221 pyatspi-27 seems uninstallable
components/gnome/pyatspi/pyatspi-PYVER.p5m
components/meta-packages/history/history
--- a/components/gnome/pyatspi/pyatspi-PYVER.p5m	Mon Sep 26 16:23:01 2016 -0700
+++ b/components/gnome/pyatspi/pyatspi-PYVER.p5m	Mon Sep 26 13:09:41 2016 -0700
@@ -24,7 +24,7 @@
 #
 
 set name=pkg.fmri \
-    value=pkg:/library/python/pyatspi-$(PYV)@$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
+    value=pkg:/library/python/pyatspi2-$(PYV)@$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
 set name=pkg.summary value="Python API to AT-SPI on D-Bus"
 set name=com.oracle.info.description value="Python API to AT-SPI on D-Bus"
 set name=com.oracle.info.tpno value=$(TPNO)
@@ -65,9 +65,13 @@
 license COPYING.GPL license=GPLv2
 license COPYING license=LGPLv2.1
 
+# force the rename with an optional dependency on the old name
+$(PYTHON_2.7_ONLY)depend type=optional \
+    fmri=library/python/[email protected]
+
 # force a dependency on the unversioned package
 depend type=require \
-    fmri=library/python/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
+    fmri=library/python/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
 
 # force a dependency on the Python runtime
 depend type=require fmri=runtime/python-$(PYV)
--- a/components/meta-packages/history/history	Mon Sep 26 16:23:01 2016 -0700
+++ b/components/meta-packages/history/history	Mon Sep 26 13:09:41 2016 -0700
@@ -963,7 +963,7 @@
 library/python-2/[email protected]
 library/python-2/[email protected]
 library/python-2/[email protected]
-library/python-2/[email protected],5.12-5.12.0.0.0.85.0 library/python/[email protected] incorporate=consolidation/desktop/gnome-incorporation
+library/python-2/[email protected],5.12-5.12.0.0.0.109.0 incorporate=consolidation/desktop/gnome-incorporation
 library/python-2/[email protected],5.12-5.12.0.0.0.85.0 library/python/[email protected] incorporate=consolidation/desktop/gnome-incorporation
 library/python-2/[email protected],5.12-5.12.0.0.0.85.0 library/python/[email protected] incorporate=consolidation/desktop/gnome-incorporation
 library/python-2/[email protected],5.12-5.12.0.0.0.85.0 library/python/[email protected] incorporate=consolidation/desktop/gnome-incorporation
@@ -1009,6 +1009,7 @@
 library/python/[email protected]
 library/python/[email protected]
 library/python/[email protected]
+library/python/[email protected] library/python/[email protected] incorporate=consolidation/desktop/gnome-incorporation
 library/python/[email protected],5.12-5.12.0.0.0.90.0
 library/python/[email protected]
 library/python/[email protected]