OI-SFEgcc.spec
changeset 21 c5a5d6f3c1e8
child 22 3964ea74751c
equal deleted inserted replaced
20:565e0daa124c 21:c5a5d6f3c1e8
       
     1 #
       
     2 # spec file for package SFEgcc
       
     3 #
       
     4 # includes module(s): GNU gcc
       
     5 #
       
     6 
       
     7 ##NOTE## This spec file is an interim solution regarding the path layout on disk
       
     8 ##       expect relocation to /usr/gcc/4.5/ and symlinks provided from /usr/gnu 
       
     9 ##       into to that location (provided by the latest installed or "pkg fix"ed gcc-45 
       
    10 ##NOTE## most likely the package name will change to SFEgcc-43 and another empty
       
    11 ##       package SFEgcc will be created always requiring the latest SFEgcc-<major><minor>
       
    12 ##NOTE## If you experience problems with that version bump, please drop us a note
       
    13 ##NOTE## you will need "pkg uninstall SFEgccruntime and SFEgcc" *before* you can
       
    14 #        to get this spec build successfully. Reason: older runtime-libs interfere
       
    15 #        with building this eventually incompatible, newer gcc runtime from this spec
       
    16 
       
    17 
       
    18 # to more widely test if this change causes regressions, by default off:
       
    19 # want this? compile with: --with-handle_pragma_pack_push_pop
       
    20 %define with_handle_pragma_pack_push_pop %{?_with_handle_pragma_pack_push_pop:1}%{?!_with_handle_pragma_pack_push_pop:0}
       
    21 
       
    22 %include Solaris.inc
       
    23 %include base.inc
       
    24 
       
    25 %define osbuild %(uname -v | sed -e 's/[A-z_]//g')
       
    26 
       
    27 ##TODO## should include/arch64.inc consider setting _arch64 that way?
       
    28 #        gcc builds 64-bit libs/binaries even on 32-bit CPUs/Kernels (e.g. ATOM CPU)
       
    29 %ifarch amd64 i386
       
    30 %define _arch64 amd64
       
    31 %else
       
    32 %define _arch64 sparcv9
       
    33 %endif
       
    34 
       
    35 
       
    36 #default to SUNWbinutils
       
    37 ##TODO## if necessary add osbuild numbers to decide SUNW/SFE version
       
    38 %define SUNWbinutils    %(/usr/bin/pkginfo -q SUNWbinutils 2>/dev/null && echo 1 || echo 0)
       
    39 %define SFEbinutils     %(/usr/bin/pkginfo -q SFEbinutils  2>/dev/null && echo 1 || echo 0)
       
    40 #see below, older builds then 126 have too old gmp / mpfr to gcc version around 4.4.4
       
    41 #%define SFEgmp          %(/usr/bin/pkginfo -q SFEgmp  2>/dev/null  && echo 1 || echo 0)
       
    42 ##TODO## to be replaced by packagenamemacros, selecting SFEgmp on specific osbuilds where
       
    43 #it is too old for fresh gcc builds
       
    44 %define SFEgmp          1
       
    45 #%define SFEmpfr         %(/usr/bin/pkginfo -q SFEmpfr 2>/dev/null  && echo 1 || echo 0)
       
    46 ##TODO## to be replaced by packagenamemacros, selecting SFEmpfr on specific osbuilds where
       
    47 #it is too old for fresh gcc builds
       
    48 %define SFEmpfr         1
       
    49 
       
    50 # force using SFEbinutils
       
    51 #if SFEbinutils is not present, force it by the commandline switch --with_SFEbinutils
       
    52 %define with_SFEbinutils %{?_with_SFEbinutils:1}%{?!_with_SFEbinutils:0}
       
    53 %if %with_SFEbinutils
       
    54 %define SFEbinutils 1
       
    55 %define SUNWbinutils 0
       
    56 %endif
       
    57 
       
    58 # force using gmp | mpfr
       
    59 #if SFEgmp is not present, force them as required by the commandline switch --with_SFEgmp
       
    60 %define with_SFEgmp %{?_with_SFEgmp:1}%{?!_with_SFEgmp:0}
       
    61 #if build is lower then 126 then force it (update to gmp see CR 6863696)
       
    62 %if %(expr %{osbuild} '<' 126)
       
    63 %define with_SFEgmp 1
       
    64 %endif
       
    65 
       
    66 %if %with_SFEgmp
       
    67 %define SFEgmp 1
       
    68 %endif
       
    69 
       
    70 #if SFEgmp is not present, force them as required by the commandline switch --with_SFEmpfr
       
    71 %define with_SFEmpfr %{?_with_SFEmpfr:1}%{?!_with_SFEmpfr:0}
       
    72 #if build is lower then 126 then force it (update to gmp see CR 6863684)
       
    73 %if %(expr %{osbuild} '<' 126)
       
    74 %define with_SFEmpfr 1
       
    75 %endif
       
    76 
       
    77 %if %with_SFEmpfr
       
    78 %define SFEmpfr 1
       
    79 %endif
       
    80 
       
    81 #if SFElibmpc is not present, force them as required by the commandline switch --with-SFElibmpc
       
    82 #future OS versins might include a libmpc, leave code commented until then
       
    83 %define with_SFElibmpc %{?_with_SFElibmpc:1}%{?!_with_SFElibmpc:0}
       
    84 #parked #if build is lower then 126 then force it (update to gmp see CR 6863684)
       
    85 #parked %if %(expr %{osbuild} '<' 126)
       
    86 #for *now* require SFElibmpc in any case
       
    87 %define with_SFElibmpc 1
       
    88 #parked %endif
       
    89 
       
    90 %if %with_SFElibmpc
       
    91 %define SFElibmpc 1
       
    92 %endif
       
    93 
       
    94 %define major_minor 4.6
       
    95 %define _prefix /usr/gcc/%major_minor
       
    96 %define _infodir %{_prefix}/info
       
    97 %define _std_bindir %_basedir/bin
       
    98 %define _std_libdir %_basedir/lib
       
    99 
       
   100 Name:                SFEgccruntime
       
   101 IPS_package_name:    runtime/gcc
       
   102 Summary:             GNU gcc runtime libraries required by applications
       
   103 Version:             4.6.2
       
   104 License:             GPLv3+
       
   105 SUNW_Copyright:      gcc.copyright
       
   106 Source:              ftp://ftp.gnu.org/pub/gnu/gcc/gcc-%{version}/gcc-%{version}.tar.bz2
       
   107 Patch1:              gcc-01-libtool-rpath.diff
       
   108 %if %with_handle_pragma_pack_push_pop
       
   109 Patch2:              gcc-02-handle_pragma_pack_push_pop.diff
       
   110 %else
       
   111 %endif
       
   112 Patch3:              gcc-03-gnulib.diff
       
   113 SUNW_BaseDir:        %{_basedir}
       
   114 BuildRoot:           %{_tmppath}/%{name}-%{version}-build
       
   115 %include default-depend.inc
       
   116 
       
   117 BuildRequires: SFElibiconv-devel
       
   118 Requires:      SFElibiconv
       
   119 BuildRequires: SUNWbash
       
   120 
       
   121 %if %SFEgmp
       
   122 BuildRequires: SFEgmp-devel
       
   123 Requires: SFEgmp
       
   124 #workaround on IPS which is wrong with BASEdir as "/" -> then assume /usr/gnu
       
   125 %define SFEgmpbasedir %(pkgparam SFEgmp BASEDIR 2>/dev/null | sed -e 's+^/$+/usr/gnu+')
       
   126 %else
       
   127 BuildRequires: SUNWgnu-mp
       
   128 Requires: SUNWgnu-mp
       
   129 %endif
       
   130 
       
   131 %if %SFEmpfr
       
   132 BuildRequires: SFEmpfr-devel
       
   133 Requires: SFEmpfr
       
   134 #workaround on IPS which is wrong with BASEdir as "/" -> then assume /usr/gnu
       
   135 %define SFEmpfrbasedir %(pkgparam SFEmpfr BASEDIR 2>/dev/null | sed -e 's+^/$+/usr/gnu+')
       
   136 %else
       
   137 BuildRequires: SUNWgnu-mpfr
       
   138 Requires: SUNWgnu-mpfr
       
   139 %endif
       
   140 
       
   141 %if %SFElibmpc
       
   142 BuildRequires: SFElibmpc-devel
       
   143 Requires: SFElibmpc
       
   144 #workaround on IPS which is wrong with BASEdir as "/" -> then assume /usr/gnu
       
   145 %define SFElibmpcbasedir %(pkgparam SFElibmpc BASEDIR 2>/dev/null | sed -e 's+^/$+/usr/gnu+')
       
   146 %else
       
   147 #BuildRequires: empty
       
   148 #Requires: empty
       
   149 %endif
       
   150 
       
   151 %if %SFEbinutils
       
   152 BuildRequires: SFEbinutils
       
   153 Requires: SFEbinutils
       
   154 %else
       
   155 BuildRequires: SUNWbinutils
       
   156 Requires: SUNWbinutils
       
   157 %endif
       
   158 
       
   159 Requires: SUNWpostrun
       
   160 
       
   161 %package devel
       
   162 Summary:                 GNU gcc
       
   163 Version:                 %{version}
       
   164 SUNW_BaseDir:            %{_basedir}
       
   165 %include default-depend.inc
       
   166 Requires: %name
       
   167 
       
   168 %if %SFEgmp
       
   169 BuildRequires: SFEgmp-devel
       
   170 Requires: SFEgmp
       
   171 %else
       
   172 BuildRequires: SUNWgnu-mp
       
   173 Requires: SUNWgnu-mp
       
   174 %endif
       
   175 
       
   176 %if %SFEmpfr
       
   177 BuildRequires: SFEmpfr-devel
       
   178 Requires: SFEmpfr
       
   179 %else
       
   180 BuildRequires: SUNWgnu-mpfr
       
   181 Requires: SUNWgnu-mpfr
       
   182 %endif
       
   183 
       
   184 %if %SFElibmpc
       
   185 BuildRequires: SFElibmpc-devel
       
   186 Requires: SFElibmpc
       
   187 %else
       
   188 #BuildRequires: SUNWthis-package-not-availbale
       
   189 #Requires: SUNWthis-package-not-availbale
       
   190 %endif
       
   191 
       
   192 #Requires: SUNWpostrun
       
   193 
       
   194 
       
   195 %if %build_l10n
       
   196 %package l10n
       
   197 Summary:                 %{summary} - l10n files
       
   198 SUNW_BaseDir:            %{_basedir}
       
   199 %include default-depend.inc
       
   200 Requires:                %{name}
       
   201 %endif
       
   202 
       
   203 %prep
       
   204 %setup -q -c -n %{name}-%version
       
   205 mkdir gcc
       
   206 #with 4.3.3 in new directory libjava/classpath/
       
   207 cd gcc-%{version}/libjava/classpath/
       
   208 #%patch1 -p1
       
   209 cd ../../..
       
   210 cd gcc-%{version}
       
   211 %if %with_handle_pragma_pack_push_pop
       
   212 %patch2 -p1
       
   213 %else
       
   214 %endif
       
   215 #%patch3 -p1
       
   216 
       
   217 %build
       
   218 CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
       
   219 if test "x$CPUS" = "x" -o $CPUS = 0; then
       
   220      CPUS=1
       
   221 fi
       
   222 
       
   223 #perl -w -pi.bak -e "s,^#\!\s*/bin/sh,#\!/usr/bin/bash -x," `find . -type f -name configure -exec grep -q "^#\!.*/bin/sh" {} \; -print`
       
   224 #perl -w -pi.bak -e "s,^#\!\s*/bin/sh,#\!/usr/bin/bash -x," `find . -type f -name configure -exec grep -q "^#\!.*/bin/sh" {} \; -print`
       
   225 
       
   226 cd gcc
       
   227 
       
   228 %if %build_l10n
       
   229 nlsopt='--with-libiconv-prefix=/usr/gnu -enable-nls'
       
   230 %else
       
   231 nlsopt=-disable-nls
       
   232 %endif
       
   233 
       
   234 %define ld_options      -zignore -zcombreloc -Bdirect -i
       
   235 
       
   236 export CC=gcc
       
   237 export CXX=g++
       
   238 #export CONFIG_SHELL=/usr/bin/bash
       
   239 export CONFIG_SHELL=/usr/bin/ksh
       
   240 export CPP="cc -E -Xs"
       
   241 export CFLAGS="-O"
       
   242 # for stage2 and stage3 GCC
       
   243 #export BOOT_CFLAGS="%gcc_optflags -Os -Xlinker -i %gcc_picflags"
       
   244 #-m64 and i586 mutually exclusive
       
   245 export BOOT_CFLAGS="-Os -Xlinker -i %gcc_picflags"
       
   246 # for target libraries (built with bootstrapped GCC)
       
   247 #export CFLAGS_FOR_TARGET="%gcc_optflags -O2 -Xlinker -i %gcc_picflags"
       
   248 #-m64 and i586 mutually exclusive
       
   249 export CFLAGS_FOR_TARGET="-O2 -Xlinker -i %gcc_picflags"
       
   250 export LDFLAGS="%_ldflags %gnu_lib_path"
       
   251 export LD_OPTIONS="%ld_options %gnu_lib_path"
       
   252 #export LD_LIBRARY_PATH="%gnu_lib_path"
       
   253 
       
   254 # For pod2man
       
   255 export PATH="$PATH:/usr/perl5/bin"
       
   256 
       
   257 %define build_gcc_with_gnu_ld 0
       
   258 #saw problems. 134 did compile, OI147 stopped with probably linker errors
       
   259 ##TODO## research which osbuild started to fail, adjust the number below
       
   260 #%if %(expr %{osbuild} '>=' 146)
       
   261 #%define build_gcc_with_gnu_ld 1
       
   262 #%endif
       
   263 
       
   264 %if %build_gcc_with_gnu_ld
       
   265 export LD="/usr/gnu/bin/ld"
       
   266 %else
       
   267 export LD=/usr/bin/ld
       
   268 %endif
       
   269 
       
   270 
       
   271 ../gcc-%{version}/configure			\
       
   272 	--prefix=%{_prefix}			\
       
   273         --libdir=%{_libdir}			\
       
   274         --libexecdir=%{_libexecdir}		\
       
   275         --mandir=%{_mandir}			\
       
   276 	--infodir=%{_infodir}			\
       
   277 %if %SUNWbinutils
       
   278 	--with-build-time-tools=/usr/sfw	\
       
   279 	--with-as=/usr/sfw/bin/gas		\
       
   280 	--with-gnu-as				\
       
   281 %else
       
   282 	--with-as=/usr/gnu/bin/as		\
       
   283 	--with-gnu-as				\
       
   284 %endif
       
   285 %if %build_gcc_with_gnu_ld
       
   286 	--with-ld=/usr/gnu/bin/ld		\
       
   287 	--with-gnu-ld				\
       
   288 %else
       
   289 	--with-ld=$LD				\
       
   290 	--without-gnu-ld			\
       
   291 %endif
       
   292 	--enable-languages=c,c++,fortran,objc	\
       
   293 	--enable-shared				\
       
   294 	--disable-static			\
       
   295 	--enable-decimal-float			\
       
   296 %if %SFEgmp
       
   297 	--with-gmp=%{SFEgmpbasedir}             \
       
   298 %else
       
   299         --with-gmp_include=%{_basedir}/include/gmp \
       
   300 %endif
       
   301 %if %SFEmpfr
       
   302 	--with-mpfr=%{SFEmpfrbasedir}           \
       
   303 %else
       
   304         --with-mpfr_include=%{_basedir}/include/mpfr \
       
   305 %endif
       
   306 %if %SFElibmpc
       
   307 	--with-mpc=%{SFElibmpcbasedir}           \
       
   308 %else
       
   309         --with-mpc_include=%{_basedir}/include	\
       
   310 %endif
       
   311 	$nlsopt
       
   312 
       
   313 make -j$CPUS bootstrap-lean BOOT_CFLAGS="$BOOT_CFLAGS" CFLAGS_FOR_TARGET="$CFLAGS_FOR_TARGET" CXXFLAGS_FOR_TARGET="$CFLAGS_FOR_TARGET"
       
   314 
       
   315 %install
       
   316 rm -rf $RPM_BUILD_ROOT
       
   317 
       
   318 cd gcc
       
   319 make install DESTDIR=$RPM_BUILD_ROOT
       
   320 
       
   321 cd $RPM_BUILD_ROOT%{_prefix}
       
   322 ln -s share/man man
       
   323 
       
   324 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
       
   325 
       
   326 %if %build_l10n
       
   327 %else
       
   328 # REMOVE l10n FILES
       
   329 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale
       
   330 %endif
       
   331 
       
   332 #link runtime libs, for compatibility
       
   333 #note: links only "basename_of_lib", then "major"-number version libs
       
   334 #leaves out "minor" and "micro" version libs, they are normally not
       
   335 #to be linked by userland binaries (runtime linking, see output of "ldd binaryname")
       
   336 mkdir %buildroot%_std_libdir
       
   337 cd %buildroot%_std_libdir
       
   338 ln -s ../gcc/%major_minor/lib/libgcc_s.so.1
       
   339 ln -s ../gcc/%major_minor/lib/libgcc_s.so
       
   340 ln -s ../gcc/%major_minor/lib/libgfortran.so.3
       
   341 ln -s ../gcc/%major_minor/lib/libgfortran.so
       
   342 ln -s ../gcc/%major_minor/lib/libgomp.so.1
       
   343 ln -s ../gcc/%major_minor/lib/libgomp.so
       
   344 ln -s ../gcc/%major_minor/lib/libobjc.so
       
   345 ln -s ../gcc/%major_minor/lib/libssp.so.0
       
   346 ln -s ../gcc/%major_minor/lib/libssp.so
       
   347 ln -s ../gcc/%major_minor/lib/libstdc++.so.6
       
   348 ln -s ../gcc/%major_minor/lib/libstdc++.so
       
   349 #link arch runtime libs for compatibility
       
   350 %ifarch amd64 sparcv9
       
   351 mkdir %buildroot%_std_libdir/%_arch64
       
   352 cd %buildroot%_std_libdir/%_arch64
       
   353 ln -s ../../gcc/%major_minor/lib/%{_arch64}/libgcc_s.so.1
       
   354 ln -s ../../gcc/%major_minor/lib/%{_arch64}/libgcc_s.so
       
   355 ln -s ../../gcc/%major_minor/lib/%{_arch64}/libgfortran.so.3
       
   356 ln -s ../../gcc/%major_minor/lib/%{_arch64}/libgfortran.so
       
   357 ln -s ../../gcc/%major_minor/lib/%{_arch64}/libgomp.so.1
       
   358 ln -s ../../gcc/%major_minor/lib/%{_arch64}/libgomp.so
       
   359 ln -s ../../gcc/%major_minor/lib/%{_arch64}/libobjc.so.3
       
   360 ln -s ../../gcc/%major_minor/lib/%{_arch64}/libobjc.so
       
   361 ln -s ../../gcc/%major_minor/lib/%{_arch64}/libssp.so.0
       
   362 ln -s ../../gcc/%major_minor/lib/%{_arch64}/libssp.so
       
   363 ln -s ../../gcc/%major_minor/lib/%{_arch64}/libstdc++.so.6
       
   364 ln -s ../../gcc/%major_minor/lib/%{_arch64}/libstdc++.so
       
   365 %endif
       
   366 
       
   367 #link binaries into usual place the former SFEgcc used and 
       
   368 #a lot of spec files still use and are as well the recommended
       
   369 #paths to specify just what the "default" SFEgcc 4-series
       
   370 #compiler is called from. Note: binaries built that way *may*
       
   371 #point to libraries found in a compiler major.minor specific
       
   372 #directory in /usr/gcc/<majornumber>.<minornumber> 
       
   373 #This is in preparation for eventually getting a meta-level
       
   374 #package SFEgcc (contains symlinks only into /usr/gcc/<majornumber>.<minornumber>,
       
   375 #and is the package Requirement written in customer spec files.
       
   376 #below that SFEgcc packages, a SFEgcc-452 exists with the real compiler in it
       
   377 
       
   378 #NOTE: the os-distro delivers the "SFW" version of gcc 3.x.x
       
   379 #and therefore does deliver links into /usr/gnu/bin:
       
   380 #/usr/gnu/bin/cc    ->    ../../sfw/bin/gcc     (stays)
       
   381 #/usr/gnu/bin/cpp   ->    ../../sfw/bin/cpp     (stays, interferes with us)
       
   382 #we do exclude "cpp" from this SFEgcc.spec for that reason!
       
   383 
       
   384 #link binaries, enables CC=/usr/gnu/bin/gcc CXX=/usr/gnu/bin/g++ 
       
   385 #to get SFEgcc.spec version 4.x compiler in use without specifying
       
   386 #the exact SFEgcc compiler version number, just use the most recent 4.x.x
       
   387 mkdir %buildroot%_std_bindir
       
   388 cd %buildroot%_std_bindir
       
   389 ln -s ../gcc/%major_minor/bin/g++
       
   390 ln -s ../gcc/%major_minor/bin/gcc
       
   391 ln -s ../gcc/%major_minor/bin/gcov
       
   392 ln -s ../gcc/%major_minor/bin/gfortran
       
   393 
       
   394 rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.a
       
   395 rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
       
   396 %ifarch amd64 sparcv9
       
   397 rm -f $RPM_BUILD_ROOT%{_libdir}/%{_arch64}/lib*.a
       
   398 rm -f $RPM_BUILD_ROOT%{_libdir}/%{_arch64}/lib*.la
       
   399 %endif
       
   400 
       
   401 
       
   402 %clean
       
   403 rm -rf $RPM_BUILD_ROOT
       
   404 
       
   405 
       
   406 %files
       
   407 %defattr (-, root, bin)
       
   408 %dir %attr (0755, root, bin) %{_prefix}
       
   409 %dir %attr (0755, root, bin) %{_libdir}
       
   410 %{_libdir}/lib*.so*
       
   411 %{_libdir}/lib*.spec
       
   412 %dir %_std_libdir
       
   413 %_std_libdir/lib*.so*
       
   414 %ifarch amd64 sparcv9 i386
       
   415 %dir %attr (0755, root, bin) %{_libdir}/%{_arch64}
       
   416 %{_libdir}/%{_arch64}/lib*.so*
       
   417 %{_libdir}/%{_arch64}/lib*.spec
       
   418 %_std_libdir/%_arch64
       
   419 %endif
       
   420 
       
   421 
       
   422 %files devel
       
   423 %defattr (-, root, bin)
       
   424 %dir %attr (0755, root, bin) %{_prefix}
       
   425 %{_prefix}/man
       
   426 %dir %attr (0755, root, bin) %{_bindir}
       
   427 %{_bindir}/*
       
   428 %_std_bindir
       
   429 %dir %attr (0755, root, bin) %{_libdir}
       
   430 %{_libdir}/gcc
       
   431 %dir %attr (0755, root, sys) %{_datadir}
       
   432 %dir %attr (0755, root, bin) %{_mandir}
       
   433 %dir %attr (0755, root, bin) %{_mandir}/man1
       
   434 %{_mandir}/man1/*.1
       
   435 %dir %attr (0755, root, bin) %{_mandir}/man7
       
   436 %{_mandir}/man7/*.7
       
   437 %{_infodir}
       
   438 %{_includedir}
       
   439 
       
   440 %dir %attr (0755, root, sys) %{_datadir}/gcc-%{version}
       
   441 %dir %attr (0755, root, sys) %{_datadir}/gcc-%{version}/python
       
   442 %dir %attr (0755, root, sys) %{_datadir}/gcc-%{version}/python/libstdcxx
       
   443 %dir %attr (0755, root, sys) %{_datadir}/gcc-%{version}/python/libstdcxx/v6
       
   444 %{_datadir}/gcc-%{version}/python/libstdcxx/v6/printers.py
       
   445 %{_datadir}/gcc-%{version}/python/libstdcxx/v6/__init__.py
       
   446 %{_datadir}/gcc-%{version}/python/libstdcxx/__init__.py
       
   447 
       
   448 %if %build_l10n
       
   449 %files l10n
       
   450 %defattr (-, root, bin)
       
   451 %dir %attr (0755, root, bin) %{_prefix}
       
   452 %dir %attr (0755, root, sys) %{_datadir}
       
   453 %attr (-, root, other) %{_datadir}/locale
       
   454 %endif
       
   455 
       
   456 %changelog
       
   457 * Sun Oct 30 2011 - Alex Viskovatoff
       
   458 - fork OI-SFEgcc.spec off SFEgcc.spec rev 4859; bump to 4.6.2
       
   459 - symlinks in /usr/bin and /usr/lib; use facets
       
   460 * Sat Jul 23 2011 - Guido Berhoerster <[email protected]>
       
   461 - added License and SUNW_Copyright tags
       
   462 * Sun Jul 17 2011 - Alex Viskovatoff
       
   463 - do not hardcode <majornumber>.<minornumber>
       
   464 * Sun Jul 17 2011 - Milan Jurik
       
   465 - bump to 4.6.1
       
   466 * Tue May 17 2011 - Milan Jurik
       
   467 - bump to 4.5.3
       
   468 * Thu Mar 17 2011 - Thomas Wagner
       
   469 - temporarily force SFEgmp SFEmpfr to have pkgtool --autodeps working in correct build-order
       
   470 * Wed Mar 16 2011 - Thomas Wagner
       
   471 - symlinks did not go into package, added %{_gnu_bindir}/* to %files SFEgcc 
       
   472 * Tue Mar 15 2011 - Thomas Wagner
       
   473 - add missing %define _gnu_bindir %{_basedir}/gnu/bin
       
   474 * Sat Mar 12 2011 - Thomas Wagner
       
   475 - make symlinks to get SFEgcc.spec version 4.x.x to have the gcc 4.x.x
       
   476   default compiler accessible by /usr/gnu/bin/gcc and /usr/gnu/bin/g++ 
       
   477   and /usr/gnu/bin/gfortran ...
       
   478 * Fri Mar 04 2011 - Milan Jurik
       
   479 - RUNPATH enforced to contain /usr/gnu/lib, libs symlinked to /usr/gnu/lib
       
   480 * Wed Mar 02 2011 - Milan Jurik
       
   481 - fix NLS build, need to fix linker for g++ still
       
   482 * Tue Mar 01 2011 - Milan Jurik
       
   483 - move to /usr/gcc/4.5
       
   484 * Tue Feb 08 2011 - Thomas Wagner
       
   485 - interim solution for very old gcc-4.3.3, derived from experimental/SFEgcc-4.5.2.spec
       
   486 * Sun Jan 30 2011 - Thomas Wagner
       
   487 - bump to 4.5.2
       
   488 * Sat Oct 23 2010 - Thomas Wagner
       
   489 - bump to 4.5.1
       
   490 - require SFEgmp / SFEmpfr (new version) for builds below 126. may add
       
   491   upper limit later if OS contains required version as SUNWgnu-mp / SUNWgnu-mpfr
       
   492 - finetune BASEDIR detection (SVR4 works, IPS lacks BASEDIR -> emulate)
       
   493 - merge new logic for (Build)Requires from SFEgcc version 4.4.4 to 4.5.0 spec file
       
   494 - start with osbuild >= 146 to use gnu ld for linking (build_gcc_with_gnu_ld)
       
   495   because looks like linker error
       
   496 - collect python files from directory based on gcc %version
       
   497 - make spec bailout if the symlink /usr/gnu/bin/cc exists
       
   498 - add (Build)Requires SFElibmpc.spec  (SFEMpc might retire, naming)
       
   499 - add new python files to %files
       
   500 - add experimental --with-SFEbinutils to force using more fresh SFEbinutils
       
   501 - don't hard-code ld-wrapper location, use instead `which ld-wrapper`
       
   502 * Mon Jul 28 2010 - Thomas Wagner
       
   503 - bump to 4.5.0
       
   504 * Wed Aug 18 2010 - Thomas Wagner
       
   505 - try with defaults to SUNWbinutils SUNWgnu-mp SUNWgnu-mpfr
       
   506   this might break gcc compile on older osbuild versions
       
   507 - stop and exit 1 if the link /usr/gnu/bin/cc exists. Give user hint to 
       
   508   remove this problematic symlink of gcc to cc
       
   509 - search ld-wrapper from PATH (e.g. /opt/jdsbld/bin or /opt/dtbld/bin)
       
   510 - workaround IPS bug that ever prints BASEdir as "/" even if it presents 
       
   511   "/usr/gnu" to have configure find SFEgmp and SFEmpfr in case it should 
       
   512 * Sun Jun  6 2010 - Thomas Wagner
       
   513 - bump to 4.4.4
       
   514 - add switches to force SFEgmp and SFEmpfr
       
   515 - experimenting with gcc related CFLAGS/LDFLAGS
       
   516 * Fri Feb 05 2010 - Albert Lee <[email protected]>
       
   517 - Fix bootstrap compiler options
       
   518 * Sun Aug 09 2009 - Thomas Wagner
       
   519 - BuildRequires: SUNWbash
       
   520 * Sat Mar 14 2009 - Thomas Wagner
       
   521 - change logic to require SFEgmp/SFEmpfr only if *no* SUNWgnu-mp/SUNWgnu-mpfr is present (this is on old OS builds)
       
   522 - make SFEgcc use of new SUNWgnu-mp/SUNWgnu-mpfr (replacement for SFEgmp/SFEmpfr, SFE-versions still work with SFEgcc)
       
   523 - detect new location of SFEgmp/SFEmpfr now in /usr/gnu and use them only if missing SUNWgnu-mp/SUNWgnu-mpfr
       
   524 - add (Build)Requires: SFElibiconv(-devel) (thanks to check-deps.pl)
       
   525 * Sat Feb 21 2009 - Thomas Wagner
       
   526 - bump to 4.3.3
       
   527 - make conditional SFEgmp  / SUNWgnu-mp
       
   528 - make conditional SFEmpfr / SUNWgnu-mpfr
       
   529 - add extra configure switch if SUNWgnu-mp and/or SUNWgnu-mpfr is used
       
   530 * Sun Jan 25 2009 - Thomas Wagner
       
   531 - make default without HANDLE_PRAGMA_PACK_PUSH_POP. switch on with:
       
   532   --with-handle_pragma_pack_push_pop
       
   533 * Sat Jan 24 2009 - Thomas Wagner
       
   534 - add HANDLE_PRAGMA_PACK_PUSH_POP (might help wine)
       
   535 - bump to 4.2.4, version SFEgcc wit %{version}
       
   536 * Wed Jan  7 2009 - Thomas Wagner
       
   537 - add conditional SUNWbinutils/SFEbinutils to SFEgcc package
       
   538 * Sun Dec 28 2008 - Thomas Wagner
       
   539 - work around %files section on i386/32-bit not finding %{_arch64} binaries because _arch64 is unset ... _arch64 only set if running 64-bit OS in include/arch64.inc
       
   540 * Sat Dec 27 2008 - Thomas Wagner
       
   541 - add conditional SUNWbinutils/SFEbinutils to re-enable build on old OS
       
   542 - add configure-switch for SUNWbinutils otherwise left over SFEbinutils catched by configure/compile. SUNWbinuils not found otherwise.
       
   543 * Wed Aug 06 2008 - [email protected]
       
   544 - change SFEbinutils to SUNWbinutils, defaulting to SUN ld
       
   545 * Mon Mar 10 2008 - [email protected]
       
   546 - add missing defattr
       
   547 * Sun Mar  2 2008 - Mark Wright <[email protected]>
       
   548 - Add gcc-01-libtool-rpath.diff patch for a problem where
       
   549 - the old, modified libtool 1.4 in gcc 4.2.3 drops
       
   550 - -rpath /usr/gnu/lib when building libstdc++.so.6.0.9.
       
   551 * Fri Feb 29 2008 - Mark Wright <[email protected]>
       
   552 - Bump to 4.2.3.  Remove patch for 32787 as it is upstreamed into gcc 4.2.3.
       
   553 * Sat Jan 26 2008 - Moinak Ghosh <[email protected]>
       
   554 - Refactor package to have SFEgcc and SFEgccruntime.
       
   555 * Sun Oct 14 2007 - Mark Wright <[email protected]>
       
   556 - Bump to 4.2.2.
       
   557 * Wed Aug 15 2007 - Mark Wright <[email protected]>
       
   558 - Change from /usr/ccs/bin/ld to /usr/gnu/bin/ld, this change
       
   559   requires SFEbinutils built with binutils-01-bug-2495.diff,
       
   560   binutils-02-ld-m-elf_i386.diff and binutils-03-lib-amd64-ld-so-1.diff.
       
   561   Add objc to --enable-languages, add --enable-decimal-float.
       
   562 * Wed Jul 24 2007 - Mark Wright <[email protected]>
       
   563 - Bump to 4.2.1, add patch for gcc bug 32787.
       
   564 * Wed May 16 2007 - Doug Scott <[email protected]>
       
   565 - Bump to 4.2.0
       
   566 * Tue Mar 20 2007 - Doug Scott <[email protected]>
       
   567 - Added LD_OPTIONS so libs in /usr/gnu/lib will be found
       
   568 * Sun Mar  7 2007 - Doug Scott <[email protected]>
       
   569 - change to use GNU as from SFEbinutils
       
   570 * Sun Mar  7 2007 - Doug Scott <[email protected]>
       
   571 - Initial spec