src/cmd/fsexam/fsexam.sol.spec
changeset 147 8c4ef02c14b8
parent 146 841e634f8d60
child 148 91c620d9e52f
equal deleted inserted replaced
146:841e634f8d60 147:8c4ef02c14b8
     1 #
       
     2 # CDDL HEADER START
       
     3 #
       
     4 # The contents of this file are subject to the terms of the
       
     5 # Common Development and Distribution License (the "License").  
       
     6 # You may not use this file except in compliance with the License.
       
     7 #
       
     8 # You can obtain a copy of the license at src/OPENSOLARIS.LICENSE
       
     9 # or http://www.opensolaris.org/os/licensing.
       
    10 # See the License for the specific language governing permissions
       
    11 # and limitations under the License.
       
    12 #
       
    13 # When distributing Covered Code, include this CDDL HEADER in each
       
    14 # file and include the License file at src/OPENSOLARIS.LICENSE.
       
    15 # If applicable, add the following below this CDDL HEADER, with the
       
    16 # fields enclosed by brackets "[]" replaced with your own identifying
       
    17 # information: Portions Copyright [yyyy] [name of copyright owner]
       
    18 #
       
    19 # CDDL HEADER END
       
    20 #
       
    21 # Copyright 2006 Sun Microsystems, Inc.  All rights reserved.
       
    22 # Use is subject to license terms.
       
    23 #
       
    24 %include Solaris.inc
       
    25 
       
    26 %define name    SUNWfsexam 
       
    27 %define cmpt    fsexam
       
    28 
       
    29 Summary: File System Examiner
       
    30 Name: SUNWfsexam 
       
    31 Version: 0.3
       
    32 Release: 16
       
    33 License: CDDL
       
    34 Group: User Interface/Desktop
       
    35 Source: %{name}-%{version}.tar.bz2
       
    36 BuildRoot: %{_tmppath}/%{name}-%{version}-root
       
    37 
       
    38 %include default-depend.inc
       
    39 #BuildRequires: SUNWgnome-javahelp-convert
       
    40 Requires: SUNWgnome-libs
       
    41 Requires: SUNWgnome-base-libs
       
    42 Requires: SUNWgnome-config
       
    43 
       
    44 %description
       
    45 File System Examiner is to help user migrate file name and file content from
       
    46 legacy encoding to UTF8 encoding.
       
    47 
       
    48 
       
    49 %prep
       
    50 %setup
       
    51 
       
    52 %build
       
    53 export LDFLAGS="-L%{_libdir} -R%{_libdir}"
       
    54 export CFLAGS="-I%{_includedir} %optflags"
       
    55 export MSGFMT="/usr/bin/msgfmt"
       
    56 export ACLOCAL_FLAGS="-I %{_datadir}/aclocal"
       
    57 export PERL5LIB=%{_prefix}/perl5/site_perl/5.6.1/sun4-solaris-64int
       
    58 export PKG_CONFIG_PATH=%{_libdir}/pkgconfig:/usr/lib/pkgconfig
       
    59 autoconf
       
    60 
       
    61 CFLAGS="$RPM_OPT_FLAGS"                      \
       
    62 ./configure --prefix=%{_prefix}              \
       
    63             --sysconfdir=%{_sysconfdir}
       
    64 make
       
    65 
       
    66 %install
       
    67 rm -rf ${RPM_BUILD_ROOT}
       
    68 export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
       
    69 %makeinstall
       
    70 javahelp-convert-install $RPM_BUILD_ROOT %{cmpt} %{cmpt}.xml
       
    71 
       
    72 %clean
       
    73 rm -rf ${RPM_BUILD_ROOT}
       
    74 
       
    75 %post
       
    76 GCONF_CONFIG_SOURCE=`%{_bindir}/gconftool-2 --get-default-source` %{_bindir}/gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/fsexam.schemas
       
    77 
       
    78 %files 
       
    79 %defattr(-, root, other)
       
    80 %{_bindir}/*
       
    81 %{_sysconfdir}/gconf/schemas/*
       
    82 %{_datadir}/applications/fsexam.desktop
       
    83 %{_datadir}/pixmaps/*.png
       
    84 %{_datadir}/locale/*/LC_MESSAGES/fsexam.mo
       
    85 %{_datadir}/omf
       
    86 %{_datadir}/gnome/help/fsexam/*
       
    87 %{_datadir}/gnome/javahelp/fsexam
       
    88 %doc AUTHORS ChangeLog COPYING COPYING.LIB NEWS README
       
    89 
       
    90 %changelog
       
    91 * Wed Aug 11 2004 Federic Zhang <[email protected]>
       
    92 - Bump to 0.3
       
    93 
       
    94 * Tue Aug 10 2004 Federic Zhang <[email protected]>
       
    95 - For Cinnabar build 16, implement Undo and UI polish
       
    96  
       
    97 * Fri Jul 23 2004 Federic Zhang <[email protected]>
       
    98 - For Cinnbar Beta build 15
       
    99 
       
   100 * Mon May 31 2004 Gain  Tu <[email protected]>
       
   101 - For Cinnabar build 11, add l10en menu, context-sensitive menu, help, reverse
       
   102 
       
   103 * Mon May 24 2004 Gavin Tu <[email protected]>
       
   104 - menu can be l10ned, alloc memory for name dynamiclly 
       
   105 
       
   106 * Thu May 13 2004 Federic Zhang <[email protected]>
       
   107 - For Cinnabar build 10, added fsexam.desktop and fsexam-icon.png
       
   108 
       
   109 * Tue Apr 20 2004 Federic Zhang <[email protected]>
       
   110 - For Cinnabar build8, added CFLAGS env and prefix option
       
   111 
       
   112 * Mon Apr 11 2004 Federic Zhang <[email protected]>
       
   113 - version 0.1