SUNWlibdaemon.spec
changeset 10043 2f1bf7bc6013
child 10900 1737e29df6e2
equal deleted inserted replaced
10042:53220a5d12de 10043:2f1bf7bc6013
       
     1 #
       
     2 # spec file for package SUNWlibdaemon
       
     3 #
       
     4 # includes module(s): libdaemon
       
     5 #
       
     6 # Copyright (c) 2006 Sun Microsystems, Inc.
       
     7 # This file and all modifications and additions to the pristine
       
     8 # package are under the same license as the package itself.
       
     9 #
       
    10 
       
    11 %include Solaris.inc
       
    12 
       
    13 %use libdaemon = libdaemon.spec 
       
    14 
       
    15 Name:                    SUNWlibdaemon
       
    16 Summary:                 Lightweight C library for UNIX daemons
       
    17 Version:                 %{libdaemon.version}
       
    18 SUNW_BaseDir:            %{_basedir}
       
    19 BuildRoot:               %{_tmppath}/%{name}-%{version}-build
       
    20 
       
    21 %include default-depend.inc
       
    22 
       
    23 %package devel
       
    24 Summary:                 %{summary} - development files
       
    25 SUNW_BaseDir:            %{_prefix}
       
    26 %include default-depend.inc
       
    27 
       
    28 %prep
       
    29 rm -rf %name-%version
       
    30 mkdir %name-%version
       
    31 %libdaemon.prep -d %name-%version
       
    32 
       
    33 %build
       
    34 PKG_CONFIG_DISABLE_UNISTALLED=
       
    35 unset PKG_CONFIG_DISABLE_UNISTALLED
       
    36 export PKG_CONFIG_PATH=../libdaemon-%{libdaemon.version}:%{_pkg_config_path}
       
    37 
       
    38 export PKG_CONFIG_PATH32="$PKG_CONFIG_PATH"
       
    39 
       
    40 export PKG_CONFIG_PATH64=../libdaemon-%{libdaemon.version}-64:%{_pkg_config_path64}
       
    41 
       
    42 
       
    43 export CFLAGS="%optflags"
       
    44 export RPM_OPT_FLAGS="$CFLAGS"
       
    45 export LDFLAGS="%_ldflags"
       
    46 
       
    47 %libdaemon.build -d %name-%version
       
    48 
       
    49 %install
       
    50 %libdaemon.install -d %name-%version
       
    51 
       
    52 %{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}
       
    53 
       
    54 %clean
       
    55 rm -rf $RPM_BUILD_ROOT
       
    56 
       
    57 %files
       
    58 %defattr (-, root, other)
       
    59 %dir %attr (0755, root, bin) %{_libdir}
       
    60 %{_libdir}/libdaemon*.so*
       
    61 
       
    62 %files devel
       
    63 %defattr (-, root, other)
       
    64 %dir %attr (0755, root, bin) %{_libdir}
       
    65 %dir %attr (0755, root, other) %{_libdir}/pkgconfig
       
    66 %{_libdir}/pkgconfig/*
       
    67 %dir %attr (0755, root, bin) %{_includedir}
       
    68 %{_includedir}/*
       
    69 
       
    70 
       
    71 %changelog
       
    72 * Mon May 29 2006 - [email protected]
       
    73 - Initial spec file created.