SUNWlibnotify.spec
branchgnome-2-28
changeset 18610 43c66ab55c32
equal deleted inserted replaced
18609:dc24da2623f4 18610:43c66ab55c32
       
     1 #
       
     2 # spec file for package SUNWlibnotify
       
     3 #
       
     4 # includes module(s): libnotify
       
     5 #
       
     6 # Copyright 2009 Sun Microsystems, Inc.
       
     7 # This file and all modifications and additions to the pristine
       
     8 # package are under the same license as the package itself.
       
     9 #
       
    10 %define owner jedy
       
    11 #
       
    12 %include Solaris.inc
       
    13 
       
    14 %ifarch amd64 sparcv9
       
    15 %include arch64.inc
       
    16 %use libnotify64 = libnotify.spec
       
    17 %endif
       
    18 
       
    19 %include base.inc
       
    20 %use libnotify = libnotify.spec
       
    21 
       
    22 Name:                    SUNWlibnotify
       
    23 Summary:                 Library for desktop notifications
       
    24 Version:                 %{default_pkg_version}
       
    25 SUNW_BaseDir:            %{_basedir}
       
    26 SUNW_Copyright:          %{name}.copyright
       
    27 BuildRoot:               %{_tmppath}/%{name}-%{version}-build
       
    28 
       
    29 %include default-depend.inc
       
    30 
       
    31 BuildRequires:           SUNWgtk2
       
    32 
       
    33 %prep
       
    34 rm -rf %name-%version
       
    35 mkdir %name-%version
       
    36 
       
    37 %ifarch amd64 sparcv9
       
    38 mkdir %name-%version/%{_arch64}
       
    39 %libnotify64.prep -d %name-%version/%{_arch64}
       
    40 %endif
       
    41 
       
    42 mkdir %name-%version/%{base_arch}
       
    43 %libnotify.prep -d %name-%version/%{base_arch}
       
    44 
       
    45 %build
       
    46 %ifarch amd64 sparcv9
       
    47 export PKG_CONFIG_PATH=%{_libdir}/%{_arch64}/pkgconfig
       
    48 export CFLAGS="%optflags64"
       
    49 export LDFLAGS="%_ldflags"
       
    50 %libnotify64.build -d %name-%version/%{_arch64}
       
    51 %endif
       
    52 
       
    53 export CFLAGS="%optflags"
       
    54 export LDFLAGS="%_ldflags"
       
    55 %libnotify.build -d %name-%version/%{base_arch}
       
    56 
       
    57 %install
       
    58 rm -rf $RPM_BUILD_ROOT
       
    59 
       
    60 %ifarch amd64 sparcv9
       
    61 %libnotify64.install -d %name-%version/%{_arch64}
       
    62 %endif
       
    63 
       
    64 %libnotify.install -d %name-%version/%{base_arch}
       
    65 
       
    66 find $RPM_BUILD_ROOT%{_libdir} -type f -name "*.a" -exec rm -f {} ';'
       
    67 find $RPM_BUILD_ROOT%{_libdir} -type f -name "*.la" -exec rm -f {} ';'
       
    68 
       
    69 %clean
       
    70 rm -rf $RPM_BUILD_ROOT
       
    71 
       
    72 %post
       
    73 
       
    74 %files
       
    75 %defattr (-, root, bin)
       
    76 %dir %attr (0755, root, bin) %{_bindir}
       
    77 %{_bindir}/notify-send
       
    78 %dir %attr (0755, root, other) %{_libdir}/pkgconfig
       
    79 %{_libdir}/libnotify.so*
       
    80 %{_libdir}/pkgconfig/libnotify.pc
       
    81 %ifarch amd64 sparcv9
       
    82 %dir %attr (0755, root, bin) %{_bindir}/%{_arch64}
       
    83 %{_bindir}/%{_arch64}/notify-send
       
    84 %dir %attr (0755, root, other) %{_libdir}/%{_arch64}/pkgconfig
       
    85 %{_libdir}/%{_arch64}/libnotify.so*
       
    86 %{_libdir}/%{_arch64}/pkgconfig/libnotify.pc
       
    87 %endif
       
    88 %dir %attr (0755, root, sys) %{_datadir}
       
    89 %{_datadir}/gtk-doc/html/libnotify/*
       
    90 %{_includedir}/libnotify/*.h
       
    91 
       
    92 %changelog
       
    93 * Thu Jan 21 2010 - [email protected]
       
    94 - Updates cflags to fix 64-bit build problem.
       
    95 * Sun Jan  3 2009 - [email protected]
       
    96 - Add dep on SUNWgtk2.
       
    97 * Tue Dec 29 2009 - [email protected]
       
    98 - Add 64-bit support.
       
    99 * Thu Dec  3 2009 - [email protected]
       
   100 - Separate into own spec (from gnome-panel).
       
   101