SUNWgnome-media-apps.spec
changeset 12577 50cc056d0d0f
parent 12263 930dc7240f6a
child 12593 92dca2f87244
equal deleted inserted replaced
12576:ef2c65ee992e 12577:50cc056d0d0f
     1 #
     1 #
     2 # spec file for packages SUNWgnome-media, SUNWgnome-freedb-libs,
     2 # spec file for packages SUNWgnome-media, SUNWgnome-sound-recorder
     3 #                        SUNWgnome-sound-recorder
       
     4 #
     3 #
     5 # includes module(s): gnome-media
     4 # includes module(s): gnome-media
     6 #
     5 #
     7 # Copyright 2008 Sun Microsystems, Inc.
     6 # Copyright 2008 Sun Microsystems, Inc.
     8 # This file and all modifications and additions to the pristine
     7 # This file and all modifications and additions to the pristine
     9 # package are under the same license as the package itself.
     8 # package are under the same license as the package itself.
    10 #
     9 #
    11 # Owner: yippi
    10 # Owner: yippi
    12 #
    11 #
    13 %include Solaris.inc
    12 %include Solaris.inc
    14 
       
    15 # Add --with-gnome-cd when calling pkgtool if you want to build 
       
    16 # gnome-cd.  We normally don't build/ship this program, but this
       
    17 # option is available for those who want to test with it or 
       
    18 # rebuild with gnome-cd because they want to use it.
       
    19 #
       
    20 %define build_with_gnome_cd %{?_with_gnome_cd:1}%{?!_with_gnome_cd:0}
       
    21 
    13 
    22 %use gmedia = gnome-media.spec
    14 %use gmedia = gnome-media.spec
    23 
    15 
    24 Name:                    SUNWgnome-media-apps
    16 Name:                    SUNWgnome-media-apps
    25 Summary:                 GNOME media components
    17 Summary:                 GNOME media components
    68 %package devel
    60 %package devel
    69 Summary:                 %{summary} - development files
    61 Summary:                 %{summary} - development files
    70 SUNW_BaseDir:            %{_basedir}
    62 SUNW_BaseDir:            %{_basedir}
    71 %include default-depend.inc
    63 %include default-depend.inc
    72 
    64 
    73 %package -n SUNWgnome-freedb-libs
       
    74 Summary:                 GNOME free CD database access library
       
    75 SUNW_BaseDir:            %{_basedir}
       
    76 %include default-depend.inc
       
    77 Requires: SUNWgnome-freedb-libs-root
       
    78 Requires: SUNWgnome-libs
       
    79 Requires: SUNWgnome-base-libs
       
    80 Requires: SUNWgnome-component
       
    81 Requires: SUNWgnome-config
       
    82 Requires: SUNWpostrun
       
    83 
       
    84 %package -n SUNWgnome-freedb-libs-root
       
    85 Summary:                 GNOME free CD database access library - / filesystem
       
    86 SUNW_BaseDir:            /
       
    87 %include default-depend.inc
       
    88 Requires: SUNWpostrun-root
       
    89 Requires: SUNWgnome-config
       
    90 
       
    91 %package -n SUNWgnome-sound-recorder
    65 %package -n SUNWgnome-sound-recorder
    92 Summary:                 GNOME sound recording utilities
    66 Summary:                 GNOME sound recording utilities
    93 SUNW_BaseDir:            %{_basedir}
    67 SUNW_BaseDir:            %{_basedir}
    94 %include default-depend.inc
    68 %include default-depend.inc
    95 Requires: SUNWgnome-sound-recorder-root
    69 Requires: SUNWgnome-sound-recorder-root
   135 cd %{_builddir}/%name-%version/sun-manpages
   109 cd %{_builddir}/%name-%version/sun-manpages
   136 make install DESTDIR=$RPM_BUILD_ROOT
   110 make install DESTDIR=$RPM_BUILD_ROOT
   137 
   111 
   138 chmod 755 $RPM_BUILD_ROOT%{_mandir}/man1/*.1
   112 chmod 755 $RPM_BUILD_ROOT%{_mandir}/man1/*.1
   139 
   113 
   140 # Move gnome-cd to gnome-CD since gnome-cd is a symlink to
       
   141 # sound-juicer.
       
   142 #
       
   143 %if %build_with_gnome_cd
       
   144 mv $RPM_BUILD_ROOT%{_bindir}/gnome-cd $RPM_BUILD_ROOT%{_bindir}/gnome-CD
       
   145 %endif
       
   146 
       
   147 # Remove .la and .a file as we don't ship them.
   114 # Remove .la and .a file as we don't ship them.
   148 rm $RPM_BUILD_ROOT%{_libdir}/libglade/2.0/lib*.la
   115 rm $RPM_BUILD_ROOT%{_libdir}/libglade/2.0/lib*.la
   149 rm $RPM_BUILD_ROOT%{_libdir}/libglade/2.0/lib*.a
   116 rm $RPM_BUILD_ROOT%{_libdir}/libglade/2.0/lib*.a
   150 
   117 
   151 %if %build_l10n
   118 %if %build_l10n
   161 
   128 
   162 %clean
   129 %clean
   163 rm -rf $RPM_BUILD_ROOT
   130 rm -rf $RPM_BUILD_ROOT
   164 
   131 
   165 %post -n SUNWgnome-sound-recorder
   132 %post -n SUNWgnome-sound-recorder
   166 ( echo 'test -x /usr/bin/update-desktop-database || exit 0';
   133 %include desktop-database-install.script
   167   echo '/usr/bin/update-desktop-database'
   134 %include scrollkeeper-update.script
   168 ) | $BASEDIR/lib/postrun -b -u -c JDS_wait
   135 %include icon-cache.script
   169 ( echo 'test -x /usr/bin/scrollkeeper-update || exit 0';
       
   170   echo '/usr/bin/scrollkeeper-update'
       
   171 ) | $BASEDIR/lib/postrun -b -u -c JDS
       
   172 
   136 
   173 %postun -n SUNWgnome-sound-recorder
   137 %postun -n SUNWgnome-sound-recorder
   174 test -x $BASEDIR/lib/postrun || exit 0
   138 test -x $BASEDIR/lib/postrun || exit 0
   175 ( echo 'test -x /usr/bin/update-desktop-database || exit 0';
   139 %include desktop-database-uninstall.script
   176   echo '/usr/bin/update-desktop-database'
   140 %include scrollkeeper-update.script
   177 ) | $BASEDIR/lib/postrun -b -u -c JDS
   141 %include icon-cache.script
   178 ( echo 'test -x /usr/bin/scrollkeeper-update || exit 0';
       
   179   echo '/usr/bin/scrollkeeper-update'
       
   180 ) | $BASEDIR/lib/postrun -b -u -c JDS
       
   181 
   142 
   182 %post -n SUNWgnome-sound-recorder-root
   143 %post -n SUNWgnome-sound-recorder-root
   183 %include gconf-install.script
   144 %include gconf-install.script
   184 
   145 
   185 %preun -n SUNWgnome-sound-recorder-root
   146 %preun -n SUNWgnome-sound-recorder-root
   197   echo 'schemas="$SDIR/gnome-sound-recorder.schemas"';
   158   echo 'schemas="$SDIR/gnome-sound-recorder.schemas"';
   198   echo '$PKG_INSTALL_ROOT/usr/bin/gconftool-2 --makefile-uninstall-rule $schemas'
   159   echo '$PKG_INSTALL_ROOT/usr/bin/gconftool-2 --makefile-uninstall-rule $schemas'
   199 ) | $BASEDIR/var/lib/postrun/postrun -i -c JDS -a
   160 ) | $BASEDIR/var/lib/postrun/postrun -i -c JDS -a
   200 
   161 
   201 %post
   162 %post
   202 ( echo 'test -x /usr/bin/update-desktop-database || exit 0';
   163 %include desktop-database-install.script
   203   echo '/usr/bin/update-desktop-database'
   164 %include scrollkeeper-update.script
   204 ) | $BASEDIR/lib/postrun -b -u -c JDS_wait
   165 %include icon-cache.script
   205 ( echo 'test -x /usr/bin/scrollkeeper-update || exit 0';
   166 ( echo 'test -x /usr/bin/scrollkeeper-update || exit 0';
   206   echo '/usr/bin/scrollkeeper-update'
   167   echo '/usr/bin/scrollkeeper-update'
   207 ) | $BASEDIR/lib/postrun -b -u -c JDS
   168 ) | $BASEDIR/lib/postrun -b -u -c JDS
   208 
   169 
   209 %postun
   170 %postun
   210 test -x $BASEDIR/lib/postrun || exit 0
   171 test -x $BASEDIR/lib/postrun || exit 0
   211 ( echo 'test -x /usr/bin/update-desktop-database || exit 0';
   172 %include desktop-database-uninstall.script
   212   echo '/usr/bin/update-desktop-database'
   173 %include scrollkeeper-update.script
   213 ) | $BASEDIR/lib/postrun -b -u -c JDS
   174 %include icon-cache.script
   214 ( echo 'test -x /usr/bin/scrollkeeper-update || exit 0';
       
   215   echo '/usr/bin/scrollkeeper-update'
       
   216 ) | $BASEDIR/lib/postrun -b -u -c JDS
       
   217 
   175 
   218 %post root
   176 %post root
   219 %include gconf-install.script
   177 %include gconf-install.script
   220 
   178 
   221 %preun root
   179 %preun root
   229   echo 'GCONF_BACKEND_DIR=$PKG_INSTALL_ROOT/usr/lib/GConf/2';
   187   echo 'GCONF_BACKEND_DIR=$PKG_INSTALL_ROOT/usr/lib/GConf/2';
   230   echo 'LD_LIBRARY_PATH=$PKG_INSTALL_ROOT/usr/lib';
   188   echo 'LD_LIBRARY_PATH=$PKG_INSTALL_ROOT/usr/lib';
   231   echo 'export GCONF_CONFIG_SOURCE GCONF_BACKEND_DIR LD_LIBRARY_PATH';
   189   echo 'export GCONF_CONFIG_SOURCE GCONF_BACKEND_DIR LD_LIBRARY_PATH';
   232   echo 'SDIR=$BASEDIR%{_sysconfdir}/gconf/schemas';
   190   echo 'SDIR=$BASEDIR%{_sysconfdir}/gconf/schemas';
   233   echo 'schemas="$SDIR/gnome-audio-profiles.schemas';
   191   echo 'schemas="$SDIR/gnome-audio-profiles.schemas';
   234 %if %build_with_gnome_cd
       
   235   echo '         $SDIR/gnome-cd.schemas';
       
   236 %endif
       
   237   echo '         $SDIR/gnome-volume-control.schemas"';
   192   echo '         $SDIR/gnome-volume-control.schemas"';
   238   echo '$PKG_INSTALL_ROOT/usr/bin/gconftool-2 --makefile-uninstall-rule $schemas'
       
   239 ) | $BASEDIR/var/lib/postrun/postrun -i -c JDS -a
       
   240 
       
   241 %post -n SUNWgnome-freedb-libs
       
   242 ( echo 'test -x /usr/bin/update-desktop-database || exit 0';
       
   243   echo '/usr/bin/update-desktop-database'
       
   244 ) | $BASEDIR/lib/postrun -b -u -c JDS_wait
       
   245 ( echo 'test -x /usr/bin/scrollkeeper-update || exit 0';
       
   246   echo '/usr/bin/scrollkeeper-update'
       
   247 ) | $BASEDIR/lib/postrun -b -u -c JDS
       
   248 
       
   249 %postun -n SUNWgnome-freedb-libs
       
   250 test -x $BASEDIR/lib/postrun || exit 0
       
   251 ( echo 'test -x /usr/bin/update-desktop-database || exit 0';
       
   252   echo '/usr/bin/update-desktop-database'
       
   253 ) | $BASEDIR/lib/postrun -b -u -c JDS
       
   254 ( echo 'test -x /usr/bin/scrollkeeper-update || exit 0';
       
   255   echo '/usr/bin/scrollkeeper-update'
       
   256 ) | $BASEDIR/lib/postrun -b -u -c JDS
       
   257 
       
   258 %post -n SUNWgnome-freedb-libs-root
       
   259 %include gconf-install.script
       
   260 
       
   261 %preun -n SUNWgnome-freedb-libs-root
       
   262 test -x $BASEDIR/var/lib/postrun/postrun || exit 0
       
   263 ( echo 'test -x $PKG_INSTALL_ROOT/usr/bin/gconftool-2 || {';
       
   264   echo '  echo "WARNING: gconftool-2 not found; not uninstalling gconf schemas"';
       
   265   echo '  exit 0';
       
   266   echo '}';
       
   267   echo 'umask 0022';
       
   268   echo 'GCONF_CONFIG_SOURCE=xml:merged:$BASEDIR/etc/gconf/gconf.xml.defaults';
       
   269   echo 'GCONF_BACKEND_DIR=$PKG_INSTALL_ROOT/usr/lib/GConf/2';
       
   270   echo 'LD_LIBRARY_PATH=$PKG_INSTALL_ROOT/usr/lib';
       
   271   echo 'export GCONF_CONFIG_SOURCE GCONF_BACKEND_DIR LD_LIBRARY_PATH';
       
   272   echo 'SDIR=$BASEDIR%{_sysconfdir}/gconf/schemas';
       
   273   echo 'schemas="$SDIR/CDDB-Slave2.schemas"';
       
   274   echo '$PKG_INSTALL_ROOT/usr/bin/gconftool-2 --makefile-uninstall-rule $schemas'
   193   echo '$PKG_INSTALL_ROOT/usr/bin/gconftool-2 --makefile-uninstall-rule $schemas'
   275 ) | $BASEDIR/var/lib/postrun/postrun -i -c JDS -a
   194 ) | $BASEDIR/var/lib/postrun/postrun -i -c JDS -a
   276 
   195 
   277 %files
   196 %files
   278 %defattr (-, root, bin)
   197 %defattr (-, root, bin)
   292 %{_datadir}/gnome/help/gstreamer-properties/C
   211 %{_datadir}/gnome/help/gstreamer-properties/C
   293 %{_datadir}/gnome-media
   212 %{_datadir}/gnome-media
   294 %{_datadir}/gstreamer-properties
   213 %{_datadir}/gstreamer-properties
   295 %dir %attr (-, root, other) %{_datadir}/icons
   214 %dir %attr (-, root, other) %{_datadir}/icons
   296 %dir %attr (-, root, other) %{_datadir}/icons/hicolor
   215 %dir %attr (-, root, other) %{_datadir}/icons/hicolor
       
   216 %dir %attr (-, root, other) %{_datadir}/icons/hicolor/16x16
       
   217 %dir %attr (-, root, other) %{_datadir}/icons/hicolor/16x16/devices
       
   218 %dir %attr (-, root, other) %{_datadir}/icons/hicolor/16x16/status
   297 %dir %attr (-, root, other) %{_datadir}/icons/hicolor/48x48
   219 %dir %attr (-, root, other) %{_datadir}/icons/hicolor/48x48
   298 %dir %attr (-, root, other) %{_datadir}/icons/hicolor/48x48/apps
   220 %dir %attr (-, root, other) %{_datadir}/icons/hicolor/48x48/apps
       
   221 %{_datadir}/icons/hicolor/16x16/devices/gvc-3d-sound.png
       
   222 %{_datadir}/icons/hicolor/16x16/devices/gvc-headphones.png
       
   223 %{_datadir}/icons/hicolor/16x16/devices/gvc-line-in.png
       
   224 %{_datadir}/icons/hicolor/16x16/devices/gvc-tone.png
       
   225 %{_datadir}/icons/hicolor/16x16/status/audio-input-microphone-muted.png
   299 %{_datadir}/icons/hicolor/48x48/apps/gstreamer-properties.png
   226 %{_datadir}/icons/hicolor/48x48/apps/gstreamer-properties.png
   300 %{_datadir}/omf/*/gstreamer-properties-C.omf
   227 %{_datadir}/omf/*/gstreamer-properties-C.omf
   301 %{_datadir}/omf/gnome-sound-recorder/gnome-sound-recorder-C.omf
   228 %{_datadir}/omf/gnome-sound-recorder/gnome-sound-recorder-C.omf
   302 %{_datadir}/omf/gnome-volume-control/gnome-volume-control-C.omf
   229 %{_datadir}/omf/gnome-volume-control/gnome-volume-control-C.omf
   303 %dir %attr(0755, root, bin) %{_mandir}
   230 %dir %attr(0755, root, bin) %{_mandir}
   304 %dir %attr(0755, root, bin) %{_mandir}/man1
   231 %dir %attr(0755, root, bin) %{_mandir}/man1
   305 %{_mandir}/man1/gnome-audio-profiles-properties.1
   232 %{_mandir}/man1/gnome-audio-profiles-properties.1
   306 %{_mandir}/man1/gnome-volume-control.1
   233 %{_mandir}/man1/gnome-volume-control.1
   307 %{_mandir}/man1/gst*
   234 %{_mandir}/man1/gst*
   308 %if %build_with_gnome_cd
       
   309 %{_bindir}/gnome-CD
       
   310 %{_datadir}/applications/gnome-cd.desktop
       
   311 %dir %attr (0755, root, other) %{_datadir}/pixmaps
       
   312 %{_datadir}/pixmaps/gnome-cd.png
       
   313 %{_datadir}/pixmaps/gnome-cd/
       
   314 %{_datadir}/gnome/help/gnome-cd/C
       
   315 %{_datadir}/omf/*/gnome-cd-C.omf
       
   316 %endif
       
   317 
       
   318 %files -n SUNWgnome-freedb-libs
       
   319 %defattr (-, root, bin)
       
   320 %dir %attr (0755, root, bin) %{_bindir}
       
   321 %{_bindir}/cddb-slave2-properties
       
   322 %dir %attr (0755, root, bin) %{_libdir}
       
   323 %{_libexecdir}/CDDBSlave2
       
   324 %{_libexecdir}/cddb-track-editor
       
   325 %{_libdir}/bonobo/servers/GNOME_Media_CDDBSlave2.server
       
   326 %{_libdir}/libcddb-slave2*.so*
       
   327 %dir %attr (0755, root, sys) %{_datadir}
       
   328 %dir %attr (0755, root, other) %{_datadir}/applications
       
   329 %{_datadir}/applications/cddb-slave.desktop
       
   330 %dir %attr(0755, root, bin) %{_mandir}
       
   331 %dir %attr(0755, root, bin) %{_mandir}/man1
       
   332 %{_mandir}/man1/cddb-slave2-properties.1
       
   333 
   235 
   334 %files -n SUNWgnome-sound-recorder
   236 %files -n SUNWgnome-sound-recorder
   335 %defattr (-, root, bin)
   237 %defattr (-, root, bin)
   336 %dir %attr (0755, root, bin) %{_bindir}
   238 %dir %attr (0755, root, bin) %{_bindir}
   337 %{_bindir}/gnome-sound-recorder
   239 %{_bindir}/gnome-sound-recorder
   338 %{_bindir}/vumeter
       
   339 %dir %attr (0755, root, sys) %{_datadir}
   240 %dir %attr (0755, root, sys) %{_datadir}
   340 %dir %attr (0755, root, other) %{_datadir}/applications
   241 %dir %attr (0755, root, other) %{_datadir}/applications
   341 %{_datadir}/applications/gnome-sound-recorder.desktop
   242 %{_datadir}/applications/gnome-sound-recorder.desktop
   342 %{_datadir}/applications/reclevel.desktop
       
   343 %{_datadir}/applications/vumeter.desktop
       
   344 %dir %attr (0755, root, other) %{_datadir}/gnome
   243 %dir %attr (0755, root, other) %{_datadir}/gnome
   345 %{_datadir}/gnome/help/gnome-sound-recorder/C
   244 %{_datadir}/gnome/help/gnome-sound-recorder/C
   346 #FIXME: Not in 2.20.0 tarball:%{_datadir}/omf/*/grecord-C.omf 
       
   347 %{_datadir}/gnome-sound-recorder
   245 %{_datadir}/gnome-sound-recorder
   348 #FIXME: Not in 2.20.0 tarball:%dir %attr (0755, root, other) %{_datadir}/pixmaps
       
   349 #FIXME: Not in 2.20.0 tarball:%{_datadir}/pixmaps/gnome-mixer.png
       
   350 %dir %attr (-, root, other) %{_datadir}/icons
   246 %dir %attr (-, root, other) %{_datadir}/icons
   351 %dir %attr (-, root, other) %{_datadir}/icons/hicolor
   247 %dir %attr (-, root, other) %{_datadir}/icons/hicolor
       
   248 %dir %attr (-, root, other) %{_datadir}/icons/hicolor/16x16
       
   249 %dir %attr (-, root, other) %{_datadir}/icons/hicolor/16x16/apps
       
   250 %dir %attr (-, root, other) %{_datadir}/icons/hicolor/22x22
       
   251 %dir %attr (-, root, other) %{_datadir}/icons/hicolor/22x22/apps
       
   252 %dir %attr (-, root, other) %{_datadir}/icons/hicolor/24x24
       
   253 %dir %attr (-, root, other) %{_datadir}/icons/hicolor/24x24/apps
       
   254 %dir %attr (-, root, other) %{_datadir}/icons/hicolor/32x32
       
   255 %dir %attr (-, root, other) %{_datadir}/icons/hicolor/32x32/apps
   352 %dir %attr (-, root, other) %{_datadir}/icons/hicolor/48x48
   256 %dir %attr (-, root, other) %{_datadir}/icons/hicolor/48x48
   353 %dir %attr (-, root, other) %{_datadir}/icons/hicolor/48x48/apps
   257 %dir %attr (-, root, other) %{_datadir}/icons/hicolor/48x48/apps
   354 %{_datadir}/icons/hicolor/48x48/apps/gnome-grecord.png
   258 %dir %attr (-, root, other) %{_datadir}/icons/hicolor/scalable
   355 %{_datadir}/icons/hicolor/48x48/apps/gnome-reclevel.png
   259 %dir %attr (-, root, other) %{_datadir}/icons/hicolor/scalable/apps
   356 %{_datadir}/icons/hicolor/48x48/apps/gnome-vumeter.png
   260 %{_datadir}/icons/hicolor/16x16/apps/gnome-sound-recorder.png
       
   261 %{_datadir}/icons/hicolor/22x22/apps/gnome-sound-recorder.png
       
   262 %{_datadir}/icons/hicolor/24x24/apps/gnome-sound-recorder.png
       
   263 %{_datadir}/icons/hicolor/32x32/apps/gnome-sound-recorder.png
       
   264 %{_datadir}/icons/hicolor/48x48/apps/gnome-sound-recorder.png
       
   265 %{_datadir}/icons/hicolor/scalable/apps/gnome-sound-recorder.svg
   357 %dir %attr(0755, root, bin) %{_mandir}
   266 %dir %attr(0755, root, bin) %{_mandir}
   358 %dir %attr(0755, root, bin) %{_mandir}/man1
   267 %dir %attr(0755, root, bin) %{_mandir}/man1
   359 %{_mandir}/man1/gnome-sound-recorder.1
   268 %{_mandir}/man1/gnome-sound-recorder.1
   360 %{_mandir}/man1/vumeter.1
       
   361 
   269 
   362 %if %build_l10n
   270 %if %build_l10n
   363 %files l10n
   271 %files l10n
   364 %defattr (-, root, bin)
   272 %defattr (-, root, bin)
   365 %dir %attr (0755, root, sys) %{_datadir}
   273 %dir %attr (0755, root, sys) %{_datadir}
   373 %files root
   281 %files root
   374 %defattr (-, root, sys)
   282 %defattr (-, root, sys)
   375 %attr (0755, root, sys) %dir %{_sysconfdir}
   283 %attr (0755, root, sys) %dir %{_sysconfdir}
   376 %{_sysconfdir}/gconf/schemas/gnome-audio-profiles.schemas
   284 %{_sysconfdir}/gconf/schemas/gnome-audio-profiles.schemas
   377 %{_sysconfdir}/gconf/schemas/gnome-volume-control.schemas
   285 %{_sysconfdir}/gconf/schemas/gnome-volume-control.schemas
   378 %if %build_with_gnome_cd
       
   379 %{_sysconfdir}/gconf/schemas/gnome-cd.schemas
       
   380 %endif
       
   381 
       
   382 %files -n SUNWgnome-freedb-libs-root
       
   383 %defattr (-, root, sys)
       
   384 %attr (0755, root, sys) %dir %{_sysconfdir}
       
   385 %{_sysconfdir}/gconf/schemas/CDDB-Slave2.schemas
       
   386 
   286 
   387 %files -n SUNWgnome-sound-recorder-root
   287 %files -n SUNWgnome-sound-recorder-root
   388 %defattr (-, root, sys)
   288 %defattr (-, root, sys)
   389 %attr (0755, root, sys) %dir %{_sysconfdir}
   289 %attr (0755, root, sys) %dir %{_sysconfdir}
   390 %{_sysconfdir}/gconf/schemas/gnome-sound-recorder.schemas
   290 %{_sysconfdir}/gconf/schemas/gnome-sound-recorder.schemas
   393 %defattr (-, root, bin)
   293 %defattr (-, root, bin)
   394 %dir %attr (0755, root, bin) %{_libdir}
   294 %dir %attr (0755, root, bin) %{_libdir}
   395 %dir %attr (0755, root, other) %{_libdir}/pkgconfig
   295 %dir %attr (0755, root, other) %{_libdir}/pkgconfig
   396 %{_libdir}/pkgconfig/*
   296 %{_libdir}/pkgconfig/*
   397 %dir %attr (0755, root, bin) %{_includedir}
   297 %dir %attr (0755, root, bin) %{_includedir}
   398 %{_includedir}/cddb-slave2
       
   399 %{_includedir}/gnome-media/profiles
   298 %{_includedir}/gnome-media/profiles
   400 %dir %attr (0755, root, sys) %{_datadir}
   299 %dir %attr (0755, root, sys) %{_datadir}
   401 %{_datadir}/idl
       
   402 
   300 
   403 %changelog
   301 %changelog
       
   302 * Tue Jun 03 2008 - [email protected]
       
   303 - Packaging changes related to bumping to 2.23.  No longer ship
       
   304   cddb code or vumeter since these are no longer supported upstream.
       
   305   Remove support for building with gnome-cd since this is also
       
   306   no longer supported upstream.
   404 * Wed May 07 2008 - [email protected]
   307 * Wed May 07 2008 - [email protected]
   405 - Remove PERL5LIB setting as it is not necessary.
   308 - Remove PERL5LIB setting as it is not necessary.
   406 * Wed Apr 02 2008 - [email protected]
   309 * Wed Apr 02 2008 - [email protected]
   407 - Add SUNW_Copyright.
   310 - Add SUNW_Copyright.
   408 * Wed Mar 12 2008 - [email protected]
   311 * Wed Mar 12 2008 - [email protected]