gob2.spec
changeset 7376 609397372f40
equal deleted inserted replaced
7375:dd6bce4363fb 7376:609397372f40
       
     1 #
       
     2 # spec file for package gob2
       
     3 #
       
     4 # Copyright (c) 2005 Sun Microsystems, Inc.
       
     5 # This file and all modifications and additions to the pristine
       
     6 # package are under the same license as the package itself.
       
     7 #
       
     8 Name:         gob2
       
     9 License:      GPL
       
    10 Group:        Development/Libraries/GNOME
       
    11 Version:      2.0.14
       
    12 Release:      1
       
    13 Distribution: java-desktop-system
       
    14 Vendor:       Sun Microsystems, Inc.
       
    15 Summary:      GOB2, The GObject Builder
       
    16 Source:       http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.0/%{name}-%{version}.tar.bz2
       
    17 Url:          http://www.5z.com/jirka/gob.html
       
    18 BuildRoot:    %{_tmppath}/%{name}-%{version}-build
       
    19 Docdir:       %{_defaultdocdir}/doc
       
    20 Autoreqprov:  on
       
    21 Prereq:       /sbin/ldconfig
       
    22 
       
    23 %description
       
    24 GOB is a simple preprocessor for making GObject objects (glib objects).
       
    25 It makes objects from a single file which has inline C code so that
       
    26 you don't have to edit the generated files.  Syntax is somewhat inspired
       
    27 by java and yacc.  It supports generating C++ code
       
    28 
       
    29 %prep
       
    30 %setup -q
       
    31 
       
    32 %build
       
    33 
       
    34 %ifos linux
       
    35 if [ -x /usr/bin/getconf ]; then
       
    36   CPUS=`getconf _NPROCESSORS_ONLN`
       
    37 fi
       
    38 %else
       
    39   CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
       
    40 %endif
       
    41 if test "x$CPUS" = "x" -o $CPUS = 0; then
       
    42   CPUS=1
       
    43 fi
       
    44 
       
    45 aclocal $ACLOCAL_FLAGS
       
    46 libtoolize --force
       
    47 glib-gettextize --force --copy
       
    48 intltoolize --force --automake
       
    49 autoheader
       
    50 automake -a -f -c --gnu
       
    51 autoconf
       
    52 ./configure --prefix=%{_prefix}			\
       
    53 	    --bindir=%{_bindir}			\
       
    54             --mandir=%{_mandir} 
       
    55 
       
    56 make -j$CPUS
       
    57 
       
    58 %install
       
    59 rm -rf $RPM_BUILD_ROOT
       
    60 make install DESTDIR=$RPM_BUILD_ROOT mkdir_p="mkdir -p"
       
    61 find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
       
    62 find $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
       
    63 
       
    64 %clean
       
    65 rm -rf $RPM_BUILD_ROOT
       
    66 
       
    67 %files
       
    68 %defattr(-, root, root)
       
    69 %doc README AUTHORS COPYING NEWS TODO ChangeLog
       
    70 %doc examples
       
    71 %{_bindir}/*
       
    72 %{_mandir}/man1/*
       
    73 %{_datadir}/aclocal/*
       
    74 
       
    75 %changelog
       
    76 * Tue Jun 06 2006 - [email protected]
       
    77 - Initial version created.
       
    78