SUNWlibnotify.spec
changeset 17252 af4e2100afc3
parent 17097 2d876008dff0
child 17266 b3cda03a61df
equal deleted inserted replaced
17251:4c53628c690c 17252:af4e2100afc3
     8 # package are under the same license as the package itself.
     8 # package are under the same license as the package itself.
     9 #
     9 #
    10 %define owner jedy
    10 %define owner jedy
    11 #
    11 #
    12 %include Solaris.inc
    12 %include Solaris.inc
       
    13 
       
    14 %ifarch amd64 sparcv9
       
    15 %include arch64.inc
       
    16 %use libnotify64 = libnotify.spec
       
    17 %endif
       
    18 
       
    19 %include base.inc
    13 %use libnotify = libnotify.spec
    20 %use libnotify = libnotify.spec
    14 
    21 
    15 Name:                    SUNWlibnotify
    22 Name:                    SUNWlibnotify
    16 Summary:                 Library for desktop notifications
    23 Summary:                 Library for desktop notifications
    17 Version:                 %{default_pkg_version}
    24 Version:                 %{default_pkg_version}
    23 
    30 
    24 %prep
    31 %prep
    25 rm -rf %name-%version
    32 rm -rf %name-%version
    26 mkdir %name-%version
    33 mkdir %name-%version
    27 
    34 
    28 %libnotify.prep -d %name-%version
    35 %ifarch amd64 sparcv9
       
    36 mkdir %name-%version/%{_arch64}
       
    37 %libnotify64.prep -d %name-%version/%{_arch64}
       
    38 %endif
       
    39 
       
    40 mkdir %name-%version/%{base_arch}
       
    41 %libnotify.prep -d %name-%version/%{base_arch}
    29 
    42 
    30 %build
    43 %build
       
    44 %ifarch amd64 sparcv9
    31 export CFLAGS="%optflags"
    45 export CFLAGS="%optflags"
    32 export RPM_OPT_FLAGS="$CFLAGS"
       
    33 export LDFLAGS="%_ldflags"
    46 export LDFLAGS="%_ldflags"
    34 #export ACLOCAL_FLAGS="-I %{_datadir}/aclocal"
    47 %libnotify64.build -d %name-%version/%{_arch64}
       
    48 %endif
    35 
    49 
    36 %libnotify.build -d %name-%version
    50 export CFLAGS="%optflags"
       
    51 export LDFLAGS="%_ldflags"
       
    52 %libnotify.build -d %name-%version/%{base_arch}
    37 
    53 
    38 %install
    54 %install
    39 rm -rf $RPM_BUILD_ROOT
    55 rm -rf $RPM_BUILD_ROOT
    40 
    56 
    41 %libnotify.install -d %name-%version
    57 %ifarch amd64 sparcv9
       
    58 %libnotify64.install -d %name-%version/%{_arch64}
       
    59 %endif
       
    60 
       
    61 %libnotify.install -d %name-%version/%{base_arch}
    42 
    62 
    43 find $RPM_BUILD_ROOT%{_libdir} -type f -name "*.a" -exec rm -f {} ';'
    63 find $RPM_BUILD_ROOT%{_libdir} -type f -name "*.a" -exec rm -f {} ';'
    44 find $RPM_BUILD_ROOT%{_libdir} -type f -name "*.la" -exec rm -f {} ';'
    64 find $RPM_BUILD_ROOT%{_libdir} -type f -name "*.la" -exec rm -f {} ';'
    45 
    65 
    46 %clean
    66 %clean
    53 %dir %attr (0755, root, bin) %{_bindir}
    73 %dir %attr (0755, root, bin) %{_bindir}
    54 %{_bindir}/notify-send
    74 %{_bindir}/notify-send
    55 %dir %attr (0755, root, other) %{_libdir}/pkgconfig
    75 %dir %attr (0755, root, other) %{_libdir}/pkgconfig
    56 %{_libdir}/libnotify.so*
    76 %{_libdir}/libnotify.so*
    57 %{_libdir}/pkgconfig/libnotify.pc
    77 %{_libdir}/pkgconfig/libnotify.pc
       
    78 %ifarch amd64 sparcv9
       
    79 %dir %attr (0755, root, bin) %{_bindir}/%{_arch64}
       
    80 %{_bindir}/%{_arch64}/notify-send
       
    81 %dir %attr (0755, root, other) %{_libdir}/%{_arch64}/pkgconfig
       
    82 %{_libdir}/%{_arch64}/libnotify.so*
       
    83 %{_libdir}/%{_arch64}/pkgconfig/libnotify.pc
       
    84 %endif
    58 %dir %attr (0755, root, sys) %{_datadir}
    85 %dir %attr (0755, root, sys) %{_datadir}
    59 %{_datadir}/gtk-doc/html/libnotify/*
    86 %{_datadir}/gtk-doc/html/libnotify/*
    60 %{_includedir}/libnotify/*.h
    87 %{_includedir}/libnotify/*.h
    61 
    88 
    62 %changelog
    89 %changelog
       
    90 * Tue Dec 29 2009 - [email protected]
       
    91 - Add 64-bit support.
    63 * Thu Dec  3 2009 - [email protected]
    92 * Thu Dec  3 2009 - [email protected]
    64 - Separate into own spec (from gnome-panel).
    93 - Separate into own spec (from gnome-panel).
    65 
    94