linc.spec
changeset 1197 dd8c590934ca
parent 1196 c7e797fda7c6
child 1198 e0b17b7e57ab
equal deleted inserted replaced
1196:c7e797fda7c6 1197:dd8c590934ca
     1 Name:         linc
       
     2 License:      LGPL
       
     3 Group:        System/Libraries
       
     4 Version:      1.0.3
       
     5 Release:      12
       
     6 Distribution: Mercury
       
     7 Vendor:       Sun Microsystems, Inc.
       
     8 Summary:      Network Client/Server Library
       
     9 Source:       http://ftp.gnome.org/pub/GNOME/sources/linc/1.0/linc-%{version}.tar.bz2
       
    10 URL:          http://www.gnome.org
       
    11 BuildRoot:    %{_tmppath}/%{name}-%{version}-build
       
    12 Docdir:       %{_defaultdocdir}/doc
       
    13 AutoReqProv:  on
       
    14 
       
    15 %define glib2_version 2.2.1
       
    16 %define pkgconfig_version 0.15.0
       
    17 %define gtk_doc_version 1.0
       
    18 
       
    19 Requires:      glib2 >= %{glib2_version}
       
    20 BuildRequires: glib2-devel >= %{glib2_version}
       
    21 BuildRequires: pkgconfig >= %{pkgconfig_version}
       
    22 BuildRequires: gtk-doc >= %{gtk_doc_version}
       
    23 
       
    24 %description 
       
    25 linc is a library that eases the task of writing networked servers &
       
    26 clients. It takes care of connection initiation and maintenance, and the
       
    27 details of various transports. It is used by ORBit2 to handle message
       
    28 transmission/receipt.
       
    29 
       
    30 Currently supported transports:
       
    31 IPv4 (tested)
       
    32 UNIX domain sockets (tested)
       
    33 IPv6
       
    34 IrDA
       
    35 
       
    36 The connections can optionally be encrypted using OpenSSL.
       
    37 
       
    38 %package devel
       
    39 Summary:      Network Client/Server Development Library
       
    40 Group:        Development/Libraries/GNOME
       
    41 Requires:     %{name} = %{version}
       
    42 Requires:     glib2-devel >= %{glib2_version}
       
    43 
       
    44 %description devel
       
    45 linc is a library that eases the task of writing networked servers &
       
    46 clients. It takes care of connection initiation and maintenance, and the
       
    47 details of various transports. It is used by ORBit2 to handle message
       
    48 transmission/receipt.
       
    49 
       
    50 Currently supported transports:
       
    51 IPv4 (tested)
       
    52 UNIX domain sockets (tested)
       
    53 IPv6
       
    54 IrDA
       
    55 
       
    56 
       
    57 %prep
       
    58 %setup -q 
       
    59 
       
    60 %build
       
    61 
       
    62 CFLAGS="$RPM_OPT_FLAGS"				\
       
    63 ./configure --prefix=%{_prefix}			\
       
    64 	    --sysconfdir=%{_sysconfdir}		\
       
    65 	    --with-openssl			\
       
    66 	    --disable-gtk-doc
       
    67 make
       
    68 
       
    69 %install
       
    70 make DESTDIR=$RPM_BUILD_ROOT install
       
    71 
       
    72 %clean
       
    73 rm -rf $RPM_BUILD_ROOT
       
    74 
       
    75 %post
       
    76 /sbin/ldconfig
       
    77 
       
    78 %postun
       
    79 /sbin/ldconfig
       
    80 
       
    81 %files 
       
    82 %defattr(-, root, root)
       
    83 %{_libdir}/lib*.so.*
       
    84 
       
    85 %files devel
       
    86 %defattr(-, root, root)
       
    87 %{_libdir}/lib*.so
       
    88 %{_libdir}/pkgconfig/*.pc
       
    89 %{_includedir}/linc-1.0
       
    90 %{_datadir}/aclocal/*
       
    91 %{_prefix}/bin/linc-config
       
    92 %{_datadir}/gtk-doc/html/linc
       
    93 
       
    94 %changelog
       
    95 * Thu Aug 14 2003 - <[email protected]>
       
    96 - remove *.a, *.la
       
    97 
       
    98 * Sat Aug 02 2003 - <[email protected]>
       
    99 - Remove linc-cleanup-sockets from %files since
       
   100   it's not installed anymore
       
   101 
       
   102 * Fri Aug 01 2003 - <[email protected]>
       
   103 - Upgrade to 1.0.3
       
   104 
       
   105 * Mon May 12 2003 - <[email protected]>
       
   106 - initial Sun release