gnome-python.spec
changeset 6193 011617068c65
parent 5606 fc9ef0930572
child 6200 19ff8721b8f2
--- a/gnome-python.spec	Thu Oct 27 20:17:04 2005 +0000
+++ b/gnome-python.spec	Thu Oct 27 20:17:24 2005 +0000
@@ -20,7 +20,7 @@
 Autoreqprov:		on
 
 %define libglade_version           2.4.0
-%define python_version             2.2
+%define python_version             2.4
 %define pygtk2_version             2.4.0
 %define pyorbit_version            2.0.1
 %define libgnomeui_version         2.0.0
@@ -70,13 +70,16 @@
 CFLAGS="$RPM_OPT_FLAGS"				\
 ./configure 	--prefix=%{_prefix}		\
 	    	--sysconfdir=%{_sysconfdir}
-make
+make \
+    pyexecdir=%{_libdir}/python%{python_version}/vendor-packages \
+    pythondir=%{_libdir}/python%{python_version}/vendor-packages
 
 %install
-make DESTDIR=$RPM_BUILD_ROOT install
+make install DESTDIR=$RPM_BUILD_ROOT \
+    pyexecdir=%{_libdir}/python%{python_version}/vendor-packages \
+    pythondir=%{_libdir}/python%{python_version}/vendor-packages
 find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
 find $RPM_BUILD_ROOT -type f -name "*.pyo" -exec rm -f {} ';'
-find $RPM_BUILD_ROOT -type f -name "*.pyc" -exec rm -f {} ';'
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -87,7 +90,7 @@
 
 %files
 %defattr(-, root, root)
-%{_libdir}/python?.?/site-packages/gtk-2.0
+%{_libdir}/python?.?/vendor-packages/gtk-2.0
 
 %doc AUTHORS NEWS README ChangeLog
 %doc examples