SUNWglibmm.spec
changeset 11624 1147178b8480
child 11636 3ada0c8e3831
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/SUNWglibmm.spec	Tue Feb 12 23:09:08 2008 +0000
@@ -0,0 +1,121 @@
+#
+# spec file for package SUNWglibmm
+#
+# includes module(s): glibmm
+#
+# # Copyright 2008 Sun Microsystems, Inc.
+# This file and all modifications and additions to the pristine
+# package are under the same license as the package itself.
+#
+# Owner: SimonZheng
+#
+%include Solaris.inc
+%use glibmm = glibmm.spec
+
+Name:                    SUNWglibmm
+Summary:                 glibmm - C++ Wrapper for the Glib2 Library
+Version:                 %{default_pkg_version}
+SUNW_BaseDir:            %{_basedir}
+BuildRoot:               %{_tmppath}/%{name}-%{version}-build
+
+%include default-depend.inc
+Requires: SUNWgnome-base-libs
+BuildRequires: SUNWgnome-base-libs-devel
+Requires: SUNWsigcpp
+BuildRequires: SUNWsigcpp-devel
+
+%package devel
+Summary:                 %{summary} - development files
+SUNW_BaseDir:            %{_basedir}
+%include default-depend.inc
+Requires: %name
+Requires: SUNWgnome-base-libs-devel
+
+%if %build_l10n
+%package l10n
+Summary:		 %{summary} - l10n files
+SUNW_BaseDir:		 %{_basedir}
+%include default-depend.inc
+Requires:		 %{name}
+%endif
+
+%prep
+rm -rf %name-%version
+mkdir %name-%version
+%glibmm.prep -d %name-%version
+cd %{_builddir}/%name-%version
+
+%build
+%if %cc_is_gcc
+%else
+export CXX="${CXX} -norunpath"
+%endif
+export CXXFLAGS="%cxx_optflags"
+export PERL_PATH=/usr/perl5/bin/perl
+%glibmm.build -d %name-%version
+
+%install
+rm -rf $RPM_BUILD_ROOT
+%glibmm.install -d %name-%version
+find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
+find $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
+
+%if %build_l10n
+%else
+# REMOVE l10n FILES
+rm -rf $RPM_BUILD_ROOT%{_datadir}/locale
+%endif
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+%include desktop-database-install.script
+%include scrollkeeper-update.script
+
+%postun
+test -x $BASEDIR/lib/postrun || exit 0
+%include desktop-database-uninstall.script
+%include scrollkeeper-update.script
+
+%files
+%defattr (-, root, bin)
+%dir %attr (0755, root, bin) %{_libdir}
+%{_libdir}/lib*
+
+%files devel
+%defattr (-, root, bin)
+%dir %attr (0755, root, bin) %{_libdir}
+%dir %attr (0755, root, other) %{_libdir}/pkgconfig
+%{_libdir}/pkgconfig/*
+%{_libdir}/glibmm*
+%dir %attr (0755, root, sys) %{_datadir}
+%dir %attr (0755, root, other) %{_datadir}/doc
+%{_datadir}/doc/*
+%dir %attr (0755, root, other) %{_datadir}/aclocal
+%{_datadir}/aclocal/*
+%dir %attr (0755, root, bin) %{_includedir}
+%{_includedir}/*
+
+%changelog
+* Mon Jau 28 2008 - [email protected]
+- Split into SUNWglibmm.spec and glibmm.spec.
+- Change download URL to GNOME official website.
+* Fri Aug 17 2007 - [email protected]
+- Bump to 2.12.10
+* Tue Apr 17 2007 - [email protected]
+- Bump to 2.12.8.
+* Fri Mar 16 2007 - [email protected]
+- bump to 2.12.7
+* Wed Jan 03 2007 - [email protected]
+- Bump to 2.12.4
+* Fri Jun 23 2006 - [email protected]
+- rename to SFEglibmm
+- update permissions
+- bump to 2.10.4
+* Fri May 12 2006 - [email protected]
+- Bump to 2.10.2.
+* Fri Mar 10 2006 - [email protected]
+- Bump to 2.10.0.
+* Thu Nov 17 2005 - [email protected]
+- create