eel.spec
changeset 209 1774456c7622
parent 156 acc6f409a6eb
child 290 c7a3d7801635
--- a/eel.spec	Wed May 28 18:33:46 2003 +0000
+++ b/eel.spec	Wed May 28 18:39:36 2003 +0000
@@ -1,96 +1,67 @@
-#
-# Copyright (c) 2003 Sun Microsystems Inc.
-# This file and all modifications and additions to the pristine
-# package are under the same license as the package itself.
-#
-
 Name:         eel
-License:      GPL
-Group:        Development/Libraries/GNOME
+License:      LGPL
+Group:        System/Libraries/GNOME
 Version:      2.2.2
 Release:      1
 Distribution: Mercury
 Vendor:       Sun Microsystems Inc.
-Summary:      The Eazel Extensions Library for GNOME 2.2
-Source:       http://ftp.gnome.org/pub/gnome/sources/eel/2.2/eel-%{version}.tar.bz2
-URL:          www.gnome.org
+Summary:      Eazel Extensions Library
+Source:       http://ftp.gnome.org/pub/GNOME/sources/eel/2.2/eel-%{version}.tar.bz2
+URL:          http://www.gnome.org
 BuildRoot:    %{_tmppath}/%{name}-%{version}-build
-Docdir:       %{_defaultdocdir}/eel2
+Docdir:       %{_defaultdocdir}/doc
 Autoreqprov:  on
 
-%define pango_version 1.2.1
-%define gtk2_version 2.2.1
 %define libgnomeui_version 2.2.0.1
-%define gnome_vfs_version 2.2.3
 %define librsvg_version 2.2.4
-%define bonobo_activation_version 2.2.1
 %define libxml2_version 2.4.23
-%define libart_lgpl_version 2.3.11
+%define gnome_vfs_version 2.2.3
 %define gail_version 1.2.0
+%define GConf_version 2.2.0
 
-Requires: pango >= %{pango_version}
-Requires: gtk2 >= %{gtk2_version}
+BuildRequires: libgnomeui-devel >= %{libgnomeui_version}
+BuildRequires: librsvg-devel >= %{librsvg_version}
+BuildRequires: gail-devel >= %{gail_version}
 Requires: libgnomeui >= %{libgnomeui_version}
-Requires: gnome-vfs >= %{gnome_vfs_version}
 Requires: librsvg >= %{librsvg_version}
-Requires: bonobo-activation >= %{bonobo_activation_version}
-Requires: libxml2 >= %{libxml2_version}
-Requires: libart_lgpl >= %{libart_lgpl_version}
-
-BuildRequires: pango-devel >= %{pango_version}
-BuildRequires: gtk2-devel >= %{gtk2_version}
-BuildRequires: libgnomeui-devel >= %{libgnomeui_version}
-BuildRequires: gnome-vfs-devel >= %{gnome_vfs_version}
-BuildRequires: librsvg-devel >= %{librsvg_version}
-BuildRequires: bonobo-activation-devel >= %{bonobo_activation_version}
-BuildRequires: libxml2-devel >= %{libxml2_version}
-BuildRequires: libart_lgpl-devel >= %{libart_lgpl_version}
-BuildRequires: gail-devel >= %{gail_version}
-BuildRequires: pango
-
+Requires: gail >= %{gail_version}
 
 %description
 This library extends the Gtk+ library with some useful routines for
 applications like Nautilus.
 
 %package devel
-Summary:      The development files for the eel library
+Summary:      Eazel Extensions Development Library
 Group:        Development/Libraries/GNOME
-Autoreqprov:  on
-Requires: %{name} = %{version}
-
-Requires: gtk2-devel >= %{gtk2_version}
-Requires: libgnomeui-devel >= %{libgnomeui_version}
-Requires: gnome-vfs-devel >= %{gnome_vfs_version}
-Requires: librsvg-devel >= %{librsvg_version}
-Requires: bonobo-activation-devel >= %{bonobo_activation_version}
-Requires: libxml2-devel >= %{libxml2_version}
-Requires: libart_lgpl-devel >= %{libart_lgpl_version}
-Requires: gail-devel >= %{gail_version}
+Requires:     %{name} = %{version}
+Requires:     libxml2-devel >= %{libxml2_version}
+Requires:     gnome-vfs-devel >= %{gnome_vfs_version}
+Requires:     GConf-devel >= %{GConf_version}
 
 %description devel
-This packages contains the header and library files to develop with
-the eel library. See package eel.
+This library extends the Gtk+ library with some useful routines for
+applications like Nautilus.
 
 %prep
 %setup -q
 
 %build
-CFLAGS="$RPM_OPT_FLAGS" \
-  ./configure \
-	--prefix=%{_prefix} \
-	--sysconfdir=%{_sysconfdir}
+CFLAGS="$RPM_OPT_FLAGS"			\
+./configure --prefix=%{_prefix}		\
+	    --sysconfdir=%{_sysconfdir}
 make
 
 %install
-make install DESTDIR=$RPM_BUILD_ROOT
+make DESTDIR=$RPM_BUILD_ROOT install
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post -p /sbin/ldconfig
+%post
+/sbin/ldconfig
 
-%postun -p /sbin/ldconfig
+%postun
+/sbin/ldconfig
 
 %files
 %defattr (-, root, root)