control-center.spec
changeset 8075 17a7c59fa91b
parent 8054 a32ae1408847
child 8149 480174e90a78
--- a/control-center.spec	Tue Sep 05 18:25:01 2006 +0000
+++ b/control-center.spec	Tue Sep 05 23:33:04 2006 +0000
@@ -160,6 +160,13 @@
 autoheader
 automake -a -c -f
 autoconf
+
+%if %with_hal
+export ENABLE_HAL_CONFIG="--enable-hal"
+%else
+export ENABLE_HAL_CONFIG="--disable-hal"
+%endif
+
 CFLAGS="$RPM_OPT_FLAGS -DDBUS_API_SUBJECT_TO_CHANGE" \
   ./configure \
     --prefix=%{_prefix} \
@@ -167,7 +174,8 @@
     --sysconfdir=%{_sysconfdir} \
     --disable-scrollkeeper \
     --enable-aboutme \
-    --disable-hal
+    --disable-libxklavier \
+    $ENABLE_HAL_CONFIG
 make -j $CPUS
 
 %install
@@ -253,6 +261,10 @@
 %{_libdir}/*.so
 
 %changelog
+* Tue Sep 05 2006 - [email protected]
+- Now call with --disable-libxklavier to build without
+  libxklavier, and --enable-hal/disable-hal as appropriate.
+
 * Mon Sep 04 2006 - [email protected]
 - Bump to 2.16.0.