Solaris/SUNWgnome-cd.spec
changeset 5518 235b0b4aa324
child 5799 2f964ba8d2bb
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/Solaris/SUNWgnome-cd.spec	Thu Aug 11 18:34:53 2005 +0000
@@ -0,0 +1,112 @@
+#
+# spec file for package SUNWgnome-cd
+#
+# includes module(s): sound-juicer
+#
+# Copyright (c) 2004 Sun Microsystems, Inc.
+# This file and all modifications and additions to the pristine
+# package are under the same license as the package itself.
+#
+                                                                                
+%include Solaris.inc
+%use soundjuicer = sound-juicer.spec
+
+Name:                    SUNWgnome-cd
+Summary:                 CD ripping tool - platform dependent files, /usr filesystem
+Version:                 2.10.0
+Patch1:                  sound-juicer-01-solaris.diff
+SUNW_BaseDir:            %{_basedir}
+BuildRoot:               %{_tmppath}/%{name}-%{version}-build
+                                                                                
+%include default-depend.inc
+BuildRequires: SUNWgnome-javahelp-convert
+BuildRequires: SUNWmusicbrainz-devel
+BuildRequires: SUNWgnome-cd-burner-devel
+BuildRequires: SUNWgnome-media-apps-devel
+Requires: SUNWmusicbrainz
+Requires: SUNWgnome-cd-burner
+Requires: SUNWgnome-media-apps
+
+%package share
+Summary:                 CD ripping tool - platform independent files, /usr/share
+SUNW_BaseDir:            %{_basedir}
+%include default-depend.inc
+
+%package l10n
+Summary:                 %{summary} - l10n files
+SUNW_BaseDir:            %{_basedir}
+%include default-depend.inc
+Requires:                %{name}
+
+%package root
+Summary:                 CD ripping tool - platform dependent files, / filesystem
+SUNW_BaseDir:            /
+%include default-depend.inc
+
+%prep
+rm -rf %name-%version
+mkdir %name-%version
+%soundjuicer.prep -d %name-%version
+cd sound-juicer-%{soundjuicer.version}
+%patch1 -p1
+cd ..
+
+%build
+export ACLOCAL_FLAGS="-I %{_datadir}/aclocal"
+%soundjuicer.build -d %name-%version
+
+%install
+%soundjuicer.install -d %name-%version
+export GCONF_CONFIG_SOURCE=xml::$RPM_BUILD_ROOT%{_sysconfdir}/gconf/gconf.xml.defaults
+SCHEMAS="sound-juicer.schemas"
+for S in $RPM_BUILD_ROOT/%{_sysconfdir}/gconf/schemas/*.schemas; do
+  %{_bindir}/gconftool-2 --makefile-install-rule $S >/dev/null
+done
+chmod -R a+rX $RPM_BUILD_ROOT/%{_sysconfdir}
+for f in apps/?gconf.xml \
+         schemas/?gconf.xml \
+         schemas/apps/?gconf.xml \
+    ; do
+  test ! -s $RPM_BUILD_ROOT%{_sysconfdir}/gconf/gconf.xml.defaults/$f && \
+    rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/gconf/gconf.xml.defaults/$f
+done
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr (-, root, other)
+%dir %attr (0755, root, bin) %{_bindir}
+%{_bindir}/*
+
+%files share
+%defattr (-, root, other)
+%dir %attr (0755, root, sys) %{_datadir}
+%{_datadir}/applications
+%{_datadir}/gnome/help/*/C
+%{_datadir}/gnome/javahelp/*/C
+%{_datadir}/omf/*/*-C.omf
+%{_datadir}/pixmaps
+%{_datadir}/sound-juicer
+
+%files l10n
+%defattr (-, root, other)
+%dir %attr (0755, root, sys) %{_datadir}
+%{_datadir}/locale
+
+%files root
+%attr (0755, root, sys) %dir %{_sysconfdir}
+%defattr (-, root, other)
+%{_sysconfdir}/*
+%defattr (0755, root, sys)
+
+%changelog
+* Mon Jul 25 2005 - [email protected]
+- Add dependency SUNWgnome-media-apps, SUNWmusicbrainz
+  and SUNWgnome-cd-burner
+
+* Fri Jul 22 2005 - [email protected]
+- Changed the name to SUNWgnome-cd from SUNWsound-juicer
+
+* Thu Jul 07 2005 - [email protected]
+- Initial spec-file created