libglade.spec
changeset 4121 397b519ee64a
parent 4007 3cf8b6afa295
child 4127 69ec35a2e770
--- a/libglade.spec	Fri Oct 01 16:20:25 2004 +0000
+++ b/libglade.spec	Sat Oct 02 22:06:15 2004 +0000
@@ -43,6 +43,12 @@
 %setup -q
 %patch -p1
 
+%ifos solaris
+cd ..
+cp -rp libglade-%{version} libglade-%{version}-64
+%endif
+
+
 %build
 %ifos linux
 if [ -x /usr/bin/getconf ]; then
@@ -54,6 +60,40 @@
 if test "x$CPUS" = "x" -o $CPUS = 0; then
   CPUS=1
 fi
+
+
+CONFLAGS="--prefix=%{_prefix}"
+
+%ifos solaris
+
+CPUS=$(($CPUS*4))
+
+cd ../libglade-%version-64
+
+export CFLAGS="$CFLAGS64"
+export LDFLAGS="$LDFLAGS64"
+export PKG_CONFIG_PATH="$PKG_CONFIG_PATH64"
+
+libtoolize --force
+aclocal $ACLOCAL_FLAGS -I %{_datadir}/aclocal/gnome2-macros
+automake -a -c -f
+autoconf
+./configure $CONFLAGS					\
+            --bindir=%{_bindir}/%{_arch64}		\
+            --libdir=%{_libdir}/%{_arch64}		\
+            --libexecdir=%{_libexecdir}/%{_arch64}	\
+            --sysconfdir=%{_sysconfdir}/%{_arch64}	\
+	    --disable-gtk-doc
+
+make -j $CPUS
+
+cd ../libglade-%version
+
+export LDFLAGS="$LDFLAGS32"
+export PKG_CONFIG_PATH="$PKG_CONFIG_PATH32"
+
+%endif
+
 libtoolize --force
 aclocal $ACLOCAL_FLAGS -I %{_datadir}/aclocal/gnome2-macros
 automake -a -c -f
@@ -65,6 +105,13 @@
 make -j $CPUS
 
 %install
+
+%ifos solaris
+cd ../libglade-%version-64
+make install DESTDIR=$RPM_BUILD_ROOT
+cd ../libglade-%version
+%endif
+
 make DESTDIR=$RPM_BUILD_ROOT install
 install -d $RPM_BUILD_ROOT%{_mandir}/man3
 install --mode=0644 %SOURCE1 $RPM_BUILD_ROOT%{_mandir}/man3
@@ -94,6 +141,9 @@
 %{_mandir}/man3/*
 
 %changelog
+* Sat Oct  2 2004 - [email protected]
+- Create 64bit libraries for Solaris
+
 * Wed Aug 18 2004 - [email protected]
 - added --enable-gtk-doc.