gnome-pilot.spec
changeset 3263 3c14210c0b99
parent 3224 8ca3f4526524
child 3279 5d64ee516a02
--- a/gnome-pilot.spec	Tue Jul 06 20:35:42 2004 +0000
+++ b/gnome-pilot.spec	Wed Jul 07 09:21:36 2004 +0000
@@ -60,6 +60,17 @@
 %patch6 -p1
 
 %build
+%ifos linux
+if [ -x /usr/bin/getconf ]; then
+  CPUS=`getconf _NPROCESSORS_ONLN`
+fi
+%else
+  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l`
+%endif
+if test "x$CPUS" = "x" -o $CPUS = 0; then
+  CPUS=1
+fi
+
 LC_ALL=
 LANG=
 export LC_ALL LANG
@@ -74,7 +85,7 @@
 	     --mandir=%{_mandir}		\
              --libexecdir=%{_libexecdir}        \
 	     --localstatedir=/var
-make
+make -j $CPUS
 
 %install
 export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
@@ -127,6 +138,9 @@
 %{_libdir}/*.so
 
 %changelog
+* Wed Jul 07 2004 - [email protected]
+- added "-j $CPUS" to make to speed up builds
+
 * Wed Jun 09 2004 - [email protected]
 - Integrated docs and associated patch from [email protected]