libglade.spec
changeset 3263 3c14210c0b99
parent 3224 8ca3f4526524
child 3320 1b6af4da604e
--- a/libglade.spec	Tue Jul 06 20:35:42 2004 +0000
+++ b/libglade.spec	Wed Jul 07 09:21:36 2004 +0000
@@ -54,6 +54,17 @@
 
 %build
 %ifos linux
+if [ -x /usr/bin/getconf ]; then
+  CPUS=`getconf _NPROCESSORS_ONLN`
+fi
+%else
+  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l`
+%endif
+if test "x$CPUS" = "x" -o $CPUS = 0; then
+  CPUS=1
+fi
+
+%ifos linux
 export PATH=%{JDS_CBE_prefix}/bin:$PATH
 export ACLOCAL_FLAGS="-I %{JDS_CBE_prefix}/share/aclocal -I %{_datadir}/aclocal"
 %endif
@@ -64,7 +75,7 @@
 CFLAGS="$RPM_OPT_FLAGS"				\
 ./configure --prefix=%{_prefix}			\
             --sysconfdir=%{_sysconfdir}
-make
+make -j $CPUS
 
 %install
 make DESTDIR=$RPM_BUILD_ROOT install
@@ -94,6 +105,9 @@
 %{_mandir}/man3/*
 
 %changelog
+* Wed Jul 07 2004 - [email protected]
+- added "-j $CPUS" to make to speed up builds
+
 * Tue Mar 16 2004 - <[email protected]>
 - Bump to 2.3.6