yelp.spec
changeset 3263 3c14210c0b99
parent 3224 8ca3f4526524
child 3279 5d64ee516a02
--- a/yelp.spec	Tue Jul 06 20:35:42 2004 +0000
+++ b/yelp.spec	Wed Jul 07 09:21:36 2004 +0000
@@ -67,6 +67,17 @@
 bzcat %SOURCE1 | tar xf -
 
 %build
+%ifos linux
+if [ -x /usr/bin/getconf ]; then
+  CPUS=`getconf _NPROCESSORS_ONLN`
+fi
+%else
+  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l`
+%endif
+if test "x$CPUS" = "x" -o $CPUS = 0; then
+  CPUS=1
+fi
+
 libtoolize --force
 aclocal $ACLOCAL_FLAGS -I %{_datadir}/aclocal/gnome2-macros
 automake -a -c -f
@@ -77,7 +88,7 @@
     --sysconfdir=%{_sysconfdir} \
     --libexecdir=%{_libexecdir} \
     --localstatedir=/var/lib
-make
+make -j $CPUS
 
 %install
 make install DESTDIR=$RPM_BUILD_ROOT
@@ -103,6 +114,9 @@
 %{_mandir}/man1/*
 
 %changelog
+* Wed Jul 07 2004 - [email protected]
+- added "-j $CPUS" to make to speed up builds
+
 * Thu May 20 2004 - [email protected]
 - added yelp-03-session-save.diff. Yelp is session aware now!