SUNWgnome-python-libs.spec
changeset 10617 4aa1d48bc616
parent 10572 8cdee8cd9c9c
child 10625 b9e2a08788ba
--- a/SUNWgnome-python-libs.spec	Fri Oct 05 21:09:47 2007 +0000
+++ b/SUNWgnome-python-libs.spec	Sun Oct 07 16:28:40 2007 +0000
@@ -16,6 +16,7 @@
 %use pyspi = pyspi.spec
 %use pygobject = pygobject.spec
 %use pygtk2 = pygtk2.spec
+%use pygtksourceview = pygtksourceview.spec
 
 Name:              SUNWgnome-python-libs
 Summary:           Python support libraries for GNOME
@@ -67,6 +68,7 @@
 %pyorbit.prep -d %name-%version
 %gnome_python.prep -d %name-%version
 %pyspi.prep -d %name-%version
+%pygtksourceview.prep -d %name-%version
 
 %build
 PKG_CONFIG_DISABLE_UNINSTALLED=
@@ -95,6 +97,9 @@
 %gnome_python.build -d %name-%version
 export CFLAGS="`echo %optflags | sed -e 's/-xregs=no.frameptr//'`"
 %pyspi.build -d %name-%version
+export PYTHONPATH=%{_builddir}/%name-%version/pygtk-%{pygtk2.version}
+export top_builddir=%{_builddir}/%name-%version/pygtksourceview-%{pygtksourceview.version}
+%pygtksourceview.build -d %name-%version
 
 %install
 %pygobject.install -d %name-%version
@@ -104,6 +109,7 @@
 %gnome_python.install -d %name-%version
 export PYTHON_PATH=%{_builddir}/%name-%version/pygtk-%{pygtk2.version}
 %pyspi.install -d %name-%version
+%pygtksourceview.install -d %name-%version
 
 # Move demo to demo directory.
 #
@@ -139,6 +145,8 @@
 %{_prefix}/demo/jds/bin/pygtk-demo
 
 %changelog
+* Sun Oct  7 2007 - [email protected]
+- Add pygtksourceview as it is required to build python bindings in gedit.
 * Fri Sep 28 2007 - [email protected]
 - delete some unnecessary env vars
 * Fri Aug 31 2007 - [email protected]