SUNWPython26.spec
branchgnome-2-28
changeset 18668 5af2546c3167
parent 18549 69f43e94c6d6
--- a/SUNWPython26.spec	Thu Mar 25 09:26:52 2010 +0000
+++ b/SUNWPython26.spec	Sun Mar 28 09:18:06 2010 +0000
@@ -3,7 +3,7 @@
 #
 # includes module(s): Python
 #
-# Copyright 2009 Sun Microsystems, Inc.
+# Copyright 2010 Sun Microsystems, Inc.
 # This file and all modifications and additions to the pristine
 # package are under the same license as the package itself.
 #
@@ -83,6 +83,8 @@
 Patch18:                 Python26-18-readline.diff
 # date:2009-12-17 owner:laca type:feature bugster:6784248
 Patch19:                 Python26-19-ext-stdio.diff
+# date:2010-03-27 owner:laca type:feature bugster:6936333
+Patch20:                 Python26-20-py_db.diff
 
 %include default-depend.inc
 BuildRequires: SUNWTk
@@ -138,6 +140,7 @@
 %patch17 -p1
 %patch18 -p1 -b .readline
 %patch19 -p1
+%patch20 -p1
 cd ..
 
 echo fixing python binary name/path in python scripts:
@@ -201,6 +204,11 @@
 perl -pi -e 's/^(#define _XOPEN_SOURCE_EXTENDED.*)/\/* $1 *\//' pyconfig.h
 
 make
+
+cd py_db
+make OPT="${OPT}" all32
+cd ..
+
 cd ..
 
 %ifarch sparcv9 amd64
@@ -232,6 +240,10 @@
 perl -pi -e 's/^(#define _XOPEN_SOURCE_EXTENDED.*)/\/* $1 *\//' pyconfig.h
 
 make
+cd py_db
+make OPT="${OPT}" all64
+cd ..
+
 %endif
 
 %install
@@ -239,6 +251,9 @@
 %ifarch sparcv9 amd64
 cd Python-%{version}-64
 make install DESTDIR=$RPM_BUILD_ROOT BINDIR=%{_bindir}/%{_arch64}
+ginstall -m 555 -D py_db/libpython%{majmin}_db_64.so $RPM_BUILD_ROOT%{_libdir}/%{_arch64}/libpython%{majmin}_db.so.1.0
+ln -s libpython%{majmin}_db.so.1.0 $RPM_BUILD_ROOT%{_libdir}/%{_arch64}/libpython%{majmin}_db.so
+ginstall -m 555 -D py_db/check_offset64 $RPM_BUILD_ROOT%{_libdir}/python%{majmin}/test/
 rm -f $RPM_BUILD_ROOT%{_bindir}/%{_arch64}/idle
 rm -f $RPM_BUILD_ROOT%{_bindir}/%{_arch64}/pydoc
 rm -f $RPM_BUILD_ROOT%{_bindir}/%{_arch64}/smtpd.py
@@ -247,6 +262,9 @@
 
 cd Python-%{version}
 make install DESTDIR=$RPM_BUILD_ROOT
+ginstall -m 555 -D py_db/libpython%{majmin}_db.so $RPM_BUILD_ROOT%{_libdir}/libpython%{majmin}_db.so.1.0
+ln -s libpython%{majmin}_db.so.1.0 $RPM_BUILD_ROOT%{_libdir}/libpython%{majmin}_db.so
+ginstall -m 555 -D py_db/check_offset $RPM_BUILD_ROOT%{_libdir}/python%{majmin}/test/
 
 # FIXME: delete while 2.5 is not the default:
 rm $RPM_BUILD_ROOT%{_bindir}/smtpd.py