Solaris/SUNWgob2.spec
changeset 7376 609397372f40
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/Solaris/SUNWgob2.spec	Tue Jun 06 08:02:09 2006 +0000
@@ -0,0 +1,60 @@
+#
+# spec file for package SUNWgob2
+#
+# includes module(s): gob2
+#
+# Copyright (c) 2004 Sun Microsystems, Inc.
+# This file and all modifications and additions to the pristine
+# package are under the same license as the package itself.
+#
+
+%include Solaris.inc
+%use gob2 = gob2.spec
+
+Name:          SUNWgob2
+Summary:       %{gob2.summary}
+Version:       %{gob2.version}
+SUNW_BaseDir:  %{_prefix}
+BuildRoot:     %{_tmppath}/%{name}-%{version}-build
+%include default-depend.inc
+Requires:      SUNWlibC
+Requires:      SUNWlibms
+Requires:      SUNWlibmsr
+
+%prep
+rm -rf %name-%version
+mkdir -p %name-%version
+%gob2.prep -d %name-%version
+
+%build
+export CXX="$CXX -norunpath"
+export CFLAGS="%optflags"
+export LDFLAGS="%_ldflags -lCrun -lm"
+export CXXFLAGS="%cxx_optflags -staticlib=stlport4"
+export MSGFMT="/usr/bin/msgfmt"
+%gob2.build -d %name-%version
+
+%install
+%gob2.install -d %name-%version
+
+%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr (-, root, bin)
+%dir %attr (0755, root, bin) %{_bindir}
+%{_bindir}/*
+%dir %attr(0755, root, bin) %{_mandir}
+%dir %attr(0755, root, bin) %{_mandir}/*
+%{_mandir}/*/*
+%defattr (-, root, other)
+%dir %attr(0755, root, sys) %{_datadir}
+%dir %attr(0755, root, other) %{_datadir}/aclocal
+%{_datadir}/aclocal/*
+
+%changelog
+* Tue Jun 06 2006 - [email protected]
+- Initial version created.
+