base-specs/evolution-data-server.spec
changeset 17139 872b4c1c1aa0
parent 17116 876774909cd5
child 17145 084495f9b5c9
--- a/base-specs/evolution-data-server.spec	Tue Dec 08 08:42:03 2009 +0000
+++ b/base-specs/evolution-data-server.spec	Tue Dec 08 11:57:11 2009 +0000
@@ -67,6 +67,8 @@
 Requires:       GConf >= %{GConf_version}
 Requires:       libsoup >= %{libsoup_version}
 Requires:       openldap2-client >= %{openldap2_version}
+Requires:       SUNWtls
+Requires:       SUNWpr
 
 BuildRequires:  libbonobo-devel >= %{libbonobo_version}
 BuildRequires:  gnome-vfs-devel >= %{gnome_vfs_version}
@@ -77,6 +79,8 @@
 BuildRequires:  gtk-doc >= %{gtk_doc_version}
 BuildRequires:  bison
 BuildRequires:  heimdal-devel
+BuildRequires:  SUNWtlsd
+BuildRequires:  SUNWprd
 
 %description
 evolution-data-server is the backend library for Evolution, providing
@@ -120,12 +124,11 @@
 %build
 
 %ifos linux
+if [ -x /usr/bin/getconf ]; then
+  CPUS=`getconf _NPROCESSORS_ONLN`
+fi
 %define ldap_option --with-openldap=%{_prefix}
 %define krb5_option --with-krb5=%{_prefix}
-%define nss_libs %{_libdir}/firefox
-%define nspr_libs %{_libdir}/firefox
-%define nss_includes %{_includedir}/firefox/nss
-%define nspr_includes %{_includedir}/firefox/nspr
 %else
 %define ldap_option --with-sunldap=%{_prefix}
 %if %is_s10
@@ -133,19 +136,20 @@
 %else
 %define krb5_option --with-krb5=%{_prefix}
 %endif
-%define nss_libs %{_libdir}/mps
-%define nspr_libs %{_libdir}/mps
-%define nss_includes %{_includedir}/mps
-%define nspr_includes %{_includedir}/mps
+CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
 %endif
+
+if test "x$CPUS" = "x" -o $CPUS = 0; then
+  CPUS=1
+fi
+
 %if %option_with_gnu_iconv
 %define iconv_option --with-libiconv=/usr/gnu
 %else
 %define iconv_option
 %endif
 
-export LDFLAGS="$LDFLAGS -L%{nss_libs} -R%{nss_libs} -L%{nspr_libs} -R%{nspr_libs}"
-export CFLAGS="$CFLAGS $RPM_OPT_FLAGS -I%{nss_includes} -I%{nspr_includes}"
+export LDFLAGS="$LDFLAGS -R`pkg-config --variable=libdir nss` -R`pkg-config --variable=libdir nspr`"
 
 aclocal $ACLOCAL_FLAGS -I m4
 glib-gettextize --force --copy
@@ -164,19 +168,15 @@
 	    --enable-nss=yes						\
 	    --enable-smime=yes						\
 	    --enable-nntp=yes						\
-	    --with-nss-includes=%{nss_includes}				\
-	    --with-nss-libs=%{nss_libs}					\
-	    --with-nspr-includes=%{nspr_includes}			\
-	    --with-nspr-libs=%{nspr_libs}				\
-            --without-weather                                              \
+            --enable-largefile                                          \
+	    --with-krb4=%{_prefix}					\
 	    %ldap_option						\
-	    --with-krb4=%{_prefix}					\
 	    %krb5_option						\
             %gtk_doc_option                                             \
 	    %bdb_option                                                 \
             %iconv_option
 
-make
+make -j$CPUS
 
 %install
 export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
@@ -216,6 +216,10 @@
 %{_datadir}/idl/*
 
 %changelog
+* Tue Dec 08 2009 - [email protected]
+- Use new way to figure out cflags and ldflags for nss and nspr.
+- Enable gweather and large file support.
+- Add SUNWtlsd and SUNWprd dependency.
 * Fri Dec 04 2009 - [email protected]
 - Bump to 2.29.3
 - Add patch -05-remove-bdb