SUNWgnome-panel.spec
changeset 11524 88e7dfb84677
parent 11471 c067fd6ce46e
child 11626 c68fd01ba85b
--- a/SUNWgnome-panel.spec	Thu Jan 24 16:52:40 2008 +0000
+++ b/SUNWgnome-panel.spec	Fri Jan 25 08:09:23 2008 +0000
@@ -196,6 +196,7 @@
 ) | $BASEDIR/lib/postrun -b -u -c JDS
 
 %post root
+%include gconf-install.script
 ( echo 'test -x /usr/bin/gconftool-2 || {';
   echo '  echo "ERROR: gconftool-2 not found"';
   echo '  exit 1';
@@ -205,11 +206,6 @@
   echo 'export GCONF_CONFIG_SOURCE';
   echo "SDIR=%{_sysconfdir}/gconf/schemas";
   echo 'retval=0';
-  echo 'for schemas in clock panel-compatibility panel-general panel-global \';
-  echo '               panel-object panel-toplevel window-list \';
-  echo '               workspace-switcher gweather; do' ;
-  echo '  /usr/bin/gconftool-2 --makefile-install-rule $SDIR/$schemas.schemas || retval=1';
-  echo 'done';
   echo '/usr/bin/gconftool-2  --direct --config-source=$GCONF_CONFIG_SOURCE --load %{_sysconfdir}/gconf/schemas/panel-default-setup.entries || retval=1';
   echo '/usr/bin/gconftool-2  --direct --config-source=$GCONF_CONFIG_SOURCE --load %{_sysconfdir}/gconf/schemas/panel-default-setup.entries /apps/panel/profiles/default|| retval=1';
   echo 'exit $retval'
@@ -231,7 +227,7 @@
   echo 'for schemas in clock panel-compatibility panel-general panel-global \';
   echo '               panel-object panel-toplevel window-list gweather \';
   echo '               workspace-switcher notification-daemon; do' ;
-  echo '  $PKG_INSTALL_ROOT/usr/bin/gconftool-2 --makefile-uninstall-rule $SDIR/$schemas.schemas || retval=1';
+  echo '  $PKG_INSTALL_ROOT/usr/bin/gconftool-2 --makefile-uninstall-rule $SDIR/$schemas.schemas > /dev/null || retval=1';
   echo 'done';
   echo '$PKG_INSTALL_ROOT/usr/bin/gconftool-2  --direct --config-source=$GCONF_CONFIG_SOURCE --unload $SDIR/panel-default-setup.entries || retval=1';
   echo '$PKG_INSTALL_ROOT/usr/bin/gconftool-2  --direct --config-source=$GCONF_CONFIG_SOURCE --unload $SDIR/panel-default-setup.entries /apps/panel/profiles/default || retval=1';