metacity.spec
changeset 226 9fb26844a575
parent 125 3e1b209ab0ad
child 237 1a3716a514e3
--- a/metacity.spec	Thu May 29 13:12:48 2003 +0000
+++ b/metacity.spec	Thu May 29 13:40:00 2003 +0000
@@ -1,73 +1,77 @@
-#
-# spec file for package metacity (Version 2.4.0)
-#
-# Copyright (c) 2003 Sun Microsystems Inc.
-# This file and all modifications and additions to the pristine
-# package are under the same license as the package itself.
-#
-
 Name:         metacity
 License:      GPL
 Group:        System/GUI/GNOME
-Autoreqprov:  on
 Version:      2.4.34
 Release:      1
 Distribution: Mercury
 Vendor:       Sun Microsystems Inc.
-Summary:      Fast Windowmanager for GNOME 2.0
-Source:       metacity-%{version}.tar.bz2
+Summary:      GNOME Window Manager
+Source:       http://ftp.gnome.org/pub/GNOME/sources/metacity/2.4/metacity-%{version}.tar.bz2
 Patch0:	      metacity-theme.diff
 URL:          http://www.gnome.org
 BuildRoot:    %{_tmppath}/%{name}-%{version}-build
-Docdir:       %{_defaultdocdir}/metacity
-PreReq:       filesystem
+Docdir:       %{_defaultdocdir}/doc
+Autoreqprov:  on
+
+%define intltool_version 0.25
+%define GConf_version 2.2.0
+%define pkgconfig_version 0.15.0
+%define libglade_version 2.0.1
+
+Requires: GConf >= %{GConf_version}
+Requires: libglade >= %{libglade_version}
+BuildRequires: intltool >= %{intltool_version}
+BuildRequires: pkgconfig >= %{pkgconfig_version}
+BuildRequires: GConf >= %{GConf_version}
+BuildRequires: libglade >= %{libglade_version}
 
 %description
-"Metacity" is a fast windowmanager for the GNOME 2.0 desktop.
+Metacity is the window manager for the GNOME Desktop.
 
 %prep
-%setup -n metacity-%{version}
+%setup
 %patch0
 
 %build
-./configure --prefix=%{_prefix} \
-    --bindir=%{_bindir} --mandir=%{_mandir} \
-    --localstatedir=%{_localstatedir} --libdir=%{_libdir} \
-    --datadir=%{_datadir} --includedir=%{_includedir} \
-    --sysconfdir=%{_sysconfdir} --disable-gtk-doc
+CFLAGS="$RPM_OPT_FLAGS"			\
+./configure --prefix=%{_prefix}		\
+	    --mandir=%{_mandir}		\
+	    --sysconfdir=%{_sysconfdir}
 make 
 
 %install
 export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
-make -i install DESTDIR=$RPM_BUILD_ROOT
+make DESTDIR=$RPM_BUILD_ROOT install
 unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
 
 %post
+/sbin/ldconfig
 export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
 SCHEMAS="metacity.schemas"
 for S in $SCHEMAS; do
 	gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
 done
 
+%postun
+/sbin/ldconfig
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
-%doc AUTHORS COPYING ChangeLog NEWS README
 %defattr (-, root, root)
-%{_prefix}/bin/*
-%{_prefix}/share/locale/*/LC_MESSAGES/*.mo
+%{_bindir}/*
+%{_datadir}/locale/*/LC_MESSAGES/*.mo
 %{_sysconfdir}/gconf/schemas/metacity.schemas
-%{_prefix}/libexec/*
-%{_prefix}/lib/*.so*
-%{_prefix}/lib/pkgconfig/*.pc
-%{_prefix}/include/metacity-1/metacity-private
-%{_prefix}/share/gnome/wm-properties/metacity.desktop
-%{_prefix}/share/metacity
-%{_prefix}/share/pixmaps/metacity-properties.png
-%{_prefix}/share/themes/*/metacity-1/*
+%{_libexecdir}/*
+%{_libdir}/*.so*
+%{_libdir}/pkgconfig/*.pc
+%{_includedir}/metacity-1/metacity-private
+%{_datadir}/gnome/wm-properties/metacity.desktop
+%{_datadir}/metacity
+%{_datadir}/pixmaps/metacity-properties.png
+%{_datadir}/themes/*/metacity-1/*
 
-%changelog -n metacity
+%changelog
 * Tue May 13 2003 - [email protected]
 - initial release