base-specs/libgweather.spec
changeset 11458 a2853d197d3e
child 11472 461d49eee4a8
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/base-specs/libgweather.spec	Tue Jan 15 17:03:32 2008 +0000
@@ -0,0 +1,75 @@
+#
+# spec file for package libgweather
+#
+# Copyright (c) 2008 Sun Microsystems, Inc.
+# This file and all modifications and additions to the pristine
+# package are under the same license as the package itself.
+#
+# Owner: yippi
+#
+%include l10n.inc
+Name:         libgweather
+License:      GPL
+Group:        System/GUI/GNOME
+Version:      2.21.2
+Release:      1
+Distribution: Java Desktop System
+Vendor:       Sun Microsystems, Inc.
+Summary:      libgweather
+Source:       http://ftp.gnome.org/pub/GNOME/sources/libgweather/2.21/%{name}-%{version}.tar.bz2
+# owner:dcarbery date:2008-01-15 type:bug bugzilla:??????
+Patch1:       libgweather-01-uninstalled.diff
+URL:          http://www.gnome.org
+BuildRoot:    %{_tmppath}/%{name}-%{version}-build
+Docdir:       %{_defaultdocdir}/%{name}
+Autoreqprov:  on
+
+%description
+libgweather description.
+
+%prep
+%setup -q
+%patch1 -p1
+
+%build
+%ifos linux
+if [ -x /usr/bin/getconf ]; then
+  CPUS=`getconf _NPROCESSORS_ONLN`
+fi
+%else
+  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
+%endif
+if test "x$CPUS" = "x" -o $CPUS = 0; then
+  CPUS=1
+fi
+
+#libtoolize --force
+#intltoolize --force --copy --automake
+#aclocal $ACLOCAL_FLAGS
+#autoheader
+#automake -a -c -f
+autoconf
+
+CFLAGS="$RPM_OPT_FLAGS"	\
+./configure \
+	--prefix=%{_prefix} \
+	--sysconfdir=%{_sysconfdir} \
+        --libdir=%{_libdir}         \
+        --bindir=%{_bindir}         \
+	--libexecdir=%{_libexecdir} \
+	--mandir=%{_mandir}         \
+	--localstatedir=/var/lib
+make -j $CPUS
+
+%install
+export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
+make -i install DESTDIR=$RPM_BUILD_ROOT
+unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+
+%changelog
+* Tue Jan 15 2008 - [email protected]
+- Initial Sun release.