Solaris/SUNWgnome-keyring-manager.spec
changeset 7781 aa401a2b82b6
child 7792 d8dee589c291
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/Solaris/SUNWgnome-keyring-manager.spec	Thu Jul 27 14:25:43 2006 +0000
@@ -0,0 +1,150 @@
+#
+# spec file for package SUNWgnome-keyring-manager
+#
+# includes module(s): gnome-keyring-manager
+#
+# Copyright (c) 2004 Sun Microsystems, Inc.
+# This file and all modifications and additions to the pristine
+# package are under the same license as the package itself.
+#
+
+%include Solaris.inc
+
+%use gnomekeyringmanager = gnome-keyring-manager.spec
+
+Name:                    SUNWgnome-keyring-manager
+Summary:                 GNOME Keyring Manager
+Version:                 %{default_pkg_version}
+SUNW_BaseDir:            %{_basedir}
+BuildRoot:               %{_tmppath}/%{name}-%{version}-build
+
+%include default-depend.inc
+Requires: SUNWgnome-libs
+Requires: SUNWgnome-base-libs
+Requires: SUNWgnome-config
+BuildRequires: SUNWgnome-config-devel
+BuildRequires: SUNWgnome-libs
+Requires: SUNWpostrun
+
+%if %build_l10n
+%package l10n
+Summary:                 %{summary} - l10n files
+SUNW_BaseDir:            %{_basedir}
+%include default-depend.inc
+Requires:                %{name}
+%endif
+
+%package root
+Summary:                 %{summary} - / filesystem
+SUNW_BaseDir:            /
+%include default-depend.inc
+Requires: SUNWpostrun
+Requires: SUNWgnome-config
+
+%prep
+rm -rf %name-%version
+mkdir %name-%version
+%gnomekeyringmanager.prep -d %name-%version
+
+%build
+export PKG_CONFIG_PATH=%{_pkg_config_path}
+export MSGFMT="/usr/bin/msgfmt"
+export ACLOCAL_FLAGS="-I %{_datadir}/aclocal"
+export PERL5LIB=%{_prefix}/perl5/site_perl/5.6.1/sun4-solaris-64int
+export CFLAGS="%optflags -I%{_includedir}"
+export RPM_OPT_FLAGS="$CFLAGS"
+export LDFLAGS="%_ldflags"
+
+%gnomekeyringmanager.build -d %name-%version
+
+%install
+rm -rf $RPM_BUILD_ROOT
+%gnomekeyringmanager.install -d %name-%version
+rm -rf $RPM_BUILD_ROOT%{_mandir}
+
+%if %build_l10n
+%else
+# REMOVE l10n FILES
+rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/help/*/[a-z]*
+rm -rf $RPM_BUILD_ROOT%{_datadir}/omf/*/*-[a-z][a-z].omf
+rm -rf $RPM_BUILD_ROOT%{_datadir}/omf/*/*-[a-z][a-z]_[A-Z]*.omf
+rm -rf $RPM_BUILD_ROOT%{_datadir}/locale
+%endif
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+( echo 'test -x /usr/bin/update-desktop-database || exit 0';
+  echo '/usr/bin/update-desktop-database'
+) | $PKG_INSTALL_ROOT/usr/lib/postrun -b -u -c JDS_wait
+( echo 'test -x /usr/bin/scrollkeeper-update || exit 0';
+  echo '/usr/bin/scrollkeeper-update'
+) | $PKG_INSTALL_ROOT/usr/lib/postrun -b -u -c JDS
+
+%postun
+test -x $PKG_INSTALL_ROOT/usr/lib/postrun || exit 0
+( echo 'test -x /usr/bin/update-desktop-database || exit 0';
+  echo '/usr/bin/update-desktop-database'
+) | $PKG_INSTALL_ROOT/usr/lib/postrun -b -u -c JDS
+( echo 'test -x /usr/bin/scrollkeeper-update || exit 0';
+  echo '/usr/bin/scrollkeeper-update'
+) | $PKG_INSTALL_ROOT/usr/lib/postrun -b -u -c JDS
+
+%post root
+( echo 'test -x /usr/bin/gconftool-2 || {';
+  echo '  echo "ERROR: gconftool-2 not found"';
+  echo '  exit 0';
+  echo '}';
+  echo 'umask 0022';
+  echo 'GCONF_CONFIG_SOURCE=xml:merged:/etc/gconf/gconf.xml.defaults';
+  echo 'export GCONF_CONFIG_SOURCE';
+  echo '/usr/bin/gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/*.schemas'
+) | $PKG_INSTALL_ROOT/usr/lib/postrun -u -c JDS_wait
+
+%preun root
+( echo 'test -x /usr/bin/gconftool-2 || {';
+  echo '  echo "ERROR: gconftool-2 not found"';
+  echo '  exit 0';
+  echo '}';
+  echo 'umask 0022';
+  echo 'GCONF_CONFIG_SOURCE=xml:merged:$PKG_INSTALL_ROOT/etc/gconf/gconf.xml.defaults';
+  echo 'GCONF_BACKEND_DIR=$PKG_INSTALL_ROOT/usr/lib/GConf/2';
+  echo 'LD_LIBRARY_PATH=$PKG_INSTALL_ROOT/usr/lib';
+  echo 'export GCONF_CONFIG_SOURCE GCONF_BACKEND_DIR LD_LIBRARY_PATH';
+  echo 'SDIR=$PKG_INSTALL_ROOT%{_sysconfdir}/gconf/schemas';
+  echo 'schemas="$SDIR/gnome-keyring-manager.schemas"';
+  echo '$PKG_INSTALL_ROOT/usr/bin/gconftool-2 --makefile-uninstall-rule $schemas'
+) | $PKG_INSTALL_ROOT/usr/lib/postrun -i -c JDS -a
+
+%files
+%defattr (-, root, bin)
+%dir %attr (0755, root, bin) %{_bindir}
+%{_bindir}/*
+%dir %attr (0755, root, sys) %{_datadir}
+%dir %attr (0755, root, other) %{_datadir}/applications
+%{_datadir}/applications/*
+%{_datadir}/gnome-keyring-manager
+%dir %attr (0755, root, other) %{_datadir}/gnome
+%{_datadir}/gnome/help/*/C
+%{_datadir}/omf/*/*-C.omf
+
+%if %build_l10n
+%files l10n
+%defattr (-, root, bin)
+%dir %attr (0755, root, sys) %{_datadir}
+%dir %attr (0755, root, other) %{_datadir}/gnome
+%attr (-, root, other) %{_datadir}/locale
+%{_datadir}/gnome/help/*/[a-z]*
+%{_datadir}/omf/*/*-[a-z][a-z].omf
+%{_datadir}/omf/*/*-[a-z][a-z]_[A-Z]*.omf
+%endif
+
+%files root
+%defattr (0755, root, sys)
+%attr (0755, root, sys) %dir %{_sysconfdir}
+%{_sysconfdir}/gconf/schemas/gnome-keyring-manager.schemas
+
+%changelog
+* Fri Jul 14 2006 - [email protected]
+- Initial spec