SUNWgobject-introspection.spec
changeset 16339 abbb0052893a
child 16424 5252dcba3f38
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/SUNWgobject-introspection.spec	Tue Aug 25 06:13:09 2009 +0000
@@ -0,0 +1,103 @@
+#
+# spec file for package SUNWgobject-introspection
+#
+# includes module(s): gobject-introspection
+#
+# Copyright 2009 Sun Microsystems, Inc.
+# This file and all modifications and additions to the pristine
+# package are under the same license as the package itself.
+#
+# Owner: yippi
+#
+# Note that there are some issues that you need to address to avoid build
+# issues when building this module:
+#
+# 1) For some reason SUNWPython26.spec has a problem with ctypes that causes
+#    gobject-introspection to fail to build.  Uninstalling and rebuilding this
+#    package from spec-files seems to fix this problem. Need to figure this
+#    out and get it fixed in the SUNWPython26 package.
+#
+
+%include Solaris.inc
+
+%define pythonver 2.6
+%use gi = gobject-introspection.spec
+
+Name:               SUNWgobject-introspection
+Summary:            gobject-introspection - GObject introspection support
+Version:            %{gi.version}
+SUNW_Copyright:     %{name}.copyright
+SUNW_BaseDir:       %{_basedir}
+BuildRoot:          %{_tmppath}/%{name}-%{version}-build
+
+BuildRequires:      SUNWPython26-devel
+BuildRequires:      SUNWglib2-devel
+BuildRequires:      SUNWlibffi
+Requires:           SUNWglib2
+Requires:           SUNWlibffi
+Requires:           SUNWPython26
+%include default-depend.inc
+
+%package devel
+Summary:            %{summary} - development files
+SUNW_BaseDir: %{_basedir}
+%include default-depend.inc
+
+%prep
+rm -rf %name-%version
+mkdir %name-%version
+%gi.prep -d %name-%version
+
+%build
+export CFLAGS="%optflags"
+export RPM_OPT_FLAGS="$CFLAGS"
+export LDFLAGS="%_ldflags"
+
+%gi.build -d %name-%version
+
+%install
+rm -rf $RPM_BUILD_ROOT
+%gi.install -d %name-%version
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr (-, root, bin)
+%dir %attr (0755, root, bin) %{_bindir}
+%{_bindir}/*
+%dir %attr (0755, root, bin) %{_libdir}
+%{_libdir}/*.so*
+%{_libdir}/girepository-1.0/*
+%{_libdir}/gobject-introspection/*
+%dir %attr (0755, root, sys) %{_datadir}
+%{_datadir}/gir-1.0
+%dir %attr(0755, root, bin) %{_mandir}
+%dir %attr(0755, root, bin) %{_mandir}/*
+%{_mandir}/*/*
+%doc -d gobject-introspection-%{version} AUTHORS README COPYING
+%doc(bzip2) -d gobject-introspection-%{version} COPYING.GPL COPYING.LGPL NEWS
+%dir %attr (0755, root, other) %{_datadir}/doc
+
+%files devel
+%defattr (-, root, bin)
+%dir %attr (0755, root, bin) %dir %{_libdir}
+%dir %attr (0755, root, other) %{_libdir}/pkgconfig
+%{_libdir}/pkgconfig/*
+%dir %attr (0755, root, bin) %dir %{_includedir}
+%{_includedir}/*
+%dir %attr (0755, root, sys) %{_datadir}
+%dir %attr (0755, root, other) %{_datadir}/aclocal
+%{_datadir}/aclocal/*
+
+%changelog
+* Mon Aug 24 2009 - [email protected]
+- Move from SFE, spilit base part to base-specs/gobject-introspection
+* Wed Aug 05 2009 - Halton Huo  <[email protected]>
+- Use 0.6.3 tarball release 
+- Add crash-compiler.diff to fix #587823
+* Fri Jul 03 2009 - Brian Cameron  <[email protected]
+- Remove upstream patch gobject-introspection-01-union.diff,
+  renumber rest.
+* Sat Apr 04 2009 - Brian Cameron  <[email protected]>
+- Created.